Merge branch 'f18'
This commit is contained in:
commit
1ed87e22e1
@ -1,6 +1,6 @@
|
|||||||
diff -up hostname/hostname.1.rh hostname/hostname.1
|
diff -up hostname/hostname.1.rh hostname/hostname.1
|
||||||
--- hostname/hostname.1.rh 2012-02-16 15:58:45.000000000 +0100
|
--- hostname/hostname.1.rh 2012-12-06 16:18:46.000000000 +0100
|
||||||
+++ hostname/hostname.1 2012-11-30 11:02:00.520205938 +0100
|
+++ hostname/hostname.1 2013-03-08 12:12:35.068011173 +0100
|
||||||
@@ -84,6 +84,28 @@ complete FQDN of the system is returned
|
@@ -84,6 +84,28 @@ complete FQDN of the system is returned
|
||||||
.B "THE FQDN"
|
.B "THE FQDN"
|
||||||
below).
|
below).
|
||||||
@ -40,7 +40,7 @@ diff -up hostname/hostname.1.rh hostname/hostname.1
|
|||||||
(normally by reading the contents of a file which contains
|
(normally by reading the contents of a file which contains
|
||||||
the host name, e.g.
|
the host name, e.g.
|
||||||
.IR /etc/hostname ).
|
.IR /etc/hostname ).
|
||||||
@@ -207,7 +228,7 @@ order of the output.
|
@@ -225,7 +246,7 @@ order of the output.
|
||||||
Display the short host name. This is the host name cut at the first dot.
|
Display the short host name. This is the host name cut at the first dot.
|
||||||
.TP
|
.TP
|
||||||
.I "\-v, \-\-verbose"
|
.I "\-v, \-\-verbose"
|
||||||
@ -51,8 +51,8 @@ diff -up hostname/hostname.1.rh hostname/hostname.1
|
|||||||
Print version information on standard output and exit successfully.
|
Print version information on standard output and exit successfully.
|
||||||
diff -up hostname/Makefile.rh hostname/Makefile
|
diff -up hostname/Makefile.rh hostname/Makefile
|
||||||
--- hostname/Makefile.rh 2012-02-16 16:00:52.000000000 +0100
|
--- hostname/Makefile.rh 2012-02-16 16:00:52.000000000 +0100
|
||||||
+++ hostname/Makefile 2012-11-30 11:21:16.427798533 +0100
|
+++ hostname/Makefile 2013-03-08 12:14:23.884487035 +0100
|
||||||
@@ -3,30 +3,35 @@ CFLAGS+=-O2 -Wall
|
@@ -3,30 +3,29 @@ CFLAGS+=-O2 -Wall
|
||||||
# uncomment the following line if you want to install to a different base dir.
|
# uncomment the following line if you want to install to a different base dir.
|
||||||
#BASEDIR=/mnt/test
|
#BASEDIR=/mnt/test
|
||||||
|
|
||||||
@ -77,12 +77,6 @@ diff -up hostname/Makefile.rh hostname/Makefile
|
|||||||
ln -fs hostname.1 ${BASEDIR}/usr/share/man/man1/ypdomainname.1
|
ln -fs hostname.1 ${BASEDIR}/usr/share/man/man1/ypdomainname.1
|
||||||
ln -fs hostname.1 ${BASEDIR}/usr/share/man/man1/nisdomainname.1
|
ln -fs hostname.1 ${BASEDIR}/usr/share/man/man1/nisdomainname.1
|
||||||
#install -o root -g root -m 0644 hostname.1.fr ${BASEDIR}/usr/share/man/fr/man1/hostname.1
|
#install -o root -g root -m 0644 hostname.1.fr ${BASEDIR}/usr/share/man/fr/man1/hostname.1
|
||||||
+ install -d ${BASEDIR}/usr/share/man/fr/man1
|
|
||||||
+ install -m 0644 hostname.1.fr ${BASEDIR}/usr/share/man/fr/man1/hostname.1
|
|
||||||
+ ln -fs hostname.1 ${BASEDIR}/usr/share/man/fr/man1/dnsdomainname.1
|
|
||||||
+ ln -fs hostname.1 ${BASEDIR}/usr/share/man/fr/man1/domainname.1
|
|
||||||
+ ln -fs hostname.1 ${BASEDIR}/usr/share/man/fr/man1/ypdomainname.1
|
|
||||||
+ ln -fs hostname.1 ${BASEDIR}/usr/share/man/fr/man1/nisdomainname.1
|
|
||||||
|
|
||||||
- install -d ${BASEDIR}/bin
|
- install -d ${BASEDIR}/bin
|
||||||
- install -o root -g root -m 0755 hostname ${BASEDIR}/bin
|
- install -o root -g root -m 0755 hostname ${BASEDIR}/bin
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
Summary: Utility to set/show the host name or domain name
|
Summary: Utility to set/show the host name or domain name
|
||||||
Name: hostname
|
Name: hostname
|
||||||
Version: 3.12
|
Version: 3.12
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: http://packages.qa.debian.org/h/hostname.html
|
URL: http://packages.qa.debian.org/h/hostname.html
|
||||||
@ -18,24 +18,21 @@ DNS name, and to display or set its hostname or NIS domain name.
|
|||||||
%setup -q -n hostname
|
%setup -q -n hostname
|
||||||
%patch1 -p1 -b .rh
|
%patch1 -p1 -b .rh
|
||||||
|
|
||||||
#man pages conversion
|
|
||||||
#french
|
|
||||||
iconv -f iso-8859-1 -t utf-8 -o hostname.tmp hostname.1.fr && mv hostname.tmp hostname.1.fr
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make CFLAGS="$RPM_OPT_FLAGS $CFLAGS"
|
make CFLAGS="$RPM_OPT_FLAGS $CFLAGS"
|
||||||
|
|
||||||
%install
|
%install
|
||||||
make BASEDIR=%{buildroot} install
|
make BASEDIR=%{buildroot} install
|
||||||
|
|
||||||
%find_lang %{name} --all-name --with-man
|
%files
|
||||||
|
|
||||||
%files -f %{name}.lang
|
|
||||||
%doc COPYRIGHT
|
%doc COPYRIGHT
|
||||||
/bin/*
|
/bin/*
|
||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 08 2013 Jiri Popelka <jpopelka@redhat.com> - 3.12-3
|
||||||
|
- do not ship outdated french man pages (#919198)
|
||||||
|
|
||||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.12-2
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.12-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user