Update to version 2.1 from upstream
- Remove obsolete patch for libnl build documentation
This commit is contained in:
parent
b7025e7475
commit
dd501e4202
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
/hostapd-2.0.tar.gz
|
/hostapd-2.1.tar.gz
|
||||||
|
@ -1,12 +1,12 @@
|
|||||||
diff -up hostapd-0.7.3/hostapd/Makefile.orig hostapd-0.7.3/hostapd/Makefile
|
diff -up hostapd-2.1/hostapd/Makefile.rpmopt hostapd-2.1/hostapd/Makefile
|
||||||
--- hostapd-0.7.3/hostapd/Makefile.orig 2010-09-07 11:43:39.000000000 -0400
|
--- hostapd-2.1/hostapd/Makefile.rpmopt 2014-02-14 13:25:29.935475165 -0500
|
||||||
+++ hostapd-0.7.3/hostapd/Makefile 2010-12-23 11:50:25.291553001 -0500
|
+++ hostapd-2.1/hostapd/Makefile 2014-02-14 13:26:21.701915670 -0500
|
||||||
@@ -6,6 +6,8 @@ ifndef CFLAGS
|
@@ -6,6 +6,8 @@ ifndef CFLAGS
|
||||||
CFLAGS = -MMD -O2 -Wall -g
|
CFLAGS = -MMD -O2 -Wall -g
|
||||||
endif
|
endif
|
||||||
|
|
||||||
+CFLAGS += $(EXTRA_CFLAGS)
|
+CFLAGS += $(EXTRA_CFLAGS)
|
||||||
+
|
+
|
||||||
CFLAGS += -I../src
|
CFLAGS += -I$(abspath ../src)
|
||||||
CFLAGS += -I../src/utils
|
CFLAGS += -I$(abspath ../src/utils)
|
||||||
|
|
||||||
|
@ -1,22 +0,0 @@
|
|||||||
--- a/hostapd/defconfig
|
|
||||||
+++ b/hostapd/defconfig
|
|
||||||
@@ -22,6 +22,19 @@ CONFIG_DRIVER_HOSTAP=y
|
|
||||||
# Driver interface for drivers using the nl80211 kernel interface
|
|
||||||
CONFIG_DRIVER_NL80211=y
|
|
||||||
|
|
||||||
+# driver_nl80211.c requires libnl. If you are compiling it yourself
|
|
||||||
+# you may need to point hostapd to your version of libnl.
|
|
||||||
+#
|
|
||||||
+#CFLAGS += -I$<path to libnl include files>
|
|
||||||
+#LIBS += -L$<path to libnl library files>
|
|
||||||
+
|
|
||||||
+# Use libnl v2.0 (or 3.0) libraries.
|
|
||||||
+#CONFIG_LIBNL20=y
|
|
||||||
+
|
|
||||||
+# Use libnl 3.2 libraries (if this is selected, CONFIG_LIBNL20 is ignored)
|
|
||||||
+#CONFIG_LIBNL32=y
|
|
||||||
+
|
|
||||||
+
|
|
||||||
# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
|
|
||||||
#CONFIG_DRIVER_BSD=y
|
|
||||||
#CFLAGS += -I/usr/local/include
|
|
16
hostapd.spec
16
hostapd.spec
@ -1,8 +1,8 @@
|
|||||||
%global _hardened_build 1
|
%global _hardened_build 1
|
||||||
|
|
||||||
Name: hostapd
|
Name: hostapd
|
||||||
Version: 2.0
|
Version: 2.1
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
|
Summary: IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://w1.fi/hostapd
|
URL: http://w1.fi/hostapd
|
||||||
@ -14,7 +14,6 @@ Source3: %{name}.sysconfig
|
|||||||
Source4: %{name}.init
|
Source4: %{name}.init
|
||||||
Patch0: %{name}-RPM_OPT_FLAGS.patch
|
Patch0: %{name}-RPM_OPT_FLAGS.patch
|
||||||
Patch1: %{name}-EAP-TLS-server-Fix-TLS-Message-Length-validation.patch
|
Patch1: %{name}-EAP-TLS-server-Fix-TLS-Message-Length-validation.patch
|
||||||
Patch2: %{name}-document-libnl-configuration.patch
|
|
||||||
|
|
||||||
BuildRequires: libnl3-devel
|
BuildRequires: libnl3-devel
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
@ -54,14 +53,11 @@ Logwatch scripts for hostapd.
|
|||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
# Hack Makefile to allow use of RPM_OPT_FLAGS
|
# Hack Makefile to allow use of RPM_OPT_FLAGS
|
||||||
%patch0 -p1
|
%patch0 -p1 -b .rpmopt
|
||||||
|
|
||||||
# git://w1.fi/srv/git/hostap.git
|
# git://w1.fi/srv/git/hostap.git
|
||||||
# commit 586c446e0ff42ae00315b014924ec669023bd8de
|
# commit 586c446e0ff42ae00315b014924ec669023bd8de
|
||||||
%patch1 -p1
|
%patch1 -p1 -b .message_length
|
||||||
|
|
||||||
# http://hostap.epitest.fi/gitweb/gitweb.cgi?p=hostap.git;a=commitdiff;h=3043b4f4550a71487bd9f0cc876d1baddbb7bb5d
|
|
||||||
%patch2 -p1
|
|
||||||
|
|
||||||
# Prepare default config file
|
# Prepare default config file
|
||||||
cat %{SOURCE2} | sed -e 's/HOSTAPD_VERSION/'%{version}'/' > %{name}.conf
|
cat %{SOURCE2} | sed -e 's/HOSTAPD_VERSION/'%{version}'/' > %{name}.conf
|
||||||
@ -180,6 +176,10 @@ fi
|
|||||||
%{_sysconfdir}/logwatch/scripts/services/%{name}
|
%{_sysconfdir}/logwatch/scripts/services/%{name}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 14 2014 John W. Linville <linville@redhat.com> - 2.1-1
|
||||||
|
- Update to version 2.1 from upstream
|
||||||
|
- Remove obsolete patch for libnl build documentation
|
||||||
|
|
||||||
* Mon Feb 03 2014 Simone Caronni <negativo17@gmail.com> - 2.0-6
|
* Mon Feb 03 2014 Simone Caronni <negativo17@gmail.com> - 2.0-6
|
||||||
- Add libnl build documentation and switch libnl-devel to libnl3-devel build
|
- Add libnl build documentation and switch libnl-devel to libnl3-devel build
|
||||||
dependency (#1041471).
|
dependency (#1041471).
|
||||||
|
Loading…
Reference in New Issue
Block a user