Update to version 0.7.3
This commit is contained in:
parent
1118fe3d7f
commit
41e739b0a4
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
hostapd-0.6.10.tar.gz
|
||||
/hostapd-0.7.3.tar.gz
|
||||
|
@ -1,21 +0,0 @@
|
||||
diff -up hostapd-0.6.9/hostapd/hostapd.c.orig hostapd-0.6.9/hostapd/hostapd.c
|
||||
--- hostapd-0.6.9/hostapd/hostapd.c.orig 2009-12-16 14:25:27.000000000 -0500
|
||||
+++ hostapd-0.6.9/hostapd/hostapd.c 2009-12-16 14:27:00.000000000 -0500
|
||||
@@ -1338,7 +1338,7 @@ static int hostapd_setup_bss(struct host
|
||||
}
|
||||
|
||||
if (!hostapd_drv_none(hapd)) {
|
||||
- wpa_printf(MSG_ERROR, "Using interface %s with hwaddr " MACSTR
|
||||
+ wpa_printf(MSG_DEBUG, "Using interface %s with hwaddr " MACSTR
|
||||
" and ssid '%s'",
|
||||
hapd->conf->iface, MAC2STR(hapd->own_addr),
|
||||
hapd->conf->ssid.ssid);
|
||||
@@ -1937,7 +1937,7 @@ int main(int argc, char *argv[])
|
||||
|
||||
/* Initialize interfaces */
|
||||
for (i = 0; i < interfaces.count; i++) {
|
||||
- wpa_printf(MSG_ERROR, "Configuration file: %s",
|
||||
+ wpa_printf(MSG_DEBUG, "Configuration file: %s",
|
||||
argv[optind + i]);
|
||||
interfaces.iface[i] = hostapd_init(argv[optind + i]);
|
||||
if (!interfaces.iface[i])
|
@ -1,46 +0,0 @@
|
||||
commit 8fac32f5efa7a7c3fc6eee8d3723a09e7abe27fa
|
||||
Author: Jouni Malinen <jouni.malinen@atheros.com>
|
||||
Date: Thu Mar 12 21:57:08 2009 +0200
|
||||
|
||||
Move DTIM period configuration into Beacon set operation
|
||||
|
||||
This is needed to make mac80211 work with multi-BSS configuration. The
|
||||
previous design ended up setting DTIM period for secondary BSSes before
|
||||
setting the Beacon and driver_nl80211.c was not really prepared for
|
||||
that. Eventually, the Beacon configuration routines should be combined
|
||||
into a single driver operation, but for now, just moving this call is
|
||||
the simplest workaround.
|
||||
(cherry picked from commit eb1f7446b5b86cceb1508f060f5e66e5dd791a4d)
|
||||
|
||||
diff --git a/hostapd/beacon.c b/hostapd/beacon.c
|
||||
index 1f82d9c..0a192fe 100644
|
||||
--- a/hostapd/beacon.c
|
||||
+++ b/hostapd/beacon.c
|
||||
@@ -434,6 +434,10 @@ void ieee802_11_set_beacon(struct hostapd_data *hapd)
|
||||
os_free(tail);
|
||||
os_free(head);
|
||||
|
||||
+ if (hostapd_set_dtim_period(hapd, hapd->conf->dtim_period))
|
||||
+ wpa_printf(MSG_ERROR, "Could not set DTIM period for kernel "
|
||||
+ "driver");
|
||||
+
|
||||
if (hostapd_set_cts_protect(hapd, cts_protection))
|
||||
wpa_printf(MSG_ERROR, "Failed to set CTS protect in kernel "
|
||||
"driver");
|
||||
diff --git a/hostapd/hostapd.c b/hostapd/hostapd.c
|
||||
index 3fbd3d0..7ed1720 100644
|
||||
--- a/hostapd/hostapd.c
|
||||
+++ b/hostapd/hostapd.c
|
||||
@@ -1376,12 +1376,6 @@ static int hostapd_setup_bss(struct hostapd_data *hapd, int first)
|
||||
return -1;
|
||||
}
|
||||
|
||||
- if (hostapd_set_dtim_period(hapd, hapd->conf->dtim_period)) {
|
||||
- wpa_printf(MSG_ERROR, "Could not set DTIM period for kernel "
|
||||
- "driver");
|
||||
- return -1;
|
||||
- }
|
||||
-
|
||||
/* Set SSID for the kernel driver (to be used in beacon and probe
|
||||
* response frames) */
|
||||
if (set_ssid && hostapd_set_ssid(hapd, (u8 *) conf->ssid.ssid,
|
@ -1,12 +1,12 @@
|
||||
diff -up hostapd-0.6.9/hostapd/Makefile.orig hostapd-0.6.9/hostapd/Makefile
|
||||
--- hostapd-0.6.9/hostapd/Makefile.orig 2009-12-16 18:16:19.000000000 -0500
|
||||
+++ hostapd-0.6.9/hostapd/Makefile 2009-12-16 18:16:42.000000000 -0500
|
||||
diff -up hostapd-0.7.3/hostapd/Makefile.orig hostapd-0.7.3/hostapd/Makefile
|
||||
--- hostapd-0.7.3/hostapd/Makefile.orig 2010-09-07 11:43:39.000000000 -0400
|
||||
+++ hostapd-0.7.3/hostapd/Makefile 2010-12-23 11:50:25.291553001 -0500
|
||||
@@ -6,6 +6,8 @@ ifndef CFLAGS
|
||||
CFLAGS = -MMD -O2 -Wall -g
|
||||
endif
|
||||
|
||||
+CFLAGS += $(EXTRA_CFLAGS)
|
||||
+
|
||||
# define HOSTAPD_DUMP_STATE to include SIGUSR1 handler for dumping state to
|
||||
# a file (undefine it, if you want to save in binary size)
|
||||
CFLAGS += -DHOSTAPD_DUMP_STATE
|
||||
CFLAGS += -I../src
|
||||
CFLAGS += -I../src/utils
|
||||
|
||||
|
15
hostapd.spec
15
hostapd.spec
@ -1,6 +1,6 @@
|
||||
Name: hostapd
|
||||
Version: 0.6.10
|
||||
Release: 3%{?dist}
|
||||
Version: 0.7.3
|
||||
Release: 1%{?dist}
|
||||
Summary: IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
|
||||
Group: System Environment/Daemons
|
||||
License: BSD
|
||||
@ -11,8 +11,6 @@ Source1: %{name}.init
|
||||
Source2: %{name}.conf
|
||||
Source3: %{name}.sysconfig
|
||||
Patch0: hostapd-RPM_OPT_FLAGS.patch
|
||||
Patch1: hostapd-MSG_DEBUG.patch
|
||||
Patch2: hostapd-Move-DTIM-period-configuration-into-Beacon-set-operation.patch
|
||||
|
||||
BuildRequires: libnl-devel >= 1.1
|
||||
BuildRequires: openssl-devel
|
||||
@ -46,12 +44,6 @@ Logwatch scripts for hostapd
|
||||
# Hack Makefile to allow use of RPM_OPT_FLAGS
|
||||
%patch0 -p1
|
||||
|
||||
# Quiet some unnecessary console spam at startup
|
||||
%patch1 -p1
|
||||
|
||||
# fix DTIM-setting issue w/ mac80211
|
||||
%patch2 -p1
|
||||
|
||||
|
||||
%build
|
||||
cd hostapd
|
||||
@ -143,6 +135,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Dec 23 2010 John W. Linville <linville@redhat.com> - 0.7.3-1
|
||||
- Update to version 0.7.3
|
||||
|
||||
* Wed Nov 24 2010 John W. Linville <linville@redhat.com> - 0.6.10-3
|
||||
- Use ghost directive for /var/run/hostapd
|
||||
- Remove some rpmlint warnings
|
||||
|
Loading…
Reference in New Issue
Block a user