843c9dc66e
- Fixes handling of keys which use ri-records, for both reading and writing (RHBZ#717583, RHBZ#987463). - Remove upstream patch. - Rebase dirs patch against new upstream sources. - Rebase ruby patch against new upstream sources. - Modernize the RPM spec file. - Fix .gitignore.
23 lines
1006 B
Diff
23 lines
1006 B
Diff
--- hivex-1.3.8.old/ruby/Makefile.am 2013-07-25 15:09:00.000000000 +0100
|
|
+++ hivex-1.3.8/ruby/Makefile.am 2013-07-25 23:17:05.888067146 +0100
|
|
@@ -45,13 +45,13 @@
|
|
$(RAKE) build
|
|
$(RAKE) rdoc
|
|
|
|
-RUBY_SITELIB := $(shell $(RUBY) -rrbconfig -e "puts RbConfig::CONFIG['sitelibdir']")
|
|
-RUBY_SITEARCH := $(shell $(RUBY) -rrbconfig -e "puts RbConfig::CONFIG['sitearchdir']")
|
|
+RUBY_VENDORLIB := $(shell $(RUBY) -rrbconfig -e "puts RbConfig::CONFIG['vendorlibdir']")
|
|
+RUBY_VENDORARCH := $(shell $(RUBY) -rrbconfig -e "puts RbConfig::CONFIG['vendorarchdir']")
|
|
|
|
install:
|
|
- $(MKDIR_P) $(DESTDIR)$(RUBY_SITELIB)
|
|
- $(MKDIR_P) $(DESTDIR)$(RUBY_SITEARCH)
|
|
- $(INSTALL) -p -m 0644 lib/hivex.rb $(DESTDIR)$(RUBY_SITELIB)
|
|
- $(INSTALL) -p -m 0755 ext/hivex/_hivex.so $(DESTDIR)$(RUBY_SITEARCH)
|
|
+ $(MKDIR_P) $(DESTDIR)$(RUBY_VENDORLIB)
|
|
+ $(MKDIR_P) $(DESTDIR)$(RUBY_VENDORARCH)
|
|
+ $(INSTALL) -p -m 0644 lib/hivex.rb $(DESTDIR)$(RUBY_VENDORLIB)
|
|
+ $(INSTALL) -p -m 0755 ext/hivex/_hivex.so $(DESTDIR)$(RUBY_VENDORARCH)
|
|
|
|
endif
|