23 lines
998 B
Diff
23 lines
998 B
Diff
--- hivex-1.3.3/ruby/Makefile.am.old 2012-02-08 10:57:43.447667670 +0000
|
|
+++ hivex-1.3.3/ruby/Makefile.am 2012-02-08 10:58:29.024440505 +0000
|
|
@@ -47,13 +47,13 @@
|
|
$(RAKE) build
|
|
$(RAKE) rdoc
|
|
|
|
-RUBY_SITELIB := $(shell $(RUBY) -rrbconfig -e "puts Config::CONFIG['sitelibdir']")
|
|
-RUBY_SITEARCH := $(shell $(RUBY) -rrbconfig -e "puts Config::CONFIG['sitearchdir']")
|
|
+RUBY_VENDORLIB := $(shell $(RUBY) -rrbconfig -e "puts Config::CONFIG['vendorlibdir']")
|
|
+RUBY_VENDORARCH := $(shell $(RUBY) -rrbconfig -e "puts Config::CONFIG['vendorarchdir']")
|
|
|
|
install:
|
|
- $(MKDIR_P) $(DESTDIR)$(RUBY_SITELIB)
|
|
- $(MKDIR_P) $(DESTDIR)$(RUBY_SITEARCH)
|
|
- $(INSTALL) -p -m 0644 lib/hivex.rb $(DESTDIR)$(RUBY_SITELIB)
|
|
- $(INSTALL) -p -m 0755 ext/hivex/_hivex.so $(DESTDIR)$(RUBY_SITEARCH)
|
|
+ $(MKDIR_P) $(DESTDIR)$(RUBY_VENDORLIB)
|
|
+ $(MKDIR_P) $(DESTDIR)$(RUBY_VENDORARCH)
|
|
+ $(INSTALL) -p -m 0644 lib/hivex.rb $(DESTDIR)$(RUBY_VENDORLIB)
|
|
+ $(INSTALL) -p -m 0755 ext/hivex/_hivex.so $(DESTDIR)$(RUBY_VENDORARCH)
|
|
|
|
endif
|