New upstream version 1.3.3.
- Rebased gnulib to work around RHBZ#756981. - Remove patches which are now upstream.
This commit is contained in:
parent
03c8b9bf04
commit
bcf9c37b7c
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@ hivex-1.2.2.tar.gz
|
|||||||
/hivex-1.3.0.tar.gz
|
/hivex-1.3.0.tar.gz
|
||||||
/hivex-1.3.1.tar.gz
|
/hivex-1.3.1.tar.gz
|
||||||
/hivex-1.3.2.tar.gz
|
/hivex-1.3.2.tar.gz
|
||||||
|
/hivex-1.3.3.tar.gz
|
||||||
|
@ -1,36 +0,0 @@
|
|||||||
Only in hivex-1.3.2: autom4te.cache
|
|
||||||
diff -ur hivex-1.3.2.old/configure hivex-1.3.2/configure
|
|
||||||
--- hivex-1.3.2.old/configure 2011-10-24 17:22:58.000000000 +0100
|
|
||||||
+++ hivex-1.3.2/configure 2011-10-24 18:24:55.328126051 +0100
|
|
||||||
@@ -21859,13 +21859,12 @@
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
-for ac_func in bindtextdomain open_memstream
|
|
||||||
+for ac_func in bindtextdomain
|
|
||||||
do :
|
|
||||||
- as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
|
|
||||||
-ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
|
|
||||||
-if eval test \"x\$"$as_ac_var"\" = x"yes"; then :
|
|
||||||
+ ac_fn_c_check_func "$LINENO" "bindtextdomain" "ac_cv_func_bindtextdomain"
|
|
||||||
+if test "x$ac_cv_func_bindtextdomain" = xyes; then :
|
|
||||||
cat >>confdefs.h <<_ACEOF
|
|
||||||
-#define `$as_echo "HAVE_$ac_func" | $as_tr_cpp` 1
|
|
||||||
+#define HAVE_BINDTEXTDOMAIN 1
|
|
||||||
_ACEOF
|
|
||||||
|
|
||||||
fi
|
|
||||||
@@ -24131,7 +24130,12 @@
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
- if test "x$HAVE_OPEN_MEMSTREAM" = "xyes"; then
|
|
||||||
+ac_fn_c_check_func "$LINENO" "open_memstream" "ac_cv_func_open_memstream"
|
|
||||||
+if test "x$ac_cv_func_open_memstream" = xyes; then :
|
|
||||||
+
|
|
||||||
+fi
|
|
||||||
+
|
|
||||||
+ if test "x$ac_cv_func_open_memstream" = "xyes"; then
|
|
||||||
HAVE_HIVEXSH_TRUE=
|
|
||||||
HAVE_HIVEXSH_FALSE='#'
|
|
||||||
else
|
|
@ -1,36 +0,0 @@
|
|||||||
From a6ba26dca8dd496bec71d65746b3c3b65e604f03 Mon Sep 17 00:00:00 2001
|
|
||||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
||||||
Date: Mon, 24 Oct 2011 18:15:48 +0100
|
|
||||||
Subject: [PATCH] Fix conditional test for HAVE_HIVEXSH.
|
|
||||||
|
|
||||||
This fixes commit 0a28041f4156878a74543966f9a72ed3d214ba44.
|
|
||||||
---
|
|
||||||
configure.ac | 5 +++--
|
|
||||||
1 files changed, 3 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 617ec50..547bf0a 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -137,7 +137,7 @@ dnl Check for mmap
|
|
||||||
AC_REPLACE_FUNCS([mmap])
|
|
||||||
|
|
||||||
dnl Functions.
|
|
||||||
-AC_CHECK_FUNCS([bindtextdomain open_memstream])
|
|
||||||
+AC_CHECK_FUNCS([bindtextdomain])
|
|
||||||
|
|
||||||
dnl Check for pod2man and pod2text.
|
|
||||||
AC_CHECK_PROG([POD2MAN],[pod2man],[pod2man],[no])
|
|
||||||
@@ -177,7 +177,8 @@ AC_SUBST([LIBXML2_CFLAGS])
|
|
||||||
AC_SUBST([LIBXML2_LIBS])
|
|
||||||
|
|
||||||
dnl hivexsh depends on open_memstream, which is absent on OS X.
|
|
||||||
-AM_CONDITIONAL([HAVE_HIVEXSH],[test "x$HAVE_OPEN_MEMSTREAM" = "xyes"])
|
|
||||||
+AC_CHECK_FUNC([open_memstream])
|
|
||||||
+AM_CONDITIONAL([HAVE_HIVEXSH],[test "x$ac_cv_func_open_memstream" = "xyes"])
|
|
||||||
|
|
||||||
dnl Check for OCaml (optional, for OCaml bindings).
|
|
||||||
AC_PROG_OCAML
|
|
||||||
--
|
|
||||||
1.7.6
|
|
||||||
|
|
16
hivex.spec
16
hivex.spec
@ -6,8 +6,8 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: hivex
|
Name: hivex
|
||||||
Version: 1.3.2
|
Version: 1.3.3
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Read and write Windows Registry binary hive files
|
Summary: Read and write Windows Registry binary hive files
|
||||||
|
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
@ -40,11 +40,6 @@ Conflicts: libguestfs <= 1:1.0.84
|
|||||||
# Fix Perl directory install path.
|
# Fix Perl directory install path.
|
||||||
Patch0: %{name}-1.2.3-dirs.patch
|
Patch0: %{name}-1.2.3-dirs.patch
|
||||||
|
|
||||||
# Upstream patch to fix building hivexsh, hivexget commands.
|
|
||||||
# Second patch is autoconf generated changes.
|
|
||||||
Patch1: 0001-Fix-conditional-test-for-HAVE_HIVEXSH.patch
|
|
||||||
Patch2: 0001-Fix-conditional-test-for-HAVE_HIVEXSH-autoconf.patch
|
|
||||||
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Hive files are the undocumented binary blobs that Windows uses to
|
Hive files are the undocumented binary blobs that Windows uses to
|
||||||
@ -168,8 +163,6 @@ ruby-%{name} contains Ruby bindings for %{name}.
|
|||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch0 -p1 -b .dirs
|
%patch0 -p1 -b .dirs
|
||||||
%patch1 -p1
|
|
||||||
%patch2 -p1
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -282,6 +275,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 29 2011 Richard W.M. Jones <rjones@redhat.com> - 1.3.3-1
|
||||||
|
- New upstream version 1.3.3.
|
||||||
|
- Rebased gnulib to work around RHBZ#756981.
|
||||||
|
- Remove patches which are now upstream.
|
||||||
|
|
||||||
* Mon Oct 24 2011 Richard W.M. Jones <rjones@redhat.com> - 1.3.2-3
|
* Mon Oct 24 2011 Richard W.M. Jones <rjones@redhat.com> - 1.3.2-3
|
||||||
- New upstream version 1.3.2.
|
- New upstream version 1.3.2.
|
||||||
- Add upstream patch to fix building of hivexsh, hivexget.
|
- Add upstream patch to fix building of hivexsh, hivexget.
|
||||||
|
Loading…
Reference in New Issue
Block a user