import hivex-1.3.18-20.module+el8.3.0+6423+e4cb6418
This commit is contained in:
parent
040e58bd95
commit
89fef1edfa
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
||||
SOURCES/hivex-1.3.15.tar.gz
|
||||
SOURCES/hivex-1.3.18.tar.gz
|
||||
SOURCES/libguestfs.keyring
|
||||
|
@ -1,2 +1,2 @@
|
||||
0b93f6947223bfa16012cb23d29437b8074fd29f SOURCES/hivex-1.3.15.tar.gz
|
||||
d66131981d2c978ab9cfc7e28dd052e7e273ae18 SOURCES/hivex-1.3.18.tar.gz
|
||||
1bbc40f501a7fef9eef2a39b701a71aee2fea7c4 SOURCES/libguestfs.keyring
|
||||
|
@ -0,0 +1,24 @@
|
||||
From 564a923a91d042e24e9259d86f69e0061f28ef4f Mon Sep 17 00:00:00 2001
|
||||
From: Vladimir Panteleev <git@thecybershadow.net>
|
||||
Date: Thu, 16 Jan 2020 12:11:20 +0000
|
||||
Subject: [PATCH 1/2] Win::Hivex::Regedit: Accept CRLF line endings
|
||||
|
||||
---
|
||||
perl/lib/Win/Hivex/Regedit.pm | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/perl/lib/Win/Hivex/Regedit.pm b/perl/lib/Win/Hivex/Regedit.pm
|
||||
index 34426f1..2b17036 100644
|
||||
--- a/perl/lib/Win/Hivex/Regedit.pm
|
||||
+++ b/perl/lib/Win/Hivex/Regedit.pm
|
||||
@@ -144,6 +144,7 @@ sub reg_import
|
||||
# this is fairly common in pasted regedit files.
|
||||
$lineno++;
|
||||
chomp;
|
||||
+ s/\r$//;
|
||||
if (s/\\\s*$//) {
|
||||
$_ .= <$fh>;
|
||||
redo unless eof ($fh);
|
||||
--
|
||||
2.24.1
|
||||
|
@ -1,48 +0,0 @@
|
||||
From be51757920b56a77e2e63247f9a8409ce994d33c Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Mon, 26 Feb 2018 12:38:12 +0000
|
||||
Subject: [PATCH] ocaml: Link the C bindings with LDFLAGS (RHBZ#1548536).
|
||||
|
||||
Use the ocamlmklib -ldopt flag to pass the general $(LDFLAGS) when
|
||||
calling gcc to link dllmlhivex.so. We were already passing $(CFLAGS)
|
||||
when building the object file.
|
||||
|
||||
When building using Fedora's standard hardening flags this gives:
|
||||
|
||||
ocamlmklib -o mlhivex hivex_c.o hivex.cmo \
|
||||
-verbose -ldopt '-Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld' \
|
||||
-L../lib/.libs -lhivex
|
||||
+ gcc -shared -o ./dllmlhivex.so hivex_c.o -Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -L../lib/.libs -lhivex
|
||||
+ ar rc ./libmlhivex.a hivex_c.o; ranlib ./libmlhivex.a
|
||||
+ /usr/bin/ocamlc -a -o mlhivex.cma hivex.cmo -dllib -lmlhivex -cclib -lmlhivex -cclib -L../lib/.libs -cclib -lhivex
|
||||
|
||||
This also works if $(LDFLAGS) is empty, because ocamlmklib ignores
|
||||
-ldopt ''.
|
||||
---
|
||||
ocaml/Makefile.am | 8 ++++++--
|
||||
1 file changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/ocaml/Makefile.am b/ocaml/Makefile.am
|
||||
index 61db095..85655b6 100644
|
||||
--- a/ocaml/Makefile.am
|
||||
+++ b/ocaml/Makefile.am
|
||||
@@ -41,10 +41,14 @@ OBJS = hivex_c.o hivex.cmo
|
||||
XOBJS = $(OBJS:.cmo=.cmx)
|
||||
|
||||
mlhivex.cma: $(OBJS)
|
||||
- $(OCAMLMKLIB) -o mlhivex $^ -L$(top_builddir)/lib/.libs -lhivex
|
||||
+ $(OCAMLMKLIB) -o mlhivex $^ \
|
||||
+ -ldopt '$(LDFLAGS)' \
|
||||
+ -L$(top_builddir)/lib/.libs -lhivex
|
||||
|
||||
mlhivex.cmxa: $(XOBJS)
|
||||
- $(OCAMLMKLIB) -o mlhivex $^ -L$(top_builddir)/lib/.libs -lhivex
|
||||
+ $(OCAMLMKLIB) -o mlhivex $^ \
|
||||
+ -ldopt '$(LDFLAGS)' \
|
||||
+ -L$(top_builddir)/lib/.libs -lhivex
|
||||
|
||||
hivex_c.o: hivex_c.c
|
||||
$(CC) $(AM_CPPFLAGS) $(CFLAGS) -fPIC -Wall -c $<
|
||||
--
|
||||
2.13.2
|
||||
|
36
SOURCES/0002-Win-Hivex-Regedit-Ignore-comments.patch
Normal file
36
SOURCES/0002-Win-Hivex-Regedit-Ignore-comments.patch
Normal file
@ -0,0 +1,36 @@
|
||||
From 003028c3c0d33e952430d3f4e1a987a777674eb3 Mon Sep 17 00:00:00 2001
|
||||
From: Vladimir Panteleev <git@thecybershadow.net>
|
||||
Date: Thu, 16 Jan 2020 12:11:21 +0000
|
||||
Subject: [PATCH 2/2] Win::Hivex::Regedit: Ignore comments
|
||||
|
||||
---
|
||||
perl/lib/Win/Hivex/Regedit.pm | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/perl/lib/Win/Hivex/Regedit.pm b/perl/lib/Win/Hivex/Regedit.pm
|
||||
index 2b17036..f0dbb50 100644
|
||||
--- a/perl/lib/Win/Hivex/Regedit.pm
|
||||
+++ b/perl/lib/Win/Hivex/Regedit.pm
|
||||
@@ -153,8 +153,8 @@ sub reg_import
|
||||
#print STDERR "reg_import: parsing <<<$_>>>\n";
|
||||
|
||||
if ($state eq "outer") {
|
||||
- # Ignore blank lines, headers.
|
||||
- next if /^\s*$/;
|
||||
+ # Ignore blank lines, headers, comments.
|
||||
+ next if /^\s*(;.*)?$/;
|
||||
|
||||
# .* is needed before Windows Registry Editor Version.. in
|
||||
# order to eat a possible Unicode BOM which regedit writes
|
||||
@@ -193,7 +193,7 @@ sub reg_import
|
||||
my $value = _parse_value ("", $1, $encoding);
|
||||
croak (_parse_error ($_, $lineno)) unless defined $value;
|
||||
push @newvalues, $value;
|
||||
- } elsif (/^\s*$/) { # blank line after values
|
||||
+ } elsif (/^\s*(;.*)?$/) { # blank line after values
|
||||
_merge_node ($hmap, \%params, $newnode, \@newvalues, \@delvalues);
|
||||
$state = "outer";
|
||||
} else {
|
||||
--
|
||||
2.24.1
|
||||
|
@ -1,16 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
|
||||
iQIcBAABAgAGBQJalDSOAAoJEJFzj3Pht2igdNYP/2R2+SkPNutZfQpUZfiKD/vQ
|
||||
RRAQjePYncUjNUc2WgX7LXmJN1z9WfKRzUGqQG7sD/B7BnecBtEOP4Dyw5PpjgBQ
|
||||
ae4ErdeU6uFv5xSiprnYErfGJrhYSBfDKilDjrdO7J4AlTlVVlgfeb7C5TopER81
|
||||
brVJ7iXuF6rbZmQP3c0D3GWdez3Nw719e6MmdM9FFGQQS8hg9vZlNYQPyiFEQx1U
|
||||
nNjSMaoft+OWYEQp56arjPOLj4JiIcIH9B/HLu8Tcl4FEogTCVyMsodyEFXzfBUm
|
||||
21UfIn/RNEXjI8DJ/k7kh35uWEwv8hb/0YszGAWNpSt+rrdx9+decjNdNI2DZs65
|
||||
XEcuboWN7UOZJf2p+8f78QVcbwNPRjpnfGZaVLYJYNON3y/lyvhrA8je5FOzsyVA
|
||||
4G6BwU3ythoS2NTK3Q76I7UdMDvz6vydgsLAruVVtMX5x1M7fXoplRxi1nkRjCvQ
|
||||
Qgmo0L/rwwDUitRmlRyyJqZK7j+lMlltuZAck9XCUtd72VRAUj4f56I8Xo2wwT0Y
|
||||
ioFer6o02K18pjhGLikV4ujUUKAkC1lAK1QhsEsp7y2isOe1mA3ptcGrz4rElcaH
|
||||
f78Yr7b28Gl9HSGg98uhYEwWVCl5fUwXhDUQVVNutDRPKI479O390uGG7ZNZTghS
|
||||
Lv/P/Uz1ijp+m8Hi5WsX
|
||||
=gmjv
|
||||
-----END PGP SIGNATURE-----
|
17
SOURCES/hivex-1.3.18.tar.gz.sig
Normal file
17
SOURCES/hivex-1.3.18.tar.gz.sig
Normal file
@ -0,0 +1,17 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
|
||||
iQJFBAABCAAvFiEE93dPsa0HSn6Mh2fqkXOPc+G3aKAFAlxJfxkRHHJpY2hAYW5u
|
||||
ZXhpYS5vcmcACgkQkXOPc+G3aKCZBRAAqXBbrDyf+TtXCLZBIrs0MkfrYtQFDxps
|
||||
nTNz6sdNXftYl0LKJ6dhEkNwVg0QP31ifX1mQfU4EmJiEOI7qW6xqNLPlwhkKaIP
|
||||
qoB7ctesELb3LBhcgjI9lUjaCeGXrWkIHxp9SWC3esGqHIxWVu+BwKmFt1DfAZtH
|
||||
KE9gtVO6g5sbCdZEP2b4d/PwsL1vO0glekCkEZ0n3PcOgf0isVU0IUSz2IVhcy6e
|
||||
DqY4puYFwopVEpPzzRI9oW/y2XJTTssCM9F420HDnemtUQpx0Uw637MiCRLoN6Or
|
||||
PA1IkTzx/01Ub6OKl3gbMoY3s27yOFJToBVkTmYDvZHUJpNRCj7ytaKAIiZ4aan7
|
||||
WOi+7h9cvkjcr0OhomN+5bDLg6XpaVj9SPuM3W/AgDaYu6PeSvpr5yAtg3VEArJ3
|
||||
Lh4y8b+fh1pzdkLJsvGxK+YpL+ollgTP2y2CAXxgTDv0oMrUI9O4vrNKaOSE4Qnl
|
||||
TinMMFaYvuBWzzTKfjhtnFOMI8YvAFHHVDhBSWost2ZR5W6SCd9xXAvMdUQDL3aD
|
||||
ReesInrLptdklyKL+4l8miokUfq+U0ASi1PC3+Ek/yk13LtUXHEvXfb9rQlPhOc3
|
||||
Fp1278JziKQd7xlkvMuo+Q2PSRGSDaBACqmqjwBaLsPDoz8jsiZOZ/qPg6qcx0kM
|
||||
y93C/w1pCcA=
|
||||
=YBlx
|
||||
-----END PGP SIGNATURE-----
|
@ -9,8 +9,8 @@
|
||||
%global verify_tarball_signature 1
|
||||
|
||||
Name: hivex
|
||||
Version: 1.3.15
|
||||
Release: 7%{?dist}
|
||||
Version: 1.3.18
|
||||
Release: 20%{?dist}
|
||||
Summary: Read and write Windows Registry binary hive files
|
||||
|
||||
License: LGPLv2
|
||||
@ -26,10 +26,9 @@ Source1: http://libguestfs.org/download/hivex/%{name}-%{version}.tar.gz.s
|
||||
Source2: libguestfs.keyring
|
||||
%endif
|
||||
|
||||
# Upstream patch to fix injection of LDFLAGS.
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1548536
|
||||
Patch1: 0001-ocaml-Link-the-C-bindings-with-LDFLAGS-RHBZ-1548536.patch
|
||||
BuildRequires: autoconf, automake, libtool, gettext-devel
|
||||
# Patches - all upstream since 1.3.18.
|
||||
Patch0001: 0001-Win-Hivex-Regedit-Accept-CRLF-line-endings.patch
|
||||
Patch0002: 0002-Win-Hivex-Regedit-Ignore-comments.patch
|
||||
|
||||
BuildRequires: perl-interpreter
|
||||
BuildRequires: perl-devel
|
||||
@ -176,13 +175,10 @@ gpgv2 --homedir "$tmphome" --keyring %{SOURCE2} %{SOURCE1} %{SOURCE0}
|
||||
%setup -q
|
||||
%autopatch -p1
|
||||
|
||||
# Because the patch touches Makefile.am, rerun autotools.
|
||||
autoreconf -i -f
|
||||
|
||||
|
||||
%build
|
||||
%configure \
|
||||
PYTHON=/usr/bin/python3 \
|
||||
PYTHON=%{__python3} \
|
||||
--disable-static \
|
||||
%if !%{with ocaml}
|
||||
--disable-ocaml \
|
||||
@ -209,13 +205,15 @@ rm $RPM_BUILD_ROOT%{python3_sitearch}/libhivexmod.la
|
||||
|
||||
|
||||
%check
|
||||
make check
|
||||
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
if ! make check -k; then
|
||||
for f in $( find -name test-suite.log | xargs grep -l ^FAIL: ); do
|
||||
echo
|
||||
echo "***" $f "***"
|
||||
cat $f
|
||||
echo
|
||||
done
|
||||
exit 1
|
||||
fi
|
||||
|
||||
%files -f %{name}.lang
|
||||
%doc README LICENSE
|
||||
@ -276,6 +274,14 @@ make check
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Apr 27 2020 Danilo C. L. de Paula <ddepaula@redhat.com> - 1.3.18
|
||||
- Resolves: bz#1810193
|
||||
(Upgrade components in virt:rhel module:stream for RHEL-8.3 release)
|
||||
|
||||
* Mon Apr 27 2020 Danilo C. L. de Paula <ddepaula@redhat.com> - 1.3.18
|
||||
- Resolves: bz#1810193
|
||||
(Upgrade components in virt:rhel module:stream for RHEL-8.3 release)
|
||||
|
||||
* Fri Jun 28 2019 Danilo de Paula <ddepaula@redhat.com> - 1.3.15-7
|
||||
- Rebuild all virt packages to fix RHEL's upgrade path
|
||||
- Resolves: rhbz#1695587
|
||||
|
Loading…
Reference in New Issue
Block a user