- New upstream version 1.2.5.
- This version fixes a number of important memory issues found by valgrind and upgrading to this version is recommended for all users. - Remove patch now upstream.
This commit is contained in:
parent
30cad61f34
commit
5e1b02358d
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
hivex-1.2.2.tar.gz
|
||||
/hivex-1.2.3.tar.gz
|
||||
/hivex-1.2.4.tar.gz
|
||||
/hivex-1.2.5.tar.gz
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff -ur hivex-1.2.4.old/ocaml/hivex_c.c hivex-1.2.4/ocaml/hivex_c.c
|
||||
--- hivex-1.2.4.old/ocaml/hivex_c.c 2010-11-26 18:12:20.000000000 +0000
|
||||
+++ hivex-1.2.4/ocaml/hivex_c.c 2010-12-16 13:53:09.049192941 +0000
|
||||
@@ -813,7 +813,7 @@
|
||||
Store_field (rv, 0, v);
|
||||
v = caml_alloc_string (len);
|
||||
memcpy (String_val (v), r, len);
|
||||
- caml_modify (&Field (rv, 1), len);
|
||||
+ caml_modify (&Field (rv, 1), v);
|
||||
CAMLreturn (rv);
|
||||
}
|
||||
|
||||
Only in hivex-1.2.4/ocaml: hivex_c.c~
|
14
hivex.spec
14
hivex.spec
@ -6,8 +6,8 @@
|
||||
%endif
|
||||
|
||||
Name: hivex
|
||||
Version: 1.2.4
|
||||
Release: 7%{?dist}
|
||||
Version: 1.2.5
|
||||
Release: 1%{?dist}
|
||||
Summary: Read and write Windows Registry binary hive files
|
||||
|
||||
Group: Development/Libraries
|
||||
@ -38,9 +38,6 @@ Conflicts: libguestfs <= 1:1.0.84
|
||||
# Fix Perl directory install path.
|
||||
Patch0: %{name}-1.2.3-dirs.patch
|
||||
|
||||
# Fix segfault in OCaml binding of Hivex.value_value.
|
||||
Patch1: hivex-1.2.4-fix-ocaml-value-value.patch
|
||||
|
||||
|
||||
%description
|
||||
Hive files are the undocumented binary blobs that Windows uses to
|
||||
@ -147,7 +144,6 @@ python-%{name} contains Python bindings for %{name}.
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1 -b .dirs
|
||||
%patch1 -p1
|
||||
|
||||
|
||||
%build
|
||||
@ -256,6 +252,12 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Apr 13 2011 Richard W.M. Jones <rjones@redhat.com> - 1.2.5-1
|
||||
- New upstream version 1.2.5.
|
||||
- This version fixes a number of important memory issues found by
|
||||
valgrind and upgrading to this version is recommended for all users.
|
||||
- Remove patch now upstream.
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.4-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user