New upstream version 1.3.15.
This commit is contained in:
parent
aec532f367
commit
5265c98494
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
||||
/clog
|
||||
/hivex-*.tar.gz
|
||||
/hivex-1.3.14.tar.gz.sig
|
||||
/hivex-1.3.15.tar.gz.sig
|
||||
|
@ -1,37 +0,0 @@
|
||||
From 87de49cebbf028ebb0f9950ab9e8fed97807c86e Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Wed, 8 Nov 2017 18:04:15 +0000
|
||||
Subject: [PATCH 1/2] generator: Use Bytes instead of String.
|
||||
|
||||
---
|
||||
generator/generator.ml | 10 +++++-----
|
||||
1 file changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/generator/generator.ml b/generator/generator.ml
|
||||
index 4125ae7..0401217 100755
|
||||
--- a/generator/generator.ml
|
||||
+++ b/generator/generator.ml
|
||||
@@ -415,15 +415,15 @@ let failwithf fs = ksprintf failwith fs
|
||||
let unique = let i = ref 0 in fun () -> incr i; !i
|
||||
|
||||
let replace_char s c1 c2 =
|
||||
- let s2 = String.copy s in
|
||||
+ let s2 = Bytes.of_string s in
|
||||
let r = ref false in
|
||||
- for i = 0 to String.length s2 - 1 do
|
||||
- if String.unsafe_get s2 i = c1 then (
|
||||
- String.unsafe_set s2 i c2;
|
||||
+ for i = 0 to String.length s - 1 do
|
||||
+ if String.unsafe_get s i = c1 then (
|
||||
+ Bytes.unsafe_set s2 i c2;
|
||||
r := true
|
||||
)
|
||||
done;
|
||||
- if not !r then s else s2
|
||||
+ if not !r then s else Bytes.to_string s2
|
||||
|
||||
let isspace c =
|
||||
c = ' '
|
||||
--
|
||||
2.13.1
|
||||
|
@ -1,33 +0,0 @@
|
||||
From f45648c58c18f35507475363e12a33589fb6a5f2 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Wed, 8 Nov 2017 18:05:31 +0000
|
||||
Subject: [PATCH 2/2] ocaml/t/hivex_200_write.ml: Use Bytes instead of String.
|
||||
|
||||
---
|
||||
ocaml/t/hivex_200_write.ml | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/ocaml/t/hivex_200_write.ml b/ocaml/t/hivex_200_write.ml
|
||||
index f70deee..97d9597 100644
|
||||
--- a/ocaml/t/hivex_200_write.ml
|
||||
+++ b/ocaml/t/hivex_200_write.ml
|
||||
@@ -55,14 +55,14 @@ let () =
|
||||
and utf16le_of_ascii str =
|
||||
let len = String.length str in
|
||||
let len' = len * 2 + 2 in
|
||||
- let str' = String.create len' in
|
||||
+ let str' = Bytes.create len' in
|
||||
for i = 0 to len-1 do
|
||||
str'.[i*2] <- str.[i];
|
||||
str'.[i*2+1] <- '\000'
|
||||
done;
|
||||
str'.[len'-2] <- '\000';
|
||||
str'.[len'-1] <- '\000';
|
||||
- str'
|
||||
+ Bytes.to_string str'
|
||||
in
|
||||
iter 0 0 (Hivex.root h);
|
||||
|
||||
--
|
||||
2.13.1
|
||||
|
11
hivex.spec
11
hivex.spec
@ -9,8 +9,8 @@
|
||||
%global verify_tarball_signature 1
|
||||
|
||||
Name: hivex
|
||||
Version: 1.3.14
|
||||
Release: 15%{?dist}
|
||||
Version: 1.3.15
|
||||
Release: 1%{?dist}
|
||||
Summary: Read and write Windows Registry binary hive files
|
||||
|
||||
License: LGPLv2
|
||||
@ -26,10 +26,6 @@ Source1: http://libguestfs.org/download/hivex/%{name}-%{version}.tar.gz.s
|
||||
Source2: libguestfs.keyring
|
||||
%endif
|
||||
|
||||
# Upstream patches to fix string mutability.
|
||||
Patch1: 0001-generator-Use-Bytes-instead-of-String.patch
|
||||
Patch2: 0002-ocaml-t-hivex_200_write.ml-Use-Bytes-instead-of-Stri.patch
|
||||
|
||||
BuildRequires: perl-interpreter
|
||||
BuildRequires: perl-devel
|
||||
BuildRequires: perl-generators
|
||||
@ -328,6 +324,9 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Feb 26 2018 Richard W.M. Jones <rjones@redhat.com> - 1.3.15-1
|
||||
- New upstream version 1.3.15.
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.14-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (hivex-1.3.14.tar.gz) = dd7dd52dceda580179a815fc48a2a2c7e8f7234614beceb937fba7e317df17984e65453338160c4c467b70d7d4f9bd61b48aad3ca51e19bd5e4cfbca8ee3adb6
|
||||
SHA512 (hivex-1.3.14.tar.gz.sig) = 9e4d6dbc2b05a484deb1541edd7e11f4abbd815dd92c30d9049b4b0bb866202c5d8f575b0f7ff6da732e9b56efaffe9fe940042c4fd204b520c60a6c1a65dfa7
|
||||
SHA512 (hivex-1.3.15.tar.gz) = 7ce4fd6842c7545a41dc4c4268db5f0629d618a17f29a68dda6990a0dd4530cdf0e0c654f00104274c57e792aa4bcf712bcac1c76e2fd2dbce9aeae1e5751517
|
||||
SHA512 (hivex-1.3.15.tar.gz.sig) = 9cd0231f9d0293657aeec398c6b601800c7d61925340504c338a04339d7fa6d534f5b0cdf40bb3f94d7cd8fddeba29f049a9946163e5b0fc0186f07f48646802
|
||||
|
Loading…
Reference in New Issue
Block a user