New upstream version 1.2.8.
This commit is contained in:
parent
0558bf05c3
commit
0201ac1020
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@ hivex-1.2.2.tar.gz
|
|||||||
/hivex-1.2.5.tar.gz
|
/hivex-1.2.5.tar.gz
|
||||||
/hivex-1.2.6.tar.gz
|
/hivex-1.2.6.tar.gz
|
||||||
/hivex-1.2.7.tar.gz
|
/hivex-1.2.7.tar.gz
|
||||||
|
/hivex-1.2.8.tar.gz
|
||||||
|
@ -1,25 +0,0 @@
|
|||||||
From f408b757b1d75429fae5fa7630a4fc5451844de7 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Richard W.M. Jones <rjones@redhat.com>
|
|
||||||
Date: Tue, 17 May 2011 17:19:27 +0100
|
|
||||||
Subject: [PATCH 1/2] ocaml: Set package name when installing native bindings.
|
|
||||||
|
|
||||||
This fixes commit b8ad15031cacf910634b4f4f4632232949c4acd2.
|
|
||||||
---
|
|
||||||
ocaml/Makefile.am | 1 +
|
|
||||||
1 files changed, 1 insertions(+), 0 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/ocaml/Makefile.am b/ocaml/Makefile.am
|
|
||||||
index b97fe37..58fa8e3 100644
|
|
||||||
--- a/ocaml/Makefile.am
|
|
||||||
+++ b/ocaml/Makefile.am
|
|
||||||
@@ -98,6 +98,7 @@ install-data-hook:
|
|
||||||
if HAVE_OCAMLOPT
|
|
||||||
$(OCAMLFIND) install \
|
|
||||||
-ldconf ignore -destdir $(DESTDIR)$(OCAMLLIB) \
|
|
||||||
+ hivex \
|
|
||||||
*.cmx *.cmxa
|
|
||||||
endif
|
|
||||||
|
|
||||||
--
|
|
||||||
1.7.5.1
|
|
||||||
|
|
@ -1,49 +0,0 @@
|
|||||||
From ee947dd4e44bb407a8b9e4cd33a0a2e25077fa6b Mon Sep 17 00:00:00 2001
|
|
||||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
||||||
Date: Fri, 22 Jul 2011 10:39:37 +0100
|
|
||||||
Subject: [PATCH] perl: Fix CCFLAGS on Perl 5.14.
|
|
||||||
|
|
||||||
A change to ExtUtils::CBuilder in Perl 5.14 causes CCFLAGS to
|
|
||||||
completely replace, rather than appending, the C flags.
|
|
||||||
|
|
||||||
The unfortunate consequence of this is that vital flags such as
|
|
||||||
-D_FILE_OFFSET_BITS=64 are missing. For 32 bit code, this means you
|
|
||||||
get binary-incompatible code that completely fails to load.
|
|
||||||
|
|
||||||
For further analysis see:
|
|
||||||
|
|
||||||
http://www.nntp.perl.org/group/perl.perl5.porters/2011/04/msg171535.html
|
|
||||||
|
|
||||||
This commit changes CCFLAGS so that it appends to the existing
|
|
||||||
$Config{ccflags} instead of replacing it. On earlier versions of Perl
|
|
||||||
this means we get two copies of the flags, which is unfortunate but
|
|
||||||
should be safe.
|
|
||||||
|
|
||||||
Also, ignore MYMETA.yml file produced by Perl 5.14.
|
|
||||||
---
|
|
||||||
.gitignore | 1 +
|
|
||||||
perl/Makefile.PL.in | 3 ++-
|
|
||||||
2 files changed, 3 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/perl/Makefile.PL.in b/perl/Makefile.PL.in
|
|
||||||
index e6e3d72..77b4a0e 100644
|
|
||||||
--- a/perl/Makefile.PL.in
|
|
||||||
+++ b/perl/Makefile.PL.in
|
|
||||||
@@ -15,6 +15,7 @@
|
|
||||||
# along with this program; if not, write to the Free Software
|
|
||||||
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
|
|
||||||
|
|
||||||
+use Config;
|
|
||||||
use ExtUtils::MakeMaker;
|
|
||||||
|
|
||||||
WriteMakefile (
|
|
||||||
@@ -26,5 +27,5 @@ WriteMakefile (
|
|
||||||
LIBS => '-L@top_builddir@/lib/.libs -lhivex',
|
|
||||||
INC => '-I@top_builddir@/lib -I@top_srcdir@/lib',
|
|
||||||
TYPEMAPS => [ '@srcdir@/typemap' ],
|
|
||||||
- CCFLAGS => '@CFLAGS@',
|
|
||||||
+ CCFLAGS => $Config{ccflags} . ' @CFLAGS@',
|
|
||||||
);
|
|
||||||
--
|
|
||||||
1.7.5.2
|
|
||||||
|
|
@ -1,46 +0,0 @@
|
|||||||
From 5fc8bc9d9ef6dd23d55771c8def7c369f32e7919 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Richard W.M. Jones <rjones@redhat.com>
|
|
||||||
Date: Tue, 17 May 2011 17:37:31 +0100
|
|
||||||
Subject: [PATCH 2/2] ocaml: Really fix 'make install' rule.
|
|
||||||
|
|
||||||
This fixes commit b8ad15031cacf910634b4f4f4632232949c4acd2
|
|
||||||
and commit f408b757b1d75429fae5fa7630a4fc5451844de7.
|
|
||||||
---
|
|
||||||
ocaml/Makefile.am | 16 ++++++++--------
|
|
||||||
1 files changed, 8 insertions(+), 8 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/ocaml/Makefile.am b/ocaml/Makefile.am
|
|
||||||
index 58fa8e3..c688df0 100644
|
|
||||||
--- a/ocaml/Makefile.am
|
|
||||||
+++ b/ocaml/Makefile.am
|
|
||||||
@@ -88,19 +88,19 @@ include .depend
|
|
||||||
SUFFIXES = .cmo .cmi .cmx .ml .mli .mll .mly
|
|
||||||
|
|
||||||
# Do the installation by hand, because we want to run ocamlfind.
|
|
||||||
+install_files = META *.so *.a *.cma *.cmi *.mli
|
|
||||||
+
|
|
||||||
+if HAVE_OCAMLOPT
|
|
||||||
+install_files += *.cmx *.cmxa
|
|
||||||
+endif
|
|
||||||
+
|
|
||||||
install-data-hook:
|
|
||||||
mkdir -p $(DESTDIR)$(OCAMLLIB)
|
|
||||||
mkdir -p $(DESTDIR)$(OCAMLLIB)/stublibs
|
|
||||||
$(OCAMLFIND) install \
|
|
||||||
-ldconf ignore -destdir $(DESTDIR)$(OCAMLLIB) \
|
|
||||||
- hivex \
|
|
||||||
- META *.so *.a *.cma *.cmi *.mli
|
|
||||||
-if HAVE_OCAMLOPT
|
|
||||||
- $(OCAMLFIND) install \
|
|
||||||
- -ldconf ignore -destdir $(DESTDIR)$(OCAMLLIB) \
|
|
||||||
- hivex \
|
|
||||||
- *.cmx *.cmxa
|
|
||||||
-endif
|
|
||||||
+ $(PACKAGE_NAME) \
|
|
||||||
+ $(install_files)
|
|
||||||
|
|
||||||
CLEANFILES += $(noinst_DATA)
|
|
||||||
|
|
||||||
--
|
|
||||||
1.7.5.1
|
|
||||||
|
|
20
hivex.spec
20
hivex.spec
@ -6,8 +6,8 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: hivex
|
Name: hivex
|
||||||
Version: 1.2.7
|
Version: 1.2.8
|
||||||
Release: 9%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Read and write Windows Registry binary hive files
|
Summary: Read and write Windows Registry binary hive files
|
||||||
|
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
@ -38,14 +38,6 @@ Conflicts: libguestfs <= 1:1.0.84
|
|||||||
# Fix Perl directory install path.
|
# Fix Perl directory install path.
|
||||||
Patch0: %{name}-1.2.3-dirs.patch
|
Patch0: %{name}-1.2.3-dirs.patch
|
||||||
|
|
||||||
# Add upstream patches to fix ocaml install rule.
|
|
||||||
Patch1: 0001-ocaml-Set-package-name-when-installing-native-bindin.patch
|
|
||||||
Patch2: 0002-ocaml-Really-fix-make-install-rule.patch
|
|
||||||
Patch3: ocaml-Fix-autotools.patch
|
|
||||||
|
|
||||||
# Upstream patch to fix Perl CCFLAGS for Perl 5.14 on i686.
|
|
||||||
Patch4: 0001-perl-Fix-CCFLAGS-on-Perl-5.14.patch
|
|
||||||
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Hive files are the undocumented binary blobs that Windows uses to
|
Hive files are the undocumented binary blobs that Windows uses to
|
||||||
@ -152,10 +144,6 @@ python-%{name} contains Python bindings for %{name}.
|
|||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch0 -p1 -b .dirs
|
%patch0 -p1 -b .dirs
|
||||||
%patch1 -p1
|
|
||||||
%patch2 -p1
|
|
||||||
%patch3 -p1
|
|
||||||
%patch4 -p1
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -268,6 +256,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Aug 12 2011 Richard W.M. Jones <rjones@redhat.com> - 1.2.8-1
|
||||||
|
- New upstream version 1.2.8.
|
||||||
|
- Remove 4 upstream patches.
|
||||||
|
|
||||||
* Fri Jul 22 2011 Richard W.M. Jones <rjones@redhat.com> - 1.2.7-9
|
* Fri Jul 22 2011 Richard W.M. Jones <rjones@redhat.com> - 1.2.7-9
|
||||||
- Add upstream patch to fix Perl CCFLAGS for Perl 5.14 on i686.
|
- Add upstream patch to fix Perl CCFLAGS for Perl 5.14 on i686.
|
||||||
- Enable 'make check'.
|
- Enable 'make check'.
|
||||||
|
@ -1,52 +0,0 @@
|
|||||||
--- hivex/ocaml/Makefile.in.orig 2011-05-17 17:38:17.300761216 +0100
|
|
||||||
+++ hivex/ocaml/Makefile.in 2011-05-17 17:38:27.668965851 +0100
|
|
||||||
@@ -54,7 +54,8 @@
|
|
||||||
@HAVE_OCAMLOPT_TRUE@@HAVE_OCAML_TRUE@am__append_1 = mlhivex.cmxa
|
|
||||||
DIST_COMMON = $(srcdir)/.depend $(srcdir)/META.in \
|
|
||||||
$(srcdir)/Makefile.am $(srcdir)/Makefile.in
|
|
||||||
-@HAVE_OCAML_TRUE@am__append_2 = $(noinst_DATA)
|
|
||||||
+@HAVE_OCAMLOPT_TRUE@@HAVE_OCAML_TRUE@am__append_2 = *.cmx *.cmxa
|
|
||||||
+@HAVE_OCAML_TRUE@am__append_3 = $(noinst_DATA)
|
|
||||||
subdir = ocaml
|
|
||||||
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
|
||||||
am__aclocal_m4_deps = $(top_srcdir)/m4/00gnulib.m4 \
|
|
||||||
@@ -870,7 +871,7 @@
|
|
||||||
t/*.ml
|
|
||||||
|
|
||||||
CLEANFILES = *.cmi *.cmo *.cmx *.cma *.cmxa *.o *.a *.so t/*.cmi \
|
|
||||||
- t/*.cmo t/*.cmx t/*.o t/*.a t/*.so $(am__append_2)
|
|
||||||
+ t/*.cmo t/*.cmx t/*.o t/*.a t/*.so $(am__append_3)
|
|
||||||
AM_CPPFLAGS = \
|
|
||||||
-I$(top_builddir) -I$(OCAMLLIB) -I$(top_srcdir)/ocaml \
|
|
||||||
-I$(top_srcdir)/lib \
|
|
||||||
@@ -894,6 +895,10 @@
|
|
||||||
@HAVE_OCAML_TRUE@ t/hivex_300_fold
|
|
||||||
|
|
||||||
@HAVE_OCAML_TRUE@SUFFIXES = .cmo .cmi .cmx .ml .mli .mll .mly
|
|
||||||
+
|
|
||||||
+# Do the installation by hand, because we want to run ocamlfind.
|
|
||||||
+@HAVE_OCAML_TRUE@install_files = META *.so *.a *.cma *.cmi *.mli \
|
|
||||||
+@HAVE_OCAML_TRUE@ $(am__append_2)
|
|
||||||
all: all-am
|
|
||||||
|
|
||||||
.SUFFIXES:
|
|
||||||
@@ -1211,17 +1216,13 @@
|
|
||||||
@HAVE_OCAML_TRUE@hivex.cmo: hivex.cmi
|
|
||||||
@HAVE_OCAML_TRUE@hivex.cmx: hivex.cmi
|
|
||||||
|
|
||||||
-# Do the installation by hand, because we want to run ocamlfind.
|
|
||||||
@HAVE_OCAML_TRUE@install-data-hook:
|
|
||||||
@HAVE_OCAML_TRUE@ mkdir -p $(DESTDIR)$(OCAMLLIB)
|
|
||||||
@HAVE_OCAML_TRUE@ mkdir -p $(DESTDIR)$(OCAMLLIB)/stublibs
|
|
||||||
@HAVE_OCAML_TRUE@ $(OCAMLFIND) install \
|
|
||||||
@HAVE_OCAML_TRUE@ -ldconf ignore -destdir $(DESTDIR)$(OCAMLLIB) \
|
|
||||||
-@HAVE_OCAML_TRUE@ hivex \
|
|
||||||
-@HAVE_OCAML_TRUE@ META *.so *.a *.cma *.cmi *.mli
|
|
||||||
-@HAVE_OCAMLOPT_TRUE@@HAVE_OCAML_TRUE@ $(OCAMLFIND) install \
|
|
||||||
-@HAVE_OCAMLOPT_TRUE@@HAVE_OCAML_TRUE@ -ldconf ignore -destdir $(DESTDIR)$(OCAMLLIB) \
|
|
||||||
-@HAVE_OCAMLOPT_TRUE@@HAVE_OCAML_TRUE@ *.cmx *.cmxa
|
|
||||||
+@HAVE_OCAML_TRUE@ $(PACKAGE_NAME) \
|
|
||||||
+@HAVE_OCAML_TRUE@ $(install_files)
|
|
||||||
|
|
||||||
# Tell version 3.79 and up of GNU make to not build goals in this
|
|
||||||
# directory in parallel. (See RHBZ#502309).
|
|
Loading…
Reference in New Issue
Block a user