New upstream version 1.3.16.
This commit is contained in:
parent
a09a6a1e25
commit
007a5cc180
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
|||||||
/hivex-*.tar.gz
|
/hivex-*.tar.gz
|
||||||
/hivex-1.3.14.tar.gz.sig
|
/hivex-1.3.14.tar.gz.sig
|
||||||
/hivex-1.3.15.tar.gz.sig
|
/hivex-1.3.15.tar.gz.sig
|
||||||
|
/hivex-1.3.16.tar.gz.sig
|
||||||
|
@ -1,48 +0,0 @@
|
|||||||
From be51757920b56a77e2e63247f9a8409ce994d33c Mon Sep 17 00:00:00 2001
|
|
||||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
||||||
Date: Mon, 26 Feb 2018 12:38:12 +0000
|
|
||||||
Subject: [PATCH] ocaml: Link the C bindings with LDFLAGS (RHBZ#1548536).
|
|
||||||
|
|
||||||
Use the ocamlmklib -ldopt flag to pass the general $(LDFLAGS) when
|
|
||||||
calling gcc to link dllmlhivex.so. We were already passing $(CFLAGS)
|
|
||||||
when building the object file.
|
|
||||||
|
|
||||||
When building using Fedora's standard hardening flags this gives:
|
|
||||||
|
|
||||||
ocamlmklib -o mlhivex hivex_c.o hivex.cmo \
|
|
||||||
-verbose -ldopt '-Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld' \
|
|
||||||
-L../lib/.libs -lhivex
|
|
||||||
+ gcc -shared -o ./dllmlhivex.so hivex_c.o -Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -L../lib/.libs -lhivex
|
|
||||||
+ ar rc ./libmlhivex.a hivex_c.o; ranlib ./libmlhivex.a
|
|
||||||
+ /usr/bin/ocamlc -a -o mlhivex.cma hivex.cmo -dllib -lmlhivex -cclib -lmlhivex -cclib -L../lib/.libs -cclib -lhivex
|
|
||||||
|
|
||||||
This also works if $(LDFLAGS) is empty, because ocamlmklib ignores
|
|
||||||
-ldopt ''.
|
|
||||||
---
|
|
||||||
ocaml/Makefile.am | 8 ++++++--
|
|
||||||
1 file changed, 6 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/ocaml/Makefile.am b/ocaml/Makefile.am
|
|
||||||
index 61db095..85655b6 100644
|
|
||||||
--- a/ocaml/Makefile.am
|
|
||||||
+++ b/ocaml/Makefile.am
|
|
||||||
@@ -41,10 +41,14 @@ OBJS = hivex_c.o hivex.cmo
|
|
||||||
XOBJS = $(OBJS:.cmo=.cmx)
|
|
||||||
|
|
||||||
mlhivex.cma: $(OBJS)
|
|
||||||
- $(OCAMLMKLIB) -o mlhivex $^ -L$(top_builddir)/lib/.libs -lhivex
|
|
||||||
+ $(OCAMLMKLIB) -o mlhivex $^ \
|
|
||||||
+ -ldopt '$(LDFLAGS)' \
|
|
||||||
+ -L$(top_builddir)/lib/.libs -lhivex
|
|
||||||
|
|
||||||
mlhivex.cmxa: $(XOBJS)
|
|
||||||
- $(OCAMLMKLIB) -o mlhivex $^ -L$(top_builddir)/lib/.libs -lhivex
|
|
||||||
+ $(OCAMLMKLIB) -o mlhivex $^ \
|
|
||||||
+ -ldopt '$(LDFLAGS)' \
|
|
||||||
+ -L$(top_builddir)/lib/.libs -lhivex
|
|
||||||
|
|
||||||
hivex_c.o: hivex_c.c
|
|
||||||
$(CC) $(AM_CPPFLAGS) $(CFLAGS) -fPIC -Wall -c $<
|
|
||||||
--
|
|
||||||
2.13.2
|
|
||||||
|
|
15
hivex.spec
15
hivex.spec
@ -9,8 +9,8 @@
|
|||||||
%global verify_tarball_signature 1
|
%global verify_tarball_signature 1
|
||||||
|
|
||||||
Name: hivex
|
Name: hivex
|
||||||
Version: 1.3.15
|
Version: 1.3.16
|
||||||
Release: 12%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Read and write Windows Registry binary hive files
|
Summary: Read and write Windows Registry binary hive files
|
||||||
|
|
||||||
License: LGPLv2
|
License: LGPLv2
|
||||||
@ -26,11 +26,6 @@ Source1: http://libguestfs.org/download/hivex/%{name}-%{version}.tar.gz.s
|
|||||||
Source2: libguestfs.keyring
|
Source2: libguestfs.keyring
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# Upstream patch to fix injection of LDFLAGS.
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1548536
|
|
||||||
Patch1: 0001-ocaml-Link-the-C-bindings-with-LDFLAGS-RHBZ-1548536.patch
|
|
||||||
BuildRequires: autoconf, automake, libtool, gettext-devel
|
|
||||||
|
|
||||||
BuildRequires: perl-interpreter
|
BuildRequires: perl-interpreter
|
||||||
BuildRequires: perl-devel
|
BuildRequires: perl-devel
|
||||||
BuildRequires: perl-generators
|
BuildRequires: perl-generators
|
||||||
@ -186,9 +181,6 @@ gpgv2 --homedir "$tmphome" --keyring %{SOURCE2} %{SOURCE1} %{SOURCE0}
|
|||||||
%setup -q
|
%setup -q
|
||||||
%autopatch -p1
|
%autopatch -p1
|
||||||
|
|
||||||
# Because the patch touches Makefile.am, rerun autotools.
|
|
||||||
autoreconf -i -f
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
@ -285,6 +277,9 @@ make check
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 17 2019 Richard W.M. Jones <rjones@redhat.com> - 1.3.16-1
|
||||||
|
- New upstream version 1.3.16.
|
||||||
|
|
||||||
* Thu Jan 10 2019 Miro Hrončok <mhroncok@redhat.com> - 1.3.15-12
|
* Thu Jan 10 2019 Miro Hrončok <mhroncok@redhat.com> - 1.3.15-12
|
||||||
- Remove Python 2 subpackage
|
- Remove Python 2 subpackage
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (hivex-1.3.15.tar.gz) = 7ce4fd6842c7545a41dc4c4268db5f0629d618a17f29a68dda6990a0dd4530cdf0e0c654f00104274c57e792aa4bcf712bcac1c76e2fd2dbce9aeae1e5751517
|
SHA512 (hivex-1.3.16.tar.gz) = f7c09b256af8b7466124b681c2b6e1e0aacac763e3bd9057f617dad1ffb9e1f2298d58223539b872e8502316eaff123c27f81257341807f0086cc672ac85a788
|
||||||
SHA512 (hivex-1.3.15.tar.gz.sig) = 9cd0231f9d0293657aeec398c6b601800c7d61925340504c338a04339d7fa6d534f5b0cdf40bb3f94d7cd8fddeba29f049a9946163e5b0fc0186f07f48646802
|
SHA512 (hivex-1.3.16.tar.gz.sig) = 1dc89e4fc5e51bbb705ff38d5cbbe99502b09f740263e4a1b6616328d9b62b29b181bace3a2952189374833cff6c1bb18a1894a4c002a8097a0450c80948a9a4
|
||||||
|
Loading…
Reference in New Issue
Block a user