New upstream release
- Clean up sPEC file
This commit is contained in:
parent
9e51e40176
commit
33efd8e404
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@ highlight-3.1-beta2.tar.bz2
|
|||||||
/highlight-3.9.tar.bz2
|
/highlight-3.9.tar.bz2
|
||||||
/highlight-3.11-beta.tar.bz2
|
/highlight-3.11-beta.tar.bz2
|
||||||
/highlight-3.12.tar.bz2
|
/highlight-3.12.tar.bz2
|
||||||
|
/highlight-3.13.tar.bz2
|
||||||
|
31
highlight-3.13-lua.patch
Normal file
31
highlight-3.13-lua.patch
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
diff -up highlight-3.13/src/gui-qt/highlight.pro.mk highlight-3.13/src/gui-qt/highlight.pro
|
||||||
|
--- highlight-3.13/src/gui-qt/highlight.pro.mk 2013-02-19 18:43:29.139258245 +0100
|
||||||
|
+++ highlight-3.13/src/gui-qt/highlight.pro 2013-02-19 18:44:26.651647337 +0100
|
||||||
|
@@ -31,9 +31,9 @@ unix:LIBS += -L.. -lhighlight
|
||||||
|
|
||||||
|
# If Lua 5.2 is not default on your system yet you have to omit 5.1 here:
|
||||||
|
unix {
|
||||||
|
- LIBS += -llua5.1
|
||||||
|
+ LIBS += -llua
|
||||||
|
CONFIG += link_pkgconfig
|
||||||
|
- PKGCONFIG += lua5.1
|
||||||
|
+ PKGCONFIG += lua
|
||||||
|
}
|
||||||
|
|
||||||
|
win32:QMAKE_POST_LINK = f:/upx/upx.exe --best ../../highlight-gui.exe
|
||||||
|
diff -up highlight-3.13/src/makefile.mk highlight-3.13/src/makefile
|
||||||
|
--- highlight-3.13/src/makefile.mk 2013-02-01 21:37:56.000000000 +0100
|
||||||
|
+++ highlight-3.13/src/makefile 2013-02-19 18:33:33.025879310 +0100
|
||||||
|
@@ -34,10 +34,10 @@ INCLUDE_DIR=./include/
|
||||||
|
|
||||||
|
|
||||||
|
# If Lua 5.2 is not default on your system yet you have to omit 5.1:
|
||||||
|
-LUA_CFLAGS=$(shell pkg-config --cflags lua5.1)
|
||||||
|
+LUA_CFLAGS=$(shell pkg-config --cflags lua)
|
||||||
|
|
||||||
|
# default lua lib
|
||||||
|
-LUA_LIBS=$(shell pkg-config --libs lua5.1)
|
||||||
|
+LUA_LIBS=$(shell pkg-config --libs lua)
|
||||||
|
# luajit lib
|
||||||
|
#LUA_LIBS=$(shell pkg-config --libs luajit)
|
||||||
|
|
@ -1,21 +1,20 @@
|
|||||||
Name: highlight
|
Name: highlight
|
||||||
Summary: Universal source code to formatted text converter
|
Summary: Universal source code to formatted text converter
|
||||||
|
|
||||||
Version: 3.12
|
Version: 3.13
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
License: GPLv3
|
License: GPLv3
|
||||||
|
|
||||||
URL: http://www.andre-simon.de/
|
URL: http://www.andre-simon.de/
|
||||||
Source0: http://www.andre-simon.de/zip/%{name}-%{version}.tar.bz2
|
Source0: http://www.andre-simon.de/zip/%{name}-%{version}.tar.bz2
|
||||||
|
Patch1: highlight-3.13-lua.patch
|
||||||
|
|
||||||
BuildRequires: qt-devel >= 1:4.4
|
BuildRequires: qt-devel >= 1:4.4
|
||||||
BuildRequires: lua-devel, boost-devel
|
BuildRequires: lua-devel, boost-devel
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-root-%(%{__id_u} -n)
|
|
||||||
|
|
||||||
%{?filter_setup:
|
%{?filter_setup:
|
||||||
%filter_from_provides /^perl(/d;
|
%filter_from_provides /^perl(/d;
|
||||||
%filter_from_requires /^perl(/d;
|
%filter_from_requires /^perl(/d;
|
||||||
@ -38,8 +37,8 @@ Requires: %{name} = %{version}-%{release}
|
|||||||
A Qt-based GUI for the highlight source code formatter source.
|
A Qt-based GUI for the highlight source code formatter source.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
|
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch1 -p1 -b .mk
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" LDFLAGS=
|
make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" LDFLAGS=
|
||||||
@ -49,8 +48,6 @@ make gui %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
|
|||||||
LDFLAGS=
|
LDFLAGS=
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
|
||||||
|
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
|
mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
|
||||||
@ -64,9 +61,6 @@ desktop-file-install \
|
|||||||
--dir $RPM_BUILD_ROOT%{_datadir}/applications \
|
--dir $RPM_BUILD_ROOT%{_datadir}/applications \
|
||||||
highlight.desktop
|
highlight.desktop
|
||||||
|
|
||||||
%clean
|
|
||||||
rm -rf $RPM_BUILD_ROOT
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_bindir}/highlight
|
%{_bindir}/highlight
|
||||||
@ -84,6 +78,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/pixmaps/highlight.xpm
|
%{_datadir}/pixmaps/highlight.xpm
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 19 2013 Jochen Schmitt <Jochen herr-schmitt de> - 3.13-1
|
||||||
|
- New upstream release
|
||||||
|
- Clean up sPEC file
|
||||||
|
|
||||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.12-2
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.12-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user