import hexedit-1.6-1.el9
This commit is contained in:
parent
f944a9ae4d
commit
fada82f87b
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/1.5.tar.gz
|
SOURCES/hexedit-1.6.tar.gz
|
||||||
|
@ -1 +1 @@
|
|||||||
e49d5a613d2c4540b03563db5eb8e827793f77b2 SOURCES/1.5.tar.gz
|
561e967aecff92a487614ed0f98f917949b39ac4 SOURCES/hexedit-1.6.tar.gz
|
||||||
|
@ -1,27 +1,31 @@
|
|||||||
Author:Filip Januš <fjanus@redhat.com>
|
Author:Filip Januš <fjanus@redhat.com>
|
||||||
This patch fixs inconsistency between filename and configure.ac
|
This patch fixs inconsistency between filename and configure.ac
|
||||||
|
|
||||||
diff -ur hexedit-1.5/configure.ac hxpatch/configure.ac
|
diff -ur hexedit-1.6.old/configure.ac hexedit-1.6/configure.ac
|
||||||
--- hexedit-1.5/configure.ac 2020-08-28 11:51:07.000000000 +0200
|
--- hexedit-1.6.old/configure.ac 2022-04-22 09:06:10.000000000 +0100
|
||||||
+++ hxpatch/configure.ac 2021-03-16 15:37:40.127591071 +0100
|
+++ hexedit-1.6/configure.ac 2022-05-02 22:30:54.942894809 +0100
|
||||||
@@ -14,7 +14,7 @@
|
@@ -15,7 +15,7 @@
|
||||||
VERSION=TheVERSION
|
VERSION=TheVERSION
|
||||||
INCL=hexedit.h
|
INCL=hexedit.h
|
||||||
SRCS="hexedit.c display.c mark.c page.c file.c interact.c misc.c search.c"
|
SRCS="hexedit.c display.c mark.c page.c file.c interact.c misc.c search.c"
|
||||||
-OTHER="COPYING Changes TODO install-sh configure config.h.in hexedit.1 hexedit-TheVERSION.lsm Makefile.in configure.in Makefile-build.in"
|
-OTHER="COPYING Changes TODO install-sh configure config.h.in hexedit.1 hexedit-TheVERSION.lsm Makefile.in configure.ac Makefile-build.in"
|
||||||
+OTHER="COPYING Changes TODO install-sh configure config.h.in hexedit.1 hexedit.lsm Makefile.in configure.in Makefile-build.in"
|
+OTHER="COPYING Changes TODO install-sh configure config.h.in hexedit.1 hexedit.lsm Makefile.in configure.ac Makefile-build.in"
|
||||||
AC_SUBST(PRODUCT)
|
AC_SUBST(PRODUCT)
|
||||||
AC_SUBST(VERSION)
|
AC_SUBST(VERSION)
|
||||||
AC_SUBST(INCL)
|
AC_SUBST(INCL)
|
||||||
@@ -72,4 +72,4 @@
|
@@ -74,5 +74,5 @@
|
||||||
#endif
|
#endif
|
||||||
)
|
)
|
||||||
|
|
||||||
-AC_OUTPUT(Makefile Makefile-build hexedit.1)
|
-AC_CONFIG_FILES([Makefile Makefile-build hexedit.1])
|
||||||
+AC_OUTPUT(Makefile Makefile-build hexedit.1 hexedit.lsm)
|
+AC_CONFIG_FILES([Makefile Makefile-build hexedit.1 hexedit.lsm])
|
||||||
diff -ur hexedit-1.5/hexedit.lsm.in hxpatch/hexedit.lsm.in
|
AC_OUTPUT
|
||||||
--- hexedit-1.5/hexedit.lsm.in 2020-08-28 11:51:07.000000000 +0200
|
Only in hexedit-1.6: configure.ac~
|
||||||
+++ hxpatch/hexedit.lsm.in 2021-03-16 12:12:49.664995112 +0100
|
Only in hexedit-1.6: configure.ac.orig
|
||||||
|
Only in hexedit-1.6: configure.ac.rej
|
||||||
|
diff -ur hexedit-1.6.old/hexedit.lsm.in hexedit-1.6/hexedit.lsm.in
|
||||||
|
--- hexedit-1.6.old/hexedit.lsm.in 2022-04-22 09:06:10.000000000 +0100
|
||||||
|
+++ hexedit-1.6/hexedit.lsm.in 2022-05-02 22:30:07.618550082 +0100
|
||||||
@@ -1,6 +1,6 @@
|
@@ -1,6 +1,6 @@
|
||||||
Begin3
|
Begin3
|
||||||
Title: hexedit
|
Title: hexedit
|
@ -1,15 +1,18 @@
|
|||||||
|
%global forgeurl https://github.com/pixel/hexedit
|
||||||
|
|
||||||
|
Version: 1.6
|
||||||
|
%forgemeta
|
||||||
|
|
||||||
Summary: A hexadecimal file viewer and editor
|
Summary: A hexadecimal file viewer and editor
|
||||||
Name: hexedit
|
Name: hexedit
|
||||||
Version: 1.5
|
Release: 1%{?dist}
|
||||||
Release: 3%{?dist}
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
|
|
||||||
URL: http://rigaux.org/hexedit.html
|
URL: http://rigaux.org/hexedit.html
|
||||||
Source: https://github.com/pixel/%{name}/archive/%{version}.tar.gz
|
Source: %{forgesource}
|
||||||
|
|
||||||
Patch1: hexedit-1.2.13-config.patch
|
Patch1: hexedit-1.2.13-config.patch
|
||||||
# Document --color option. Sent upstream 2013-04-05.
|
# Document --color option. Sent upstream 2013-04-05.
|
||||||
Patch2: hexedit-1.5.patch
|
Patch2: hexedit-1.6-fix-lsm.patch
|
||||||
|
|
||||||
BuildRequires: ncurses-devel
|
BuildRequires: ncurses-devel
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -22,7 +25,7 @@ as the file is read a piece at a time. Hexedit can be used to modify the file
|
|||||||
and search through it.
|
and search through it.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}
|
%forgesetup
|
||||||
|
|
||||||
%patch1 -p1 -b .config
|
%patch1 -p1 -b .config
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
@ -44,6 +47,10 @@ make install \
|
|||||||
%{_mandir}/man1/hexedit.1*
|
%{_mandir}/man1/hexedit.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 02 2022 Richard W.M. Jones <rjones@redhat.com> - 1.6-1
|
||||||
|
- New upstream version 1.6
|
||||||
|
resolves: rhbz#2081103
|
||||||
|
|
||||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 1.5-3
|
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 1.5-3
|
||||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||||
Related: rhbz#1991688
|
Related: rhbz#1991688
|
||||||
|
Loading…
Reference in New Issue
Block a user