import hexchat-2.14.3-17.el9

This commit is contained in:
CentOS Sources 2021-11-02 16:53:17 -04:00 committed by Stepan Oksanichenko
commit 6d3be469d8
8 changed files with 4676 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/hexchat-2.14.3.tar.xz

1
.hexchat.metadata Normal file
View File

@ -0,0 +1 @@
a219796d70023b675e5ea24af9f22beb9e855abb SOURCES/hexchat-2.14.3.tar.xz

View File

@ -0,0 +1,25 @@
From 090fd29acf4af0d8e13fcf2861b14a356db72641 Mon Sep 17 00:00:00 2001
From: Sbgodin <christophe.henry@sbgodin.fr>
Date: Sun, 7 Mar 2021 12:51:45 +0000
Subject: [PATCH] python: Fix exception with list_pluginpref()
__decode cannot work (with Python3) because prefs_str has no attribute 'decode'.
Related to https://github.com/hexchat/hexchat/issues/2531
---
plugins/python/_hexchat.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/plugins/python/_hexchat.py b/plugins/python/_hexchat.py
index 567b34934..5e4b0c65f 100644
--- a/plugins/python/_hexchat.py
+++ b/plugins/python/_hexchat.py
@@ -319,7 +319,7 @@ def del_pluginpref(name):
def list_pluginpref():
prefs_str = ffi.new('char[4096]')
if lib.hexchat_pluginpref_list(lib.ph, prefs_str) == 1:
- return __decode(prefs_str).split(',')
+ return __decode(ffi.string(prefs_str)).split(',')
return []

View File

@ -0,0 +1,48 @@
From 163608d7fd861c2c4911a38f45be484c88626bdc Mon Sep 17 00:00:00 2001
From: John Levon <levon@movementarian.org>
Date: Mon, 7 Sep 2020 17:53:31 +0100
Subject: [PATCH] Use pango_font_metrics_get_height() to calculate font height
(#2500)
---
src/fe-gtk/xtext.c | 18 ++++++++++++++++--
1 file changed, 16 insertions(+), 2 deletions(-)
diff --git a/src/fe-gtk/xtext.c b/src/fe-gtk/xtext.c
index fac0c4e6d..418bb4da5 100644
--- a/src/fe-gtk/xtext.c
+++ b/src/fe-gtk/xtext.c
@@ -283,8 +283,24 @@ backend_font_open (GtkXText *xtext, char *name)
metrics = pango_context_get_metrics (context, xtext->font->font, lang);
xtext->font->ascent = pango_font_metrics_get_ascent (metrics) / PANGO_SCALE;
xtext->font->descent = pango_font_metrics_get_descent (metrics) / PANGO_SCALE;
+
+ /*
+ * In later versions of pango, a font's height should be calculated like
+ * this to account for line gap; a typical symptom of not doing so is
+ * cutting off the underscore on some fonts.
+ */
+#if PANGO_VERSION_CHECK(1, 44, 0)
+ xtext->fontsize = pango_font_metrics_get_height (metrics) / PANGO_SCALE + 1;
+
+ if (xtext->fontsize == 0)
+ xtext->fontsize = xtext->font->ascent + xtext->font->descent;
+#else
+ xtext->fontsize = xtext->font->ascent + xtext->font->descent;
+#endif
+
pango_font_metrics_unref (metrics);
}
+
static int
backend_get_text_width_emph (GtkXText *xtext, guchar *str, int len, int emphasis)
{
@@ -3479,8 +3495,6 @@ gtk_xtext_set_font (GtkXText *xtext, char *name)
if (xtext->font == NULL)
return FALSE;
- xtext->fontsize = xtext->font->ascent + xtext->font->descent;
-
{
char *time_str;
int stamp_size = xtext_get_stamp_str (time(0), &time_str);

View File

@ -0,0 +1,28 @@
From 5deb69591992d4fede9090b60d3dc847612a4d60 Mon Sep 17 00:00:00 2001
From: Patrick Griffis <tingping@tingping.se>
Date: Wed, 11 Mar 2020 11:07:56 -0700
Subject: [PATCH] build: Better support building against python 3.8+
Closes #2441
---
plugins/python/meson.build | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/plugins/python/meson.build b/plugins/python/meson.build
index 2ad5128e5..eb762134a 100644
--- a/plugins/python/meson.build
+++ b/plugins/python/meson.build
@@ -1,6 +1,12 @@
python_opt = get_option('with-python')
if python_opt.startswith('python3')
- python_dep = dependency(python_opt, version: '>= 3.3')
+ # Python 3.8 introduced a new -embed variant
+ if not python_opt.endswith('-embed')
+ python_dep = dependency(python_opt + '-embed', version: '>= 3.3', required: false)
+ endif
+ if not python_dep.found()
+ python_dep = dependency(python_opt, version: '>= 3.3')
+ endif
else
python_dep = dependency(python_opt, version: '>= 2.7')
endif

View File

@ -0,0 +1,199 @@
From 54321bae1feaf0845d75f67245c95795651277f5 Mon Sep 17 00:00:00 2001
From: Michael Catanzaro <mcatanzaro@redhat.com>
Date: Mon, 12 Jul 2021 08:38:02 -0500
Subject: [PATCH] Avoid direct use of libproxy
Since hexchat already depends on GLib, it's better to use GProxyResolver
instead. This might use libproxy, or not, as appropriate.
P.S. This removes a memory safety issue because proxy_list is allocated
using malloc(), not g_malloc(), and therefore using g_strfreev() is
incorrect. The proper way to free the proxy list returned by libproxy
is to use px_proxy_factory_free_proxies() (but nobody does that because
it was added in libproxy 0.4.16, which is somewhat recent).
---
meson.build | 1 -
meson_options.txt | 3 ---
src/common/hexchat.c | 16 ----------------
src/common/meson.build | 4 ----
src/common/server.c | 26 ++++++++++++++++----------
src/fe-gtk/setup.c | 2 --
6 files changed, 16 insertions(+), 36 deletions(-)
diff --git a/meson.build b/meson.build
index 18baf26e126e..381e3fd87ac6 100644
--- a/meson.build
+++ b/meson.build
@@ -33,7 +33,6 @@ config_h.set10('ENABLE_NLS', true)
# Optional features
config_h.set('USE_OPENSSL', get_option('with-ssl'))
-config_h.set('USE_LIBPROXY', get_option('with-libproxy'))
config_h.set('USE_LIBCANBERRA', get_option('with-libcanberra'))
config_h.set('USE_DBUS', get_option('with-dbus'))
config_h.set('USE_PLUGIN', get_option('with-plugin'))
diff --git a/meson_options.txt b/meson_options.txt
index 100a5ee72ad7..ad03d6bc58ef 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -13,9 +13,6 @@ option('with-plugin', type: 'boolean',
option('with-dbus', type: 'boolean',
description: 'Support used for single-instance and scripting interface, Unix only'
)
-option('with-libproxy', type: 'boolean',
- description: 'Support for getting proxy information, Unix only'
-)
option('with-libnotify', type: 'boolean',
description: 'Support for freedesktop notifications, Unix only'
)
diff --git a/src/common/hexchat.c b/src/common/hexchat.c
index e9a9a7fc9fcd..a98fcafba2f7 100644
--- a/src/common/hexchat.c
+++ b/src/common/hexchat.c
@@ -57,10 +57,6 @@
#include <glib-object.h> /* for g_type_init() */
#endif
-#ifdef USE_LIBPROXY
-#include <proxy.h>
-#endif
-
GSList *popup_list = 0;
GSList *button_list = 0;
GSList *dlgbutton_list = 0;
@@ -111,10 +107,6 @@ struct session *current_tab;
struct session *current_sess = 0;
struct hexchatprefs prefs;
-#ifdef USE_LIBPROXY
-pxProxyFactory *libproxy_factory;
-#endif
-
/*
* Update the priority queue of the "interesting sessions"
* (sess_list_by_lastact).
@@ -1101,10 +1093,6 @@ main (int argc, char *argv[])
hexchat_remote ();
#endif
-#ifdef USE_LIBPROXY
- libproxy_factory = px_proxy_factory_new ();
-#endif
-
#ifdef WIN32
coinit_result = CoInitializeEx (NULL, COINIT_APARTMENTTHREADED);
if (SUCCEEDED (coinit_result))
@@ -1147,10 +1135,6 @@ main (int argc, char *argv[])
}
#endif
-#ifdef USE_LIBPROXY
- px_proxy_factory_free (libproxy_factory);
-#endif
-
#ifdef WIN32
WSACleanup ();
#endif
diff --git a/src/common/meson.build b/src/common/meson.build
index bbb646459522..5885ec9e47c1 100644
--- a/src/common/meson.build
+++ b/src/common/meson.build
@@ -77,10 +77,6 @@ if get_option('with-ssl')
common_deps += libssl_dep
endif
-if get_option('with-libproxy')
- common_deps += dependency('libproxy-1.0')
-endif
-
if get_option('with-libcanberra')
common_deps += dependency('libcanberra', version: '>= 0.22')
endif
diff --git a/src/common/server.c b/src/common/server.c
index 3db0a9635fc5..a96e81f43d15 100644
--- a/src/common/server.c
+++ b/src/common/server.c
@@ -61,10 +61,6 @@
#include "ssl.h"
#endif
-#ifdef USE_LIBPROXY
-#include <proxy.h>
-#endif
-
#ifdef USE_OPENSSL
/* local variables */
static struct session *g_sess = NULL;
@@ -78,9 +74,15 @@ static void server_disconnect (session * sess, int sendquit, int err);
static int server_cleanup (server * serv);
static void server_connect (server *serv, char *hostname, int port, int no_login);
-#ifdef USE_LIBPROXY
-extern pxProxyFactory *libproxy_factory;
-#endif
+static void
+write_error (char *message, GError **error)
+{
+ if (error == NULL || *error == NULL) {
+ return;
+ }
+ g_printerr ("%s: %s\n", message, (*error)->message);
+ g_clear_error (error);
+}
/* actually send to the socket. This might do a character translation or
send via SSL. server/dcc both use this function. */
@@ -1365,14 +1367,16 @@ server_child (server * serv)
if (!serv->dont_use_proxy) /* blocked in serverlist? */
{
-#ifdef USE_LIBPROXY
if (prefs.hex_net_proxy_type == 5)
{
char **proxy_list;
char *url, *proxy;
+ GProxyResolver *resolver;
+ GError *error = NULL;
+ resolver = g_proxy_resolver_get_default ();
url = g_strdup_printf ("irc://%s:%d", hostname, port);
- proxy_list = px_proxy_factory_get_proxies (libproxy_factory, url);
+ proxy_list = g_proxy_resolver_lookup (resolver, url, NULL, &error);
if (proxy_list) {
/* can use only one */
@@ -1385,6 +1389,8 @@ server_child (server * serv)
proxy_type = 3;
else if (!strncmp (proxy, "socks", 5))
proxy_type = 2;
+ } else {
+ write_error ("Failed to lookup proxy", &error);
}
if (proxy_type) {
@@ -1399,7 +1405,7 @@ server_child (server * serv)
g_strfreev (proxy_list);
g_free (url);
}
-#endif
+
if (prefs.hex_net_proxy_host[0] &&
prefs.hex_net_proxy_type > 0 &&
prefs.hex_net_proxy_use != 2) /* proxy is NOT dcc-only */
diff --git a/src/fe-gtk/setup.c b/src/fe-gtk/setup.c
index 3d003eefc776..a7e3a15cac52 100644
--- a/src/fe-gtk/setup.c
+++ b/src/fe-gtk/setup.c
@@ -614,9 +614,7 @@ static const char *const proxytypes[] =
N_("SOCKS4"),
N_("SOCKS5"),
N_("HTTP"),
-#ifdef USE_LIBPROXY
N_("Auto"),
-#endif
NULL
};
--
2.31.1

File diff suppressed because it is too large Load Diff

307
SPECS/hexchat.spec Normal file
View File

@ -0,0 +1,307 @@
%global app_id io.github.Hexchat
Summary: A popular and easy to use graphical IRC (chat) client
Name: hexchat
Version: 2.14.3
Release: 17%{?dist}
License: GPLv2+
URL: https://hexchat.github.io
Source: https://dl.hexchat.net/hexchat/%{name}-%{version}.tar.xz
# Patch to link better to python 3.8
Patch1: https://github.com/hexchat/hexchat/commit/5deb69591992d4fede9090b60d3dc847612a4d60.patch
Patch2: python-plugin-from-master.patch
Patch3: https://github.com/hexchat/hexchat/commit/163608d7fd861c2c4911a38f45be484c88626bdc.patch
Patch4: https://github.com/hexchat/hexchat/commit/090fd29acf4af0d8e13fcf2861b14a356db72641.patch
# https://github.com/hexchat/hexchat/pull/2609
# https://bugzilla.redhat.com/show_bug.cgi?id=1981509
Patch5: hexchat-Avoid-direct-use-of-libproxy.patch
BuildRequires: gcc
BuildRequires: meson
BuildRequires: hicolor-icon-theme
BuildRequires: pkgconfig(glib-2.0)
BuildRequires: pkgconfig(gtk+-2.0)
BuildRequires: pkgconfig(dbus-glib-1)
BuildRequires: pkgconfig(libcanberra)
BuildRequires: pkgconfig(libnotify)
BuildRequires: pkgconfig(iso-codes)
BuildRequires: pkgconfig(openssl)
BuildRequires: pkgconfig(python3)
BuildRequires: pkgconfig(libpci)
BuildRequires: pkgconfig(lua)
BuildRequires: perl-devel, perl-ExtUtils-Embed
BuildRequires: python3-cffi
Requires: python3-cffi
Requires: (enchant or enchant2)
Recommends: sound-theme-freedesktop
%description
HexChat is an easy to use graphical IRC chat client for the X Window System.
It allows you to join multiple IRC channels (chat rooms) at the same time,
talk publicly, private one-on-one conversations etc. Even file transfers
are possible.
%package devel
Summary: Development files for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
This package contains the development files for %{name}.
%prep
%autosetup -p1
%build
%meson -Dwith-lua=lua
%meson_build
%install
%meson_install
%find_lang %{name}
%files -f %{name}.lang
%{_bindir}/hexchat
%license COPYING
%doc readme.md
%dir %{_libdir}/hexchat
%dir %{_libdir}/hexchat/plugins
%{_libdir}/hexchat/plugins/checksum.so
%{_libdir}/hexchat/plugins/fishlim.so
%{_libdir}/hexchat/plugins/lua.so
%{_libdir}/hexchat/plugins/sysinfo.so
%{_libdir}/hexchat/plugins/perl.so
%{_libdir}/hexchat/plugins/python.so
%{_libdir}/hexchat/python
%{_datadir}/applications/%{app_id}.desktop
%{_datadir}/icons/hicolor/*/apps/%{name}.*
%{_datadir}/metainfo/%{app_id}.appdata.xml
%{_datadir}/dbus-1/services/org.hexchat.service.service
%{_mandir}/man1/*.gz
%files devel
%{_includedir}/hexchat-plugin.h
%{_libdir}/pkgconfig/hexchat-plugin.pc
%changelog
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 2.14.3-17
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688
* Wed Jul 28 2021 Florian Weimer <fweimer@redhat.com> - 2.14.3-16
- Rebuild to pick up OpenSSL 3.0 Beta ABI (#1984097)
* Mon Jul 12 2021 Debarshi Ray <rishi@fedoraproject.org> - 2.14.3-15
- Avoid direct use of libproxy
Resolves: #1981509
* Wed Jun 16 2021 Mohan Boddu <mboddu@redhat.com> - 2.14.3-14
- Rebuilt for RHEL 9 BETA for openssl 3.0
Related: rhbz#1971065
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 2.14.3-13
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
* Fri Mar 12 2021 Kevin Fenzi <kevin@scrye.com> - 2.14.3-12
- Add patch to fix exception in python3 plugin.
* Sat Feb 06 2021 Mikel Olasagasti Uranga <mikel@olasagasti.info> - 2.14.3-11
- Include patch to fix underscore not being printed correctly
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.14.3-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Fri Jan 15 2021 Kevin Fenzi <kevin@scrye.com> - 2.14.3-9
- Fix typo in last commit
* Fri Jan 15 2021 Kevin Fenzi <kevin@scrye.com> - 2.14.3-8
- Add missing dependency on cffi. Fixes rhbz#1914874
* Wed Dec 30 2020 Kevin Fenzi <kevin@scrye.com> - 2.14.3-7
- Backport new python plugin from devel upstream. RHBZ#1883982
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.14.3-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Mon Jun 22 2020 Jitka Plesnikova <jplesnik@redhat.com> - 2.14.3-5
- Perl 5.32 rebuild
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 2.14.3-4
- Rebuilt for Python 3.9
* Fri Mar 27 2020 Kevin Fenzi <kevin@scrye.com> - 2.14.3-3
- Add patch to link better against python3.8. Fixes #1817862
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.14.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Tue Jan 07 2020 Kevin Fenzi <kevin@scrye.com> - 2.14.3-1
- Update to 2.14.3.
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 2.14.2-6
- Rebuilt for Python 3.8
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.14.2-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Thu May 30 2019 Jitka Plesnikova <jplesnik@redhat.com> - 2.14.2-4
- Perl 5.30 rebuild
* Tue Apr 30 2019 Adam Williamson <awilliam@redhat.com> - 2.14.2-3
- Apply a fix suggested by ncoghlan for the crash-on-exit bug (#1632039)
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.14.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Thu Sep 06 2018 Gwyn Ciesla <limburgher@gmail.com> - 2.14.2-1
- 2.14.2
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.14.1-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Wed Jul 04 2018 Petr Pisar <ppisar@redhat.com> - 2.14.1-5
- Perl 5.28 rebuild
* Mon Jul 02 2018 Kevin Fenzi <kevin@scrye.com> - 2.14.1-4
- Rebuild for python 3.7
* Wed Jun 27 2018 Jitka Plesnikova <jplesnik@redhat.com> - 2.14.1-3
- Perl 5.28 rebuild
* Wed Mar 21 2018 Patrick Griffis <tingping@fedoraproject.org> 2.14.1-2
- Always use lua over luajit, just more common
- Remove no longer needed snippets
- Add enchant/enchant2 to requires
* Wed Mar 14 2018 Patrick Griffis <tingping@fedoraproject.org> 2.14.1-1
- Version bump to 2.14.1
* Sat Mar 10 2018 Patrick Griffis <tingping@fedoraproject.org> 2.14.0-1
- Version bump to 2.14.0
* Thu Feb 08 2018 Patrick Griffis <tingping@fedoraproject.org> 2.12.4-11
- Add patch fixing rendering issue: https://bugzilla.redhat.com/show_bug.cgi?id=1536298
* Tue Feb 6 2018 Peter Robinson <pbrobinson@fedoraproject.org> 2.12.4-10
- Disable luajit on aarch64 due to crashes
* Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 2.12.4-9
- Rebuilt for switch to libxcrypt
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.12.4-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.12.4-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Sun Jun 11 2017 Kevin Fenzi <kevin@scrye.com> - 2.12.4-6
- Add patch for python LC_ALL / LANGUAGES.
- https://github.com/hexchat/hexchat/issues/2013
* Sun Jun 04 2017 Jitka Plesnikova <jplesnik@redhat.com> - 2.12.4-5
- Perl 5.26 rebuild
* Sun Mar 12 2017 Peter Robinson <pbrobinson@fedoraproject.org> 2.12.4-4
- Explicitly require openssl-devel so we build against 1.1
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.12.4-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 2.12.4-2
- Rebuild for Python 3.6
* Sat Dec 10 2016 Patrick Griffis <tingping@tingping.se> - 2.12.4-1
- Version bump to 2.12.4
* Sat Oct 22 2016 Patrick Griffis <tingping@tingping.se> - 2.12.3-1
- Version bump to 2.12.3
- Fix building against OpenSSL 1.1.0
* Sun Oct 9 2016 Dan Horák <dan[at]danny.cz> - 2.12.2-2
- Not all arches have luajit
* Sat Oct 8 2016 Patrick Griffis <tingping@tingping.se> - 2.12.2-1
- Version bump to 2.12.2
* Sat Oct 8 2016 Patrick Griffis <tingping@tingping.se> - 2.12.1-7
- Modernize spec file
* Mon Sep 19 2016 Peter Robinson <pbrobinson@fedoraproject.org> 2.12.1-6
- aarch64 now has LuaJIT
* Mon Aug 29 2016 Igor Gnatenko <ignatenko@redhat.com> - 2.12.1-5
- Rebuild for LuaJIT 2.1.0
* Tue Jul 5 2016 TingPing <tingping@tingping.se> - 2.12.1-4
- Fix input style theming with Adwaita
* Tue May 17 2016 Jitka Plesnikova <jplesnik@redhat.com> - 2.12.1-3
- Perl 5.24 rebuild
* Tue May 3 2016 Peter Robinson <pbrobinson@fedoraproject.org> 2.12.1-2
- Not all arches have luajit
* Sun May 1 2016 TingPing <tingping@tingping.se> - 2.12.1-1
- Version bump to 2.12.1
* Sat Mar 12 2016 TingPing <tingping@tingping.se> - 2.12.0-1
- Version bump to 2.12.0
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.10.2-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Thu Nov 12 2015 Kevin Fenzi <kevin@scrye.com> - 2.10.2-6
- Build against python 3.5 specifically.
* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.10.2-5
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.10.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 2.10.2-3
- Perl 5.22 rebuild
* Fri Jan 30 2015 TingPing <tingping@tingping.se> - 2.10.2-2
- Do not own icon directories owned by hicolor-icon-theme (#1171904)
- Build against python3
- Make use of license macro
* Tue Nov 25 2014 TingPing <tingping@tingping.se> - 2.10.2-1
- Version bump to 2.10.2
* Thu Aug 28 2014 Jitka Plesnikova <jplesnik@redhat.com> - 2.10.1-3
- Perl 5.20 rebuild
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.10.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Mon Jul 28 2014 TingPing <tingping@tingping.se> - 2.10.1-1
- Version bump to 2.10.1
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.10.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Mon Jun 2 2014 TingPing <tingping@tingping.se> - 2.10.0-1
- Version bump to 2.10.0
* Mon Sep 16 2013 TingPing <tingping@tingping.se> - 2.9.6.1-1
- Version bump to 2.9.6.1
* Wed Sep 11 2013 TingPing <tingping@tingping.se> - 2.9.6-1
- Version bump to 2.9.6
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.9.5-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Sat Aug 03 2013 Kevin Fenzi <kevin@scrye.com> 2.9.5-2
- Rebuild for new perl
* Mon Apr 1 2013 TingPing <tingping@tingping.se> - 2.9.5-1
- Version bump to 2.9.5
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.9.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Thu Dec 27 2012 TingPing <tingping@tingping.se> - 2.9.4-1
- Initial HexChat package