RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/hexchat#37de72687af88e7d0cdb93bdafe3b5cac96e4f82
This commit is contained in:
parent
3ee596a9f1
commit
242abc6b53
18
.gitignore
vendored
18
.gitignore
vendored
@ -0,0 +1,18 @@
|
||||
/hexchat-2.9.4.tar.xz
|
||||
/hexchat-2.9.5.tar.xz
|
||||
/hexchat-2.9.6.tar.xz
|
||||
/hexchat-2.9.6.1.tar.xz
|
||||
/hexchat-2.10.0.tar.xz
|
||||
/hexchat-2.10.1.tar.xz
|
||||
/hexchat-2.10.2.tar.xz
|
||||
/hexchat-2.12.0.tar.xz
|
||||
/hexchat-2.12.1.tar.xz
|
||||
/91df075d62606ee295932f1dfefc98187b5ce839.patch
|
||||
/hexchat-2.12.2.tar.xz
|
||||
/hexchat-2.12.3.tar.xz
|
||||
/hexchat-2.12.4.tar.xz
|
||||
/hexchat-2.12.4-repack.tar.xz
|
||||
/hexchat-2.14.0.tar.xz
|
||||
/hexchat-2.14.1.tar.xz
|
||||
/hexchat-2.14.2.tar.xz
|
||||
/hexchat-2.14.3.tar.xz
|
@ -0,0 +1,31 @@
|
||||
From d9c637ae8a1137d3ca512d2c560589903a4bd79d Mon Sep 17 00:00:00 2001
|
||||
From: Adam Williamson <awilliam@redhat.com>
|
||||
Date: Tue, 30 Apr 2019 11:16:01 -0700
|
||||
Subject: [PATCH] Python plugin: Call EndInterpreter when deinit'ing the plugin
|
||||
|
||||
This fixes https://github.com/hexchat/hexchat/issues/2237 , a
|
||||
commonly-encountered bug when using Hexchat 2.14 on Python 3.7.
|
||||
Thanks to @ncoghlan for the fix.
|
||||
|
||||
Signed-off-by: Adam Williamson <awilliam@redhat.com>
|
||||
---
|
||||
plugins/python/python.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/plugins/python/python.c b/plugins/python/python.c
|
||||
index 4403474d..475756ba 100644
|
||||
--- a/plugins/python/python.c
|
||||
+++ b/plugins/python/python.c
|
||||
@@ -2806,6 +2806,9 @@ hexchat_plugin_deinit(void)
|
||||
xchatout_buffer = NULL;
|
||||
|
||||
if (interp_plugin) {
|
||||
+ PyThreadState *tstate = ((PluginObject*)interp_plugin)->tstate;
|
||||
+ PyThreadState_Swap(tstate);
|
||||
+ Py_EndInterpreter(tstate);
|
||||
Py_DECREF(interp_plugin);
|
||||
interp_plugin = NULL;
|
||||
}
|
||||
--
|
||||
2.21.0
|
||||
|
28
5deb69591992d4fede9090b60d3dc847612a4d60.patch
Normal file
28
5deb69591992d4fede9090b60d3dc847612a4d60.patch
Normal file
@ -0,0 +1,28 @@
|
||||
From 5deb69591992d4fede9090b60d3dc847612a4d60 Mon Sep 17 00:00:00 2001
|
||||
From: Patrick Griffis <tingping@tingping.se>
|
||||
Date: Wed, 11 Mar 2020 11:07:56 -0700
|
||||
Subject: [PATCH] build: Better support building against python 3.8+
|
||||
|
||||
Closes #2441
|
||||
---
|
||||
plugins/python/meson.build | 8 +++++++-
|
||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/plugins/python/meson.build b/plugins/python/meson.build
|
||||
index 2ad5128e5..eb762134a 100644
|
||||
--- a/plugins/python/meson.build
|
||||
+++ b/plugins/python/meson.build
|
||||
@@ -1,6 +1,12 @@
|
||||
python_opt = get_option('with-python')
|
||||
if python_opt.startswith('python3')
|
||||
- python_dep = dependency(python_opt, version: '>= 3.3')
|
||||
+ # Python 3.8 introduced a new -embed variant
|
||||
+ if not python_opt.endswith('-embed')
|
||||
+ python_dep = dependency(python_opt + '-embed', version: '>= 3.3', required: false)
|
||||
+ endif
|
||||
+ if not python_dep.found()
|
||||
+ python_dep = dependency(python_opt, version: '>= 3.3')
|
||||
+ endif
|
||||
else
|
||||
python_dep = dependency(python_opt, version: '>= 2.7')
|
||||
endif
|
262
hexchat.spec
Normal file
262
hexchat.spec
Normal file
@ -0,0 +1,262 @@
|
||||
%global app_id io.github.Hexchat
|
||||
|
||||
Summary: A popular and easy to use graphical IRC (chat) client
|
||||
Name: hexchat
|
||||
Version: 2.14.3
|
||||
Release: 6%{?dist}
|
||||
License: GPLv2+
|
||||
URL: https://hexchat.github.io
|
||||
Source: https://dl.hexchat.net/hexchat/%{name}-%{version}.tar.xz
|
||||
|
||||
# Patch to link better to python 3.8
|
||||
Patch1: https://github.com/hexchat/hexchat/commit/5deb69591992d4fede9090b60d3dc847612a4d60.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: meson
|
||||
BuildRequires: hicolor-icon-theme
|
||||
BuildRequires: pkgconfig(glib-2.0)
|
||||
BuildRequires: pkgconfig(gtk+-2.0)
|
||||
BuildRequires: pkgconfig(dbus-glib-1)
|
||||
BuildRequires: pkgconfig(libcanberra)
|
||||
BuildRequires: pkgconfig(libnotify)
|
||||
BuildRequires: pkgconfig(libproxy-1.0)
|
||||
BuildRequires: pkgconfig(iso-codes)
|
||||
BuildRequires: pkgconfig(openssl)
|
||||
BuildRequires: pkgconfig(python3)
|
||||
BuildRequires: pkgconfig(libpci)
|
||||
BuildRequires: pkgconfig(lua)
|
||||
BuildRequires: perl-devel, perl-ExtUtils-Embed
|
||||
Requires: (enchant or enchant2)
|
||||
Recommends: sound-theme-freedesktop
|
||||
|
||||
%description
|
||||
HexChat is an easy to use graphical IRC chat client for the X Window System.
|
||||
It allows you to join multiple IRC channels (chat rooms) at the same time,
|
||||
talk publicly, private one-on-one conversations etc. Even file transfers
|
||||
are possible.
|
||||
|
||||
%package devel
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
%description devel
|
||||
This package contains the development files for %{name}.
|
||||
|
||||
%prep
|
||||
%autosetup -p1
|
||||
|
||||
%build
|
||||
%meson -Dwith-lua=lua
|
||||
%meson_build
|
||||
|
||||
%install
|
||||
%meson_install
|
||||
%find_lang %{name}
|
||||
|
||||
%files -f %{name}.lang
|
||||
%{_bindir}/hexchat
|
||||
%license COPYING
|
||||
%doc readme.md
|
||||
%dir %{_libdir}/hexchat
|
||||
%dir %{_libdir}/hexchat/plugins
|
||||
%{_libdir}/hexchat/plugins/checksum.so
|
||||
%{_libdir}/hexchat/plugins/fishlim.so
|
||||
%{_libdir}/hexchat/plugins/lua.so
|
||||
%{_libdir}/hexchat/plugins/sysinfo.so
|
||||
%{_libdir}/hexchat/plugins/perl.so
|
||||
%{_libdir}/hexchat/plugins/python.so
|
||||
%{_datadir}/applications/%{app_id}.desktop
|
||||
%{_datadir}/icons/hicolor/*/apps/%{name}.*
|
||||
%{_datadir}/metainfo/%{app_id}.appdata.xml
|
||||
%{_datadir}/dbus-1/services/org.hexchat.service.service
|
||||
%{_mandir}/man1/*.gz
|
||||
|
||||
%files devel
|
||||
%{_includedir}/hexchat-plugin.h
|
||||
%{_libdir}/pkgconfig/hexchat-plugin.pc
|
||||
|
||||
%changelog
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.14.3-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon Jun 22 2020 Jitka Plesnikova <jplesnik@redhat.com> - 2.14.3-5
|
||||
- Perl 5.32 rebuild
|
||||
|
||||
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 2.14.3-4
|
||||
- Rebuilt for Python 3.9
|
||||
|
||||
* Fri Mar 27 2020 Kevin Fenzi <kevin@scrye.com> - 2.14.3-3
|
||||
- Add patch to link better against python3.8. Fixes #1817862
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.14.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Tue Jan 07 2020 Kevin Fenzi <kevin@scrye.com> - 2.14.3-1
|
||||
- Update to 2.14.3.
|
||||
|
||||
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 2.14.2-6
|
||||
- Rebuilt for Python 3.8
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.14.2-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Thu May 30 2019 Jitka Plesnikova <jplesnik@redhat.com> - 2.14.2-4
|
||||
- Perl 5.30 rebuild
|
||||
|
||||
* Tue Apr 30 2019 Adam Williamson <awilliam@redhat.com> - 2.14.2-3
|
||||
- Apply a fix suggested by ncoghlan for the crash-on-exit bug (#1632039)
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.14.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Thu Sep 06 2018 Gwyn Ciesla <limburgher@gmail.com> - 2.14.2-1
|
||||
- 2.14.2
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.14.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Wed Jul 04 2018 Petr Pisar <ppisar@redhat.com> - 2.14.1-5
|
||||
- Perl 5.28 rebuild
|
||||
|
||||
* Mon Jul 02 2018 Kevin Fenzi <kevin@scrye.com> - 2.14.1-4
|
||||
- Rebuild for python 3.7
|
||||
|
||||
* Wed Jun 27 2018 Jitka Plesnikova <jplesnik@redhat.com> - 2.14.1-3
|
||||
- Perl 5.28 rebuild
|
||||
|
||||
* Wed Mar 21 2018 Patrick Griffis <tingping@fedoraproject.org> 2.14.1-2
|
||||
- Always use lua over luajit, just more common
|
||||
- Remove no longer needed snippets
|
||||
- Add enchant/enchant2 to requires
|
||||
|
||||
* Wed Mar 14 2018 Patrick Griffis <tingping@fedoraproject.org> 2.14.1-1
|
||||
- Version bump to 2.14.1
|
||||
|
||||
* Sat Mar 10 2018 Patrick Griffis <tingping@fedoraproject.org> 2.14.0-1
|
||||
- Version bump to 2.14.0
|
||||
|
||||
* Thu Feb 08 2018 Patrick Griffis <tingping@fedoraproject.org> 2.12.4-11
|
||||
- Add patch fixing rendering issue: https://bugzilla.redhat.com/show_bug.cgi?id=1536298
|
||||
|
||||
* Tue Feb 6 2018 Peter Robinson <pbrobinson@fedoraproject.org> 2.12.4-10
|
||||
- Disable luajit on aarch64 due to crashes
|
||||
|
||||
* Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 2.12.4-9
|
||||
- Rebuilt for switch to libxcrypt
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.12.4-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.12.4-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sun Jun 11 2017 Kevin Fenzi <kevin@scrye.com> - 2.12.4-6
|
||||
- Add patch for python LC_ALL / LANGUAGES.
|
||||
- https://github.com/hexchat/hexchat/issues/2013
|
||||
|
||||
* Sun Jun 04 2017 Jitka Plesnikova <jplesnik@redhat.com> - 2.12.4-5
|
||||
- Perl 5.26 rebuild
|
||||
|
||||
* Sun Mar 12 2017 Peter Robinson <pbrobinson@fedoraproject.org> 2.12.4-4
|
||||
- Explicitly require openssl-devel so we build against 1.1
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.12.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 2.12.4-2
|
||||
- Rebuild for Python 3.6
|
||||
|
||||
* Sat Dec 10 2016 Patrick Griffis <tingping@tingping.se> - 2.12.4-1
|
||||
- Version bump to 2.12.4
|
||||
|
||||
* Sat Oct 22 2016 Patrick Griffis <tingping@tingping.se> - 2.12.3-1
|
||||
- Version bump to 2.12.3
|
||||
- Fix building against OpenSSL 1.1.0
|
||||
|
||||
* Sun Oct 9 2016 Dan Horák <dan[at]danny.cz> - 2.12.2-2
|
||||
- Not all arches have luajit
|
||||
|
||||
* Sat Oct 8 2016 Patrick Griffis <tingping@tingping.se> - 2.12.2-1
|
||||
- Version bump to 2.12.2
|
||||
|
||||
* Sat Oct 8 2016 Patrick Griffis <tingping@tingping.se> - 2.12.1-7
|
||||
- Modernize spec file
|
||||
|
||||
* Mon Sep 19 2016 Peter Robinson <pbrobinson@fedoraproject.org> 2.12.1-6
|
||||
- aarch64 now has LuaJIT
|
||||
|
||||
* Mon Aug 29 2016 Igor Gnatenko <ignatenko@redhat.com> - 2.12.1-5
|
||||
- Rebuild for LuaJIT 2.1.0
|
||||
|
||||
* Tue Jul 5 2016 TingPing <tingping@tingping.se> - 2.12.1-4
|
||||
- Fix input style theming with Adwaita
|
||||
|
||||
* Tue May 17 2016 Jitka Plesnikova <jplesnik@redhat.com> - 2.12.1-3
|
||||
- Perl 5.24 rebuild
|
||||
|
||||
* Tue May 3 2016 Peter Robinson <pbrobinson@fedoraproject.org> 2.12.1-2
|
||||
- Not all arches have luajit
|
||||
|
||||
* Sun May 1 2016 TingPing <tingping@tingping.se> - 2.12.1-1
|
||||
- Version bump to 2.12.1
|
||||
|
||||
* Sat Mar 12 2016 TingPing <tingping@tingping.se> - 2.12.0-1
|
||||
- Version bump to 2.12.0
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.10.2-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Nov 12 2015 Kevin Fenzi <kevin@scrye.com> - 2.10.2-6
|
||||
- Build against python 3.5 specifically.
|
||||
|
||||
* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.10.2-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.10.2-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 2.10.2-3
|
||||
- Perl 5.22 rebuild
|
||||
|
||||
* Fri Jan 30 2015 TingPing <tingping@tingping.se> - 2.10.2-2
|
||||
- Do not own icon directories owned by hicolor-icon-theme (#1171904)
|
||||
- Build against python3
|
||||
- Make use of license macro
|
||||
|
||||
* Tue Nov 25 2014 TingPing <tingping@tingping.se> - 2.10.2-1
|
||||
- Version bump to 2.10.2
|
||||
|
||||
* Thu Aug 28 2014 Jitka Plesnikova <jplesnik@redhat.com> - 2.10.1-3
|
||||
- Perl 5.20 rebuild
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.10.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Mon Jul 28 2014 TingPing <tingping@tingping.se> - 2.10.1-1
|
||||
- Version bump to 2.10.1
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.10.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon Jun 2 2014 TingPing <tingping@tingping.se> - 2.10.0-1
|
||||
- Version bump to 2.10.0
|
||||
|
||||
* Mon Sep 16 2013 TingPing <tingping@tingping.se> - 2.9.6.1-1
|
||||
- Version bump to 2.9.6.1
|
||||
|
||||
* Wed Sep 11 2013 TingPing <tingping@tingping.se> - 2.9.6-1
|
||||
- Version bump to 2.9.6
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.9.5-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Sat Aug 03 2013 Kevin Fenzi <kevin@scrye.com> 2.9.5-2
|
||||
- Rebuild for new perl
|
||||
|
||||
* Mon Apr 1 2013 TingPing <tingping@tingping.se> - 2.9.5-1
|
||||
- Version bump to 2.9.5
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.9.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Thu Dec 27 2012 TingPing <tingping@tingping.se> - 2.9.4-1
|
||||
- Initial HexChat package
|
Loading…
Reference in New Issue
Block a user