21 lines
764 B
Diff
21 lines
764 B
Diff
diff -up hdparm-9.8/Makefile.nostrip hdparm-9.8/Makefile
|
|
--- hdparm-9.8/Makefile.nostrip 2009-01-14 12:48:52.000000000 +0100
|
|
+++ hdparm-9.8/Makefile 2009-01-14 12:49:17.000000000 +0100
|
|
@@ -16,7 +16,7 @@ STRIP ?= strip
|
|
CFLAGS := -O2 -W -Wall -Wbad-function-cast -Wcast-align -Wpointer-arith -Wcast-qual -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -fkeep-inline-functions -Wwrite-strings -Waggregate-return -Wnested-externs -Wtrigraphs $(CFLAGS)
|
|
|
|
#LDFLAGS = -s -static
|
|
-LDFLAGS = -s
|
|
+LDFLAGS =
|
|
INSTALL = install
|
|
INSTALL_DATA = $(INSTALL) -m 644
|
|
INSTALL_DIR = $(INSTALL) -m 755 -d
|
|
@@ -28,7 +28,6 @@ all: hdparm
|
|
|
|
hdparm: hdparm.h sgio.h $(OBJS)
|
|
$(CC) $(LDFLAGS) -o hdparm $(OBJS)
|
|
- $(STRIP) hdparm
|
|
|
|
hdparm.o: hdparm.h sgio.h
|
|
|