new patch to get a usable debuginfo rpm

This commit is contained in:
Karsten Hopp 2007-07-10 10:30:30 +00:00
parent b6b6bae470
commit c68cde5ba6
2 changed files with 20 additions and 11 deletions

View File

@ -1,11 +0,0 @@
--- hdparm-5.9/Makefile.rh1 2005-05-10 10:35:32.000000000 +0200
+++ hdparm-5.9/Makefile 2005-05-10 10:35:35.000000000 +0200
@@ -16,7 +16,7 @@
CFLAGS := -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m32 -march=i386 -mtune=pentium4 -fasynchronous-unwind-tables -W -Wall -Wbad-function-cast -Wcast-align -Wpointer-arith -Wcast-qual -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -fkeep-inline-functions -Wwrite-strings -Waggregate-return -Wnested-externs -Wtrigraphs $(CFLAGS)
-LDFLAGS = -s
+LDFLAGS =
INSTALL = install
INSTALL_DATA = $(INSTALL) -m 644
INSTALL_PROGRAM = $(INSTALL)

20
hdparm-7.6-nostrip.patch Normal file
View File

@ -0,0 +1,20 @@
--- hdparm-7.6/Makefile.nostrip 2007-07-10 12:28:33.000000000 +0200
+++ hdparm-7.6/Makefile 2007-07-10 12:28:53.000000000 +0200
@@ -16,7 +16,7 @@ endif
CFLAGS := -O2 -W -Wall -Wbad-function-cast -Wcast-align -Wpointer-arith -Wcast-qual -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -fkeep-inline-functions -Wwrite-strings -Waggregate-return -Wnested-externs -Wtrigraphs $(CFLAGS)
-LDFLAGS = -s
+LDFLAGS =
INSTALL = install
INSTALL_DATA = $(INSTALL) -m 644
INSTALL_DIR = $(INSTALL) -m 755 -d
@@ -28,7 +28,7 @@ all: hdparm
hdparm: hdparm.h $(OBJS)
$(CC) $(LDFLAGS) -o hdparm $(OBJS)
- strip hdparm
+# strip hdparm
install: all hdparm.8
if [ ! -z $(DESTDIR) ]; then $(INSTALL_DIR) $(DESTDIR) ; fi