- update to 6.1 (BLKGETSIZE fixes)
- work around hdparm's usage of kernel headers, assume that we run it on little-endian machines only
This commit is contained in:
parent
8f56a036bc
commit
6f1f0b4ca8
20
hdparm-6.1-incl.patch
Normal file
20
hdparm-6.1-incl.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- hdparm-6.1/hdparm.h.incl 2005-06-08 14:21:57.000000000 +0200
|
||||
+++ hdparm-6.1/hdparm.h 2005-06-08 14:27:50.000000000 +0200
|
||||
@@ -24,3 +24,5 @@
|
||||
extern void no_xt (void);
|
||||
extern void process_dev (char *devname);
|
||||
|
||||
+#define IDE_DRIVE_TASK_OUT 3
|
||||
+#define __le16_to_cpus(x) do {} while (0)
|
||||
--- hdparm-6.1/hdparm.c.incl 2005-06-08 14:18:28.000000000 +0200
|
||||
+++ hdparm-6.1/hdparm.c 2005-06-08 14:18:54.000000000 +0200
|
||||
@@ -19,7 +19,8 @@
|
||||
#include <linux/types.h>
|
||||
#include <linux/hdreg.h>
|
||||
#include <linux/major.h>
|
||||
-#include <asm/byteorder.h>
|
||||
+/* #include <asm/byteorder.h> */
|
||||
+#include <endian.h>
|
||||
|
||||
#include "hdparm.h"
|
||||
|
11
hdparm.spec
11
hdparm.spec
@ -1,12 +1,13 @@
|
||||
Summary: A utility for displaying and/or setting hard disk parameters.
|
||||
Name: hdparm
|
||||
Version: 5.9
|
||||
Release: 3
|
||||
Version: 6.1
|
||||
Release: 1
|
||||
License: BSD
|
||||
Group: Applications/System
|
||||
Source: http://www.ibiblio.org/pub/Linux/system/hardware/hdparm-%{version}.tar.gz
|
||||
Patch0: hdparm-5.8-help.patch
|
||||
Patch1: hdparm-5.9-nostrip.patch
|
||||
Patch2: hdparm-6.1-incl.patch
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||
ExcludeArch: s390 s390x
|
||||
|
||||
@ -19,6 +20,7 @@ performance and to spin down hard drives for power conservation.
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
perl -pi -e "s/-O2/$RPM_OPT_FLAGS/g" Makefile
|
||||
@ -41,6 +43,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/man8/hdparm.8*
|
||||
|
||||
%changelog
|
||||
* Wed Jun 08 2005 Karsten Hopp <karsten@redhat.de> 6.1-1
|
||||
- update to 6.1 (BLKGETSIZE fixes)
|
||||
- work around hdparm's usage of kernel headers, assume
|
||||
that we run it on little-endian machines only
|
||||
|
||||
* Wed May 18 2005 Karsten Hopp <karsten@redhat.de> 5.9-3
|
||||
- remove /etc/sysconfig/harddisks (#157673)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user