Update to 1.8.3 (#1528829)
This commit is contained in:
parent
4edfee5666
commit
dfcbdc82f8
1
.gitignore
vendored
1
.gitignore
vendored
@ -41,3 +41,4 @@ haproxy-1.4.8.tar.gz
|
||||
/haproxy-1.7.9.tar.gz
|
||||
/haproxy-1.8.1.tar.gz
|
||||
/haproxy-1.8.2.tar.gz
|
||||
/haproxy-1.8.3.tar.gz
|
||||
|
@ -1,153 +0,0 @@
|
||||
From f5a4b94ce9febc3b171a40f5d5fb6d0b0f9150e1 Mon Sep 17 00:00:00 2001
|
||||
From: Ryan O'Hara <rohara@redhat.com>
|
||||
Date: Fri, 15 Dec 2017 10:01:31 -0600
|
||||
Subject: [PATCH 2/2] Fix compiler warnings in halog.c
|
||||
|
||||
There were several unused variables in halog.c that each caused a
|
||||
compiler warning [-Wunused-but-set-variable]. This patch simply
|
||||
removes the declaration of said vairables and any instance where the
|
||||
unused variable was assigned a value.
|
||||
---
|
||||
contrib/halog/halog.c | 25 ++++++++-----------------
|
||||
1 file changed, 8 insertions(+), 17 deletions(-)
|
||||
|
||||
diff --git a/contrib/halog/halog.c b/contrib/halog/halog.c
|
||||
index fc336b4d..a7248173 100644
|
||||
--- a/contrib/halog/halog.c
|
||||
+++ b/contrib/halog/halog.c
|
||||
@@ -466,7 +466,7 @@ int convert_date(const char *field)
|
||||
{
|
||||
unsigned int h, m, s, ms;
|
||||
unsigned char c;
|
||||
- const char *b, *e;
|
||||
+ const char *e;
|
||||
|
||||
h = m = s = ms = 0;
|
||||
e = field;
|
||||
@@ -481,7 +481,6 @@ int convert_date(const char *field)
|
||||
}
|
||||
|
||||
/* hour + ':' */
|
||||
- b = e;
|
||||
while (1) {
|
||||
c = *(e++) - '0';
|
||||
if (c > 9)
|
||||
@@ -492,7 +491,6 @@ int convert_date(const char *field)
|
||||
goto out_err;
|
||||
|
||||
/* minute + ':' */
|
||||
- b = e;
|
||||
while (1) {
|
||||
c = *(e++) - '0';
|
||||
if (c > 9)
|
||||
@@ -503,7 +501,6 @@ int convert_date(const char *field)
|
||||
goto out_err;
|
||||
|
||||
/* second + '.' or ']' */
|
||||
- b = e;
|
||||
while (1) {
|
||||
c = *(e++) - '0';
|
||||
if (c > 9)
|
||||
@@ -516,7 +513,6 @@ int convert_date(const char *field)
|
||||
/* if there's a '.', we have milliseconds */
|
||||
if (c == (unsigned char)('.' - '0')) {
|
||||
/* millisecond second + ']' */
|
||||
- b = e;
|
||||
while (1) {
|
||||
c = *(e++) - '0';
|
||||
if (c > 9)
|
||||
@@ -539,7 +535,7 @@ int convert_date_to_timestamp(const char *field)
|
||||
{
|
||||
unsigned int d, mo, y, h, m, s;
|
||||
unsigned char c;
|
||||
- const char *b, *e;
|
||||
+ const char *e;
|
||||
time_t rawtime;
|
||||
static struct tm * timeinfo;
|
||||
static int last_res;
|
||||
@@ -626,7 +622,6 @@ int convert_date_to_timestamp(const char *field)
|
||||
}
|
||||
|
||||
/* hour + ':' */
|
||||
- b = e;
|
||||
while (1) {
|
||||
c = *(e++) - '0';
|
||||
if (c > 9)
|
||||
@@ -637,7 +632,6 @@ int convert_date_to_timestamp(const char *field)
|
||||
goto out_err;
|
||||
|
||||
/* minute + ':' */
|
||||
- b = e;
|
||||
while (1) {
|
||||
c = *(e++) - '0';
|
||||
if (c > 9)
|
||||
@@ -648,7 +642,6 @@ int convert_date_to_timestamp(const char *field)
|
||||
goto out_err;
|
||||
|
||||
/* second + '.' or ']' */
|
||||
- b = e;
|
||||
while (1) {
|
||||
c = *(e++) - '0';
|
||||
if (c > 9)
|
||||
@@ -690,10 +683,10 @@ void truncated_line(int linenum, const char *line)
|
||||
|
||||
int main(int argc, char **argv)
|
||||
{
|
||||
- const char *b, *e, *p, *time_field, *accept_field, *source_field;
|
||||
+ const char *b, *p, *time_field, *accept_field, *source_field;
|
||||
const char *filter_term_code_name = NULL;
|
||||
const char *output_file = NULL;
|
||||
- int f, last, err;
|
||||
+ int f, last;
|
||||
struct timer *t = NULL;
|
||||
struct eb32_node *n;
|
||||
struct url_stat *ustat = NULL;
|
||||
@@ -945,7 +938,7 @@ int main(int argc, char **argv)
|
||||
}
|
||||
}
|
||||
|
||||
- e = field_stop(time_field + 1);
|
||||
+ field_stop(time_field + 1);
|
||||
/* we have field TIME_FIELD in [time_field]..[e-1] */
|
||||
p = time_field;
|
||||
f = 0;
|
||||
@@ -969,17 +962,15 @@ int main(int argc, char **argv)
|
||||
}
|
||||
}
|
||||
|
||||
- e = field_stop(time_field + 1);
|
||||
+ field_stop(time_field + 1);
|
||||
/* we have field TIME_FIELD in [time_field]..[e-1], let's check only the response time */
|
||||
|
||||
p = time_field;
|
||||
- err = 0;
|
||||
f = 0;
|
||||
while (!SEP(*p)) {
|
||||
tps = str2ic(p);
|
||||
if (tps < 0) {
|
||||
tps = -1;
|
||||
- err = 1;
|
||||
}
|
||||
if (++f == 4)
|
||||
break;
|
||||
@@ -1706,7 +1697,7 @@ void filter_count_ip(const char *source_field, const char *accept_field, const c
|
||||
void filter_graphs(const char *accept_field, const char *time_field, struct timer **tptr)
|
||||
{
|
||||
struct timer *t2;
|
||||
- const char *e, *p;
|
||||
+ const char *p;
|
||||
int f, err, array[5];
|
||||
|
||||
if (!time_field) {
|
||||
@@ -1717,7 +1708,7 @@ void filter_graphs(const char *accept_field, const char *time_field, struct time
|
||||
}
|
||||
}
|
||||
|
||||
- e = field_stop(time_field + 1);
|
||||
+ field_stop(time_field + 1);
|
||||
/* we have field TIME_FIELD in [time_field]..[e-1] */
|
||||
|
||||
p = time_field;
|
||||
--
|
||||
2.14.2
|
||||
|
@ -1,34 +0,0 @@
|
||||
From 84c6a66cdb51bd5a279ab35216bb6f0710e2a626 Mon Sep 17 00:00:00 2001
|
||||
From: Ryan O'Hara <rohara@redhat.com>
|
||||
Date: Fri, 15 Dec 2017 09:58:09 -0600
|
||||
Subject: [PATCH 1/2] Fix compiler warning in iprange.c
|
||||
|
||||
The declaration of main() in iprange.c did not specify a type, causing
|
||||
a compiler warning [-Wimplicit-int]. This patch simply declares main()
|
||||
to be type 'int' and calls exit(0) at the end of the function.
|
||||
---
|
||||
contrib/iprange/iprange.c | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/contrib/iprange/iprange.c b/contrib/iprange/iprange.c
|
||||
index 91690c77..abae0076 100644
|
||||
--- a/contrib/iprange/iprange.c
|
||||
+++ b/contrib/iprange/iprange.c
|
||||
@@ -111,7 +111,7 @@ static void usage(const char *argv0)
|
||||
"\n", argv0);
|
||||
}
|
||||
|
||||
-main(int argc, char **argv)
|
||||
+int main(int argc, char **argv)
|
||||
{
|
||||
char line[MAXLINE];
|
||||
int l, lnum;
|
||||
@@ -198,4 +198,5 @@ main(int argc, char **argv)
|
||||
convert_range(sa, da, he, NULL);
|
||||
}
|
||||
}
|
||||
+ exit(0);
|
||||
}
|
||||
--
|
||||
2.14.2
|
||||
|
10
haproxy.spec
10
haproxy.spec
@ -7,7 +7,7 @@
|
||||
%global _hardened_build 1
|
||||
|
||||
Name: haproxy
|
||||
Version: 1.8.2
|
||||
Version: 1.8.3
|
||||
Release: 1%{?dist}
|
||||
Summary: HAProxy reverse proxy for high availability environments
|
||||
|
||||
@ -22,9 +22,6 @@ Source3: %{name}.logrotate
|
||||
Source4: %{name}.sysconfig
|
||||
Source5: halog.1
|
||||
|
||||
Patch0: contrib-halog-compliler-warnings.patch
|
||||
Patch1: contrib-iprange-compliler-warnings.patch
|
||||
|
||||
BuildRequires: lua-devel
|
||||
BuildRequires: pcre-devel
|
||||
BuildRequires: zlib-devel
|
||||
@ -52,8 +49,6 @@ availability environments. Indeed, it can:
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
regparm_opts=
|
||||
@ -139,6 +134,9 @@ exit 0
|
||||
%attr(-,%{haproxy_user},%{haproxy_group}) %dir %{haproxy_home}
|
||||
|
||||
%changelog
|
||||
* Fri Jan 05 2018 Ryan O'Hara <rohara@redhat.com> - 1.8.3-1
|
||||
- Update to 1.8.3 (#1528829)
|
||||
|
||||
* Wed Dec 27 2017 Ryan O'Hara <rohara@redhat.com> - 1.8.2-1
|
||||
- Update to 1.8.2
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (haproxy-1.8.2.tar.gz) = 9b75d41c4d40bd9ded39514f38b3118c06047b8e245657a1e029e3bb8a31164ee52aa86d7daef67558bca4c517f0f8eacba8595c4c2826cac37b93282e15f4c3
|
||||
SHA512 (haproxy-1.8.3.tar.gz) = 6118ccbcfe07d96c2cce1a78c30db9c428f8b64e64fc3f5660392a501ecbaefdc5b10bea2f65c6bb3d8e7763b3e17db4ee34e13f689474f8243b52250e212600
|
||||
|
Loading…
Reference in New Issue
Block a user