adding upstream patches for mandir and error reporting

This commit is contained in:
jjh 2008-11-22 21:08:17 +00:00
parent bb820850b4
commit c0a4a74569
3 changed files with 85 additions and 3 deletions

View File

@ -0,0 +1,47 @@
From 304d6fb00fe32fca1bd932a301d4afb7d54c92bc Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@1wt.eu>
Date: Sun, 16 Nov 2008 07:40:34 +0100
Subject: [PATCH] [BUG] critical errors should be reported even in daemon mode
Josh Goebel reported that haproxy silently dies when it fails to
chroot. In fact, it does so when in daemon mode, because daemon
mode has been disabling output for ages.
Since the code has been reworked, this could have been changed
because there is no reason for this anymore, hence this patch.
---
src/haproxy.c | 8 ++------
1 files changed, 2 insertions(+), 6 deletions(-)
diff --git a/src/haproxy.c b/src/haproxy.c
index 50b013b..3eedfce 100644
--- a/src/haproxy.c
+++ b/src/haproxy.c
@@ -895,11 +895,6 @@ int main(int argc, char **argv)
signal(SIGTTOU, sig_pause);
signal(SIGTTIN, sig_listen);
- if (global.mode & MODE_DAEMON) {
- global.mode &= ~MODE_VERBOSE;
- global.mode |= MODE_QUIET;
- }
-
/* MODE_QUIET can inhibit alerts and warnings below this line */
global.mode &= ~MODE_STARTING;
@@ -1061,10 +1056,11 @@ int main(int argc, char **argv)
* it would have already be done, and 0-2 would have been affected to listening
* sockets
*/
- if (!(global.mode & MODE_QUIET)) {
+ if (!(global.mode & MODE_QUIET) || (global.mode & MODE_VERBOSE)) {
/* detach from the tty */
fclose(stdin); fclose(stdout); fclose(stderr);
close(0); close(1); close(2); /* close all fd's */
+ global.mode &= ~MODE_VERBOSE;
global.mode |= MODE_QUIET; /* ensure that we won't say anything from now */
}
pid = getpid(); /* update child's pid */
--
1.5.5.1

26
haproxy-1.3-mandir.patch Normal file
View File

@ -0,0 +1,26 @@
From a2b53f8831b84b7c8647d7e960b84defd3bcbfa8 Mon Sep 17 00:00:00 2001
From: Jeremy Hinegardner <jeremy@hinegardner.org>
Date: Sat, 15 Nov 2008 17:29:03 -0700
Subject: [PATCH] [BUILD] fix MANDIR default location to match documentation
I found this while building for Fedora.
---
Makefile | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/Makefile b/Makefile
index bf172f6..eb72de6 100644
--- a/Makefile
+++ b/Makefile
@@ -62,7 +62,7 @@
DESTDIR =
PREFIX = /usr/local
SBINDIR = $(PREFIX)/sbin
-MANDIR = $(PREFIX)/man
+MANDIR = $(PREFIX)/share/man
DOCDIR = $(PREFIX)/doc/haproxy
#### TARGET system
--
1.5.5.1

View File

@ -6,7 +6,7 @@
Name: haproxy
Version: 1.3.15.6
Release: 1%{?dist}
Release: 2%{?dist}
Summary: HA-Proxy is a TCP/HTTP reverse proxy for high availability environments
Group: System Environment/Daemons
@ -17,6 +17,10 @@ Source0: http://haproxy.1wt.eu/download/1.3/src/haproxy-%{version}.tar.gz
Source1: %{name}.init
Source2: %{name}.cfg
# patches from upstream, these will be merged into the next release
Patch0: haproxy-1.3-mandir.patch
Patch1: haproxy-1.3-error-reporting.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: pcre-devel
@ -41,6 +45,8 @@ availability environments. Indeed, it can:
%prep
%setup -q
%patch0 -p1 -b .mandir
%patch1 -p1 -b .error-reporting
%build
@ -58,8 +64,8 @@ make %{?_smp_mflags} CPU="generic" TARGET="linux26" USE_PCRE=1 ${regparm_opts} A
%install
rm -rf %{buildroot}
make install-bin DESTDIR=%{buildroot} PREFIX=%{_prefix} MANDIR=%{_mandir}
make install-man DESTDIR=%{buildroot} PREFIX=%{_prefix} MANDIR=%{_mandir}
make install-bin DESTDIR=%{buildroot} PREFIX=%{_prefix}
make install-man DESTDIR=%{buildroot} PREFIX=%{_prefix}
%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{haproxy_confdir}/%{name}.cfg
@ -127,6 +133,9 @@ fi
%changelog
* Sat Nov 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 1.3.15.6-2
- apply upstream patches
* Sat Nov 15 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 1.3.15.6-1
- update to 1.3.15.6
- use new build targets from upstream