Update to 1.4.25
This commit is contained in:
parent
d474681ad2
commit
98262d96d7
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@ haproxy-1.4.8.tar.gz
|
|||||||
/haproxy-1.4.22.tar.gz
|
/haproxy-1.4.22.tar.gz
|
||||||
/haproxy-1.4.23.tar.gz
|
/haproxy-1.4.23.tar.gz
|
||||||
/haproxy-1.4.24.tar.gz
|
/haproxy-1.4.24.tar.gz
|
||||||
|
/haproxy-1.4.25.tar.gz
|
||||||
|
102
halog-unused-variables.patch
Normal file
102
halog-unused-variables.patch
Normal file
@ -0,0 +1,102 @@
|
|||||||
|
--- contrib/halog/halog.c.orig 2014-02-02 18:41:29.000000000 -0500
|
||||||
|
+++ contrib/halog/halog.c 2014-02-21 22:08:19.265000000 -0500
|
||||||
|
@@ -456,7 +456,7 @@
|
||||||
|
{
|
||||||
|
unsigned int h, m, s, ms;
|
||||||
|
unsigned char c;
|
||||||
|
- const char *b, *e;
|
||||||
|
+ const char *e;
|
||||||
|
|
||||||
|
h = m = s = ms = 0;
|
||||||
|
e = field;
|
||||||
|
@@ -471,7 +471,6 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
/* hour + ':' */
|
||||||
|
- b = e;
|
||||||
|
while (1) {
|
||||||
|
c = *(e++) - '0';
|
||||||
|
if (c > 9)
|
||||||
|
@@ -482,7 +481,6 @@
|
||||||
|
goto out_err;
|
||||||
|
|
||||||
|
/* minute + ':' */
|
||||||
|
- b = e;
|
||||||
|
while (1) {
|
||||||
|
c = *(e++) - '0';
|
||||||
|
if (c > 9)
|
||||||
|
@@ -493,7 +491,6 @@
|
||||||
|
goto out_err;
|
||||||
|
|
||||||
|
/* second + '.' or ']' */
|
||||||
|
- b = e;
|
||||||
|
while (1) {
|
||||||
|
c = *(e++) - '0';
|
||||||
|
if (c > 9)
|
||||||
|
@@ -506,7 +503,6 @@
|
||||||
|
/* if there's a '.', we have milliseconds */
|
||||||
|
if (c == (unsigned char)('.' - '0')) {
|
||||||
|
/* millisecond second + ']' */
|
||||||
|
- b = e;
|
||||||
|
while (1) {
|
||||||
|
c = *(e++) - '0';
|
||||||
|
if (c > 9)
|
||||||
|
@@ -529,10 +525,10 @@
|
||||||
|
|
||||||
|
int main(int argc, char **argv)
|
||||||
|
{
|
||||||
|
- const char *b, *e, *p, *time_field, *accept_field, *source_field;
|
||||||
|
+ const char *b, *p, *time_field, *accept_field, *source_field;
|
||||||
|
const char *filter_term_code_name = NULL;
|
||||||
|
const char *output_file = NULL;
|
||||||
|
- int f, last, err;
|
||||||
|
+ int f, last;
|
||||||
|
struct timer *t = NULL;
|
||||||
|
struct eb32_node *n;
|
||||||
|
struct url_stat *ustat = NULL;
|
||||||
|
@@ -761,7 +757,7 @@
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
- e = field_stop(time_field + 1);
|
||||||
|
+ field_stop(time_field + 1);
|
||||||
|
/* we have field TIME_FIELD in [time_field]..[e-1] */
|
||||||
|
p = time_field;
|
||||||
|
f = 0;
|
||||||
|
@@ -785,17 +781,15 @@
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
- e = field_stop(time_field + 1);
|
||||||
|
+ field_stop(time_field + 1);
|
||||||
|
/* we have field TIME_FIELD in [time_field]..[e-1], let's check only the response time */
|
||||||
|
|
||||||
|
p = time_field;
|
||||||
|
- err = 0;
|
||||||
|
f = 0;
|
||||||
|
while (!SEP(*p)) {
|
||||||
|
tps = str2ic(p);
|
||||||
|
if (tps < 0) {
|
||||||
|
tps = -1;
|
||||||
|
- err = 1;
|
||||||
|
}
|
||||||
|
if (++f == 4)
|
||||||
|
break;
|
||||||
|
@@ -1521,7 +1515,7 @@
|
||||||
|
void filter_graphs(const char *accept_field, const char *time_field, struct timer **tptr)
|
||||||
|
{
|
||||||
|
struct timer *t2;
|
||||||
|
- const char *e, *p;
|
||||||
|
+ const char *p;
|
||||||
|
int f, err, array[5];
|
||||||
|
|
||||||
|
if (!time_field) {
|
||||||
|
@@ -1532,7 +1526,7 @@
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
- e = field_stop(time_field + 1);
|
||||||
|
+ field_stop(time_field + 1);
|
||||||
|
/* we have field TIME_FIELD in [time_field]..[e-1] */
|
||||||
|
|
||||||
|
p = time_field;
|
11
haproxy.spec
11
haproxy.spec
@ -7,8 +7,8 @@
|
|||||||
%global _hardened_build 1
|
%global _hardened_build 1
|
||||||
|
|
||||||
Name: haproxy
|
Name: haproxy
|
||||||
Version: 1.4.24
|
Version: 1.4.25
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: HA-Proxy is a TCP/HTTP reverse proxy for high availability environments
|
Summary: HA-Proxy is a TCP/HTTP reverse proxy for high availability environments
|
||||||
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -20,10 +20,11 @@ Source1: %{name}.service
|
|||||||
Source2: %{name}.cfg
|
Source2: %{name}.cfg
|
||||||
Source3: %{name}.logrotate
|
Source3: %{name}.logrotate
|
||||||
|
|
||||||
|
Patch0: halog-unused-variables.patch
|
||||||
|
|
||||||
BuildRequires: pcre-devel
|
BuildRequires: pcre-devel
|
||||||
BuildRequires: systemd-units
|
BuildRequires: systemd-units
|
||||||
|
|
||||||
|
|
||||||
Requires(pre): shadow-utils
|
Requires(pre): shadow-utils
|
||||||
Requires(post): systemd
|
Requires(post): systemd
|
||||||
Requires(preun): systemd
|
Requires(preun): systemd
|
||||||
@ -44,6 +45,7 @@ availability environments. Indeed, it can:
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p0
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -131,6 +133,9 @@ exit 0
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 27 2014 Ryan O'Hara <rohara@redhat.com> - 1.4.25-1
|
||||||
|
- Update to 1.4.25
|
||||||
|
|
||||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.24-2
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.24-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user