Remove unused patches
This commit is contained in:
parent
6d98e358f8
commit
6e1a18252b
@ -1,38 +0,0 @@
|
||||
From 623401b983185c1e0f6507e96557de3bc46fd41b Mon Sep 17 00:00:00 2001
|
||||
From: Thierry FOURNIER <tfournier@exceliance.fr>
|
||||
Date: Fri, 6 Feb 2015 17:53:54 +0100
|
||||
Subject: [PATCH 2/3] BUG/MEDIUM: pattern: some entries are not deleted with
|
||||
case insensitive match
|
||||
|
||||
ACL or map entries are not deleted with the command "del acl" or "del map"
|
||||
if the case insentive flag is set.
|
||||
|
||||
This is because the the case insensitive string are stored in a list and the
|
||||
default delete function associated with string looks in a tree. I add a check
|
||||
of the case insensitive flag and execute the delete function for lists if it
|
||||
is set.
|
||||
|
||||
This patch must be backported in 1.5 version.
|
||||
(cherry picked from commit 73bc285be194f443dc7eab9c949e87e1dbe8f70c)
|
||||
---
|
||||
src/pattern.c | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/pattern.c b/src/pattern.c
|
||||
index a6fc52d..b19ffe2 100644
|
||||
--- a/src/pattern.c
|
||||
+++ b/src/pattern.c
|
||||
@@ -1308,6 +1308,10 @@ void pat_del_tree_str(struct pattern_expr *expr, struct pat_ref_elt *ref)
|
||||
struct ebmb_node *node, *next_node;
|
||||
struct pattern_tree *elt;
|
||||
|
||||
+ /* If the flag PAT_F_IGNORE_CASE is set, we cannot use trees */
|
||||
+ if (expr->mflags & PAT_MF_IGNORE_CASE)
|
||||
+ return pat_del_list_ptr(expr, ref);
|
||||
+
|
||||
/* browse each node of the tree. */
|
||||
for (node = ebmb_first(&expr->pattern_tree), next_node = node ? ebmb_next(node) : NULL;
|
||||
node;
|
||||
--
|
||||
1.9.3
|
||||
|
@ -1,30 +0,0 @@
|
||||
From e338a8741983acc9a4501a03ecd593d89e6fade3 Mon Sep 17 00:00:00 2001
|
||||
From: Thierry FOURNIER <tfournier@exceliance.fr>
|
||||
Date: Fri, 6 Feb 2015 17:50:55 +0100
|
||||
Subject: [PATCH 1/3] BUG/MINOR: pattern: error message missing
|
||||
|
||||
This patch must be backported in 1.5 version.
|
||||
(cherry picked from commit 8aa8384e22dd0b66ded00c70a9c6034278b4bb69)
|
||||
---
|
||||
src/pattern.c | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/pattern.c b/src/pattern.c
|
||||
index 208e33a..a6fc52d 100644
|
||||
--- a/src/pattern.c
|
||||
+++ b/src/pattern.c
|
||||
@@ -989,8 +989,10 @@ int pat_idx_list_ptr(struct pattern_expr *expr, struct pattern *pat, char **err)
|
||||
|
||||
/* allocate pattern */
|
||||
patl = calloc(1, sizeof(*patl));
|
||||
- if (!patl)
|
||||
+ if (!patl) {
|
||||
+ memprintf(err, "out of memory while indexing pattern");
|
||||
return 0;
|
||||
+ }
|
||||
|
||||
/* duplicate pattern */
|
||||
memcpy(&patl->pat, pat, sizeof(*pat));
|
||||
--
|
||||
1.9.3
|
||||
|
11
haproxy.spec
11
haproxy.spec
@ -8,7 +8,7 @@
|
||||
|
||||
Name: haproxy
|
||||
Version: 1.5.12
|
||||
Release: 1%{?dist}
|
||||
Release: %{?dist}
|
||||
Summary: HAProxy reverse proxy for high availability environments
|
||||
|
||||
Group: System Environment/Daemons
|
||||
@ -24,9 +24,7 @@ Source5: halog.1
|
||||
|
||||
Patch0: halog-unused-variables.patch
|
||||
Patch1: iprange-return-type.patch
|
||||
Patch2: haproxy-pattern-oom-error.patch
|
||||
Patch3: haproxy-pattern-delete-acl-map.patch
|
||||
Patch4: haproxy-tcp-user-timeout.patch
|
||||
Patch2: haproxy-tcp-user-timeout.patch
|
||||
|
||||
BuildRequires: pcre-devel
|
||||
BuildRequires: zlib-devel
|
||||
@ -57,8 +55,6 @@ availability environments. Indeed, it can:
|
||||
%patch0 -p0
|
||||
%patch1 -p0
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
|
||||
%build
|
||||
regparm_opts=
|
||||
@ -144,6 +140,9 @@ exit 0
|
||||
%attr(-,%{haproxy_user},%{haproxy_group}) %dir %{haproxy_home}
|
||||
|
||||
%changelog
|
||||
* Tue May 05 2015 Ryan O'Hara <rohara@redhat.com> - 1.5.12-2
|
||||
- Remove unused patches
|
||||
|
||||
* Tue May 05 2015 Ryan O'Hara <rohara@redhat.com> - 1.5.12-1
|
||||
- Update to 1.5.12 (#1217922)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user