diff --git a/.gitignore b/.gitignore
index bb4e160..3c27dda 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,3 @@
-hamcrest-1.1.tgz
/hamcrest-all-1.3.pom
/hamcrest-core-1.3.pom
/hamcrest-generator-1.3.pom
@@ -6,4 +5,9 @@ hamcrest-1.1.tgz
/hamcrest-library-1.3.pom
/hamcrest-parent-1.3.pom
/hamcrest-text-1.3.pom
-/hamcrest-1.3.tgz
+/hamcrest-*.tgz
+/hamcrest-*/
+/.project
+/*.src.rpm
+/noarch
+/.build-*.log
diff --git a/hamcrest-1.3-no-integration.patch b/hamcrest-1.3-no-integration.patch
deleted file mode 100644
index 886083d..0000000
--- a/hamcrest-1.3-no-integration.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/build.xml b/build.xml
-index c59c9fa..e5eaa56 100644
---- a/build.xml
-+++ b/build.xml
-@@ -112,7 +112,7 @@
- build/hamcrest-integration-${version}.jar"/>
-
-
--
-
-
-@@ -132,7 +132,6 @@
-
-
-
--
-
-
-
-@@ -146,11 +145,6 @@
-
--
--
--
--
--
-
-
-
diff --git a/hamcrest.spec b/hamcrest.spec
index 771e567..e2cd5b8 100644
--- a/hamcrest.spec
+++ b/hamcrest.spec
@@ -33,9 +33,6 @@
%define bcond_with() %{expand:%%{?_with_%{1}:%%global with_%{1} 1}}
%define bcond_without() %{expand:%%{!?_without_%{1}:%%global with_%{1} 1}}
-# This option controls integration which requires easymock2 and jmock
-%bcond_without integration
-
# This option controls jarjar on qdox
# Since bundling the qdox classes prevents upgrades, we disable it by default
%bcond_with jarjar
@@ -43,14 +40,9 @@
# This option controls tests which requires ant-junit and testng
%bcond_with tests
-# If integration is disabled, then tests are disabled
-%if %without integration
-%bcond_with tests
-%endif
-
Name: hamcrest
Version: 1.3
-Release: 7%{?dist}
+Release: 8%{?dist}
Epoch: 0
Summary: Library of matchers for building test expressions
License: BSD
@@ -75,24 +67,18 @@ Source12: hamcrest-generator-MANIFEST.MF
Patch0: %{name}-%{version}-build.patch
Patch1: %{name}-%{version}-no-jarjar.patch
-Patch2: %{name}-%{version}-no-integration.patch
Patch3: %{name}-%{version}-javadoc.patch
Requires: java-headless >= 1:1.6.0
Requires: qdox
-%if %with integration
Requires: easymock3
-#Requires: jmock
-%endif
BuildRequires: jpackage-utils >= 0:1.7.4
BuildRequires: java-devel >= 1:1.6.0
BuildRequires: ant >= 0:1.6.5
BuildRequires: ant-junit
BuildRequires: zip
-%if %with integration
BuildRequires: easymock3
-%endif
%if %with jarjar
BuildRequires: jarjar
%endif
@@ -143,12 +129,9 @@ ln -sf $(build-classpath jarjar) lib/generator/
# BUILD/hamcrest-1.1/lib/generator/qdox-1.6.1.jar.no
ln -sf $(build-classpath qdox) lib/generator/
# BUILD/hamcrest-1.1/lib/integration/easymock-2.2.jar.no
-%if %with integration
-# easymock2 is now compat package
ln -sf $(build-classpath easymock3) lib/integration/
# BUILD/hamcrest-1.1/lib/integration/jmock-1.10RC1.jar.no
ln -sf $(build-classpath jmock) lib/integration/
-%endif
# BUILD/hamcrest-1.1/lib/integration/testng-4.6-jdk15.jar.no
%if %with tests
ln -sf $(build-classpath testng-jdk15) lib/integration/
@@ -157,9 +140,6 @@ ln -sf $(build-classpath testng-jdk15) lib/integration/
%if %without jarjar
%patch1 -p1
%endif
-%if %without integration
-%patch2 -p1
-%endif
%patch3 -p1
perl -pi -e 's/\r$//g' LICENSE.txt
@@ -224,11 +204,9 @@ install -m 644 build/%{name}-library-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%
install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_mavenpomdir}/JPP.%{name}-library.pom
%add_maven_depmap JPP.%{name}-library.pom %{name}/library.jar
-%if %with integration
install -m 644 build/%{name}-integration-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}/integration.jar
install -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_mavenpomdir}/JPP.%{name}-integration.pom
%add_maven_depmap JPP.%{name}-integration.pom %{name}/integration.jar
-%endif
install -m 644 build/%{name}-text-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}/text.jar
install -m 644 %{SOURCE7} $RPM_BUILD_ROOT%{_mavenpomdir}/JPP.%{name}-text.pom
@@ -246,22 +224,12 @@ cp -pr build/temp/hamcrest-all-1.3-javadoc.jar.contents/* $RPM_BUILD_ROOT%{_java
install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/%{name}
cp -pr %{name}-examples $RPM_BUILD_ROOT%{_datadir}/%{name}/
-%files
+%files -f .mfiles
%doc LICENSE.txt
%dir %{_javadir}/%{name}
-%{_javadir}/%{name}/all.jar
-%{_javadir}/%{name}/core.jar
-%{_javadir}/%{name}/generator.jar
-%if %with integration
-%{_javadir}/%{name}/integration.jar
-%endif
-%{_javadir}/%{name}/library.jar
-%{_javadir}/%{name}/text.jar
%if %with tests
%{_javadir}/%{name}/unit-test.jar
%endif
-%{_mavenpomdir}/*
-%{_mavendepmapfragdir}/*
%files javadoc
%{_javadocdir}/%{name}
@@ -270,6 +238,11 @@ cp -pr %{name}-examples $RPM_BUILD_ROOT%{_datadir}/%{name}/
%{_datadir}/%{name}
%changelog
+* Wed Jul 30 2014 Mat Booth - 0:1.3-8
+- Fix FTBFS
+- Always build integration jar (removes some complexity from the spec)
+- Drop unused patch
+
* Sat Jun 07 2014 Fedora Release Engineering - 0:1.3-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild