- initial import

This commit is contained in:
dwalluck 2008-10-27 19:00:46 +00:00
parent 3e9c6ed52c
commit 643a32b000
14 changed files with 811 additions and 0 deletions

View File

@ -0,0 +1 @@
hamcrest-1.1.tgz

42
hamcrest-1.1-build.patch Normal file
View File

@ -0,0 +1,42 @@
--- build.xml.sav0 2007-06-30 15:03:43.000000000 +0200
+++ build.xml 2008-02-14 12:07:25.000000000 +0100
@@ -26,17 +26,17 @@
<java-to-jar srcdir="hamcrest-generator/src/main/java"
destjar="build/temp/hamcrest-generator-${version}-nodeps.jar"
classpath="
- lib/generator/qdox-1.6.1.jar;
+ lib/generator/qdox.jar;
"/>
<taskdef name="jarjar"
classname="com.tonicsystems.jarjar.JarJarTask"
- classpath="lib/generator/jarjar-1.0rc3.jar"/>
+ classpath="lib/generator/jarjar.jar"/>
<!-- Bundle QDox classes in hamcrest-generator.jar so user doesn't need to care
about it's existence. Uses JarJar to place classes under a different package
to prevent conflict. -->
<jarjar jarfile="build/hamcrest-generator-${version}.jar">
<zipfileset src="build/temp/hamcrest-generator-${version}-nodeps.jar"/>
- <zipfileset src="lib/generator/qdox-1.6.1.jar"/>
+ <zipfileset src="lib/generator/qdox.jar"/>
<rule pattern="com.thoughtworks.qdox.**"
result="org.hamcrest.generator.qdox.@1"/>
</jarjar>
@@ -211,7 +211,7 @@
<target name="javadoc" depends="library">
<mkdir dir="build/javadoc"/>
<javadoc destdir="build/javadoc" source="1.5" failonerror="yes"
- overview="overview.html">
+ >
<classpath>
<fileset dir="lib/integration">
@@ -223,7 +223,8 @@
<packageset dir="hamcrest-library/src/main/java" excludes="org/hamcrest/internal"/>
<packageset dir="hamcrest-text/src/main/java" excludes="**/internal/**"/>
<packageset dir="hamcrest-integration/src/main/java"/>
- <packageset dir="build/generated-code"/>
+ <packageset dir="build/temp/hamcrest-core/generated-code"/>
+ <packageset dir="build/temp/hamcrest-library/generated-code"/>
<group title="Hamcrest API and Utility Classes" packages="org.hamcrest"/>
<group title="Matcher Library" packages="org.hamcrest.*"/>

View File

@ -0,0 +1,41 @@
--- hamcrest-1.1/build.xml~ 2008-10-24 11:37:35.000000000 -0400
+++ hamcrest-1.1/build.xml 2008-10-24 11:39:22.839767600 -0400
@@ -147,14 +147,13 @@
</target>
<target name="bigjar"
- depends="core, library, text, integration, generator"
+ depends="core, library, text, generator"
description="Build a single Jar (hamcrest-all.jar) that contains core, library, generator and integration.">
<jar jarfile="build/hamcrest-all-${version}.jar" duplicate="preserve">
<zipfileset src="build/hamcrest-core-${version}.jar"/>
<zipfileset src="build/hamcrest-library-${version}.jar"/>
<zipfileset src="build/hamcrest-text-${version}.jar"/>
<zipfileset src="build/hamcrest-generator-${version}.jar"/>
- <zipfileset src="build/hamcrest-integration-${version}.jar"/>
</jar>
</target>
@@ -201,22 +200,15 @@
<javadoc destdir="build/javadoc" source="1.5" failonerror="yes"
>
- <classpath>
- <fileset dir="lib/integration">
- <include name="*.jar"/>
- </fileset>
- </classpath>
<packageset dir="hamcrest-core/src/main/java"/>
<packageset dir="hamcrest-library/src/main/java" excludes="org/hamcrest/internal"/>
<packageset dir="hamcrest-text/src/main/java" excludes="**/internal/**"/>
- <packageset dir="hamcrest-integration/src/main/java"/>
<packageset dir="build/temp/hamcrest-core/generated-code"/>
<packageset dir="build/temp/hamcrest-library/generated-code"/>
<group title="Hamcrest API and Utility Classes" packages="org.hamcrest"/>
<group title="Matcher Library" packages="org.hamcrest.*"/>
- <group title="Integration" packages="org.hamcrest.integration, org.hamcrest.integration.*"/>
<link offline="false" href="http://java.sun.com/j2se/1.5.0/docs/api/"/>
<link offline="false" href="http://www.junit.org/junit/javadoc/3.8.1/"/>

View File

@ -0,0 +1,26 @@
--- hamcrest-1.1/build.xml.jarjar 2008-10-24 11:35:30.171892280 -0400
+++ hamcrest-1.1/build.xml 2008-10-24 11:36:07.667890720 -0400
@@ -24,22 +24,10 @@
<target name="generator"
description="Build code generator tool">
<java-to-jar srcdir="hamcrest-generator/src/main/java"
- destjar="build/temp/hamcrest-generator-${version}-nodeps.jar"
+ destjar="build/hamcrest-generator-${version}.jar"
classpath="
lib/generator/qdox.jar;
"/>
- <taskdef name="jarjar"
- classname="com.tonicsystems.jarjar.JarJarTask"
- classpath="lib/generator/jarjar.jar"/>
- <!-- Bundle QDox classes in hamcrest-generator.jar so user doesn't need to care
- about it's existence. Uses JarJar to place classes under a different package
- to prevent conflict. -->
- <jarjar jarfile="build/hamcrest-generator-${version}.jar">
- <zipfileset src="build/temp/hamcrest-generator-${version}-nodeps.jar"/>
- <zipfileset src="lib/generator/qdox.jar"/>
- <rule pattern="com.thoughtworks.qdox.**"
- result="org.hamcrest.generator.qdox.@1"/>
- </jarjar>
</target>
<target name="core"

12
hamcrest-all-1.1.pom Normal file
View File

@ -0,0 +1,12 @@
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.hamcrest</groupId>
<artifactId>hamcrest-parent</artifactId>
<version>1.1</version>
</parent>
<artifactId>hamcrest-all</artifactId>
<packaging>jar</packaging>
<name>Hamcrest All</name>
</project>

12
hamcrest-core-1.1.pom Normal file
View File

@ -0,0 +1,12 @@
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.hamcrest</groupId>
<artifactId>hamcrest-parent</artifactId>
<version>1.1</version>
</parent>
<artifactId>hamcrest-core</artifactId>
<packaging>jar</packaging>
<name>Hamcrest Core</name>
</project>

View File

@ -0,0 +1,20 @@
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.hamcrest</groupId>
<artifactId>hamcrest-parent</artifactId>
<version>1.1</version>
</parent>
<artifactId>hamcrest-generator</artifactId>
<packaging>jar</packaging>
<name>Hamcrest Generator</name>
<dependencies>
<dependency>
<groupId>${pom.groupId}</groupId>
<artifactId>hamcrest-core</artifactId>
<version>${pom.version}</version>
</dependency>
</dependencies>
</project>

View File

@ -0,0 +1,20 @@
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.hamcrest</groupId>
<artifactId>hamcrest-parent</artifactId>
<version>1.1</version>
</parent>
<artifactId>hamcrest-integration</artifactId>
<packaging>jar</packaging>
<name>Hamcrest Integration</name>
<dependencies>
<dependency>
<groupId>${pom.groupId}</groupId>
<artifactId>hamcrest-core</artifactId>
<version>${pom.version}</version>
</dependency>
</dependencies>
</project>

20
hamcrest-library-1.1.pom Normal file
View File

@ -0,0 +1,20 @@
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.hamcrest</groupId>
<artifactId>hamcrest-parent</artifactId>
<version>1.1</version>
</parent>
<artifactId>hamcrest-library</artifactId>
<packaging>jar</packaging>
<name>Hamcrest Library</name>
<dependencies>
<dependency>
<groupId>${pom.groupId}</groupId>
<artifactId>hamcrest-core</artifactId>
<version>${pom.version}</version>
</dependency>
</dependencies>
</project>

170
hamcrest-parent-1.1.pom Normal file
View File

@ -0,0 +1,170 @@
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>org.hamcrest</groupId>
<artifactId>hamcrest-parent</artifactId>
<packaging>pom</packaging>
<version>1.1</version>
<name>Hamcrest Parent</name>
<inceptionYear>2006</inceptionYear>
<organization>
<name>Hamcrest</name>
<url>http://code.google.com/p/hamcrest</url>
</organization>
<licenses>
<license>
<name>BSD style</name>
<url>http://www.opensource.org/licenses/bsd-license.php</url>
<distribution>repo</distribution>
</license>
</licenses>
<scm>
<developerConnection>scm:svn:https://hamcrest.googlecode.com/svn/tags/hamcrest-packaging-maven-1.1</developerConnection>
<url>https://hamcrest.googlecode.com/svn/tags/hamcrest-packaging-maven-1.1</url>
</scm>
<modules>
<module>hamcrest-all</module>
<module>hamcrest-core</module>
<module>hamcrest-generator</module>
<module>hamcrest-integration</module>
<module>hamcrest-library</module>
</modules>
<!-- NOTE: all dependencies are declared at scope provided as they are optional -->
<dependencyManagement>
<dependencies>
<dependency>
<groupId>jmock</groupId>
<artifactId>jmock</artifactId>
<version>1.1.0</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
<version>4.0</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>org.easymock</groupId>
<artifactId>easymock</artifactId>
<version>2.2</version>
<scope>provided</scope>
</dependency>
</dependencies>
</dependencyManagement>
<dependencies>
<dependency>
<groupId>jmock</groupId>
<artifactId>jmock</artifactId>
</dependency>
<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
</dependency>
<dependency>
<groupId>org.easymock</groupId>
<artifactId>easymock</artifactId>
</dependency>
</dependencies>
<distributionManagement>
<!--
The id used must match a server id defined in ~/.m2/settings.xml
-->
<repository>
<id>hamcrest@repo1.maven.org</id>
<name>Central Maven Repository</name>
<url>scp://repo1.maven.org/home/projects/hamcrest/repository</url>
</repository>
</distributionManagement>
<build>
<plugins>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-jar-plugin</artifactId>
<version>2.1</version>
<configuration>
<archive>
<compress>false</compress>
</archive>
</configuration>
</plugin>
<plugin>
<groupId>org.codehaus.mojo.groovy</groupId>
<artifactId>groovy-maven-plugin</artifactId>
<version>1.0-alpha-3</version>
<executions>
<execution>
<phase>generate-resources</phase>
<goals>
<goal>execute</goal>
</goals>
<configuration>
<source>
<body>
def ant = new AntBuilder()
def script = "${basedir}/src/script/download-jars.sh"
def version = "${release.version}"
if ( version == "null" ){
println("ERROR: 'release.version' property not set.")
} else {
println("Using release version ${release.version}")
}
if ( new File(script).exists() ){
// we are in top-level module
println("Found script "+script)
ant.exec(executable: script, dir: "${basedir}",
spawn: false, failifexecutionfails: true, failonerror: true){
arg(value: "http://hamcrest.googlecode.com/files/")
arg(value: "hamcrest-${release.version}.zip" )
arg(value: "target")
arg(value: "hamcrest-${release.version}")
}
} else {
// we are in child module
ant.copy(file: "${download.artifact.dir}/${artifact.name}.jar",
tofile: "${project.build.directory}/downloaded.jar", verbose: true)
ant.unjar(src: "${project.build.directory}/downloaded.jar",
dest: "${project.build.outputDirectory}")
}
</body>
</source>
</configuration>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-release-plugin</artifactId>
<version>2.0-beta-6</version>
<configuration>
<autoVersionSubmodules>true</autoVersionSubmodules>
<tagBase>https://hamcrest.googlecode.com/svn/tags</tagBase>
</configuration>
</plugin>
</plugins>
<extensions>
<extension>
<groupId>org.apache.maven.wagon</groupId>
<artifactId>wagon-webdav</artifactId>
<version>1.0-beta-2</version>
</extension>
</extensions>
</build>
<properties>
<release.version>1.1</release.version>
<download.dir>target</download.dir>
<download.name>hamcrest-${release.version}</download.name>
<artifact.name>${artifactId}-${release.version}</artifact.name>
<download.artifact.dir>${basedir}/../${download.dir}/${download.name}/${download.name}</download.artifact.dir>
</properties>
</project>

20
hamcrest-text-1.1.pom Normal file
View File

@ -0,0 +1,20 @@
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.hamcrest</groupId>
<artifactId>hamcrest-parent</artifactId>
<version>1.1</version>
</parent>
<artifactId>hamcrest-text</artifactId>
<packaging>jar</packaging>
<name>Hamcrest Text</name>
<dependencies>
<dependency>
<groupId>${pom.groupId}</groupId>
<artifactId>hamcrest-core</artifactId>
<version>${pom.version}</version>
</dependency>
</dependencies>
</project>

425
hamcrest.spec Normal file
View File

@ -0,0 +1,425 @@
# Copyright (c) 2000-2008, JPackage Project
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
# modification, are permitted provided that the following conditions
# are met:
#
# 1. Redistributions of source code must retain the above copyright
# notice, this list of conditions and the following disclaimer.
# 2. Redistributions in binary form must reproduce the above copyright
# notice, this list of conditions and the following disclaimer in the
# documentation and/or other materials provided with the
# distribution.
# 3. Neither the name of the JPackage Project nor the names of its
# contributors may be used to endorse or promote products derived
# from this software without specific prior written permission.
#
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
%define with() %{expand:%%{?with_%{1}:1}%%{!?with_%{1}:0}}
%define without() %{expand:%%{?with_%{1}:0}%%{!?with_%{1}:1}}
%define bcond_with() %{expand:%%{?_with_%{1}:%%global with_%{1} 1}}
%define bcond_without() %{expand:%%{!?_without_%{1}:%%global with_%{1} 1}}
# This option controls integration which requires easymock2 and jmock
%bcond_with integration
# This option controls jarjar on qdox
# Since bundling the qdox classes prevents upgrades, we disable it by default
%bcond_with jarjar
# This option controls tests which requires ant-junit and testng
%bcond_with tests
# If integration is disabled, then tests are disabled
%if %without integration
%bcond_with tests
%endif
%define _with_gcj_support 1
%define gcj_support %{?_with_gcj_support:1}%{!?_with_gcj_support:%{?_without_gcj_support:0}%{!?_without_gcj_support:%{?_gcj_support:%{_gcj_support}}%{!?_gcj_support:0}}}
Name: hamcrest
Version: 1.1
Release: 5.1%{?dist}
Epoch: 0
Summary: Hamcrest matcher object framework
License: BSD
URL: http://code.google.com/p/hamcrest/
Group: Development/Tools
Source0: http://hamcrest.googlecode.com/files/hamcrest-1.1.tgz
Source1: http://repo1.maven.org/maven2/org/hamcrest/hamcrest-parent/1.1/hamcrest-parent-1.1.pom
Source2: http://repo1.maven.org/maven2/org/hamcrest/hamcrest-library/1.1/hamcrest-library-1.1.pom
Source3: http://repo1.maven.org/maven2/org/hamcrest/hamcrest-integration/1.1/hamcrest-integration-1.1.pom
Source4: http://repo1.maven.org/maven2/org/hamcrest/hamcrest-generator/1.1/hamcrest-generator-1.1.pom
Source5: http://repo1.maven.org/maven2/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.pom
Source6: http://repo1.maven.org/maven2/org/hamcrest/hamcrest-all/1.1/hamcrest-all-1.1.pom
Source7: hamcrest-text-1.1.pom
Patch0: hamcrest-1.1-build.patch
Patch1: hamcrest-1.1-no-jarjar.patch
Patch2: hamcrest-1.1-no-integration.patch
Requires: java-1.6.0
%if %with integration
Requires: easymock2
Requires: jmock
%endif
Requires: qdox
BuildRequires: jpackage-utils >= 0:1.7.4
BuildRequires: java-1.6.0-devel
BuildRequires: ant >= 0:1.6.5
BuildRequires: ant-junit
%if %with integration
BuildRequires: easymock2
%endif
%if %with jarjar
BuildRequires: jarjar
%endif
%if %with integration
BuildRequires: jmock
%endif
BuildRequires: junit
BuildRequires: junit4
BuildRequires: qdox
%if %with tests
BuildRequires: testng
%endif
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
%if %{gcj_support}
BuildRequires: java-gcj-compat-devel
%else
Buildarch: noarch
%endif
Requires(post): jpackage-utils >= 0:1.7.4
Requires(postun): jpackage-utils >= 0:1.7.4
%description
Provides a library of matcher objects (also known as
constraints or predicates) allowing 'match' rules to
be defined declaratively, to be used in other frameworks.
Typical scenarios include testing frameworks, mocking
libraries and UI validation rules.
%package javadoc
Group: Documentation
Summary: Javadoc for %{name}
%description javadoc
Javadoc for %{name}.
%package demo
Group: Development/Libraries
Summary: Demos for %{name}
Requires: %{name} = %{epoch}:%{version}-%{release}
Requires: junit
Requires: junit4
Requires: testng
%description demo
Demonstrations and samples for %{name}.
%prep
%setup -q
find . -type f -name "*.jar" | xargs -t rm
# BUILD/hamcrest-%{version}/lib/generator/jarjar-1.0rc3.jar.no
%if %with jarjar
ln -sf $(build-classpath jarjar) lib/generator/
%endif
# BUILD/hamcrest-1.1/lib/generator/qdox-1.6.1.jar.no
ln -sf $(build-classpath qdox) lib/generator/
# BUILD/hamcrest-1.1/lib/integration/easymock-2.2.jar.no
%if %with integration
ln -sf $(build-classpath easymock2) lib/integration/
%endif
# BUILD/hamcrest-1.1/lib/integration/jmock-1.10RC1.jar.no
%if %with integration
ln -sf $(build-classpath jmock) lib/integration/
%endif
# BUILD/hamcrest-1.1/lib/integration/junit-3.8.1.jar.no
ln -sf $(build-classpath junit) lib/integration/
# BUILD/hamcrest-1.1/lib/integration/junit-4.0.jar.no
ln -sf $(build-classpath junit4) lib/integration/
# BUILD/hamcrest-1.1/lib/integration/testng-4.6-jdk15.jar.no
%if %with tests
ln -sf $(build-classpath testng-jdk15) lib/integration/
%endif
%patch0 -p0
%if %without jarjar
%patch1 -p1
%endif
%if %without integration
%patch2 -p1
%endif
perl -pi -e 's/\r$//g' LICENSE.txt
%build
export CLASSPATH=$(build-classpath qdox)
export OPT_JAR_LIST="junit ant/ant-junit"
%if %with integration
ant -Dant.build.javac.source=1.5 -Dversion=%{version} -Dbuild.sysclasspath=first all javadoc
%else
ant -Dant.build.javac.source=1.5 -Dversion=%{version} -Dbuild.sysclasspath=first clean core generator library text bigjar javadoc
%endif
%install
rm -rf $RPM_BUILD_ROOT
# jars
install -d -m 755 $RPM_BUILD_ROOT%{_javadir}/%{name}
install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/maven2/poms
install -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP.%{name}-parent.pom
%add_to_maven_depmap org.hamcrest %{name}-parent %{version} JPP/%{name} parent
install -m 644 build/%{name}-all-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}/all-%{version}.jar
install -m 644 %{SOURCE6} $RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP.%{name}-all.pom
%add_to_maven_depmap org.hamcrest %{name}-all %{version} JPP/%{name} all
install -m 644 build/%{name}-core-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}/core-%{version}.jar
install -m 644 %{SOURCE5} $RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP.%{name}-core.pom
%add_to_maven_depmap org.hamcrest %{name}-core %{version} JPP/%{name} core
install -m 644 build/%{name}-generator-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}/generator-%{version}.jar
install -m 644 %{SOURCE4} $RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP.%{name}-generator.pom
%add_to_maven_depmap org.hamcrest %{name}-generator %{version} JPP/%{name} generator
install -m 644 build/%{name}-library-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}/library-%{version}.jar
install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP.%{name}-library.pom
%add_to_maven_depmap org.hamcrest %{name}-library %{version} JPP/%{name} library
%if %with integration
install -m 644 build/%{name}-integration-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}/integration-%{version}.jar
install -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP.%{name}-integration.pom
%add_to_maven_depmap org.hamcrest %{name}-integration %{version} JPP/%{name} integration
%endif
install -m 644 build/%{name}-text-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}/text-%{version}.jar
install -m 644 %{SOURCE7} $RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP.%{name}-text.pom
%add_to_maven_depmap org.hamcrest %{name}-text %{version} JPP/%{name} text
%if %with tests
install -m 644 build/%{name}-unit-test-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}/unit-test-%{version}.jar
%endif
pushd $RPM_BUILD_ROOT%{_javadir}/%{name}
for jar in *-%{version}*; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done
popd
# javadoc
install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
cp -pr build/javadoc/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name}
# demo
install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/%{name}-%{version}
%if %with integration
install -m 644 build/%{name}-examples-%{version}.jar $RPM_BUILD_ROOT%{_datadir}/%{name}-%{version}
%endif
cp -pr %{name}-examples $RPM_BUILD_ROOT%{_datadir}/%{name}-%{version}/
ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_datadir}/%{name}
%if %{gcj_support}
%{_bindir}/aot-compile-rpm
%endif
%clean
rm -rf $RPM_BUILD_ROOT
%post
%update_maven_depmap
%if %{gcj_support}
if [ -x %{_bindir}/rebuild-gcj-db ]
then
%{_bindir}/rebuild-gcj-db
fi
%endif
%postun
%update_maven_depmap
%if %{gcj_support}
if [ -x %{_bindir}/rebuild-gcj-db ]
then
%{_bindir}/rebuild-gcj-db
fi
%endif
%files
%defattr(0644,root,root,0755)
%doc LICENSE.txt
%dir %{_javadir}/%{name}
%{_javadir}/%{name}/all-%{version}.jar
%{_javadir}/%{name}/all.jar
%{_javadir}/%{name}/core-%{version}.jar
%{_javadir}/%{name}/core.jar
%{_javadir}/%{name}/generator-%{version}.jar
%{_javadir}/%{name}/generator.jar
%if %with integration
%{_javadir}/%{name}/integration-%{version}.jar
%{_javadir}/%{name}/integration.jar
%endif
%{_javadir}/%{name}/library-%{version}.jar
%{_javadir}/%{name}/library.jar
%{_javadir}/%{name}/text-%{version}.jar
%{_javadir}/%{name}/text.jar
%if %with tests
%{_javadir}/%{name}/unit-test-%{version}.jar
%{_javadir}/%{name}/unit-test.jar
%endif
%{_datadir}/maven2/*
%{_mavendepmapfragdir}/*
%if %{gcj_support}
%dir %{_libdir}/gcj/%{name}
%attr(-,root,root) %{_libdir}/gcj/%{name}/all-%{version}.jar.db
%attr(-,root,root) %{_libdir}/gcj/%{name}/all-%{version}.jar.so
%endif
%files javadoc
%defattr(0644,root,root,0755)
%{_javadocdir}/%{name}-%{version}
%{_javadocdir}/%{name}
%files demo
%defattr(0644,root,root,0755)
%{_datadir}/%{name}-%{version}
%{_datadir}/%{name}
%changelog
* Fri Oct 24 2008 David Walluck <dwalluck@redhat.com> 0:1.1-5.1
- Fedora-specific: enable GCJ support
- Fedora-specific: build with java 1.6.0
- Fedora-specific: disable integration and tests
* Fri Oct 24 2008 David Walluck <dwalluck@redhat.com> 0:1.1-5
- fix GCJ file list
- simplify build by always setting OPT_JAR_LIST
* Fri Oct 24 2008 David Walluck <dwalluck@redhat.com> 0:1.1-4
- add epoch to demo Requires
* Fri Oct 24 2008 David Walluck <dwalluck@redhat.com> 0:1.1-3
- set -Dant.build.javac.source=1.5
* Fri Oct 24 2008 David Walluck <dwalluck@redhat.com> 0:1.1-2
- add options to build without integration, jarjar, and tests
- allow build with java-devel >= 1.5.0
- remove javadoc scriptlets
- use more strict file list
- fix maven directory ownership
- add non-versioned symlink for demo
- fix GCJ requires
- fix eol in LICENSE.txt
- remove Vendor and Distribution
* Tue Feb 19 2008 Ralph Apel <r.apel@r-apel.de> - 0:1.1-1jpp
- 1.1
* Mon Feb 11 2008 Ralph Apel <r.apel@r-apel.de> - 0:4.3.1-4jpp
- Fix versioned jar name, was junit-4.3.1
- Restore Epoch
* Fri Jan 25 2008 Ralph Apel <r.apel@r-apel.de> - 0:4.3.1-3jpp
- build and upload noarch packages
- Add pom and depmap frag
- BR java-devel = 1.5.0
- Restore Vendor, Distribution from macros
* Tue Aug 07 2007 Ben Konrath <bkonrath@redhat.com> - 4.3.1-2jpp
- Set gcj_support to 0 to work around problems with GCJ.
- Fix buglet with the gcj post/postun if statement.
- Fix tab / space problems.
- Fix buildroot.
- Update Summary.
- Convert html files to Unix file endings.
- Disable aot-compile-rpm because it's not working ATM.
* Mon Jul 09 2007 Ben Konrath <bkonrath@redhat.com> - 4.3.1-1jpp
- 4.3.1.
* Mon Feb 12 2007 Thomas Fitzsimmons <fitzsim@redhat.com> - 3.8.2-3jpp.1.fc7
- Add dist tag
* Mon Feb 12 2007 Thomas Fitzsimmons <fitzsim@redhat.com> - 3.8.2-3jpp.1
- Committed on behalf of Tania Bento <tbento@redhat.com>
- Update per Fedora review process
- Resolves rhbz#225954
* Thu Aug 10 2006 Deepak Bhole <dbhole@redhat.com> - 0:3.8.2-3jpp.1
- Added missing requirements.
* Thu Aug 10 2006 Karsten Hopp <karsten@redhat.de> 0:3.8.2-2jpp_3fc
- Require(post/postun): coreutils
* Sun Jun 23 2006 Deepak Bhole <dbhole@redhat.com> - 0:3.8.2-2jpp_2fc
- Rebuilt.
* Sat Jun 22 2006 Deepak Bhole <dbhole@redhat.com> - 0:3.8.2-2jpp_1fc
- Upgrade to 3.8.2
- Added conditional native compilation.
- Fix path where demo is located.
* Mon Mar 03 2006 Ralph Apel <r.apel at r-apel.de> - 0:3.8.2-1jpp
- First JPP-1.7 release
* Sun Aug 23 2004 Randy Watler <rwatler at finali.com> - 0:3.8.1-4jpp
- Rebuild with ant-1.6.2
* Fri May 09 2003 David Walluck <david@anti-microsoft.org> 0:3.8.1-3jpp
- update for JPackage 1.5
* Fri Mar 21 2003 Nicolas Mailhot <Nicolas.Mailhot (at) JPackage.org> 3.8.1-2jpp
- For jpackage-utils 1.5
* Fri Sep 06 2002 Henri Gomez <hgomez@users.sourceforge.net> 3.8.1-1jpp
- 3.8.1
* Sun Sep 01 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.8-2jpp
- used original zip file
* Thu Aug 29 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.8-1jpp
- 3.8
- group, vendor and distribution tags
* Sat Jan 19 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.7-6jpp
- versioned dir for javadoc
- no dependencies for manual and javadoc packages
- stricter dependency for demo package
- additional sources in individual archives
- section macro
* Sat Dec 1 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.7-5jpp
- javadoc in javadoc package
* Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 3.7-4jpp
- fixed previous releases ...grrr
* Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 3.7-3jpp
- added jpp extension
- removed packager tag
* Sun Sep 30 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.7-2jpp
- first unified release
- s/jPackage/JPackage
* Mon Sep 17 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.7-1mdk
- 3.7
- vendor tag
- packager tag
- s/Copyright/License/
- truncated description to 72 columns in spec
- spec cleanup
- used versioned jar
- moved demo files to %%{_datadir}/%%{name}
* Sat Feb 17 2001 Guillaume Rousse <g.rousse@linux-mandrake.com> 3.5-1mdk
- first Mandrake release

1
import.log Normal file
View File

@ -0,0 +1 @@
hamcrest-1_1-5_1_jpp5:HEAD:hamcrest-1.1-5.1.jpp5.src.rpm:1225133930

View File

@ -0,0 +1 @@
1bd4fd301c1a0dc748082378a59cb281 hamcrest-1.1.tgz