diff --git a/.gitignore b/.gitignore
index 8ae6c1a..880b6d2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,14 @@
hamcrest-1.1.tgz
+/hamcrest-all-1.3.pom
+/hamcrest-core-1.3.pom
+/hamcrest-generator-1.3.pom
+/hamcrest-integration-1.3.pom
+/hamcrest-library-1.3.pom
+/hamcrest-parent-1.3.pom
+/hamcrest-text-1.3.pom
+/hamcrest-core-MANIFEST.MF
+/hamcrest-generator-MANIFEST.MF
+/hamcrest-integration-MANIFEST.MF
+/hamcrest-library-MANIFEST.MF
+/hamcrest-text-MANIFEST.MF
+/hamcrest-1.3.tgz
diff --git a/hamcrest-1.1-build.patch b/hamcrest-1.1-build.patch
deleted file mode 100644
index 65f6b56..0000000
--- a/hamcrest-1.1-build.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- build.xml.sav0 2007-06-30 15:03:43.000000000 +0200
-+++ build.xml 2008-02-14 12:07:25.000000000 +0100
-@@ -26,17 +26,17 @@
-
-
-+ classpath="lib/generator/jarjar.jar"/>
-
-
-
--
-+
-
-
-@@ -211,7 +211,7 @@
-
-
-
-+ >
-
-
-
-@@ -223,7 +223,8 @@
-
-
-
--
-+
-+
-
-
-
diff --git a/hamcrest-1.1-no-integration.patch b/hamcrest-1.1-no-integration.patch
deleted file mode 100644
index 56861e5..0000000
--- a/hamcrest-1.1-no-integration.patch
+++ /dev/null
@@ -1,41 +0,0 @@
---- hamcrest-1.1/build.xml~ 2008-10-24 11:37:35.000000000 -0400
-+++ hamcrest-1.1/build.xml 2008-10-24 11:39:22.839767600 -0400
-@@ -147,14 +147,13 @@
-
-
-
-
-
-
-
-
--
-
-
-
-@@ -201,22 +200,15 @@
-
-
--
--
--
--
--
-
-
-
-
--
-
-
-
-
-
--
-
-
-
diff --git a/hamcrest-1.1-no-jarjar.patch b/hamcrest-1.1-no-jarjar.patch
deleted file mode 100644
index 4b1df33..0000000
--- a/hamcrest-1.1-no-jarjar.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- hamcrest-1.1/build.xml.jarjar 2008-10-24 11:35:30.171892280 -0400
-+++ hamcrest-1.1/build.xml 2008-10-24 11:36:07.667890720 -0400
-@@ -24,22 +24,10 @@
-
-
--
--
--
--
--
--
--
-
-
-
+
++ classpath="lib/generator/qdox.jar"/>
+
+
+-
++
+
+
+-
++
+
+
+
+@@ -152,7 +152,7 @@
+
+
++ windowtitle="Hamcrest" source="1.6" failonerror="yes">
+
+
+
diff --git a/hamcrest-1.3-javadoc.patch b/hamcrest-1.3-javadoc.patch
new file mode 100644
index 0000000..6c21e7d
--- /dev/null
+++ b/hamcrest-1.3-javadoc.patch
@@ -0,0 +1,17 @@
+diff --git a/build.xml b/build.xml
+index ed57763..a4550cb 100644
+--- a/build.xml
++++ b/build.xml
+@@ -135,11 +135,10 @@
+
+
+
+-
++
+
+
+
+-
+
+
+
+
+-
+
+
+@@ -132,7 +132,6 @@
+
+
+
+-
+
+
+
+@@ -146,11 +145,6 @@
+
+-
+-
+-
+-
+-
+
+
+
diff --git a/hamcrest-1.3-no-jarjar.patch b/hamcrest-1.3-no-jarjar.patch
new file mode 100644
index 0000000..caf5767
--- /dev/null
+++ b/hamcrest-1.3-no-jarjar.patch
@@ -0,0 +1,23 @@
+diff --git a/build.xml b/build.xml
+index 54d43fe..ed57763 100644
+--- a/build.xml
++++ b/build.xml
+@@ -13,17 +13,8 @@
+
+
+
+-
+-
+-
+-
+-
+-
+-
+-
+-
+
+
+
diff --git a/hamcrest-all-1.1.pom b/hamcrest-all-1.1.pom
deleted file mode 100644
index 7dc4cf6..0000000
--- a/hamcrest-all-1.1.pom
+++ /dev/null
@@ -1,12 +0,0 @@
-
- 4.0.0
-
- org.hamcrest
- hamcrest-parent
- 1.1
-
- hamcrest-all
- jar
- Hamcrest All
-
-
diff --git a/hamcrest-core-1.1.pom b/hamcrest-core-1.1.pom
deleted file mode 100644
index 0911717..0000000
--- a/hamcrest-core-1.1.pom
+++ /dev/null
@@ -1,12 +0,0 @@
-
- 4.0.0
-
- org.hamcrest
- hamcrest-parent
- 1.1
-
- hamcrest-core
- jar
- Hamcrest Core
-
-
diff --git a/hamcrest-core-MANIFEST.MF b/hamcrest-core-MANIFEST.MF
deleted file mode 100644
index 47bc4c5..0000000
--- a/hamcrest-core-MANIFEST.MF
+++ /dev/null
@@ -1,12 +0,0 @@
-Manifest-Version: 1.0
-Bundle-Vendor: %providerName
-Bundle-ActivationPolicy: lazy
-Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Bundle-Name: %pluginName
-Bundle-SymbolicName: org.hamcrest.core
-Export-Package: org.hamcrest;version="1.1.0",
- org.hamcrest.core;version="1.1.0",org.hamcrest.internal;version="1.
- 1.0";x-internal:=true
-Bundle-Version: 1.1.0.v20090501071000
-Bundle-ManifestVersion: 2
diff --git a/hamcrest-generator-1.1.pom b/hamcrest-generator-1.1.pom
deleted file mode 100644
index 8da1d8a..0000000
--- a/hamcrest-generator-1.1.pom
+++ /dev/null
@@ -1,20 +0,0 @@
-
- 4.0.0
-
- org.hamcrest
- hamcrest-parent
- 1.1
-
- hamcrest-generator
- jar
- Hamcrest Generator
-
-
-
- ${pom.groupId}
- hamcrest-core
- ${pom.version}
-
-
-
-
diff --git a/hamcrest-generator-MANIFEST.MF b/hamcrest-generator-MANIFEST.MF
deleted file mode 100644
index 57ca8cc..0000000
--- a/hamcrest-generator-MANIFEST.MF
+++ /dev/null
@@ -1,18 +0,0 @@
-Manifest-Version: 1.0
-Bundle-Vendor: %providerName
-Bundle-ActivationPolicy: lazy
-Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Bundle-Name: %pluginName
-Bundle-SymbolicName: org.hamcrest.generator
-Bundle-Version: 1.1.0.v20090501071000
-Export-Package: org.hamcrest.generator;version="1.1.0",org.hamcrest.ge
- nerator.config;version="1.1.0"
-Bundle-ManifestVersion: 2
-Import-Package: com.thoughtworks.qdox;version="1.6.3",com.thoughtworks
- .qdox.ant;version="1.6.3",com.thoughtworks.qdox.directorywalker;versi
- on="1.6.3",com.thoughtworks.qdox.junit;version="1.6.3",com.thoughtwor
- ks.qdox.model;version="1.6.3",com.thoughtworks.qdox.model.util;versio
- n="1.6.3",com.thoughtworks.qdox.parser;version="1.6.3",com.thoughtwor
- ks.qdox.parser.impl;version="1.6.3",com.thoughtworks.qdox.parser.stru
- cts;version="1.6.3",com.thoughtworks.qdox.tools;version="1.6.3"
diff --git a/hamcrest-integration-1.1.pom b/hamcrest-integration-1.1.pom
deleted file mode 100644
index 912f062..0000000
--- a/hamcrest-integration-1.1.pom
+++ /dev/null
@@ -1,20 +0,0 @@
-
- 4.0.0
-
- org.hamcrest
- hamcrest-parent
- 1.1
-
- hamcrest-integration
- jar
- Hamcrest Integration
-
-
-
- ${pom.groupId}
- hamcrest-core
- ${pom.version}
-
-
-
-
diff --git a/hamcrest-integration-MANIFEST.MF b/hamcrest-integration-MANIFEST.MF
deleted file mode 100644
index 736b0c4..0000000
--- a/hamcrest-integration-MANIFEST.MF
+++ /dev/null
@@ -1,14 +0,0 @@
-Manifest-Version: 1.0
-Bundle-Vendor: %providerName
-Bundle-ActivationPolicy: lazy
-Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Bundle-Name: %pluginName
-Bundle-SymbolicName: org.hamcrest.integration
-Require-Bundle: org.hamcrest.core;bundle-version="1.1.0"
-Bundle-Version: 1.1.0.v20090501071000
-Export-Package: org.hamcrest;integration=split;mandatory:=integration;
- version="1.1.0",org.hamcrest.integration;version="1.1.0"
-Bundle-ManifestVersion: 2
-Import-Package: org.easymock;version="2.4.0";resolution:=optional,org.
- jmock.core;version="1.10";resolution:=optional
diff --git a/hamcrest-library-1.1.pom b/hamcrest-library-1.1.pom
deleted file mode 100644
index cdef1cb..0000000
--- a/hamcrest-library-1.1.pom
+++ /dev/null
@@ -1,20 +0,0 @@
-
- 4.0.0
-
- org.hamcrest
- hamcrest-parent
- 1.1
-
- hamcrest-library
- jar
- Hamcrest Library
-
-
-
- ${pom.groupId}
- hamcrest-core
- ${pom.version}
-
-
-
-
diff --git a/hamcrest-library-MANIFEST.MF b/hamcrest-library-MANIFEST.MF
deleted file mode 100644
index 829a9a8..0000000
--- a/hamcrest-library-MANIFEST.MF
+++ /dev/null
@@ -1,15 +0,0 @@
-Manifest-Version: 1.0
-Bundle-Vendor: %providerName
-Bundle-ActivationPolicy: lazy
-Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Bundle-Name: %pluginName
-Bundle-SymbolicName: org.hamcrest.library
-Require-Bundle: org.hamcrest.core;bundle-version="1.1.0"
-Bundle-Version: 1.1.0.v20090501071000
-Export-Package: org.hamcrest;version="1.1.0";library=split;mandatory:=
- library,org.hamcrest.beans;version="1.1.0",org.hamcrest.collection;ve
- rsion="1.1.0",org.hamcrest.number;version="1.1.0",org.hamcrest.object
- ;version="1.1.0",org.hamcrest.text;version="1.1.0",org.hamcrest.xml;v
- ersion="1.1.0"
-Bundle-ManifestVersion: 2
diff --git a/hamcrest-parent-1.1.pom b/hamcrest-parent-1.1.pom
deleted file mode 100644
index 8ec7448..0000000
--- a/hamcrest-parent-1.1.pom
+++ /dev/null
@@ -1,170 +0,0 @@
-
- 4.0.0
- org.hamcrest
- hamcrest-parent
- pom
- 1.1
- Hamcrest Parent
-
- 2006
-
- Hamcrest
- http://code.google.com/p/hamcrest
-
-
-
-
- BSD style
- http://www.opensource.org/licenses/bsd-license.php
- repo
-
-
-
-
- scm:svn:https://hamcrest.googlecode.com/svn/tags/hamcrest-packaging-maven-1.1
- https://hamcrest.googlecode.com/svn/tags/hamcrest-packaging-maven-1.1
-
-
-
- hamcrest-all
- hamcrest-core
- hamcrest-generator
- hamcrest-integration
- hamcrest-library
-
-
-
-
-
-
-
- jmock
- jmock
- 1.1.0
- provided
-
-
- junit
- junit
- 4.0
- provided
-
-
- org.easymock
- easymock
- 2.2
- provided
-
-
-
-
-
-
- jmock
- jmock
-
-
- junit
- junit
-
-
- org.easymock
- easymock
-
-
-
-
-
-
- hamcrest@repo1.maven.org
- Central Maven Repository
- scp://repo1.maven.org/home/projects/hamcrest/repository
-
-
-
-
-
-
- org.apache.maven.plugins
- maven-jar-plugin
- 2.1
-
-
- false
-
-
-
-
- org.codehaus.mojo.groovy
- groovy-maven-plugin
- 1.0-alpha-3
-
-
- generate-resources
-
- execute
-
-
-
-
- def ant = new AntBuilder()
- def script = "${basedir}/src/script/download-jars.sh"
- def version = "${release.version}"
- if ( version == "null" ){
- println("ERROR: 'release.version' property not set.")
- } else {
- println("Using release version ${release.version}")
- }
- if ( new File(script).exists() ){
- // we are in top-level module
- println("Found script "+script)
- ant.exec(executable: script, dir: "${basedir}",
- spawn: false, failifexecutionfails: true, failonerror: true){
- arg(value: "http://hamcrest.googlecode.com/files/")
- arg(value: "hamcrest-${release.version}.zip" )
- arg(value: "target")
- arg(value: "hamcrest-${release.version}")
- }
- } else {
- // we are in child module
- ant.copy(file: "${download.artifact.dir}/${artifact.name}.jar",
- tofile: "${project.build.directory}/downloaded.jar", verbose: true)
- ant.unjar(src: "${project.build.directory}/downloaded.jar",
- dest: "${project.build.outputDirectory}")
- }
-
-
-
-
-
-
-
- org.apache.maven.plugins
- maven-release-plugin
- 2.0-beta-6
-
- true
- https://hamcrest.googlecode.com/svn/tags
-
-
-
-
-
- org.apache.maven.wagon
- wagon-webdav
- 1.0-beta-2
-
-
-
-
-
- 1.1
- target
- hamcrest-${release.version}
- ${artifactId}-${release.version}
- ${basedir}/../${download.dir}/${download.name}/${download.name}
-
-
-
\ No newline at end of file
diff --git a/hamcrest-text-1.1.pom b/hamcrest-text-1.1.pom
deleted file mode 100644
index 27beb20..0000000
--- a/hamcrest-text-1.1.pom
+++ /dev/null
@@ -1,20 +0,0 @@
-
- 4.0.0
-
- org.hamcrest
- hamcrest-parent
- 1.1
-
- hamcrest-text
- jar
- Hamcrest Text
-
-
-
- ${pom.groupId}
- hamcrest-core
- ${pom.version}
-
-
-
-
diff --git a/hamcrest-text-MANIFEST.MF b/hamcrest-text-MANIFEST.MF
deleted file mode 100644
index 7c4bdf9..0000000
--- a/hamcrest-text-MANIFEST.MF
+++ /dev/null
@@ -1,14 +0,0 @@
-Manifest-Version: 1.0
-Bundle-Vendor: %providerName
-Bundle-ActivationPolicy: lazy
-Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Bundle-Name: %pluginName
-Bundle-SymbolicName: org.hamcrest.text
-Require-Bundle: org.hamcrest.core;bundle-version="1.1.0",org.hamcrest.
- library;bundle-version="1.1.0"
-Bundle-Version: 1.1.0.v20090501071000
-Export-Package: org.hamcrest.text.pattern;version="1.1.0",org.hamcrest
- .text.pattern.internal.ast;version="1.1.0";x-internal:=true,org.hamcr
- est.text.pattern.internal.naming;version="1.1.0";x-internal:=true
-Bundle-ManifestVersion: 2
diff --git a/hamcrest.spec b/hamcrest.spec
index 0dee72c..02f6c50 100644
--- a/hamcrest.spec
+++ b/hamcrest.spec
@@ -49,35 +49,42 @@
%endif
Name: hamcrest
-Version: 1.1
-Release: 22%{?dist}
+Version: 1.3
+Release: 1%{?dist}
Epoch: 0
Summary: Library of matchers for building test expressions
License: BSD
URL: http://code.google.com/p/hamcrest/
Group: Development/Tools
-Source0: http://hamcrest.googlecode.com/files/hamcrest-1.1.tgz
-Source1: http://repo1.maven.org/maven2/org/hamcrest/hamcrest-parent/1.1/hamcrest-parent-1.1.pom
-Source2: http://repo1.maven.org/maven2/org/hamcrest/hamcrest-library/1.1/hamcrest-library-1.1.pom
-Source3: http://repo1.maven.org/maven2/org/hamcrest/hamcrest-integration/1.1/hamcrest-integration-1.1.pom
-Source4: http://repo1.maven.org/maven2/org/hamcrest/hamcrest-generator/1.1/hamcrest-generator-1.1.pom
-Source5: http://repo1.maven.org/maven2/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.pom
-Source6: http://repo1.maven.org/maven2/org/hamcrest/hamcrest-all/1.1/hamcrest-all-1.1.pom
-Source7: hamcrest-text-1.1.pom
+Source0: http://%{name}.googlecode.com/files/%{name}-1.3.tgz
+Source1: http://repo1.maven.org/maven2/org/%{name}/%{name}-parent/%{version}/%{name}-parent-%{version}.pom
+Source2: http://repo1.maven.org/maven2/org/%{name}/%{name}-library/%{version}/%{name}-library-%{version}.pom
+Source3: http://repo1.maven.org/maven2/org/%{name}/%{name}-integration/%{version}/%{name}-integration-%{version}.pom
+Source4: http://repo1.maven.org/maven2/org/%{name}/%{name}-generator/%{version}/%{name}-generator-%{version}.pom
+Source5: http://repo1.maven.org/maven2/org/%{name}/%{name}-core/%{version}/%{name}-core-%{version}.pom
+Source6: http://repo1.maven.org/maven2/org/%{name}/%{name}-all/%{version}/%{name}-all-%{version}.pom
+# This file was added by the maintainer for compatibility with maven dep
+# solving system
+Source7: %{name}-text-%{version}.pom
+
Source8: hamcrest-core-MANIFEST.MF
Source9: hamcrest-library-MANIFEST.MF
Source10: hamcrest-text-MANIFEST.MF
Source11: hamcrest-integration-MANIFEST.MF
Source12: hamcrest-generator-MANIFEST.MF
-Patch0: hamcrest-1.1-build.patch
-Patch1: hamcrest-1.1-no-jarjar.patch
-Patch2: hamcrest-1.1-no-integration.patch
+
+Patch0: %{name}-%{version}-build.patch
+Patch1: %{name}-%{version}-no-jarjar.patch
+Patch2: %{name}-%{version}-no-integration.patch
+Patch3: %{name}-%{version}-javadoc.patch
+
Requires: java >= 1:1.6.0
+Requires: qdox
%if %with integration
Requires: easymock2
#Requires: jmock
%endif
-Requires: qdox
+
BuildRequires: jpackage-utils >= 0:1.7.4
BuildRequires: java-devel >= 1:1.6.0
BuildRequires: ant >= 0:1.6.5
@@ -141,26 +148,27 @@ ln -sf $(build-classpath easymock2) lib/integration/
%if %with integration
ln -sf $(build-classpath jmock) lib/integration/
%endif
-# BUILD/hamcrest-1.1/lib/integration/junit-3.8.1.jar.no
-ln -sf $(build-classpath junit) lib/integration/
# BUILD/hamcrest-1.1/lib/integration/testng-4.6-jdk15.jar.no
%if %with tests
ln -sf $(build-classpath testng-jdk15) lib/integration/
%endif
-%patch0 -p0
+%patch0 -p1
%if %without jarjar
%patch1 -p1
%endif
%if %without integration
-#%patch2 -p1
+%patch2 -p1
%endif
+%patch3 -p1
perl -pi -e 's/\r$//g' LICENSE.txt
%build
export CLASSPATH=$(build-classpath qdox)
export OPT_JAR_LIST="junit ant/ant-junit"
-ant -Dant.build.javac.source=1.5 -Dversion=%{version} -Dbuild.sysclasspath=first clean core generator library text bigjar javadoc
+# The unit-test goal is switched off as some tests fail with JDK 7
+# see https://github.com/hamcrest/JavaHamcrest/issues/30
+ant -Dant.build.javac.source=1.5 -Dversion=%{version} -Dbuild.sysclasspath=last clean core generator library bigjar javadoc
# inject OSGi manifests
mkdir -p META-INF
@@ -231,7 +239,7 @@ install -m 644 build/%{name}-unit-test-%{version}.jar $RPM_BUILD_ROOT%{_javadir}
# javadoc
install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}
-cp -pr build/javadoc/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}
+cp -pr build/temp/hamcrest-all-1.3-javadoc.jar.contents/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}
# demo
install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/%{name}
@@ -261,6 +269,9 @@ cp -pr %{name}-examples $RPM_BUILD_ROOT%{_datadir}/%{name}/
%{_datadir}/%{name}
%changelog
+* Thu Mar 21 2013 Tomas Radej - 0:1.3-1
+- Updated to latest upstream version
+
* Thu Feb 14 2013 Fedora Release Engineering - 0:1.1-22
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
@@ -389,18 +400,18 @@ cp -pr %{name}-examples $RPM_BUILD_ROOT%{_datadir}/%{name}/
* Thu Aug 10 2006 Karsten Hopp 0:3.8.2-2jpp_3fc
- Require(post/postun): coreutils
-* Sun Jun 23 2006 Deepak Bhole - 0:3.8.2-2jpp_2fc
+* Fri Jun 23 2006 Deepak Bhole - 0:3.8.2-2jpp_2fc
- Rebuilt.
-* Sat Jun 22 2006 Deepak Bhole - 0:3.8.2-2jpp_1fc
+* Thu Jun 22 2006 Deepak Bhole - 0:3.8.2-2jpp_1fc
- Upgrade to 3.8.2
- Added conditional native compilation.
- Fix path where demo is located.
-* Mon Mar 03 2006 Ralph Apel - 0:3.8.2-1jpp
+* Fri Mar 03 2006 Ralph Apel - 0:3.8.2-1jpp
- First JPP-1.7 release
-* Sun Aug 23 2004 Randy Watler - 0:3.8.1-4jpp
+* Mon Aug 23 2004 Randy Watler - 0:3.8.1-4jpp
- Rebuild with ant-1.6.2
* Fri May 09 2003 David Walluck 0:3.8.1-3jpp
- update for JPackage 1.5
diff --git a/sources b/sources
index bc59c42..9f6ba52 100644
--- a/sources
+++ b/sources
@@ -1 +1,13 @@
-1bd4fd301c1a0dc748082378a59cb281 hamcrest-1.1.tgz
+29b18baac02244a9b7568d5bd5bb1c42 hamcrest-all-1.3.pom
+7cd680c223f3807e1ef353466b9a4b25 hamcrest-core-1.3.pom
+ba3c980bbf7d7b91d63d99da503aa3f4 hamcrest-generator-1.3.pom
+442fa9ad7a4dfbd6a2ab5fca6e9b36c1 hamcrest-integration-1.3.pom
+f09e58cd2a1ea76816c17141db41b2e1 hamcrest-library-1.3.pom
+7591ddb3581de8684c17e51741a7461d hamcrest-parent-1.3.pom
+de8c4213de11a0c2f83821bb700ac5eb hamcrest-text-1.3.pom
+936fbdde78bd9896985405ce7e9fedb0 hamcrest-core-MANIFEST.MF
+53744b9395f762bfbcdb9a6dcef84fc6 hamcrest-generator-MANIFEST.MF
+9dd6758de43d07f08bbd3e242b9c01ee hamcrest-integration-MANIFEST.MF
+b6d199eaa9b403df16a31e285d6d0cdc hamcrest-library-MANIFEST.MF
+e11cedd6f8f6be75c373b9519475abb3 hamcrest-text-MANIFEST.MF
+92e91c2754d44e49b72d70c10a04cb08 hamcrest-1.3.tgz