auto-import changelog data from gzip-1.3.3-9.src.rpm
Fri Jan 31 2003 Jeff Johnson <jbj@redhat.com> 1.3.3-9 - enlarge window buffer to avoid accessing beyond end-of-buffer (#78413,#83095). - re-enable rsync ready patch. Wed Jan 22 2003 Tim Powers <timp@redhat.com> - rebuilt Fri Nov 22 2002 Jeff Johnson <jbj@redhat.com> 1.3.3-7 - workaround mis-compilation with gcc-3.2-4 on alpha for now (#78413). Mon Nov 18 2002 Tim Powers <timp@redhat.com> - rebuild on all arches - remove file from buildroot we aren't shipping
This commit is contained in:
parent
eda8cdc6b9
commit
a0fdb8c212
11
gzip-1.3.3-window-size.patch
Normal file
11
gzip-1.3.3-window-size.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- gzip-1.3.3/gzip.c.orig Thu Jan 30 21:19:36 2003
|
||||
+++ gzip-1.3.3/gzip.c Thu Jan 30 21:09:52 2003
|
||||
@@ -198,7 +198,7 @@
|
||||
DECLARE(uch, inbuf, INBUFSIZ +INBUF_EXTRA);
|
||||
DECLARE(uch, outbuf, OUTBUFSIZ+OUTBUF_EXTRA);
|
||||
DECLARE(ush, d_buf, DIST_BUFSIZE);
|
||||
-DECLARE(uch, window, 2L*WSIZE);
|
||||
+DECLARE(uch, window, 2L*WSIZE + 4096);
|
||||
#ifndef MAXSEG_64K
|
||||
DECLARE(ush, tab_prefix, 1L<<BITS);
|
||||
#else
|
51
gzip.spec
51
gzip.spec
@ -1,7 +1,7 @@
|
||||
Summary: The GNU data compression program.
|
||||
Name: gzip
|
||||
Version: 1.3.3
|
||||
Release: 5
|
||||
Release: 9
|
||||
License: GPL
|
||||
Group: Applications/File
|
||||
Source: ftp://alpha.gnu.org/gnu/gzip/gzip-%{version}.tar.gz
|
||||
@ -10,8 +10,8 @@ Patch1: gzip-1.2.4-zforce.patch
|
||||
Patch2: gzip-1.2.4a-dirinfo.patch
|
||||
Patch3: gzip-1.3-stderr.patch
|
||||
Patch4: gzip-1.3.1-zgreppipe.patch
|
||||
# Currently disabled - #66913
|
||||
Patch5: gzip-1.3-rsync.patch
|
||||
Patch6: gzip-1.3.3-window-size.patch
|
||||
URL: http://www.gzip.org/
|
||||
Prereq: /sbin/install-info
|
||||
Requires: mktemp less
|
||||
@ -31,37 +31,42 @@ very commonly used data compression program.
|
||||
#patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1 -b .nixi
|
||||
#patch5 -p1 -b .rsync
|
||||
%patch5 -p1 -b .rsync
|
||||
%patch6 -p1 -b .window-size
|
||||
|
||||
%build
|
||||
export DEFS="-DNO_ASM"
|
||||
export CPPFLAGS="-DHAVE_LSTAT"
|
||||
%configure --bindir=/bin
|
||||
|
||||
make
|
||||
make gzip.info
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
%makeinstall bindir=$RPM_BUILD_ROOT/bin
|
||||
mkdir -p $RPM_BUILD_ROOT/usr/bin
|
||||
ln -sf ../../bin/gzip $RPM_BUILD_ROOT/usr/bin/gzip
|
||||
ln -sf ../../bin/gunzip $RPM_BUILD_ROOT/usr/bin/gunzip
|
||||
rm -rf ${RPM_BUILD_ROOT}
|
||||
%makeinstall bindir=${RPM_BUILD_ROOT}/bin
|
||||
mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
|
||||
ln -sf ../../bin/gzip ${RPM_BUILD_ROOT}%{_bindir}/gzip
|
||||
ln -sf ../../bin/gunzip ${RPM_BUILD_ROOT}%{_bindir}/gunzip
|
||||
|
||||
for i in zcmp zegrep zforce zless znew gzexe zdiff zfgrep zgrep zmore ; do
|
||||
mv $RPM_BUILD_ROOT/bin/$i $RPM_BUILD_ROOT/usr/bin/$i
|
||||
mv ${RPM_BUILD_ROOT}/bin/$i ${RPM_BUILD_ROOT}%{_bindir}/$i
|
||||
done
|
||||
|
||||
gzip -9nf $RPM_BUILD_ROOT%{_infodir}/gzip.info*
|
||||
gzip -9nf ${RPM_BUILD_ROOT}%{_infodir}/gzip.info*
|
||||
|
||||
|
||||
cat > $RPM_BUILD_ROOT/usr/bin/zless <<EOF
|
||||
cat > ${RPM_BUILD_ROOT}%{_bindir}/zless <<EOF
|
||||
#!/bin/sh
|
||||
/bin/zcat "\$@" | /usr/bin/less
|
||||
EOF
|
||||
chmod 755 $RPM_BUILD_ROOT/usr/bin/zless
|
||||
chmod 755 ${RPM_BUILD_ROOT}%{_bindir}/zless
|
||||
|
||||
# we don't ship it, so let's remove it from ${RPM_BUILD_ROOT}
|
||||
rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
|
||||
|
||||
%clean
|
||||
rm -rf ${RPM_BUILD_ROOT}
|
||||
|
||||
%post
|
||||
/sbin/install-info %{_infodir}/gzip.info.gz %{_infodir}/dir
|
||||
@ -75,11 +80,25 @@ fi
|
||||
%defattr(-,root,root)
|
||||
%doc NEWS README AUTHORS ChangeLog THANKS TODO
|
||||
/bin/*
|
||||
/usr/bin/*
|
||||
%{_bindir}/*
|
||||
%{_mandir}/*/*
|
||||
%{_infodir}/gzip.info*
|
||||
|
||||
%changelog
|
||||
* Fri Jan 31 2003 Jeff Johnson <jbj@redhat.com> 1.3.3-9
|
||||
- enlarge window buffer to avoid accessing beyond end-of-buffer (#78413,#83095).
|
||||
- re-enable rsync ready patch.
|
||||
|
||||
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Fri Nov 22 2002 Jeff Johnson <jbj@redhat.com> 1.3.3-7
|
||||
- workaround mis-compilation with gcc-3.2-4 on alpha for now (#78413).
|
||||
|
||||
* Mon Nov 18 2002 Tim Powers <timp@redhat.com>
|
||||
- rebuild on all arches
|
||||
- remove file from buildroot we aren't shipping
|
||||
|
||||
* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
|
||||
- automated rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user