Fix FTBFS bug (caused by gnulib)
Resolves: 1604303
This commit is contained in:
parent
b8d6e421bc
commit
42f71479a4
189
gnulib.patch
Normal file
189
gnulib.patch
Normal file
@ -0,0 +1,189 @@
|
|||||||
|
From 1831628c0630ae96a43586b2a25ca51cbdba3e53 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Paul Eggert <address@hidden>
|
||||||
|
Date: Mon, 5 Mar 2018 10:56:29 -0800
|
||||||
|
Subject: [PATCH] fflush: adjust to glibc 2.28 libio.h removal
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
Problem reported by Daniel P. Berrangé in:
|
||||||
|
https://lists.gnu.org/r/bug-gnulib/2018-03/msg00000.html
|
||||||
|
* lib/fbufmode.c (fbufmode):
|
||||||
|
* lib/fflush.c (clear_ungetc_buffer_preserving_position)
|
||||||
|
(disable_seek_optimization, rpl_fflush):
|
||||||
|
* lib/fpending.c (__fpending):
|
||||||
|
* lib/fpurge.c (fpurge):
|
||||||
|
* lib/freadable.c (freadable):
|
||||||
|
* lib/freadahead.c (freadahead):
|
||||||
|
* lib/freading.c (freading):
|
||||||
|
* lib/freadptr.c (freadptr):
|
||||||
|
* lib/freadseek.c (freadptrinc):
|
||||||
|
* lib/fseeko.c (fseeko):
|
||||||
|
* lib/fseterr.c (fseterr):
|
||||||
|
* lib/fwritable.c (fwritable):
|
||||||
|
* lib/fwriting.c (fwriting):
|
||||||
|
Check _IO_EOF_SEEN instead of _IO_ftrylockfile.
|
||||||
|
* lib/stdio-impl.h (_IO_IN_BACKUP) [_IO_EOF_SEEN]:
|
||||||
|
Define if not already defined.
|
||||||
|
---
|
||||||
|
ChangeLog | 23 +++++++++++++++++++++++
|
||||||
|
lib/fbufmode.c | 2 +-
|
||||||
|
lib/fflush.c | 6 +++---
|
||||||
|
lib/fpending.c | 2 +-
|
||||||
|
lib/fpurge.c | 2 +-
|
||||||
|
lib/freadable.c | 2 +-
|
||||||
|
lib/freadahead.c | 2 +-
|
||||||
|
lib/freading.c | 2 +-
|
||||||
|
lib/freadptr.c | 2 +-
|
||||||
|
lib/freadseek.c | 2 +-
|
||||||
|
lib/fseeko.c | 4 ++--
|
||||||
|
lib/fseterr.c | 2 +-
|
||||||
|
lib/fwritable.c | 2 +-
|
||||||
|
lib/fwriting.c | 2 +-
|
||||||
|
lib/stdio-impl.h | 6 ++++++
|
||||||
|
15 files changed, 45 insertions(+), 16 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/ChangeLog b/ChangeLog
|
||||||
|
index 667f91663..beb835670 100644
|
||||||
|
--- a/ChangeLog
|
||||||
|
+++ b/ChangeLog
|
||||||
|
@@ -1,3 +1,26 @@
|
||||||
|
+2018-03-05 Paul Eggert <address@hidden>
|
||||||
|
+
|
||||||
|
+ fflush: adjust to glibc 2.28 libio.h removal
|
||||||
|
+ Problem reported by Daniel P. Berrangé in:
|
||||||
|
+ https://lists.gnu.org/r/bug-gnulib/2018-03/msg00000.html
|
||||||
|
+ * lib/fbufmode.c (fbufmode):
|
||||||
|
+ * lib/fflush.c (clear_ungetc_buffer_preserving_position)
|
||||||
|
+ (disable_seek_optimization, rpl_fflush):
|
||||||
|
+ * lib/fpending.c (__fpending):
|
||||||
|
+ * lib/fpurge.c (fpurge):
|
||||||
|
+ * lib/freadable.c (freadable):
|
||||||
|
+ * lib/freadahead.c (freadahead):
|
||||||
|
+ * lib/freading.c (freading):
|
||||||
|
+ * lib/freadptr.c (freadptr):
|
||||||
|
+ * lib/freadseek.c (freadptrinc):
|
||||||
|
+ * lib/fseeko.c (fseeko):
|
||||||
|
+ * lib/fseterr.c (fseterr):
|
||||||
|
+ * lib/fwritable.c (fwritable):
|
||||||
|
+ * lib/fwriting.c (fwriting):
|
||||||
|
+ Check _IO_EOF_SEEN instead of _IO_ftrylockfile.
|
||||||
|
+ * lib/stdio-impl.h (_IO_IN_BACKUP) [_IO_EOF_SEEN]:
|
||||||
|
+ Define if not already defined.
|
||||||
|
+
|
||||||
|
2018-01-07 Jim Meyering <meyering@fb.com>
|
||||||
|
|
||||||
|
version 1.9
|
||||||
|
* NEWS: Record release date.
|
||||||
|
diff --git a/lib/fflush.c b/lib/fflush.c
|
||||||
|
index 983ade0ff..a6edfa105 100644
|
||||||
|
--- a/lib/fflush.c
|
||||||
|
+++ b/lib/fflush.c
|
||||||
|
@@ -33,7 +33,7 @@
|
||||||
|
#undef fflush
|
||||||
|
|
||||||
|
|
||||||
|
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
|
||||||
|
/* Clear the stream's ungetc buffer, preserving the value of ftello (fp). */
|
||||||
|
static void
|
||||||
|
@@ -72,7 +72,7 @@ clear_ungetc_buffer (FILE *fp)
|
||||||
|
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#if ! (defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */)
|
||||||
|
+#if ! (defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */)
|
||||||
|
|
||||||
|
# if (defined __sferror || defined __DragonFly__ || defined __ANDROID__) && defined __SNPT
|
||||||
|
/* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Minix 3, Android */
|
||||||
|
@@ -148,7 +148,7 @@ rpl_fflush (FILE *stream)
|
||||||
|
if (stream == NULL || ! freading (stream))
|
||||||
|
return fflush (stream);
|
||||||
|
|
||||||
|
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
|
||||||
|
clear_ungetc_buffer_preserving_position (stream);
|
||||||
|
|
||||||
|
diff --git a/lib/fpurge.c b/lib/fpurge.c
|
||||||
|
index b1d417c7a..3aedcc373 100644
|
||||||
|
--- a/lib/fpurge.c
|
||||||
|
+++ b/lib/fpurge.c
|
||||||
|
@@ -62,7 +62,7 @@ fpurge (FILE *fp)
|
||||||
|
/* Most systems provide FILE as a struct and the necessary bitmask in
|
||||||
|
<stdio.h>, because they need it for implementing getc() and putc() as
|
||||||
|
fast macros. */
|
||||||
|
-# if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
+# if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
fp->_IO_read_end = fp->_IO_read_ptr;
|
||||||
|
fp->_IO_write_ptr = fp->_IO_write_base;
|
||||||
|
/* Avoid memory leak when there is an active ungetc buffer. */
|
||||||
|
diff --git a/lib/freading.c b/lib/freading.c
|
||||||
|
index 73c28acdd..c24d0c88a 100644
|
||||||
|
--- a/lib/freading.c
|
||||||
|
+++ b/lib/freading.c
|
||||||
|
@@ -31,7 +31,7 @@ freading (FILE *fp)
|
||||||
|
/* Most systems provide FILE as a struct and the necessary bitmask in
|
||||||
|
<stdio.h>, because they need it for implementing getc() and putc() as
|
||||||
|
fast macros. */
|
||||||
|
-# if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
+# if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
return ((fp->_flags & _IO_NO_WRITES) != 0
|
||||||
|
|| ((fp->_flags & (_IO_NO_READS | _IO_CURRENTLY_PUTTING)) == 0
|
||||||
|
&& fp->_IO_read_base != NULL));
|
||||||
|
diff --git a/lib/fseeko.c b/lib/fseeko.c
|
||||||
|
index 0101ab55f..193f4e8ce 100644
|
||||||
|
--- a/lib/fseeko.c
|
||||||
|
+++ b/lib/fseeko.c
|
||||||
|
@@ -47,7 +47,7 @@ fseeko (FILE *fp, off_t offset, int whence)
|
||||||
|
#endif
|
||||||
|
|
||||||
|
/* These tests are based on fpurge.c. */
|
||||||
|
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
if (fp->_IO_read_end == fp->_IO_read_ptr
|
||||||
|
&& fp->_IO_write_ptr == fp->_IO_write_base
|
||||||
|
&& fp->_IO_save_base == NULL)
|
||||||
|
@@ -123,7 +123,7 @@ fseeko (FILE *fp, off_t offset, int whence)
|
||||||
|
return -1;
|
||||||
|
}
|
||||||
|
|
||||||
|
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
fp->_flags &= ~_IO_EOF_SEEN;
|
||||||
|
fp->_offset = pos;
|
||||||
|
#elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
|
||||||
|
diff --git a/lib/fseterr.c b/lib/fseterr.c
|
||||||
|
index 82649c3ac..adb637256 100644
|
||||||
|
--- a/lib/fseterr.c
|
||||||
|
+++ b/lib/fseterr.c
|
||||||
|
@@ -29,7 +29,7 @@ fseterr (FILE *fp)
|
||||||
|
/* Most systems provide FILE as a struct and the necessary bitmask in
|
||||||
|
<stdio.h>, because they need it for implementing getc() and putc() as
|
||||||
|
fast macros. */
|
||||||
|
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
||||||
|
fp->_flags |= _IO_ERR_SEEN;
|
||||||
|
#elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
|
||||||
|
/* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Minix 3, Android */
|
||||||
|
diff --git a/lib/stdio-impl.h b/lib/stdio-impl.h
|
||||||
|
index 78d896e9f..05c5752a2 100644
|
||||||
|
--- a/lib/stdio-impl.h
|
||||||
|
+++ b/lib/stdio-impl.h
|
||||||
|
@@ -18,6 +18,12 @@
|
||||||
|
the same implementation of stdio extension API, except that some fields
|
||||||
|
have different naming conventions, or their access requires some casts. */
|
||||||
|
|
||||||
|
+/* Glibc 2.28 made _IO_IN_BACKUP private. For now, work around this
|
||||||
|
+ problem by defining it ourselves. FIXME: Do not rely on glibc
|
||||||
|
+ internals. */
|
||||||
|
+#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN
|
||||||
|
+# define _IO_IN_BACKUP 0x100
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
/* BSD stdio derived implementations. */
|
||||||
|
|
||||||
|
--
|
||||||
|
2.14.3
|
||||||
|
|
11
gzip.spec
11
gzip.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: The GNU data compression program
|
Summary: The GNU data compression program
|
||||||
Name: gzip
|
Name: gzip
|
||||||
Version: 1.9
|
Version: 1.9
|
||||||
Release: 6%{?dist}
|
Release: 7%{?dist}
|
||||||
# info pages are under GFDL license
|
# info pages are under GFDL license
|
||||||
License: GPLv3+ and GFDL
|
License: GPLv3+ and GFDL
|
||||||
Group: Applications/File
|
Group: Applications/File
|
||||||
@ -12,6 +12,8 @@ Source1: https://www.gnu.org/licenses/fdl-1.3.txt
|
|||||||
Source100: colorzgrep.csh
|
Source100: colorzgrep.csh
|
||||||
Source101: colorzgrep.sh
|
Source101: colorzgrep.sh
|
||||||
|
|
||||||
|
Patch1: gnulib.patch
|
||||||
|
|
||||||
# Fixed in upstream code.
|
# Fixed in upstream code.
|
||||||
# http://thread.gmane.org/gmane.comp.gnu.gzip.bugs/378
|
# http://thread.gmane.org/gmane.comp.gnu.gzip.bugs/378
|
||||||
URL: http://www.gzip.org/
|
URL: http://www.gzip.org/
|
||||||
@ -37,6 +39,7 @@ very commonly used data compression program.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch1 -p1 -b .gnulib
|
||||||
cp %{SOURCE1} .
|
cp %{SOURCE1} .
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -46,7 +49,6 @@ export CC="%{__cc}"
|
|||||||
export CPP="%{__cpp}"
|
export CPP="%{__cpp}"
|
||||||
export CXX="%{__cxx}"
|
export CXX="%{__cxx}"
|
||||||
%configure
|
%configure
|
||||||
|
|
||||||
make
|
make
|
||||||
#make gzip.info
|
#make gzip.info
|
||||||
|
|
||||||
@ -77,6 +79,11 @@ install -p -m 644 %{SOURCE101} %{buildroot}%{profiledir}
|
|||||||
%{profiledir}/*
|
%{profiledir}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 26 2018 Jakub Martisko <jamartis@redhat.com> - 1.9-7
|
||||||
|
- Fix FTBFS bug (gnulib problems)
|
||||||
|
- more details: https://lists.gnu.org/r/bug-gnulib/2018-03/msg00000.html
|
||||||
|
Resolves 1604303
|
||||||
|
|
||||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.9-6
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.9-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user