Rebase to gzip 1.11
Resolves: rhbz#2001025
This commit is contained in:
parent
de64edeca2
commit
3ed6b7def3
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@ gzip-1.4.tar.xz
|
|||||||
/gzip-1.8.tar.xz
|
/gzip-1.8.tar.xz
|
||||||
/gzip-1.9.tar.xz
|
/gzip-1.9.tar.xz
|
||||||
/gzip-1.10.tar.xz
|
/gzip-1.10.tar.xz
|
||||||
|
/gzip-1.11.tar.xz
|
||||||
|
75
gzexe.patch
75
gzexe.patch
@ -1,75 +0,0 @@
|
|||||||
From 21cd963565a43dabd59516bd4cca5c76a614f255 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jakub Martisko <jamartis@redhat.com>
|
|
||||||
Date: Tue, 26 Mar 2019 12:29:30 +0100
|
|
||||||
Subject: [PATCH] Fix: the value of the skip variable in the gzexe
|
|
||||||
|
|
||||||
---
|
|
||||||
gzexe.in | 4 ++--
|
|
||||||
tests/Makefile.am | 1 +
|
|
||||||
tests/gzexe | 20 ++++++++++++++++++++
|
|
||||||
3 files changed, 23 insertions(+), 2 deletions(-)
|
|
||||||
create mode 100755 tests/gzexe
|
|
||||||
|
|
||||||
diff --git a/gzexe.in b/gzexe.in
|
|
||||||
index 6c61183..cffa84e 100644
|
|
||||||
--- a/gzexe.in
|
|
||||||
+++ b/gzexe.in
|
|
||||||
@@ -145,7 +145,7 @@ for i do
|
|
||||||
if test $decomp -eq 0; then
|
|
||||||
(cat <<'EOF' &&
|
|
||||||
#!/bin/sh
|
|
||||||
-skip=44
|
|
||||||
+skip=49
|
|
||||||
|
|
||||||
tab=' '
|
|
||||||
nl='
|
|
||||||
@@ -201,7 +201,7 @@ EOF
|
|
||||||
|
|
||||||
else
|
|
||||||
# decompression
|
|
||||||
- skip=44
|
|
||||||
+ skip=49
|
|
||||||
skip_line=`sed -e 1d -e 2q "$file"`
|
|
||||||
case $skip_line in
|
|
||||||
skip=[0-9] | skip=[0-9][0-9] | skip=[0-9][0-9][0-9])
|
|
||||||
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
|
||||||
index ebdce5b..4dfbccf 100644
|
|
||||||
--- a/tests/Makefile.am
|
|
||||||
+++ b/tests/Makefile.am
|
|
||||||
@@ -15,6 +15,7 @@
|
|
||||||
# along with this program. If not, see <https://www.gnu.org/licenses/>.
|
|
||||||
|
|
||||||
TESTS = \
|
|
||||||
+ gzexe \
|
|
||||||
gzip-env \
|
|
||||||
helin-segv \
|
|
||||||
help-version \
|
|
||||||
diff --git a/tests/gzexe b/tests/gzexe
|
|
||||||
new file mode 100755
|
|
||||||
index 0000000..45f71c7
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/tests/gzexe
|
|
||||||
@@ -0,0 +1,20 @@
|
|
||||||
+#!/bin/sh
|
|
||||||
+#Try running simple shell script compressed by gzexe
|
|
||||||
+
|
|
||||||
+. "${srcdir=.}/init.sh"; path_prepend_ ..
|
|
||||||
+
|
|
||||||
+cat <<EOF > foo || framework_failure_
|
|
||||||
+#!/bin/sh
|
|
||||||
+echo "Hello World!"
|
|
||||||
+EOF
|
|
||||||
+
|
|
||||||
+echo "Hello World!" > exp || framework_failure_
|
|
||||||
+
|
|
||||||
+fail=0
|
|
||||||
+gzexe foo || fail=1
|
|
||||||
+/bin/sh foo > out 2> err || fail=1
|
|
||||||
+
|
|
||||||
+compare exp out || fail=1
|
|
||||||
+test -s err && fail=1
|
|
||||||
+
|
|
||||||
+Exit $fail
|
|
||||||
--
|
|
||||||
2.21.0
|
|
||||||
|
|
12
gzip.spec
12
gzip.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: GNU data compression program
|
Summary: GNU data compression program
|
||||||
Name: gzip
|
Name: gzip
|
||||||
Version: 1.10
|
Version: 1.11
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
# info pages are under GFDL license
|
# info pages are under GFDL license
|
||||||
License: GPLv3+ and GFDL
|
License: GPLv3+ and GFDL
|
||||||
Source0: https://ftp.gnu.org/gnu/gzip/gzip-%{version}.tar.xz
|
Source0: https://ftp.gnu.org/gnu/gzip/gzip-%{version}.tar.xz
|
||||||
@ -12,7 +12,6 @@ Source100: colorzgrep.csh
|
|||||||
Source101: colorzgrep.sh
|
Source101: colorzgrep.sh
|
||||||
|
|
||||||
Patch1: gnulib.patch
|
Patch1: gnulib.patch
|
||||||
Patch2: gzexe.patch
|
|
||||||
|
|
||||||
# Fixed in upstream code.
|
# Fixed in upstream code.
|
||||||
# http://thread.gmane.org/gmane.comp.gnu.gzip.bugs/378
|
# http://thread.gmane.org/gmane.comp.gnu.gzip.bugs/378
|
||||||
@ -41,7 +40,6 @@ very commonly used data compression program.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch1 -p1 -b .gnulib
|
#%patch1 -p1 -b .gnulib
|
||||||
%patch2 -p1 -b .gzexe
|
|
||||||
cp %{SOURCE1} .
|
cp %{SOURCE1} .
|
||||||
autoreconf
|
autoreconf
|
||||||
|
|
||||||
@ -53,6 +51,7 @@ export CPP="%{__cpp}"
|
|||||||
export CXX="%{__cxx}"
|
export CXX="%{__cxx}"
|
||||||
%configure
|
%configure
|
||||||
make
|
make
|
||||||
|
%check
|
||||||
make check
|
make check
|
||||||
#make gzip.info
|
#make gzip.info
|
||||||
|
|
||||||
@ -81,6 +80,11 @@ install -p -m 644 %{SOURCE101} %{buildroot}%{profiledir}
|
|||||||
%{profiledir}/*
|
%{profiledir}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Oct 21 2021 Jakub Martisko <jamartis@redhat.com> - 1.11-1
|
||||||
|
- Rebase to gzip 1.11
|
||||||
|
- Run the tests in the check section instead of the build section
|
||||||
|
Resolve: rhbz#2001025
|
||||||
|
|
||||||
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.10-5
|
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.10-5
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (gzip-1.10.tar.xz) = e6ba9e3906cdb6a6235b213515093d02afa1722686f73eddacbacae628542b586b449829783b6a1701e9b9e0c4d4dfa6845904d3b6b010f5cf21aec4997c9299
|
SHA512 (gzip-1.11.tar.xz) = af297c173297d588722f4d0f140a2ae4d3ea3861464191772fb2e11e47be43644b5ae01ed63f0051d6eb4751666284de53e14c4dd9f0c1d25f61cf676fbf11f3
|
||||||
|
Loading…
Reference in New Issue
Block a user