- Resolves: 225878 update to 1.3.10 change BuildRoot
- scratch build
This commit is contained in:
parent
960eab7d6d
commit
0adb1d59b8
@ -1 +1 @@
|
||||
gzip-1.3.9.tar.gz
|
||||
gzip-1.3.10.tar.gz
|
||||
|
20
gzip-1.3.10-zgreppipe.patch
Normal file
20
gzip-1.3.10-zgreppipe.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- gzip-1.3.10/zgrep.in.pom 2006-12-30 04:01:51.000000000 +0100
|
||||
+++ gzip-1.3.10/zgrep.in 2007-02-06 10:54:33.000000000 +0100
|
||||
@@ -146,7 +146,7 @@
|
||||
|
||||
exec 3>&1
|
||||
res=0
|
||||
-
|
||||
+trap break SIGPIPE
|
||||
for i
|
||||
do
|
||||
# Fail if gzip or grep (or sed) fails.
|
||||
@@ -190,5 +190,8 @@
|
||||
r=$?
|
||||
test "$gzip_status" -eq 0 || test "$gzip_status" -eq 2 || r=2
|
||||
test $res -lt $r && res=$r
|
||||
+ # SIGPIPE + 128
|
||||
+ test "$r" -eq 141 && exit $res
|
||||
done
|
||||
+trap - SIGPIPE
|
||||
exit $res
|
@ -43,25 +43,3 @@
|
||||
if test "$ext" = ".Z"; then
|
||||
echo znew: cannot use .Z as gzip extension.
|
||||
exit 1
|
||||
--- gzip-1.3.9/zdiff.in.owl-tmp 2006-12-09 05:25:56.000000000 +0100
|
||||
+++ gzip-1.3.9/zdiff.in 2007-01-15 11:40:51.000000000 +0100
|
||||
@@ -58,13 +58,13 @@
|
||||
case "$2" in
|
||||
*[-.]gz* | *[-.][zZ] | *.t[ga]z)
|
||||
F=`echo "$2" | sed 's|.*/||;s|[-.][zZtga]*||'`
|
||||
- set -C
|
||||
- trap 'rm -f /tmp/"$F".$$; exit 2' HUP INT PIPE TERM 0
|
||||
- gzip -cdfq -- "$2" > /tmp/"$F".$$ || exit
|
||||
- gzip -cdfq -- "$1" | $comp $OPTIONS - /tmp/"$F".$$
|
||||
+ TF=`/bin/mktemp ${TMPDIR:-/tmp}/"$F".XXXXXXXXXX` || exit 1
|
||||
+ trap 'rm -f "$TF"; exit 2' EXIT HUP INT PIPE TERM
|
||||
+ gzip -cdfq -- "$2" > "$TF" || exit
|
||||
+ gzip -cdfq -- "$1" | $comp $OPTIONS - "$TF"
|
||||
STAT="$?"
|
||||
- /bin/rm -f /tmp/"$F".$$ || STAT=2
|
||||
- trap - HUP INT PIPE TERM 0
|
||||
+ rm -f "$TF" || STAT=2
|
||||
+ trap - EXIT HUP INT PIPE TERM
|
||||
exit $STAT;;
|
||||
|
||||
*) gzip -cdfq -- "$1" | $comp $OPTIONS - "$2";;
|
||||
|
@ -9,17 +9,6 @@
|
||||
exit 1
|
||||
fi
|
||||
|
||||
--- gzip-1.3.9/zgrep.in.stderr 2006-12-09 05:25:56.000000000 +0100
|
||||
+++ gzip-1.3.9/zgrep.in 2007-01-15 14:23:54.000000000 +0100
|
||||
@@ -96,7 +96,7 @@
|
||||
done
|
||||
|
||||
if test -z "$pat"; then
|
||||
- echo "$usage"
|
||||
+ echo "$usage" >&2
|
||||
exit 2
|
||||
fi
|
||||
|
||||
--- gzip-1.3.9/zforce.in.stderr 2007-01-15 14:23:54.000000000 +0100
|
||||
+++ gzip-1.3.9/zforce.in 2007-01-15 14:23:54.000000000 +0100
|
||||
@@ -40,7 +40,7 @@
|
||||
|
19
gzip.spec
19
gzip.spec
@ -1,14 +1,14 @@
|
||||
Summary: The GNU data compression program
|
||||
Name: gzip
|
||||
Version: 1.3.9
|
||||
Release: 2%{?dist}
|
||||
Version: 1.3.10
|
||||
Release: 01%{?dist}
|
||||
License: GPL
|
||||
Group: Applications/File
|
||||
Source: ftp://alpha.gnu.org/gnu/gzip/gzip-%{version}.tar.gz
|
||||
Patch0: gzip-1.3.9-openbsd-owl-tmp.patch
|
||||
Patch1: gzip-1.3.5-zforce.patch
|
||||
Patch3: gzip-1.3.9-stderr.patch
|
||||
Patch4: gzip-1.3.9-zgreppipe.patch
|
||||
Patch4: gzip-1.3.10-zgreppipe.patch
|
||||
Patch5: gzip-1.3.9-rsync.patch
|
||||
Patch6: gzip-1.3.3-window-size.patch
|
||||
Patch7: gzip-1.3.9-addsuffix.patch
|
||||
@ -17,12 +17,11 @@ Patch13: gzip-1.3.5-cve-2006-4336.patch
|
||||
Patch14: gzip-1.3.5-cve-2006-4338.patch
|
||||
Patch15: gzip-1.3.9-cve-2006-4337.patch
|
||||
Patch16: gzip-1.3.5-cve-2006-4337_len.patch
|
||||
Patch17: gzip-1.3.9-zdiff_arg.patch
|
||||
URL: http://www.gzip.org/
|
||||
Requires: /sbin/install-info
|
||||
Requires: mktemp less
|
||||
BuildRequires: texinfo
|
||||
Buildroot: %{_tmppath}/gzip-%{version}-root
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
%description
|
||||
The gzip package contains the popular GNU gzip data compression
|
||||
@ -45,7 +44,6 @@ very commonly used data compression program.
|
||||
%patch14 -p1 -b .4338
|
||||
%patch15 -p1 -b .4337
|
||||
%patch16 -p1 -b .4337l
|
||||
%patch17 -p1 -b .arg
|
||||
|
||||
%build
|
||||
export DEFS="NO_ASM"
|
||||
@ -91,11 +89,16 @@ fi
|
||||
%{_infodir}/gzip.info*
|
||||
|
||||
%changelog
|
||||
* Mon Jan 22 2007 Ivana Varekova <varekova@redhat.com> 1.3.9-2
|
||||
* Tue Feb 6 2007 Ivana Varekova <varekova@redhat.com> - 1.3.10-1
|
||||
- Resolves: 225878
|
||||
update to 1.3.10
|
||||
change BuildRoot
|
||||
|
||||
* Mon Jan 22 2007 Ivana Varekova <varekova@redhat.com> - 1.3.9-2
|
||||
- Resolves: 223702
|
||||
fix non-failsafe install-info problem
|
||||
|
||||
* Mon Jan 15 2007 Ivana Varekova <varekova@redhat.com> 1.3.9-1
|
||||
* Mon Jan 15 2007 Ivana Varekova <varekova@redhat.com> - 1.3.9-1
|
||||
- rebuild to 1.3.9
|
||||
- spec cleanup
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user