Update to 1.9.0
This commit is contained in:
parent
03f01eac84
commit
f45fdb6520
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@ gvfs-1.6.3.tar.bz2
|
||||
/gvfs-1.7.3.tar.bz2
|
||||
/gvfs-1.8.0.tar.bz2
|
||||
/gvfs-1.8.1.tar.bz2
|
||||
/gvfs-1.9.0.tar.bz2
|
||||
|
@ -1,33 +0,0 @@
|
||||
Not all gphoto drivers implement get storage info (drivers for proprietary
|
||||
protocols often don't). This patch fixes the gphoto2volumemonitor to still
|
||||
recognize cams which gphoto driver does not implement get storage info.
|
||||
|
||||
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
|
||||
diff -up gvfs-1.5.1/monitor/gphoto2/ggphoto2volumemonitor.c~ gvfs-1.5.1/monitor/gphoto2/ggphoto2volumemonitor.c
|
||||
--- gvfs-1.5.1/monitor/gphoto2/ggphoto2volumemonitor.c~ 2009-11-18 13:14:51.000000000 +0100
|
||||
+++ gvfs-1.5.1/monitor/gphoto2/ggphoto2volumemonitor.c 2010-01-06 11:46:16.000000000 +0100
|
||||
@@ -605,7 +605,7 @@ get_stores_for_camera (int bus_num, int
|
||||
GPContext *context;
|
||||
GPPortInfo info;
|
||||
GPPortInfoList *il;
|
||||
- int num_storage_info, n;
|
||||
+ int num_storage_info, n, rc;
|
||||
Camera *camera;
|
||||
char *port;
|
||||
guint i;
|
||||
@@ -637,8 +637,14 @@ get_stores_for_camera (int bus_num, int
|
||||
goto out;
|
||||
|
||||
/* Get information about the storage heads */
|
||||
- if (gp_camera_get_storageinfo (camera, &storage_info, &num_storage_info, context) != 0)
|
||||
+ rc = gp_camera_get_storageinfo (camera, &storage_info, &num_storage_info, context);
|
||||
+ if (rc != 0) {
|
||||
+ /* Not all gphoto drivers implement get storage info (drivers for proprietary
|
||||
+ protocols often don't) */
|
||||
+ if (rc == GP_ERROR_NOT_SUPPORTED)
|
||||
+ l = g_list_prepend (l, g_strdup ("/"));
|
||||
goto out;
|
||||
+ }
|
||||
|
||||
/* Append the data to the list */
|
||||
for (i = 0; i < num_storage_info; i++)
|
14
gvfs.spec
14
gvfs.spec
@ -1,11 +1,11 @@
|
||||
Summary: Backends for the gio framework in GLib
|
||||
Name: gvfs
|
||||
Version: 1.8.1
|
||||
Release: 2%{?dist}
|
||||
Version: 1.9.0
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.gtk.org
|
||||
Source: http://download.gnome.org/sources/gvfs/1.8/gvfs-%{version}.tar.bz2
|
||||
Source: http://download.gnome.org/sources/gvfs/1.9/gvfs-%{version}.tar.bz2
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: glib2-devel >= 2.27.4
|
||||
# for post-install update-gio-modules and overall functionality
|
||||
@ -35,10 +35,6 @@ BuildRequires: libtool
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=567235
|
||||
Patch0: gvfs-archive-integration.patch
|
||||
|
||||
# Recognize gphoto2 cameras which don't implement get storageinfo
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=552856
|
||||
Patch15: gvfs-1.5.1-gphoto2-no-storageinfo-support.patch
|
||||
|
||||
Obsoletes: gnome-mount <= 0.8
|
||||
Obsoletes: gnome-mount-nautilus-properties <= 0.8
|
||||
|
||||
@ -135,7 +131,6 @@ including phones and music players to applications using gvfs.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .archive-integration
|
||||
%patch15 -p1 -b .gphoto2-storageinfo
|
||||
|
||||
%build
|
||||
|
||||
@ -312,6 +307,9 @@ killall -USR1 gvfsd >&/dev/null || :
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon May 09 2011 Tomas Bzatek <tbzatek@redhat.com> - 1.9.0-1
|
||||
- Update to 1.9.0
|
||||
|
||||
* Sat May 07 2011 Christopher Aillon <caillon@redhat.com> - 1.8.1-2
|
||||
- Update gsettings scriptlet
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user