Update to 1.15.2

This commit is contained in:
Tomas Bzatek 2013-01-15 17:29:36 +01:00
parent 8918af219c
commit f163b45da8
4 changed files with 141 additions and 3 deletions

1
.gitignore vendored
View File

@ -35,3 +35,4 @@ gvfs-1.6.3.tar.bz2
/gvfs-1.14.0.tar.xz /gvfs-1.14.0.tar.xz
/gvfs-1.15.0.tar.xz /gvfs-1.15.0.tar.xz
/gvfs-1.15.1.tar.xz /gvfs-1.15.1.tar.xz
/gvfs-1.15.2.tar.xz

109
gvfs-1.15.3-autoconf.patch Normal file
View File

@ -0,0 +1,109 @@
From fdbe5dd3fc723b303970e6b4e72de3a20c41d223 Mon Sep 17 00:00:00 2001
From: Tomas Bzatek <tbzatek@redhat.com>
Date: Tue, 15 Jan 2013 16:11:44 +0000
Subject: build: Replace deprecated autoconf macros
Contains parts from https://live.gnome.org/GnomeGoals/ModernAutotools
---
diff --git a/Makefile.am b/Makefile.am
index 76aac2a..dbe5a1e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,7 +15,7 @@ if BUILD_DOCUMENTATION
SUBDIRS += man
endif
-ACLOCAL_AMFLAGS = ${ACLOCAL_FLAGS}
+ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
diff --git a/configure.ac b/configure.ac
index 88fffae..98f2ebc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,25 +2,32 @@ AC_PREREQ([2.64])
AC_INIT([gvfs],[1.15.2],[http://bugzilla.gnome.org/enter_bug.cgi?product=gvfs])
AM_INIT_AUTOMAKE([1.11.1 no-dist-gzip dist-xz tar-ustar])
-AM_CONFIG_HEADER(config.h)
+
+AC_CONFIG_HEADERS(config.h)
+AC_CONFIG_MACRO_DIR([m4])
AM_SANITY_CHECK
AC_C_CONST
-AC_ISC_POSIX
+AC_SEARCH_LIBS([strerror],[cposix])
AC_PROG_CC
AC_PROG_CPP
AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_MAKE_SET
-AM_DISABLE_STATIC
-AM_PROG_LIBTOOL
AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
AC_PATH_PROG(GIO_QUERYMODULES, gio-querymodules, no)
AM_PROG_CC_C_O
AC_PROG_SED
+
+# Initialize libtool
+LT_PREREQ([2.2])
+LT_INIT([disable-static])
+LIBTOOL_EXPORT_OPTIONS='-export-symbols-regex "^[[^_]].*"'
+AC_SUBST(LIBTOOL_EXPORT_OPTIONS)
+
AC_ARG_ENABLE(documentation,
- AC_HELP_STRING([--enable-documentation],
+ AS_HELP_STRING([--enable-documentation],
[build documentation]),,
enable_documentation=yes)
if test x$enable_documentation = xyes; then
@@ -50,9 +57,6 @@ saved_CFLAGS=$CFLAGS
AC_CHECK_MEMBERS([struct stat.st_mtimensec, struct stat.st_mtim.tv_nsec, struct stat.st_atimensec, struct stat.st_atim.tv_nsec, struct stat.st_ctimensec, struct stat.st_ctim.tv_nsec])
CFLAGS=$saved_CFLAGS
-LIBTOOL_EXPORT_OPTIONS='-export-symbols-regex "^[[^_]].*"'
-AC_SUBST(LIBTOOL_EXPORT_OPTIONS)
-
GTK_DOC_CHECK
DISTCHECK_CONFIGURE_FLAGS="--enable-gtk-doc"
AC_SUBST(DISTCHECK_CONFIGURE_FLAGS)
@@ -718,7 +722,7 @@ AM_CONDITIONAL(USE_AFP, test "x$enable_afp" != "xno")
dnl Install bash-completion file?
AC_ARG_ENABLE([bash-completion],
- AC_HELP_STRING([--disable-bash-completion],
+ AS_HELP_STRING([--disable-bash-completion],
[build without bash-completion support]),
msg_bash_completion=$enableval,
msg_bash_completion=yes)
@@ -728,7 +732,7 @@ fi
AM_CONDITIONAL(ENABLE_BASHCOMP, test "$msg_bash_completion" = "yes")
AC_ARG_WITH([bash-completion-dir],
- AC_HELP_STRING([--with-bash-completion-dir=PATH],
+ AS_HELP_STRING([--with-bash-completion-dir=PATH],
[choose directory for bash-completion file (default=DATADIR/bash-completion/completions)]),
with_bashcomp_dir=$withval,
with_bashcomp_dir=$datadir/bash-completion/completions)
@@ -850,7 +854,7 @@ else
AC_MSG_RESULT(no)
fi
-AC_OUTPUT([
+AC_CONFIG_FILES([
Makefile
common/Makefile
client/Makefile
@@ -870,6 +874,7 @@ man/Makefile
test/Makefile
po/Makefile.in
])
+AC_OUTPUT
echo
echo "gvfs configuration summary:"
--
cgit v0.9.0.2

View File

@ -1,7 +1,7 @@
Summary: Backends for the gio framework in GLib Summary: Backends for the gio framework in GLib
Name: gvfs Name: gvfs
Version: 1.15.1 Version: 1.15.2
Release: 3%{?dist} Release: 1%{?dist}
License: GPLv3 and LGPLv2+ License: GPLv3 and LGPLv2+
Group: System Environment/Libraries Group: System Environment/Libraries
URL: http://www.gtk.org URL: http://www.gtk.org
@ -39,6 +39,10 @@ BuildRequires: libtool
# http://bugzilla.gnome.org/show_bug.cgi?id=567235 # http://bugzilla.gnome.org/show_bug.cgi?id=567235
Patch0: gvfs-archive-integration.patch Patch0: gvfs-archive-integration.patch
# from git master
Patch1: gvfs-1.15.3-autoconf.patch
Obsoletes: gnome-mount <= 0.8 Obsoletes: gnome-mount <= 0.8
Obsoletes: gnome-mount-nautilus-properties <= 0.8 Obsoletes: gnome-mount-nautilus-properties <= 0.8
@ -149,9 +153,21 @@ Mac OS X and original Mac OS network shares via Apple Filing Protocol
to applications using gvfs. to applications using gvfs.
%package mtp
Summary: MTP support for gvfs
Group: System Environment/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}
BuildRequires: libmtp-devel >= 1.1.0
%description mtp
This package provides support for reading and writing files on
MTP based devices (Media Transfer Protocol) to applications using gvfs.
%prep %prep
%setup -q %setup -q
%patch0 -p1 -b .archive-integration %patch0 -p1 -b .archive-integration
%patch1 -p1 -b .autoconf
%build %build
# Needed for gvfs-0.2.1-archive-integration.patch # Needed for gvfs-0.2.1-archive-integration.patch
@ -205,6 +221,8 @@ killall -USR1 gvfsd >&/dev/null || :
killall -USR1 gvfsd >&/dev/null || : killall -USR1 gvfsd >&/dev/null || :
%post gphoto2 %post gphoto2
killall -USR1 gvfsd >&/dev/null || : killall -USR1 gvfsd >&/dev/null || :
%post mtp
killall -USR1 gvfsd >&/dev/null || :
%ifnarch s390 s390x %ifnarch s390 s390x
%post obexftp %post obexftp
killall -USR1 gvfsd >&/dev/null || : killall -USR1 gvfsd >&/dev/null || :
@ -330,7 +348,17 @@ killall -USR1 gvfsd >&/dev/null || :
%{_datadir}/gvfs/mounts/afp.mount %{_datadir}/gvfs/mounts/afp.mount
%{_datadir}/gvfs/mounts/afp-browse.mount %{_datadir}/gvfs/mounts/afp-browse.mount
%files mtp
%{_libexecdir}/gvfsd-mtp
%{_datadir}/gvfs/mounts/mtp.mount
%{_libexecdir}/gvfs-mtp-volume-monitor
%{_datadir}/dbus-1/services/org.gtk.Private.MTPVolumeMonitor.service
%{_datadir}/gvfs/remote-volume-monitors/mtp.monitor
%changelog %changelog
* Tue Jan 15 2013 Tomas Bzatek <tbzatek@redhat.com> - 1.15.2-1
- Update to 1.15.2
* Mon Jan 07 2013 Adrian Reber <adrian@lisas.de> - 1.15.1-3 * Mon Jan 07 2013 Adrian Reber <adrian@lisas.de> - 1.15.1-3
- Rebuilt for libcdio-0.90 - Rebuilt for libcdio-0.90

View File

@ -1 +1 @@
259a51b26481c49fce31cf47eeca178c gvfs-1.15.1.tar.xz c86807222be5b03c2d9ff42d9e5f33e7 gvfs-1.15.2.tar.xz