- Fix volume lists not filled correctly
This commit is contained in:
parent
1fe862dc81
commit
e4395f1c08
51
gvfs-1.1.7-gdu-monitor-empty-drives.patch
Normal file
51
gvfs-1.1.7-gdu-monitor-empty-drives.patch
Normal file
@ -0,0 +1,51 @@
|
||||
diff -up gvfs-1.1.7/monitor/gdu/ggduvolumemonitor.c.orig gvfs-1.1.7/monitor/gdu/ggduvolumemonitor.c
|
||||
--- gvfs-1.1.7/monitor/gdu/ggduvolumemonitor.c.orig 2009-03-06 13:24:00.000000000 +0100
|
||||
+++ gvfs-1.1.7/monitor/gdu/ggduvolumemonitor.c 2009-03-06 14:45:49.000000000 +0100
|
||||
@@ -617,7 +617,7 @@ get_mount_point_for_device (GduDevice *d
|
||||
for (l = fstab_mount_points; l != NULL; l = l->next)
|
||||
{
|
||||
GUnixMountPoint *mount_point = l->data;
|
||||
- const gchar *device_file;
|
||||
+ const gchar *fstab_device_file;
|
||||
const gchar *fstab_mount_path;
|
||||
|
||||
fstab_mount_path = g_unix_mount_point_get_mount_path (mount_point);
|
||||
@@ -627,18 +627,18 @@ get_mount_point_for_device (GduDevice *d
|
||||
goto out;
|
||||
}
|
||||
|
||||
- device_file = g_unix_mount_point_get_device_path (mount_point);
|
||||
- if (g_str_has_prefix (device_file, "LABEL="))
|
||||
+ fstab_device_file = g_unix_mount_point_get_device_path (mount_point);
|
||||
+ if (g_str_has_prefix (fstab_device_file, "LABEL="))
|
||||
{
|
||||
- if (g_strcmp0 (device_file + 6, gdu_device_id_get_label (d)) == 0)
|
||||
+ if (g_strcmp0 (fstab_device_file + 6, gdu_device_id_get_label (d)) == 0)
|
||||
{
|
||||
ret = mount_point;
|
||||
goto out;
|
||||
}
|
||||
}
|
||||
- else if (g_str_has_prefix (device_file, "UUID="))
|
||||
+ else if (g_str_has_prefix (fstab_device_file, "UUID="))
|
||||
{
|
||||
- if (g_ascii_strcasecmp (device_file + 5, gdu_device_id_get_uuid (d)) == 0)
|
||||
+ if (g_ascii_strcasecmp (fstab_device_file + 5, gdu_device_id_get_uuid (d)) == 0)
|
||||
{
|
||||
ret = mount_point;
|
||||
goto out;
|
||||
@@ -646,11 +646,11 @@ get_mount_point_for_device (GduDevice *d
|
||||
}
|
||||
else
|
||||
{
|
||||
- char resolved_device_file[PATH_MAX];
|
||||
+ char resolved_fstab_device_file[PATH_MAX];
|
||||
|
||||
/* handle symlinks such as /dev/disk/by-uuid/47C2-1994 */
|
||||
- if (realpath (device_file, resolved_device_file) != NULL &&
|
||||
- g_strcmp0 (resolved_device_file, device_file) == 0)
|
||||
+ if (realpath (fstab_device_file, resolved_fstab_device_file) != NULL &&
|
||||
+ g_strcmp0 (resolved_fstab_device_file, device_file) == 0)
|
||||
{
|
||||
ret = mount_point;
|
||||
goto out;
|
10
gvfs.spec
10
gvfs.spec
@ -1,7 +1,7 @@
|
||||
Summary: Backends for the gio framework in GLib
|
||||
Name: gvfs
|
||||
Version: 1.1.7
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.gtk.org
|
||||
@ -34,6 +34,10 @@ Patch1: gvfs-0.99.2-archive-integration.patch
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=573826
|
||||
Patch2: gvfs-gdu-volume-monitor-3.patch
|
||||
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=573826
|
||||
Patch3: gvfs-1.1.7-gdu-monitor-empty-drives.patch
|
||||
|
||||
|
||||
%description
|
||||
The gvfs package provides backend implementations for the gio
|
||||
framework in GLib. It includes ftp, sftp, cifs.
|
||||
@ -116,6 +120,7 @@ media players (Media Transfer Protocol) to applications using gvfs.
|
||||
%setup -q
|
||||
%patch1 -p0 -b .archive-integration
|
||||
%patch2 -p0 -b .gdu
|
||||
%patch3 -p1 -b .gdu-volumes-typo
|
||||
|
||||
%build
|
||||
|
||||
@ -259,6 +264,9 @@ update-desktop-database &> /dev/null ||:
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Mar 6 2009 Tomas Bzatek <tbzatek@redhat.com> - 1.1.7-4
|
||||
- Fix volume lists not filled correctly
|
||||
|
||||
* Wed Mar 4 2009 David Zeuthen <davidz@redhat.com> - 1.1.7-3
|
||||
- Update GVfs gdu patch to fix mount detection confusion (#488399)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user