0.99.4
This commit is contained in:
parent
27cdcb3093
commit
dbce16032c
@ -1 +1 @@
|
||||
gvfs-0.99.3.tar.bz2
|
||||
gvfs-0.99.4.tar.bz2
|
||||
|
@ -1,13 +0,0 @@
|
||||
--- gvfs-0.2.4-orig/daemon/gvfsbackendtrash.c 2008-05-26 17:54:32.000000000 -0400
|
||||
+++ gvfs-0.2.4/daemon/gvfsbackendtrash.c 2008-06-20 11:18:45.000000000 -0400
|
||||
@@ -538,6 +538,10 @@
|
||||
{
|
||||
mount = l->data;
|
||||
|
||||
+ /* Skip autofs filesystem types: the root cannot contain .Trash */
|
||||
+ if (strcmp ("autofs", g_unix_mount_get_fs_type (mount)) == 0)
|
||||
+ continue;
|
||||
+
|
||||
topdir = g_unix_mount_get_mount_path (mount);
|
||||
topdirs = g_list_prepend (topdirs, g_strdup (topdir));
|
||||
|
@ -1,14 +0,0 @@
|
||||
diff -up gvfs-0.2.3/hal/ghalvolume.c.gphoto-automount gvfs-0.2.3/hal/ghalvolume.c
|
||||
--- gvfs-0.2.3/hal/ghalvolume.c.gphoto-automount 2008-04-16 23:32:31.000000000 -0400
|
||||
+++ gvfs-0.2.3/hal/ghalvolume.c 2008-04-16 23:32:39.000000000 -0400
|
||||
@@ -519,10 +519,6 @@ g_hal_volume_new (GVolumeMonitor *volu
|
||||
|
||||
if (foreign_mount_root == NULL)
|
||||
return NULL;
|
||||
-
|
||||
- /* We don't want to automount cameras as the gphoto backend
|
||||
- blocks access from other apps */
|
||||
- ignore_automount = TRUE;
|
||||
}
|
||||
#endif
|
||||
else
|
@ -1,63 +0,0 @@
|
||||
--- trunk/programs/gvfs-mount.c 2008/04/02 19:51:01 1720
|
||||
+++ trunk/programs/gvfs-mount.c 2008/04/07 19:50:52 1726
|
||||
@@ -43,11 +43,13 @@
|
||||
static gboolean mount_unmount = FALSE;
|
||||
static gboolean mount_list = FALSE;
|
||||
static gboolean mount_list_info = FALSE;
|
||||
+static const char *unmount_scheme = NULL;
|
||||
|
||||
-static GOptionEntry entries[] =
|
||||
+static const GOptionEntry entries[] =
|
||||
{
|
||||
{ "mountable", 'm', 0, G_OPTION_ARG_NONE, &mount_mountable, "Mount as mountable", NULL },
|
||||
{ "unmount", 'u', 0, G_OPTION_ARG_NONE, &mount_unmount, "Unmount", NULL},
|
||||
+ { "unmount-scheme", 's', 0, G_OPTION_ARG_STRING, &unmount_scheme, "Unmount all mounts with the given scheme", NULL},
|
||||
{ "list", 'l', 0, G_OPTION_ARG_NONE, &mount_list, "List", NULL},
|
||||
{ "list-info", 'i', 0, G_OPTION_ARG_NONE, &mount_list_info, "List extra information", NULL},
|
||||
{ NULL }
|
||||
@@ -502,6 +504,34 @@
|
||||
g_list_free (mounts);
|
||||
}
|
||||
|
||||
+static void
|
||||
+unmount_all_with_scheme (const char *scheme)
|
||||
+{
|
||||
+ GVolumeMonitor *volume_monitor;
|
||||
+ GList *mounts;
|
||||
+ GList *l;
|
||||
+
|
||||
+ volume_monitor = g_volume_monitor_get();
|
||||
+
|
||||
+ /* populate gvfs network mounts */
|
||||
+ iterate_gmain();
|
||||
+
|
||||
+ mounts = g_volume_monitor_get_mounts (volume_monitor);
|
||||
+ for (l = mounts; l != NULL; l = l->next) {
|
||||
+ GMount *mount = G_MOUNT (l->data);
|
||||
+ GFile *root;
|
||||
+
|
||||
+ root = g_mount_get_root (mount);
|
||||
+ if (g_file_has_uri_scheme (root, scheme)) {
|
||||
+ unmount (root);
|
||||
+ }
|
||||
+ g_object_unref (root);
|
||||
+ }
|
||||
+ g_list_foreach (mounts, (GFunc)g_object_unref, NULL);
|
||||
+ g_list_free (mounts);
|
||||
+
|
||||
+}
|
||||
+
|
||||
int
|
||||
main (int argc, char *argv[])
|
||||
{
|
||||
@@ -523,6 +553,10 @@
|
||||
|
||||
if (mount_list)
|
||||
list_monitor_items ();
|
||||
+ else if (unmount_scheme != NULL)
|
||||
+ {
|
||||
+ unmount_all_with_scheme (unmount_scheme);
|
||||
+ }
|
||||
else if (argc > 1)
|
||||
{
|
||||
int i;
|
16
gvfs.spec
16
gvfs.spec
@ -1,7 +1,7 @@
|
||||
Summary: Backends for the gio framework in GLib
|
||||
Name: gvfs
|
||||
Version: 0.99.3
|
||||
Release: 2%{?dist}
|
||||
Version: 0.99.4
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.gtk.org
|
||||
@ -30,12 +30,6 @@ BuildRequires: automake autoconf
|
||||
BuildRequires: libtool
|
||||
Patch1: gvfs-0.99.2-archive-integration.patch
|
||||
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=525779
|
||||
Patch3: gvfs-0.2.4-trash-automount.patch
|
||||
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=545068
|
||||
Patch4: icon-names.patch
|
||||
|
||||
%description
|
||||
The gvfs package provides backend implementations for the gio
|
||||
framework in GLib. It includes ftp, sftp, cifs.
|
||||
@ -116,8 +110,6 @@ media players (Media Transfer Protocol) to applications using gvfs.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p0 -b .archive-integration
|
||||
%patch3 -p1 -b .trash
|
||||
%patch4 -p1 -b .icon-names
|
||||
|
||||
%build
|
||||
|
||||
@ -254,8 +246,10 @@ update-desktop-database &> /dev/null ||:
|
||||
%{_datadir}/gvfs/remote-volume-monitors/gphoto2.monitor
|
||||
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Aug 4 2008 Matthias Clasen <mclasen@redhat.com> - 0.99.4-1
|
||||
- Update to 0.99.4
|
||||
|
||||
* Sun Jul 27 2008 Matthias Clasen <mclasen@redhat.com> - 0.99.3-2
|
||||
- Use standard icon names
|
||||
|
||||
|
@ -1,51 +0,0 @@
|
||||
diff -up gvfs-0.99.3/daemon/gvfsbackendburn.c.icon-names gvfs-0.99.3/daemon/gvfsbackendburn.c
|
||||
--- gvfs-0.99.3/daemon/gvfsbackendburn.c.icon-names 2008-07-27 21:44:52.000000000 -0400
|
||||
+++ gvfs-0.99.3/daemon/gvfsbackendburn.c 2008-07-27 21:45:38.000000000 -0400
|
||||
@@ -344,7 +344,7 @@ g_vfs_backend_burn_init (GVfsBackendBurn
|
||||
|
||||
/* Translators: This is the name of the backend */
|
||||
g_vfs_backend_set_display_name (backend, _("Burn"));
|
||||
- g_vfs_backend_set_icon_name (backend, "gnome-fs-client");
|
||||
+ g_vfs_backend_set_icon_name (backend, "computer");
|
||||
g_vfs_backend_set_user_visible (backend, FALSE);
|
||||
|
||||
mount_spec = g_mount_spec_new ("burn");
|
||||
diff -up gvfs-0.99.3/daemon/gvfsbackendcomputer.c.icon-names gvfs-0.99.3/daemon/gvfsbackendcomputer.c
|
||||
--- gvfs-0.99.3/daemon/gvfsbackendcomputer.c.icon-names 2008-07-27 21:45:52.000000000 -0400
|
||||
+++ gvfs-0.99.3/daemon/gvfsbackendcomputer.c 2008-07-27 21:46:41.000000000 -0400
|
||||
@@ -177,7 +177,7 @@ g_vfs_backend_computer_init (GVfsBackend
|
||||
GMountSpec *mount_spec;
|
||||
|
||||
g_vfs_backend_set_display_name (backend, _("Computer"));
|
||||
- g_vfs_backend_set_icon_name (backend, "gnome-fs-client");
|
||||
+ g_vfs_backend_set_icon_name (backend, "computer");
|
||||
g_vfs_backend_set_user_visible (backend, FALSE);
|
||||
|
||||
mount_spec = g_mount_spec_new ("computer");
|
||||
@@ -691,7 +691,7 @@ try_query_info (GVfsBackend *backend,
|
||||
g_file_info_set_name (info, "/");
|
||||
g_file_info_set_file_type (info, G_FILE_TYPE_DIRECTORY);
|
||||
g_file_info_set_display_name (info, _("Computer"));
|
||||
- icon = g_themed_icon_new ("gnome-fs-client");
|
||||
+ icon = g_themed_icon_new ("computer");
|
||||
g_file_info_set_icon (info, icon);
|
||||
g_object_unref (icon);
|
||||
g_file_info_set_attribute_boolean (info, G_FILE_ATTRIBUTE_ACCESS_CAN_WRITE, FALSE);
|
||||
diff -up gvfs-0.99.3/daemon/gvfsbackenddnssd.c.icon-names gvfs-0.99.3/daemon/gvfsbackenddnssd.c
|
||||
--- gvfs-0.99.3/daemon/gvfsbackenddnssd.c.icon-names 2008-07-27 21:54:51.000000000 -0400
|
||||
+++ gvfs-0.99.3/daemon/gvfsbackenddnssd.c 2008-07-27 21:56:35.000000000 -0400
|
||||
@@ -50,10 +50,10 @@ static struct {
|
||||
char *icon;
|
||||
gpointer handle;
|
||||
} dns_sd_types[] = {
|
||||
- {"_ftp._tcp", "ftp", "gnome-fs-ftp"},
|
||||
- {"_webdav._tcp", "dav", "gnome-fs-share"},
|
||||
- {"_webdavs._tcp", "davs", "gnome-fs-share"},
|
||||
- {"_sftp-ssh._tcp", "sftp", "gnome-fs-ssh"},
|
||||
+ {"_ftp._tcp", "ftp", "folder-remote-ftp"},
|
||||
+ {"_webdav._tcp", "dav", "folder-remote"},
|
||||
+ {"_webdavs._tcp", "davs", "folder-remote"},
|
||||
+ {"_sftp-ssh._tcp", "sftp", "folder-remote-ssh"},
|
||||
};
|
||||
|
||||
static AvahiClient *global_client = NULL;
|
Loading…
Reference in New Issue
Block a user