Remove unused patches and files

This commit is contained in:
Tomas Bzatek 2008-05-27 09:08:34 +00:00
parent 9ae84f7b23
commit da7db62c71
10 changed files with 0 additions and 158 deletions

View File

@ -1,14 +0,0 @@
--- trunk/client/gdaemonmount.c 2008/03/05 09:27:06 1549
+++ trunk/client/gdaemonmount.c 2008/03/06 09:00:09 1570
@@ -191,7 +191,10 @@
g_object_ref (daemon_mount);
if (daemon_mount->foreign_volume == volume)
- g_daemon_mount_set_foreign_volume (daemon_mount, NULL);
+ {
+ g_object_unref (daemon_mount->foreign_volume);
+ daemon_mount->foreign_volume = NULL;
+ }
G_UNLOCK (daemon_mount);

View File

@ -1,4 +0,0 @@
[Mount]
Type=dav
Exec=@libexecdir@/gvfsd-dav
AutoMount=false

View File

@ -1,13 +0,0 @@
--- trunk/hal/ghalvolumemonitor.c 2008/03/04 15:08:53 1536
+++ trunk/hal/ghalvolumemonitor.c 2008/03/04 15:48:55 1540
@@ -159,7 +159,9 @@
list_free (monitor->last_drive_devices);
list_free (monitor->last_volume_devices);
list_free (monitor->last_mountpoints);
- list_free (monitor->last_mounts);
+ g_list_foreach (monitor->last_mounts,
+ (GFunc)g_unix_mount_free, NULL);
+ g_list_free (monitor->last_mounts);
list_free (monitor->drives);
list_free (monitor->volumes);

View File

@ -1,13 +0,0 @@
Index: hal/ghalvolumemonitor.c
===================================================================
--- hal/ghalvolumemonitor.c (revision 1262)
+++ hal/ghalvolumemonitor.c (working copy)
@@ -118,7 +118,7 @@
g_object_unref (monitor->pool);
g_list_foreach (monitor->last_camera_devices, (GFunc)g_object_unref, NULL);
- g_list_free (monitor->last_optical_disc_devices);
+ g_list_free (monitor->last_camera_devices);
g_list_foreach (monitor->last_optical_disc_devices, (GFunc)g_object_unref, NULL);
g_list_free (monitor->last_optical_disc_devices);
g_list_foreach (monitor->last_drive_devices, (GFunc)g_object_unref, NULL);

View File

@ -1,74 +0,0 @@
diff -up gvfs-0.1.8/configure.ac.libxml gvfs-0.1.8/configure.ac
--- gvfs-0.1.8/configure.ac.libxml 2008-02-26 14:18:48.000000000 +0100
+++ gvfs-0.1.8/configure.ac 2008-02-26 14:19:03.000000000 +0100
@@ -120,7 +120,7 @@ if test "x$enable_http" != "xno"; then
PKG_CHECK_EXISTS(libsoup-2.4 >= 2.3.0, msg_http=yes)
if test "x$msg_http" == "xyes"; then
- PKG_CHECK_MODULES(HTTP, libsoup-2.4)
+ PKG_CHECK_MODULES(HTTP, libsoup-2.4 libxml-2.0)
AC_DEFINE(HAVE_HTTP, 1, [Define to 1 if http/dav is going to be built])
fi
fi
diff -up gvfs-0.1.8/configure.libxml gvfs-0.1.8/configure
--- gvfs-0.1.8/configure.libxml 2008-02-26 14:18:53.000000000 +0100
+++ gvfs-0.1.8/configure 2008-02-26 14:20:41.000000000 +0100
@@ -24600,12 +24600,12 @@ if test -n "$PKG_CONFIG"; then
pkg_cv_HTTP_CFLAGS="$HTTP_CFLAGS"
else
if test -n "$PKG_CONFIG" && \
- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"libsoup-2.4\"") >&5
- ($PKG_CONFIG --exists --print-errors "libsoup-2.4") 2>&5
+ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"libsoup-2.4 libxml-2.0\"") >&5
+ ($PKG_CONFIG --exists --print-errors "libsoup-2.4 libxml-2.0") 2>&5
ac_status=$?
echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); }; then
- pkg_cv_HTTP_CFLAGS=`$PKG_CONFIG --cflags "libsoup-2.4" 2>/dev/null`
+ pkg_cv_HTTP_CFLAGS=`$PKG_CONFIG --cflags "libsoup-2.4 libxml-2.0" 2>/dev/null`
else
pkg_failed=yes
fi
@@ -24618,12 +24618,12 @@ if test -n "$PKG_CONFIG"; then
pkg_cv_HTTP_LIBS="$HTTP_LIBS"
else
if test -n "$PKG_CONFIG" && \
- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"libsoup-2.4\"") >&5
- ($PKG_CONFIG --exists --print-errors "libsoup-2.4") 2>&5
+ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"libsoup-2.4 libxml-2.0\"") >&5
+ ($PKG_CONFIG --exists --print-errors "libsoup-2.4 libxml-2.0") 2>&5
ac_status=$?
echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); }; then
- pkg_cv_HTTP_LIBS=`$PKG_CONFIG --libs "libsoup-2.4" 2>/dev/null`
+ pkg_cv_HTTP_LIBS=`$PKG_CONFIG --libs "libsoup-2.4 libxml-2.0" 2>/dev/null`
else
pkg_failed=yes
fi
@@ -24642,14 +24642,14 @@ else
_pkg_short_errors_supported=no
fi
if test $_pkg_short_errors_supported = yes; then
- HTTP_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "libsoup-2.4"`
+ HTTP_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "libsoup-2.4 libxml-2.0"`
else
- HTTP_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "libsoup-2.4"`
+ HTTP_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "libsoup-2.4 libxml-2.0"`
fi
# Put the nasty error message in config.log where it belongs
echo "$HTTP_PKG_ERRORS" >&5
- { { echo "$as_me:$LINENO: error: Package requirements (libsoup-2.4) were not met:
+ { { echo "$as_me:$LINENO: error: Package requirements (libsoup-2.4 libxml-2.0) were not met:
$HTTP_PKG_ERRORS
@@ -24660,7 +24660,7 @@ Alternatively, you may set the environme
and HTTP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
" >&5
-echo "$as_me: error: Package requirements (libsoup-2.4) were not met:
+echo "$as_me: error: Package requirements (libsoup-2.4 libxml-2.0) were not met:
$HTTP_PKG_ERRORS

View File

@ -1,14 +0,0 @@
Index: daemon/gvfschannel.c
===================================================================
--- daemon/gvfschannel.c (revision 1269)
+++ daemon/gvfschannel.c (working copy)
@@ -343,7 +343,8 @@
if (command == G_VFS_DAEMON_SOCKET_PROTOCOL_REQUEST_CANCEL)
{
- if (arg1 == channel->priv->current_job_seq_nr)
+ if (arg1 == channel->priv->current_job_seq_nr &&
+ channel->priv->current_job != NULL)
g_vfs_job_cancel (channel->priv->current_job);
else
{

View File

@ -1,11 +0,0 @@
--- trunk/client/gvfsfusedaemon.c 2008/02/19 09:41:06 1302
+++ trunk/client/gvfsfusedaemon.c 2008/03/04 15:21:22 1539
@@ -102,7 +102,7 @@
static void
debug_print (const gchar *message, ...)
{
-#ifdef DEBUG_ENABLED
+#if DEBUG_ENABLED
static FILE *debug_fhd = NULL;
va_list var_args;

View File

@ -1,5 +0,0 @@
[Mount]
Type=http
Exec=@libexecdir@/gvfsd-http
AutoMount=true
DBusName=org.gtk.vfs.mountpoint.http

View File

@ -1,6 +0,0 @@
[Mount]
Type=smb-network;smb-server
Exec=@libexecdir@/gvfsd-smb-browse
DBusName=org.gtk.vfs.mountpoint.smb_browse
AutoMount=true

View File

@ -1,4 +0,0 @@
[Mount]
Type=smb-share
Exec=@libexecdir@/gvfsd-smb
AutoMount=false