- Update to 1.7.0
This commit is contained in:
parent
83ab699b71
commit
d340866db2
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
gvfs-1.6.3.tar.bz2
|
||||
/gvfs-1.6.4.tar.bz2
|
||||
/gvfs-1.6.5.tar.gz
|
||||
/gvfs-1.7.0.tar.bz2
|
||||
|
@ -1,37 +0,0 @@
|
||||
From 0b1f1c87a01027459300b5965895def84286a361 Mon Sep 17 00:00:00 2001
|
||||
From: Tomas Bzatek <tbzatek@redhat.com>
|
||||
Date: Thu, 29 Apr 2010 16:27:46 +0200
|
||||
Subject: [PATCH] Fix stringv transfer over dbus
|
||||
|
||||
The wrong iterator passed in caused some items to be silently dropped
|
||||
plus it led to string dup of wrong pointer.
|
||||
|
||||
See bug 614544 for reference.
|
||||
---
|
||||
common/gvfsdaemonprotocol.c | 3 ++-
|
||||
1 files changed, 2 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/common/gvfsdaemonprotocol.c b/common/gvfsdaemonprotocol.c
|
||||
index 7feefeb..9070cbc 100644
|
||||
--- a/common/gvfsdaemonprotocol.c
|
||||
+++ b/common/gvfsdaemonprotocol.c
|
||||
@@ -128,6 +128,7 @@ _g_dbus_attribute_as_pointer (GFileAttributeType type,
|
||||
case G_FILE_ATTRIBUTE_TYPE_STRING:
|
||||
case G_FILE_ATTRIBUTE_TYPE_BYTE_STRING:
|
||||
case G_FILE_ATTRIBUTE_TYPE_OBJECT:
|
||||
+ case G_FILE_ATTRIBUTE_TYPE_STRINGV:
|
||||
return value->ptr;
|
||||
default:
|
||||
return (gpointer) value;
|
||||
@@ -372,7 +373,7 @@ _g_dbus_get_file_attribute (DBusMessageIter *iter,
|
||||
{
|
||||
char **strv;
|
||||
int n_elements;
|
||||
- if (!_g_dbus_message_iter_get_args (iter, NULL,
|
||||
+ if (!_g_dbus_message_iter_get_args (&variant_iter, NULL,
|
||||
DBUS_TYPE_ARRAY, DBUS_TYPE_STRING, &strv, &n_elements,
|
||||
0))
|
||||
goto error;
|
||||
--
|
||||
1.7.0.1
|
||||
|
@ -1,77 +0,0 @@
|
||||
From 0d1dc99a87d354e8af9cb0f98827bafb2cd7f577 Mon Sep 17 00:00:00 2001
|
||||
From: Tomas Bzatek <tbzatek@redhat.com>
|
||||
Date: Wed, 13 Oct 2010 16:25:51 +0200
|
||||
Subject: [PATCH] fuse: Add O_TRUNC support for open()
|
||||
|
||||
This requires kernel version 2.6.24 or later.
|
||||
|
||||
See bug 627567 for details.
|
||||
---
|
||||
client/gvfsfusedaemon.c | 16 +++++++++++-----
|
||||
1 files changed, 11 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/client/gvfsfusedaemon.c b/client/gvfsfusedaemon.c
|
||||
index 13cb74d..bc3090d 100644
|
||||
--- a/client/gvfsfusedaemon.c
|
||||
+++ b/client/gvfsfusedaemon.c
|
||||
@@ -948,7 +948,7 @@ setup_input_stream (GFile *file, FileHandle *fh)
|
||||
}
|
||||
|
||||
static gint
|
||||
-setup_output_stream (GFile *file, FileHandle *fh)
|
||||
+setup_output_stream (GFile *file, FileHandle *fh, int flags)
|
||||
{
|
||||
GError *error = NULL;
|
||||
gint result = 0;
|
||||
@@ -968,7 +968,10 @@ setup_output_stream (GFile *file, FileHandle *fh)
|
||||
|
||||
if (!fh->stream)
|
||||
{
|
||||
- fh->stream = g_file_append_to (file, 0, NULL, &error);
|
||||
+ if (flags & O_TRUNC)
|
||||
+ fh->stream = g_file_replace (file, NULL, FALSE, 0, NULL, &error);
|
||||
+ else
|
||||
+ fh->stream = g_file_append_to (file, 0, NULL, &error);
|
||||
if (fh->stream)
|
||||
fh->pos = g_seekable_tell (G_SEEKABLE (fh->stream));
|
||||
}
|
||||
@@ -1024,7 +1027,7 @@ vfs_open (const gchar *path, struct fuse_file_info *fi)
|
||||
set_pid_for_file (file);
|
||||
|
||||
if (fi->flags & O_WRONLY || fi->flags & O_RDWR)
|
||||
- result = setup_output_stream (file, fh);
|
||||
+ result = setup_output_stream (file, fh, fi->flags);
|
||||
else
|
||||
result = setup_input_stream (file, fh);
|
||||
|
||||
@@ -1406,7 +1409,7 @@ vfs_write (const gchar *path, const gchar *buf, size_t len, off_t offset,
|
||||
{
|
||||
g_mutex_lock (fh->mutex);
|
||||
|
||||
- result = setup_output_stream (file, fh);
|
||||
+ result = setup_output_stream (file, fh, 0);
|
||||
if (result == 0)
|
||||
{
|
||||
result = write_stream (fh, buf, len, offset);
|
||||
@@ -1857,7 +1860,7 @@ vfs_ftruncate (const gchar *path, off_t size, struct fuse_file_info *fi)
|
||||
{
|
||||
g_mutex_lock (fh->mutex);
|
||||
|
||||
- result = setup_output_stream (file, fh);
|
||||
+ result = setup_output_stream (file, fh, 0);
|
||||
|
||||
if (result == 0)
|
||||
{
|
||||
@@ -2336,6 +2339,9 @@ vfs_init (struct fuse_conn_info *conn)
|
||||
subthread_main_loop = g_main_loop_new (NULL, FALSE);
|
||||
subthread = g_thread_create ((GThreadFunc) subthread_main, NULL, FALSE, NULL);
|
||||
|
||||
+ /* Indicate O_TRUNC support for open() */
|
||||
+ conn->want |= FUSE_CAP_ATOMIC_O_TRUNC;
|
||||
+
|
||||
return NULL;
|
||||
}
|
||||
|
||||
--
|
||||
1.7.3.1
|
||||
|
@ -1,30 +0,0 @@
|
||||
From 4033907045abcf498686c1b34be7b0160260088d Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Henriksson <andreas@fatal.se>
|
||||
Date: Sat, 02 Oct 2010 12:51:54 +0000
|
||||
Subject: sftp: fix poll() timeout.
|
||||
|
||||
When switching from select() to poll() in commit
|
||||
"sftp: Use poll() to cope with openssh-5.6 changes" (c6be45c8934)
|
||||
the difference in seconds vs milliseconds for select/poll timeout
|
||||
argument was missed.
|
||||
|
||||
SFTP_READ_TIMEOUT is defined in seconds, so multiply it with 1000
|
||||
when using it with poll().
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=631169
|
||||
---
|
||||
diff --git a/daemon/gvfsbackendsftp.c b/daemon/gvfsbackendsftp.c
|
||||
index 9fecf6a..f6b7785 100644
|
||||
--- a/daemon/gvfsbackendsftp.c
|
||||
+++ b/daemon/gvfsbackendsftp.c
|
||||
@@ -869,7 +869,7 @@ handle_login (GVfsBackend *backend,
|
||||
fds[1].fd = prompt_fd;
|
||||
fds[1].events = POLLIN;
|
||||
|
||||
- ret = poll(fds, 2, SFTP_READ_TIMEOUT);
|
||||
+ ret = poll(fds, 2, SFTP_READ_TIMEOUT * 1000);
|
||||
|
||||
if (ret <= 0)
|
||||
{
|
||||
--
|
||||
cgit v0.8.3.1
|
25
gvfs.spec
25
gvfs.spec
@ -1,15 +1,15 @@
|
||||
Summary: Backends for the gio framework in GLib
|
||||
Name: gvfs
|
||||
Version: 1.6.5
|
||||
Version: 1.7.0
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.gtk.org
|
||||
Source: http://download.gnome.org/sources/gvfs/1.6/gvfs-%{version}.tar.gz
|
||||
Source: http://download.gnome.org/sources/gvfs/1.7/gvfs-%{version}.tar.bz2
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: glib2-devel >= 2.27.1
|
||||
BuildRequires: glib2-devel >= 2.27.4
|
||||
# for post-install update-gio-modules and overall functionality
|
||||
Requires: glib2 >= 2.27.1
|
||||
Requires: glib2 >= 2.27.4
|
||||
BuildRequires: dbus-glib-devel
|
||||
BuildRequires: /usr/bin/ssh
|
||||
BuildRequires: libcdio-devel >= 0.78.2
|
||||
@ -18,10 +18,9 @@ BuildRequires: hal-devel >= 0.5.10
|
||||
BuildRequires: libgudev-devel
|
||||
BuildRequires: libsoup-devel >= 2.26.0
|
||||
BuildRequires: avahi-glib-devel >= 0.6
|
||||
BuildRequires: gnome-keyring-devel
|
||||
BuildRequires: libgnome-keyring-devel
|
||||
BuildRequires: intltool
|
||||
BuildRequires: gettext-devel
|
||||
BuildRequires: GConf2-devel
|
||||
BuildRequires: gnome-disk-utility-devel >= 2.29.90-1
|
||||
BuildRequires: PolicyKit-devel
|
||||
BuildRequires: expat-devel
|
||||
@ -40,10 +39,6 @@ Patch0: gvfs-archive-integration.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=552856
|
||||
Patch15: gvfs-1.5.1-gphoto2-no-storageinfo-support.patch
|
||||
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=627567
|
||||
# Data loss when writing files
|
||||
Patch18: gvfs-1.6.5-fuse-open-trunc-support.patch
|
||||
|
||||
Obsoletes: gnome-mount <= 0.8
|
||||
Obsoletes: gnome-mount-nautilus-properties <= 0.8
|
||||
|
||||
@ -141,7 +136,6 @@ including phones and music players to applications using gvfs.
|
||||
%setup -q
|
||||
%patch0 -p1 -b .archive-integration
|
||||
%patch15 -p1 -b .gphoto2-storageinfo
|
||||
%patch18 -p1 -b .fuse-trunc
|
||||
|
||||
%build
|
||||
|
||||
@ -181,6 +175,10 @@ update-gio-modules "$host" &> /dev/null || :
|
||||
# Update desktop files mime mappings:
|
||||
update-desktop-database &> /dev/null ||:
|
||||
update-gio-modules "$host" &> /dev/null || :
|
||||
glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
|
||||
|
||||
%posttrans
|
||||
glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
|
||||
|
||||
|
||||
# Reload .mount files when single subpackage is installed:
|
||||
@ -219,6 +217,8 @@ killall -USR1 gvfsd >&/dev/null || :
|
||||
%{_datadir}/dbus-1/services/gvfs-daemon.service
|
||||
%{_datadir}/dbus-1/services/gvfs-metadata.service
|
||||
%{_datadir}/gvfs/remote-volume-monitors/gdu.monitor
|
||||
%{_datadir}/GConf/gsettings/*.convert
|
||||
%{_datadir}/glib-2.0/schemas/*.xml
|
||||
%{_libdir}/libgvfscommon.so.*
|
||||
%{_libdir}/libgvfscommon-dnssd.so.*
|
||||
%{_libdir}/gio/modules/libgioremote-volume-monitor.so
|
||||
@ -310,6 +310,9 @@ killall -USR1 gvfsd >&/dev/null || :
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Dec 2 2010 Tomas Bzatek <tbzatek@redhat.com> - 1.7.0-1
|
||||
- Update to 1.7.0
|
||||
|
||||
* Mon Nov 1 2010 Matthias Clasen <mclasen@redhat.com> - 1.6.5-1
|
||||
- Update to 1.6.5
|
||||
- Drop upstreamed patches
|
||||
|
Loading…
Reference in New Issue
Block a user