- Fix gedit crashed with SEGV in strlen()
- Fix SMB protocol not handled when opening from a bookmark (#509832)
This commit is contained in:
parent
908f425bdc
commit
b84fbc0b96
39
gvfs-1.3.4-output-stream-callback-arg.patch
Normal file
39
gvfs-1.3.4-output-stream-callback-arg.patch
Normal file
@ -0,0 +1,39 @@
|
||||
From a3979cd918d366be7850ca558b3040b8d2d0322d Mon Sep 17 00:00:00 2001
|
||||
From: Peter Waller <peter.waller@gmail.com>
|
||||
Date: Tue, 04 Aug 2009 09:14:30 +0000
|
||||
Subject: Bug 589915 - gedit crashed with SEGV in strlen()
|
||||
|
||||
FIx a crash introduced by commit c372064a where it was forgotten do
|
||||
adapt the function signature of a callback
|
||||
---
|
||||
diff --git a/client/gdaemonfileoutputstream.c b/client/gdaemonfileoutputstream.c
|
||||
index e47c2e8..c5263e1 100644
|
||||
--- a/client/gdaemonfileoutputstream.c
|
||||
+++ b/client/gdaemonfileoutputstream.c
|
||||
@@ -1474,6 +1474,7 @@ async_close_done (GOutputStream *stream,
|
||||
gpointer op_data,
|
||||
GAsyncReadyCallback callback,
|
||||
gpointer user_data,
|
||||
+ GCancellable *cancellable,
|
||||
GError *io_error)
|
||||
{
|
||||
GDaemonFileOutputStream *file;
|
||||
@@ -1481,7 +1482,6 @@ async_close_done (GOutputStream *stream,
|
||||
CloseOperation *op;
|
||||
gboolean result;
|
||||
GError *error;
|
||||
- GCancellable *cancellable = NULL; /* TODO: get cancellable */
|
||||
|
||||
file = G_DAEMON_FILE_OUTPUT_STREAM (stream);
|
||||
|
||||
@@ -1544,7 +1544,7 @@ g_daemon_file_output_stream_close_async (GOutputStream *stream,
|
||||
op, io_priority,
|
||||
(GAsyncReadyCallback)callback, data,
|
||||
cancellable,
|
||||
- (AsyncIteratorDone)async_close_done);
|
||||
+ async_close_done);
|
||||
}
|
||||
|
||||
static gboolean
|
||||
--
|
||||
cgit v0.8.2
|
34
gvfs-1.3.4-smb-browse-fake-content-type.patch
Normal file
34
gvfs-1.3.4-smb-browse-fake-content-type.patch
Normal file
@ -0,0 +1,34 @@
|
||||
From fa09fd4e5dda701c8862ce2d7762698b907cf90f Mon Sep 17 00:00:00 2001
|
||||
From: Tomas Bzatek <tbzatek@redhat.com>
|
||||
Date: Fri, 31 Jul 2009 16:58:54 +0200
|
||||
Subject: [PATCH] smb-browse: fake content type to allow query default handler
|
||||
|
||||
Hardcode the "inode/directory" content-type
|
||||
Fixes #573994
|
||||
---
|
||||
daemon/gvfsbackendsmbbrowse.c | 2 ++
|
||||
1 files changed, 2 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/daemon/gvfsbackendsmbbrowse.c b/daemon/gvfsbackendsmbbrowse.c
|
||||
index 6d0c07e..2eebdd2 100644
|
||||
--- a/daemon/gvfsbackendsmbbrowse.c
|
||||
+++ b/daemon/gvfsbackendsmbbrowse.c
|
||||
@@ -1229,6 +1229,7 @@ get_file_info_from_entry (GVfsBackendSmbBrowse *backend, BrowseEntry *entry, GFi
|
||||
g_file_info_set_edit_name (info, entry->name_utf8);
|
||||
g_file_info_set_attribute_string (info, "smb::comment", entry->comment);
|
||||
g_file_info_set_attribute_boolean (info, G_FILE_ATTRIBUTE_STANDARD_IS_VIRTUAL, TRUE);
|
||||
+ g_file_info_set_content_type (info, "inode/directory");
|
||||
|
||||
icon = NULL;
|
||||
if (entry->smbc_type == SMBC_WORKGROUP)
|
||||
@@ -1355,6 +1356,7 @@ try_query_info (GVfsBackend *backend,
|
||||
g_file_info_set_file_type (info, G_FILE_TYPE_DIRECTORY);
|
||||
g_file_info_set_name (info, "/");
|
||||
g_file_info_set_display_name (info, g_vfs_backend_get_display_name (backend));
|
||||
+ g_file_info_set_content_type (info, "inode/directory");
|
||||
icon = g_vfs_backend_get_icon (backend);
|
||||
if (icon != NULL)
|
||||
g_file_info_set_icon (info, icon);
|
||||
--
|
||||
1.6.3.3
|
||||
|
14
gvfs.spec
14
gvfs.spec
@ -1,7 +1,7 @@
|
||||
Summary: Backends for the gio framework in GLib
|
||||
Name: gvfs
|
||||
Version: 1.3.3
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.gtk.org
|
||||
@ -34,6 +34,12 @@ BuildRequires: automake autoconf
|
||||
BuildRequires: libtool
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=567235
|
||||
Patch1: gvfs-archive-integration.patch
|
||||
# gedit crashed with SIGSEGV in strlen()
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=589915
|
||||
Patch2: gvfs-1.3.4-output-stream-callback-arg.patch
|
||||
# smb url don't work in the run application dialog
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=573994
|
||||
Patch3: gvfs-1.3.4-smb-browse-fake-content-type.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=497631
|
||||
Patch8: gvfs-1.2.2-dnssd-deadlock.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=504339
|
||||
@ -122,6 +128,8 @@ media players (Media Transfer Protocol) to applications using gvfs.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .archive-integration
|
||||
%patch2 -p1 -b .gedit-segfault
|
||||
%patch3 -p1 -b .smb-fake-content-type
|
||||
%patch8 -p1 -b .dnssd-deadlock
|
||||
%patch9 -p1 -b .sftp-timeout
|
||||
|
||||
@ -270,6 +278,10 @@ update-desktop-database &> /dev/null ||:
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Aug 4 2009 Tomas Bzatek <tbzatek@redhat.com> - 1.3.3-2
|
||||
- Fix gedit crashed with SEGV in strlen()
|
||||
- Fix SMB protocol not handled when opening from a bookmark (#509832)
|
||||
|
||||
* Wed Jul 29 2009 Matthias Clasen <mclasen@redhat.com> - 1.3.3-1
|
||||
- Update to 1.3.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user