Update to 1.9.4
New AFP backend in separate subpackage
This commit is contained in:
parent
9662d8e984
commit
a456416bc9
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@ gvfs-1.6.3.tar.bz2
|
||||
/gvfs-1.9.1.tar.xz
|
||||
/gvfs-1.9.2.tar.xz
|
||||
/gvfs-1.9.3.tar.xz
|
||||
/gvfs-1.9.4.tar.xz
|
||||
|
@ -1,116 +0,0 @@
|
||||
From 41eaac3a128459b41a13bc2b7da0d48b275f954b Mon Sep 17 00:00:00 2001
|
||||
From: Tomas Bzatek <tbzatek@redhat.com>
|
||||
Date: Wed, 27 Jul 2011 12:15:04 +0200
|
||||
Subject: [PATCH] fuse: Bring back real statfs()
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=655401
|
||||
---
|
||||
client/gvfsfusedaemon.c | 67 ++++++++++++----------------------------------
|
||||
1 files changed, 18 insertions(+), 49 deletions(-)
|
||||
|
||||
diff --git a/client/gvfsfusedaemon.c b/client/gvfsfusedaemon.c
|
||||
index 4a772fa..b41e83b 100644
|
||||
--- a/client/gvfsfusedaemon.c
|
||||
+++ b/client/gvfsfusedaemon.c
|
||||
@@ -634,12 +634,6 @@ file_from_full_path (const gchar *path)
|
||||
* VFS functions *
|
||||
* ------------- */
|
||||
|
||||
-#if 0
|
||||
-
|
||||
-/* A stat -f <path> on a FUSE mount always results in this function being called with a path
|
||||
- * of '/'. This means we can't return valid info for the various mounts. Hopefully we can
|
||||
- * fix this in the future. */
|
||||
-
|
||||
static gint
|
||||
vfs_statfs (const gchar *path, struct statvfs *stbuf)
|
||||
{
|
||||
@@ -649,32 +643,35 @@ vfs_statfs (const gchar *path, struct statvfs *stbuf)
|
||||
|
||||
debug_print ("vfs_statfs: %s\n", path);
|
||||
|
||||
+ memset (stbuf, 0, sizeof (*stbuf));
|
||||
+
|
||||
+ /* Fallback case */
|
||||
+ stbuf->f_bsize = 4096;
|
||||
+ stbuf->f_frsize = 4096; /* Ignored by FUSE */
|
||||
+ stbuf->f_blocks = 0;
|
||||
+ stbuf->f_bfree = 0;
|
||||
+ stbuf->f_bavail = 0;
|
||||
+ stbuf->f_files = 0;
|
||||
+ stbuf->f_ffree = 0;
|
||||
+ stbuf->f_favail = 0; /* Ignored by FUSE */
|
||||
+ stbuf->f_fsid = 1; /* Ignored by FUSE */
|
||||
+ stbuf->f_flag = 0; /* Ignored by FUSE */
|
||||
+ stbuf->f_namemax = 1024;
|
||||
+
|
||||
if ((file = file_from_full_path (path)))
|
||||
{
|
||||
GFileInfo *file_info;
|
||||
|
||||
- file_info = g_file_get_filesystem_info (file, "*", NULL, &error);
|
||||
+ file_info = g_file_query_filesystem_info (file, "filesystem::*", NULL, &error);
|
||||
|
||||
if (file_info)
|
||||
{
|
||||
- memset (stbuf, 0, sizeof (*stbuf));
|
||||
-
|
||||
- stbuf->f_bsize = 4096;
|
||||
- stbuf->f_frsize = 4096; /* Ignored by FUSE */
|
||||
- stbuf->f_blocks = 0;
|
||||
- stbuf->f_bfree = 0;
|
||||
- stbuf->f_bavail = 0;
|
||||
- stbuf->f_files = 0;
|
||||
- stbuf->f_ffree = 0;
|
||||
- stbuf->f_favail = 0; /* Ignored by FUSE */
|
||||
- stbuf->f_fsid = 1; /* Ignored by FUSE */
|
||||
- stbuf->f_flag = 0; /* Ignored by FUSE */
|
||||
- stbuf->f_namemax = 1024;
|
||||
-
|
||||
if (g_file_info_has_attribute (file_info, G_FILE_ATTRIBUTE_FILESYSTEM_SIZE))
|
||||
stbuf->f_blocks = g_file_info_get_attribute_uint64 (file_info, G_FILE_ATTRIBUTE_FILESYSTEM_SIZE) / 4096;
|
||||
if (g_file_info_has_attribute (file_info, G_FILE_ATTRIBUTE_FILESYSTEM_FREE))
|
||||
stbuf->f_bfree = stbuf->f_bavail = g_file_info_get_attribute_uint64 (file_info, G_FILE_ATTRIBUTE_FILESYSTEM_FREE) / 4096;
|
||||
+
|
||||
+ g_object_unref (file_info);
|
||||
}
|
||||
else if (error)
|
||||
{
|
||||
@@ -694,34 +691,6 @@ vfs_statfs (const gchar *path, struct statvfs *stbuf)
|
||||
return result;
|
||||
}
|
||||
|
||||
-#endif
|
||||
-
|
||||
-static gint
|
||||
-vfs_statfs (const gchar *path, struct statvfs *stbuf)
|
||||
-{
|
||||
- gint result = 0;
|
||||
-
|
||||
- debug_print ("vfs_statfs: %s\n", path);
|
||||
-
|
||||
- memset (stbuf, 0, sizeof (*stbuf));
|
||||
-
|
||||
- stbuf->f_bsize = 4096;
|
||||
- stbuf->f_frsize = 4096; /* Ignored by FUSE */
|
||||
- stbuf->f_blocks = 0;
|
||||
- stbuf->f_bfree = 0;
|
||||
- stbuf->f_bavail = 0;
|
||||
- stbuf->f_files = 0;
|
||||
- stbuf->f_ffree = 0;
|
||||
- stbuf->f_favail = 0; /* Ignored by FUSE */
|
||||
- stbuf->f_fsid = 1; /* Ignored by FUSE */
|
||||
- stbuf->f_flag = 0; /* Ignored by FUSE */
|
||||
- stbuf->f_namemax = 1024;
|
||||
-
|
||||
- debug_print ("vfs_statfs: -> %s\n", g_strerror (-result));
|
||||
-
|
||||
- return result;
|
||||
-}
|
||||
-
|
||||
static mode_t
|
||||
file_info_get_stat_mode (GFileInfo *file_info)
|
||||
{
|
||||
--
|
||||
1.7.6
|
||||
|
33
gvfs.spec
33
gvfs.spec
@ -1,15 +1,15 @@
|
||||
Summary: Backends for the gio framework in GLib
|
||||
Name: gvfs
|
||||
Version: 1.9.3
|
||||
Version: 1.9.4
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.gtk.org
|
||||
Source: http://download.gnome.org/sources/gvfs/1.9/gvfs-%{version}.tar.xz
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: glib2-devel >= 2.27.4
|
||||
BuildRequires: glib2-devel >= 2.29.14
|
||||
# for post-install update-gio-modules and overall functionality
|
||||
Requires: glib2 >= 2.27.4
|
||||
Requires: glib2 >= 2.29.14
|
||||
BuildRequires: dbus-glib-devel
|
||||
BuildRequires: /usr/bin/ssh
|
||||
BuildRequires: libcdio-devel >= 0.78.2
|
||||
@ -21,9 +21,10 @@ BuildRequires: avahi-glib-devel >= 0.6
|
||||
BuildRequires: libgnome-keyring-devel
|
||||
BuildRequires: intltool
|
||||
BuildRequires: gettext-devel
|
||||
BuildRequires: gnome-disk-utility-devel >= 2.29.90-1
|
||||
BuildRequires: gnome-disk-utility-devel >= 3.0.2
|
||||
BuildRequires: PolicyKit-devel
|
||||
BuildRequires: expat-devel
|
||||
BuildRequires: libbluray-devel
|
||||
|
||||
Requires(post): desktop-file-utils
|
||||
Requires(postun): desktop-file-utils
|
||||
@ -127,6 +128,19 @@ This package provides support for reading files on mobile devices
|
||||
including phones and music players to applications using gvfs.
|
||||
%endif
|
||||
|
||||
%package afp
|
||||
Summary: AFP support for gvfs
|
||||
Group: System Environment/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
BuildRequires: libgcrypt-devel >= 1.2.2
|
||||
# this should ensure having this new subpackage installed on upgrade from older versions
|
||||
Obsoletes: %{name} < 1.9.4-1
|
||||
|
||||
%description afp
|
||||
This package provides support for reading and writing files on
|
||||
Mac OS X and original Mac OS network shares via Apple Filing Protocol
|
||||
to applications using gvfs.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
@ -235,6 +249,7 @@ killall -USR1 gvfsd >&/dev/null || :
|
||||
%{_bindir}/gvfs-info
|
||||
%{_bindir}/gvfs-less
|
||||
%{_bindir}/gvfs-ls
|
||||
%{_bindir}/gvfs-mime
|
||||
%{_bindir}/gvfs-mkdir
|
||||
%{_bindir}/gvfs-monitor-dir
|
||||
%{_bindir}/gvfs-monitor-file
|
||||
@ -295,7 +310,17 @@ killall -USR1 gvfsd >&/dev/null || :
|
||||
%{_datadir}/gvfs/remote-volume-monitors/afc.monitor
|
||||
%endif
|
||||
|
||||
%files afp
|
||||
%{_libexecdir}/gvfsd-afp
|
||||
%{_libexecdir}/gvfsd-afp-browse
|
||||
%{_datadir}/gvfs/mounts/afp.mount
|
||||
%{_datadir}/gvfs/mounts/afp-browse.mount
|
||||
|
||||
%changelog
|
||||
* Tue Aug 30 2011 Tomas Bzatek <tbzatek@redhat.com> - 1.9.4-1
|
||||
- Update to 1.9.4
|
||||
- New AFP backend in separate subpackage
|
||||
|
||||
* Tue Aug 16 2011 Matthias Clasen <mclasen@redhat.com> - 1.9.3-1
|
||||
- Update to 1.9.3
|
||||
- Drop obsolete patches
|
||||
|
Loading…
Reference in New Issue
Block a user