Update to 1.13.8

This commit is contained in:
Tomas Bzatek 2012-09-05 16:15:44 +02:00
parent f3b3f561e1
commit 95db84cf0a
4 changed files with 9 additions and 62 deletions

1
.gitignore vendored
View File

@ -30,3 +30,4 @@ gvfs-1.6.3.tar.bz2
/gvfs-1.13.3.tar.xz
/gvfs-1.13.4.tar.xz
/gvfs-1.13.7.tar.xz
/gvfs-1.13.8.tar.xz

View File

@ -1,57 +0,0 @@
diff -up gvfs-1.13.3/configure.ac.gphoto25 gvfs-1.13.3/configure.ac
--- gvfs-1.13.3/configure.ac.gphoto25 2012-07-16 17:57:18.000000000 +0200
+++ gvfs-1.13.3/configure.ac 2012-08-04 20:05:19.466122563 +0200
@@ -436,6 +436,9 @@ if test "x$enable_gphoto2" != "xno" -a \
if test "x$msg_gphoto2" = "xyes"; then
if test "x$use_gphoto2" = "xyes"; then
AC_DEFINE(HAVE_GPHOTO2, 1, [Define to 1 if gphoto2 is available])
+ PKG_CHECK_MODULES(GPHOTO2, libgphoto2 >= 2.5.0,
+ AC_DEFINE(HAVE_GPHOTO25, 1, [Define to 1 if libgphoto2 2.5 is available])
+ )
else
if test "x$enable_gphoto2" = "xyes"; then
AC_MSG_ERROR([Cannot build with gphoto2 support. Need OS tweaks in hal volume monitor.])
diff -up gvfs-1.13.3/daemon/gvfsbackendgphoto2.c.gphoto25 gvfs-1.13.3/daemon/gvfsbackendgphoto2.c
--- gvfs-1.13.3/daemon/gvfsbackendgphoto2.c.gphoto25 2012-07-16 17:31:26.000000000 +0200
+++ gvfs-1.13.3/daemon/gvfsbackendgphoto2.c 2012-08-04 20:02:26.887280094 +0200
@@ -1647,7 +1647,7 @@ do_mount (GVfsBackend *backend,
return;
}
- DEBUG (" '%s' '%s' '%s'", info.name, info.path, info.library_filename);
+ /*DEBUG (" '%s' '%s' '%s'", info.name, info.path, info.library_filename);*/
/* set port */
rc = gp_camera_set_port_info (gphoto2_backend->camera, info);
@@ -2590,7 +2590,11 @@ do_slow_file_rename_in_same_dir (GVfsBac
}
}
+#ifdef HAVE_GPHOTO25
+ rc = gp_camera_folder_put_file (gphoto2_backend->camera, dir, new_name, GP_FILE_TYPE_NORMAL, file_dest, gphoto2_backend->context);
+#else
rc = gp_camera_folder_put_file (gphoto2_backend->camera, dir, file_dest, gphoto2_backend->context);
+#endif
if (rc != 0)
goto out;
@@ -3222,14 +3226,18 @@ commit_write_handle (GVfsBackendGphoto2
if (rc != 0)
goto out;
- gp_file_set_type (file, GP_FILE_TYPE_NORMAL);
gp_file_set_name (file, write_handle->name);
gp_file_set_mtime (file, time (NULL));
gp_file_set_data_and_size (file,
dup_for_gphoto2 (write_handle->data, write_handle->size),
write_handle->size);
+#ifdef HAVE_GPHOTO25
+ rc = gp_camera_folder_put_file (gphoto2_backend->camera, write_handle->dir, write_handle->name, GP_FILE_TYPE_NORMAL, file, gphoto2_backend->context);
+#else
+ gp_file_set_type (file, GP_FILE_TYPE_NORMAL);
rc = gp_camera_folder_put_file (gphoto2_backend->camera, write_handle->dir, file, gphoto2_backend->context);
+#endif
if (rc != 0)
{
gp_file_unref (file);

View File

@ -1,16 +1,16 @@
Summary: Backends for the gio framework in GLib
Name: gvfs
Version: 1.13.7
Release: 3%{?dist}
Version: 1.13.8
Release: 1%{?dist}
License: LGPLv2+
Group: System Environment/Libraries
URL: http://www.gtk.org
Source: http://download.gnome.org/sources/gvfs/1.13/gvfs-%{version}.tar.xz
BuildRequires: pkgconfig
BuildRequires: glib2-devel >= 2.33.4
BuildRequires: glib2-devel >= 2.33.12
# for post-install update-gio-modules and overall functionality
Requires: glib2 >= 2.33.4
Requires: glib2 >= 2.33.12
BuildRequires: dbus-glib-devel
BuildRequires: /usr/bin/ssh
BuildRequires: libcdio-devel >= 0.78.2
@ -329,6 +329,9 @@ killall -USR1 gvfsd >&/dev/null || :
%{_datadir}/gvfs/mounts/afp-browse.mount
%changelog
* Wed Sep 5 2012 Tomas Bzatek <tbzatek@redhat.com> - 1.13.8-1
- Update to 1.13.8
* Wed Aug 29 2012 Tomas Bzatek <tbzatek@redhat.com> - 1.13.7-3
- Bring archive mounter back

View File

@ -1 +1 @@
bd960775581edc0e0f1c10a446108840 gvfs-1.13.7.tar.xz
5bb7403fa3a0c5659f40c6df299d90dc gvfs-1.13.8.tar.xz