Add patch from svn that adds libxml requirment
This commit is contained in:
parent
fd7bda459e
commit
7ca8afc7d3
74
gvfs-libxml.patch
Normal file
74
gvfs-libxml.patch
Normal file
@ -0,0 +1,74 @@
|
||||
diff -up gvfs-0.1.8/configure.ac.libxml gvfs-0.1.8/configure.ac
|
||||
--- gvfs-0.1.8/configure.ac.libxml 2008-02-26 14:18:48.000000000 +0100
|
||||
+++ gvfs-0.1.8/configure.ac 2008-02-26 14:19:03.000000000 +0100
|
||||
@@ -120,7 +120,7 @@ if test "x$enable_http" != "xno"; then
|
||||
PKG_CHECK_EXISTS(libsoup-2.4 >= 2.3.0, msg_http=yes)
|
||||
|
||||
if test "x$msg_http" == "xyes"; then
|
||||
- PKG_CHECK_MODULES(HTTP, libsoup-2.4)
|
||||
+ PKG_CHECK_MODULES(HTTP, libsoup-2.4 libxml-2.0)
|
||||
AC_DEFINE(HAVE_HTTP, 1, [Define to 1 if http/dav is going to be built])
|
||||
fi
|
||||
fi
|
||||
diff -up gvfs-0.1.8/configure.libxml gvfs-0.1.8/configure
|
||||
--- gvfs-0.1.8/configure.libxml 2008-02-26 14:18:53.000000000 +0100
|
||||
+++ gvfs-0.1.8/configure 2008-02-26 14:20:41.000000000 +0100
|
||||
@@ -24600,12 +24600,12 @@ if test -n "$PKG_CONFIG"; then
|
||||
pkg_cv_HTTP_CFLAGS="$HTTP_CFLAGS"
|
||||
else
|
||||
if test -n "$PKG_CONFIG" && \
|
||||
- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"libsoup-2.4\"") >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "libsoup-2.4") 2>&5
|
||||
+ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"libsoup-2.4 libxml-2.0\"") >&5
|
||||
+ ($PKG_CONFIG --exists --print-errors "libsoup-2.4 libxml-2.0") 2>&5
|
||||
ac_status=$?
|
||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; then
|
||||
- pkg_cv_HTTP_CFLAGS=`$PKG_CONFIG --cflags "libsoup-2.4" 2>/dev/null`
|
||||
+ pkg_cv_HTTP_CFLAGS=`$PKG_CONFIG --cflags "libsoup-2.4 libxml-2.0" 2>/dev/null`
|
||||
else
|
||||
pkg_failed=yes
|
||||
fi
|
||||
@@ -24618,12 +24618,12 @@ if test -n "$PKG_CONFIG"; then
|
||||
pkg_cv_HTTP_LIBS="$HTTP_LIBS"
|
||||
else
|
||||
if test -n "$PKG_CONFIG" && \
|
||||
- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"libsoup-2.4\"") >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "libsoup-2.4") 2>&5
|
||||
+ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"libsoup-2.4 libxml-2.0\"") >&5
|
||||
+ ($PKG_CONFIG --exists --print-errors "libsoup-2.4 libxml-2.0") 2>&5
|
||||
ac_status=$?
|
||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; then
|
||||
- pkg_cv_HTTP_LIBS=`$PKG_CONFIG --libs "libsoup-2.4" 2>/dev/null`
|
||||
+ pkg_cv_HTTP_LIBS=`$PKG_CONFIG --libs "libsoup-2.4 libxml-2.0" 2>/dev/null`
|
||||
else
|
||||
pkg_failed=yes
|
||||
fi
|
||||
@@ -24642,14 +24642,14 @@ else
|
||||
_pkg_short_errors_supported=no
|
||||
fi
|
||||
if test $_pkg_short_errors_supported = yes; then
|
||||
- HTTP_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "libsoup-2.4"`
|
||||
+ HTTP_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "libsoup-2.4 libxml-2.0"`
|
||||
else
|
||||
- HTTP_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "libsoup-2.4"`
|
||||
+ HTTP_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "libsoup-2.4 libxml-2.0"`
|
||||
fi
|
||||
# Put the nasty error message in config.log where it belongs
|
||||
echo "$HTTP_PKG_ERRORS" >&5
|
||||
|
||||
- { { echo "$as_me:$LINENO: error: Package requirements (libsoup-2.4) were not met:
|
||||
+ { { echo "$as_me:$LINENO: error: Package requirements (libsoup-2.4 libxml-2.0) were not met:
|
||||
|
||||
$HTTP_PKG_ERRORS
|
||||
|
||||
@@ -24660,7 +24660,7 @@ Alternatively, you may set the environme
|
||||
and HTTP_LIBS to avoid the need to call pkg-config.
|
||||
See the pkg-config man page for more details.
|
||||
" >&5
|
||||
-echo "$as_me: error: Package requirements (libsoup-2.4) were not met:
|
||||
+echo "$as_me: error: Package requirements (libsoup-2.4 libxml-2.0) were not met:
|
||||
|
||||
$HTTP_PKG_ERRORS
|
||||
|
@ -24,6 +24,9 @@ BuildRequires: gettext-devel
|
||||
BuildRequires: perl(XML::Parser)
|
||||
BuildRequires: GConf2-devel
|
||||
|
||||
# From head:
|
||||
Patch1: gvfs-libxml.patch
|
||||
|
||||
%description
|
||||
The gvfs package provides backend implementations for the gio
|
||||
framework in GLib. It includes ftp, sftp, cifs.
|
||||
@ -38,7 +41,10 @@ The gvfs-devel package contains headers and other files that are
|
||||
required to develop applications using gvfs.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%setup -q
|
||||
|
||||
%patch1 -p1 -b .libxml
|
||||
|
||||
|
||||
%build
|
||||
%configure
|
||||
|
Loading…
Reference in New Issue
Block a user