- Update to 1.2.0
This commit is contained in:
parent
b0abe829ef
commit
59f45f8514
@ -1 +1 @@
|
||||
gvfs-1.1.8.tar.bz2
|
||||
gvfs-1.2.0.tar.bz2
|
||||
|
@ -1,14 +0,0 @@
|
||||
Index: client/gdaemonfilemonitor.c
|
||||
===================================================================
|
||||
--- client/gdaemonfilemonitor.c (revision 2316)
|
||||
+++ client/gdaemonfilemonitor.c (revision 2317)
|
||||
@@ -202,6 +202,9 @@
|
||||
G_VFS_DBUS_MONITOR_INTERFACE,
|
||||
G_VFS_DBUS_MONITOR_OP_UNSUBSCRIBE);
|
||||
|
||||
+ _g_dbus_message_append_args (message, DBUS_TYPE_OBJECT_PATH,
|
||||
+ &daemon_monitor->object_path, 0);
|
||||
+
|
||||
_g_vfs_daemon_call_async (message,
|
||||
NULL, NULL,
|
||||
NULL);
|
@ -1,20 +0,0 @@
|
||||
Index: daemon/gvfsbackendsftp.c
|
||||
===================================================================
|
||||
--- daemon/gvfsbackendsftp.c (revision 2315)
|
||||
+++ daemon/gvfsbackendsftp.c (revision 2316)
|
||||
@@ -560,6 +560,15 @@
|
||||
&bytes_read, NULL, error))
|
||||
return NULL;
|
||||
|
||||
+ /* Make sure we handle ssh exiting early, e.g. if no further
|
||||
+ authentication methods */
|
||||
+ if (bytes_read == 0)
|
||||
+ {
|
||||
+ g_set_error_literal (error,
|
||||
+ G_IO_ERROR, G_IO_ERROR_FAILED,
|
||||
+ _("ssh program unexpectedly exited"));
|
||||
+ return NULL;
|
||||
+ }
|
||||
|
||||
len = GUINT32_FROM_BE (len);
|
||||
|
16
gvfs.spec
16
gvfs.spec
@ -1,11 +1,11 @@
|
||||
Summary: Backends for the gio framework in GLib
|
||||
Name: gvfs
|
||||
Version: 1.1.8
|
||||
Release: 2%{?dist}
|
||||
Version: 1.2.0
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.gtk.org
|
||||
Source: http://download.gnome.org/sources/gvfs/1.1/gvfs-%{version}.tar.bz2
|
||||
Source: http://download.gnome.org/sources/gvfs/1.2/gvfs-%{version}.tar.bz2
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: glib2-devel >= 2.19.2
|
||||
@ -40,11 +40,6 @@ Patch3: gvfs-1.1.7-gdu-monitor-empty-drives.patch
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=573826
|
||||
Patch4: gvfs-1.1.7-gdu-computer-expose-devices.patch
|
||||
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=574754
|
||||
Patch5: gvfs-1.1.8-sftp-cpu-eating.patch
|
||||
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=563418
|
||||
Patch6: gvfs-1.1.8-monitor-leaks.patch
|
||||
|
||||
%description
|
||||
The gvfs package provides backend implementations for the gio
|
||||
@ -130,8 +125,6 @@ media players (Media Transfer Protocol) to applications using gvfs.
|
||||
%patch2 -p0 -b .gdu
|
||||
%patch3 -p1 -b .gdu-volumes-typo
|
||||
%patch4 -p1 -b .computer-gdu
|
||||
%patch5 -p0 -b .sftp-100-cpu
|
||||
%patch6 -p0 -b .monitor-leaks
|
||||
|
||||
%build
|
||||
|
||||
@ -275,6 +268,9 @@ update-desktop-database &> /dev/null ||:
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Mar 16 2009 Tomas Bzatek <tbzatek@redhat.com> - 1.2.0-1
|
||||
- Update to 1.2.0
|
||||
|
||||
* Wed Mar 11 2009 Tomas Bzatek <tbzatek@redhat.com> - 1.1.8-2
|
||||
- Fix 100% cpu usage when connecting to a ssh key and denying key access
|
||||
- Fix monitors leak
|
||||
|
Loading…
Reference in New Issue
Block a user