Update to 1.33.90
This commit is contained in:
parent
c6ff2f2f53
commit
4a48997ea2
@ -1,57 +0,0 @@
|
|||||||
From c155704092c1848a42539ab91cad9052c38e62af Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ondrej Holy <oholy@redhat.com>
|
|
||||||
Date: Mon, 24 Jul 2017 12:00:09 +0200
|
|
||||||
Subject: [PATCH] gdaemonfileenumerator: Fix crashes in synchronous enumerator
|
|
||||||
code
|
|
||||||
|
|
||||||
Commit 2eae108 ported the code to GTask and slightly changed processing.
|
|
||||||
The changes trigger the following criticals and cause crashes of some
|
|
||||||
applications (e.g. Firefox, Thunderbird).
|
|
||||||
GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
|
|
||||||
|
|
||||||
Return TRUE from signal handlers in order to prevent further processing
|
|
||||||
of the invocations, which cause the mentioned issues.
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=784953
|
|
||||||
---
|
|
||||||
client/gdaemonfileenumerator.c | 8 ++++++--
|
|
||||||
1 file changed, 6 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/client/gdaemonfileenumerator.c b/client/gdaemonfileenumerator.c
|
|
||||||
index aa30ee24..f3ba336b 100644
|
|
||||||
--- a/client/gdaemonfileenumerator.c
|
|
||||||
+++ b/client/gdaemonfileenumerator.c
|
|
||||||
@@ -194,7 +194,7 @@ next_files_sync_check (GDaemonFileEnumerator *enumerator)
|
|
||||||
g_mutex_unlock (&enumerator->next_files_mutex);
|
|
||||||
}
|
|
||||||
|
|
||||||
-static void
|
|
||||||
+static gboolean
|
|
||||||
handle_done (GVfsDBusEnumerator *object,
|
|
||||||
GDBusMethodInvocation *invocation,
|
|
||||||
gpointer user_data)
|
|
||||||
@@ -209,9 +209,11 @@ handle_done (GVfsDBusEnumerator *object,
|
|
||||||
g_signal_emit (enumerator, signals[CHANGED], 0);
|
|
||||||
|
|
||||||
gvfs_dbus_enumerator_complete_done (object, invocation);
|
|
||||||
+
|
|
||||||
+ return TRUE;
|
|
||||||
}
|
|
||||||
|
|
||||||
-static void
|
|
||||||
+static gboolean
|
|
||||||
handle_got_info (GVfsDBusEnumerator *object,
|
|
||||||
GDBusMethodInvocation *invocation,
|
|
||||||
GVariant *arg_infos,
|
|
||||||
@@ -248,6 +250,8 @@ handle_got_info (GVfsDBusEnumerator *object,
|
|
||||||
g_signal_emit (enumerator, signals[CHANGED], 0);
|
|
||||||
|
|
||||||
gvfs_dbus_enumerator_complete_got_info (object, invocation);
|
|
||||||
+
|
|
||||||
+ return TRUE;
|
|
||||||
}
|
|
||||||
|
|
||||||
static void
|
|
||||||
--
|
|
||||||
2.13.3
|
|
||||||
|
|
@ -1,30 +0,0 @@
|
|||||||
From 5fbae72a807dc0947143a4a65e7193cc24654108 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ondrej Holy <oholy@redhat.com>
|
|
||||||
Date: Wed, 19 Jul 2017 16:34:10 +0200
|
|
||||||
Subject: [PATCH] goa: Fix password-based authentication
|
|
||||||
|
|
||||||
Password-based authentication used for ownCloud/Nextcloud was broken
|
|
||||||
by GTask port (commit fdda284). GTask is used as user_data for async
|
|
||||||
callbacks currently, however, user_data is incorrectly cast to MountOp
|
|
||||||
in this case. Use g_task_get_task_data in order to fix this issue.
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=780496
|
|
||||||
---
|
|
||||||
monitor/goa/goavolume.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/monitor/goa/goavolume.c b/monitor/goa/goavolume.c
|
|
||||||
index 00c7e541..c077dd94 100644
|
|
||||||
--- a/monitor/goa/goavolume.c
|
|
||||||
+++ b/monitor/goa/goavolume.c
|
|
||||||
@@ -105,7 +105,7 @@ mount_operation_ask_password_cb (GMountOperation *op,
|
|
||||||
GAskPasswordFlags flags,
|
|
||||||
gpointer user_data)
|
|
||||||
{
|
|
||||||
- MountOp *data = user_data;
|
|
||||||
+ MountOp *data = g_task_get_task_data (user_data);
|
|
||||||
|
|
||||||
g_mount_operation_set_password (data->mount_operation, data->passwd);
|
|
||||||
g_mount_operation_reply (data->mount_operation, G_MOUNT_OPERATION_HANDLED);
|
|
||||||
--
|
|
||||||
2.13.2
|
|
15
gvfs.spec
15
gvfs.spec
@ -21,8 +21,8 @@
|
|||||||
%global udisks2_version 1.97
|
%global udisks2_version 1.97
|
||||||
|
|
||||||
Name: gvfs
|
Name: gvfs
|
||||||
Version: 1.33.3
|
Version: 1.33.90
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Backends for the gio framework in GLib
|
Summary: Backends for the gio framework in GLib
|
||||||
|
|
||||||
License: GPLv3 and LGPLv2+ and BSD and MPLv2.0
|
License: GPLv3 and LGPLv2+ and BSD and MPLv2.0
|
||||||
@ -32,12 +32,6 @@ Source0: https://download.gnome.org/sources/gvfs/1.33/gvfs-%{version}.tar.xz
|
|||||||
# http://bugzilla.gnome.org/show_bug.cgi?id=567235
|
# http://bugzilla.gnome.org/show_bug.cgi?id=567235
|
||||||
Patch0: gvfs-archive-integration.patch
|
Patch0: gvfs-archive-integration.patch
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1461066
|
|
||||||
Patch1: goa-Fix-password-based-authentication.patch
|
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1472819
|
|
||||||
Patch2: gdaemonfileenumerator-Fix-crashes-in-synchronous-e.patch
|
|
||||||
|
|
||||||
BuildRequires: pkgconfig
|
BuildRequires: pkgconfig
|
||||||
BuildRequires: pkgconfig(glib-2.0) >= %{glib2_version}
|
BuildRequires: pkgconfig(glib-2.0) >= %{glib2_version}
|
||||||
BuildRequires: pkgconfig(dbus-glib-1)
|
BuildRequires: pkgconfig(dbus-glib-1)
|
||||||
@ -220,8 +214,6 @@ the functionality of the installed gvfs package.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .archive-integration
|
%patch0 -p1 -b .archive-integration
|
||||||
%patch1 -p1 -b .goa-Fix-password-based-authentication
|
|
||||||
%patch2 -p1 -b .gdaemonfileenumerator-Fix-crashes-in-synchronous-e
|
|
||||||
|
|
||||||
# Needed for gvfs-0.2.1-archive-integration.patch
|
# Needed for gvfs-0.2.1-archive-integration.patch
|
||||||
autoreconf -fi
|
autoreconf -fi
|
||||||
@ -415,6 +407,9 @@ killall -USR1 gvfsd >&/dev/null || :
|
|||||||
%{_datadir}/installed-tests
|
%{_datadir}/installed-tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Aug 09 2017 Ondrej Holy <oholy@redhat.com> - 1.33.90-1
|
||||||
|
- Update to 1.33.90
|
||||||
|
|
||||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.33.3-5
|
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.33.3-5
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (gvfs-1.33.3.tar.xz) = 96b273b2390f1f0f9434e8a2ee55b2f48e90515084fb118c6031ec21a25724ffe571025127b446321e2906edfffcf101ec8b390023ee9b2659a46df2f4f75376
|
SHA512 (gvfs-1.33.90.tar.xz) = b706e6e67dd0be34b6875e6d130d2889d38cbb818ea9405307d2fbb8de2ef440d3166c26be5aafe06395f2204111ac287898f0f94f78db3d395a333e55e1ed59
|
||||||
|
Loading…
Reference in New Issue
Block a user