Remove mount-archive.desktop helper
It was just temporary workaround, which survive many years. It has been more-or-less superseded by the Nautilus custom archive handling. Let's remove it now, so we don't have to port this to meson. See the following upstream discussion: https://bugzilla.gnome.org/show_bug.cgi?id=567235
This commit is contained in:
parent
aefaf30965
commit
2ebd52b83c
@ -1,50 +0,0 @@
|
|||||||
diff -up gvfs-1.29.90/Makefile.am.archive-integration gvfs-1.29.90/Makefile.am
|
|
||||||
--- gvfs-1.29.90/Makefile.am.archive-integration 2016-08-11 14:01:26.000000000 +0200
|
|
||||||
+++ gvfs-1.29.90/Makefile.am 2016-08-13 12:19:21.313402711 +0200
|
|
||||||
@@ -1,5 +1,20 @@
|
|
||||||
NULL =
|
|
||||||
|
|
||||||
+desktop_in_files = mount-archive.desktop.in
|
|
||||||
+
|
|
||||||
+mount-archive.desktop.in: mount-archive.desktop.in.in
|
|
||||||
+ sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
|
|
||||||
+
|
|
||||||
+desktopdir = $(datadir)/applications
|
|
||||||
+if HAVE_ARCHIVE
|
|
||||||
+desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
|
|
||||||
+
|
|
||||||
+$(desktop_DATA): %.desktop: %.desktop.in
|
|
||||||
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
|
|
||||||
+else
|
|
||||||
+desktop_DATA =
|
|
||||||
+endif
|
|
||||||
+
|
|
||||||
SUBDIRS = \
|
|
||||||
common \
|
|
||||||
metadata \
|
|
||||||
@@ -24,6 +39,8 @@ EXTRA_DIST = \
|
|
||||||
gvfs.doap \
|
|
||||||
README.commits \
|
|
||||||
MAINTAINERS \
|
|
||||||
+ mount-archive.desktop.in.in \
|
|
||||||
+ $(desktop_in_files) \
|
|
||||||
m4 \
|
|
||||||
gettext/its/polkit.loc \
|
|
||||||
gettext/its/polkit.its \
|
|
||||||
diff -up gvfs-1.29.90/mount-archive.desktop.in.in.archive-integration gvfs-1.29.90/mount-archive.desktop.in.in
|
|
||||||
--- gvfs-1.29.90/mount-archive.desktop.in.in.archive-integration 2016-08-13 12:19:21.313402711 +0200
|
|
||||||
+++ gvfs-1.29.90/mount-archive.desktop.in.in 2016-08-13 12:19:21.313402711 +0200
|
|
||||||
@@ -0,0 +1,13 @@
|
|
||||||
+[Desktop Entry]
|
|
||||||
+Name=Archive Mounter
|
|
||||||
+Exec=@libexecdir@/gvfsd-archive file=%u
|
|
||||||
+X-Gnome-Vfs-System=gio
|
|
||||||
+MimeType=application/x-cd-image;application/x-bzip-compressed-tar;application/x-compressed-tar;application/x-tar;application/x-cpio;application/x-zip;application/zip;application/x-lzma-compressed-tar;application/x-xz-compressed-tar;
|
|
||||||
+Terminal=false
|
|
||||||
+StartupNotify=false
|
|
||||||
+Type=Application
|
|
||||||
+NoDisplay=true
|
|
||||||
+X-GNOME-Bugzilla-Bugzilla=GNOME
|
|
||||||
+X-GNOME-Bugzilla-Product=gvfs
|
|
||||||
+X-GNOME-Bugzilla-Component=archive-backend
|
|
||||||
+X-GNOME-Bugzilla-Version=@VERSION@
|
|
13
gvfs.spec
13
gvfs.spec
@ -29,9 +29,6 @@ License: GPLv3 and LGPLv2+ and BSD and MPLv2.0
|
|||||||
URL: https://wiki.gnome.org/Projects/gvfs
|
URL: https://wiki.gnome.org/Projects/gvfs
|
||||||
Source0: https://download.gnome.org/sources/gvfs/1.37/gvfs-%{version}.tar.xz
|
Source0: https://download.gnome.org/sources/gvfs/1.37/gvfs-%{version}.tar.xz
|
||||||
|
|
||||||
# http://bugzilla.gnome.org/show_bug.cgi?id=567235
|
|
||||||
Patch0: gvfs-archive-integration.patch
|
|
||||||
|
|
||||||
BuildRequires: pkgconfig
|
BuildRequires: pkgconfig
|
||||||
BuildRequires: pkgconfig(glib-2.0) >= %{glib2_version}
|
BuildRequires: pkgconfig(glib-2.0) >= %{glib2_version}
|
||||||
BuildRequires: pkgconfig(dbus-glib-1)
|
BuildRequires: pkgconfig(dbus-glib-1)
|
||||||
@ -52,10 +49,6 @@ BuildRequires: docbook-style-xsl
|
|||||||
BuildRequires: pkgconfig(polkit-gobject-1)
|
BuildRequires: pkgconfig(polkit-gobject-1)
|
||||||
BuildRequires: pkgconfig(libcap)
|
BuildRequires: pkgconfig(libcap)
|
||||||
|
|
||||||
# The patch touches Makefile.am files:
|
|
||||||
BuildRequires: automake autoconf
|
|
||||||
BuildRequires: libtool
|
|
||||||
|
|
||||||
Requires: %{name}-client%{?_isa} = %{version}-%{release}
|
Requires: %{name}-client%{?_isa} = %{version}-%{release}
|
||||||
Requires: glib2%{?_isa} >= %{glib2_version}
|
Requires: glib2%{?_isa} >= %{glib2_version}
|
||||||
Requires: udisks2 >= %{udisks2_version}
|
Requires: udisks2 >= %{udisks2_version}
|
||||||
@ -213,10 +206,6 @@ the functionality of the installed gvfs package.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .archive-integration
|
|
||||||
|
|
||||||
# Needed for gvfs-0.2.1-archive-integration.patch
|
|
||||||
autoreconf -fi
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
@ -345,7 +334,6 @@ killall -USR1 gvfsd >&/dev/null || :
|
|||||||
|
|
||||||
|
|
||||||
%files archive
|
%files archive
|
||||||
%{_datadir}/applications/mount-archive.desktop
|
|
||||||
%{_libexecdir}/gvfsd-archive
|
%{_libexecdir}/gvfsd-archive
|
||||||
%{_datadir}/gvfs/mounts/archive.mount
|
%{_datadir}/gvfs/mounts/archive.mount
|
||||||
|
|
||||||
@ -404,6 +392,7 @@ killall -USR1 gvfsd >&/dev/null || :
|
|||||||
%changelog
|
%changelog
|
||||||
* Wed May 09 2018 Ondrej Holy <oholy@redhat.com> - 1.37.1-1
|
* Wed May 09 2018 Ondrej Holy <oholy@redhat.com> - 1.37.1-1
|
||||||
- Update to 1.37.1
|
- Update to 1.37.1
|
||||||
|
- Remove mount-archive.desktop helper
|
||||||
|
|
||||||
* Tue May 08 2018 Kalev Lember <klember@redhat.com> - 1.36.2-1
|
* Tue May 08 2018 Kalev Lember <klember@redhat.com> - 1.36.2-1
|
||||||
- Update to 1.36.2
|
- Update to 1.36.2
|
||||||
|
Loading…
Reference in New Issue
Block a user