Update to 1.51.90
This commit is contained in:
parent
62c4c0d2d0
commit
2b2153639a
10
gvfs.spec
10
gvfs.spec
@ -21,17 +21,14 @@
|
|||||||
%global udisks2_version 1.97
|
%global udisks2_version 1.97
|
||||||
|
|
||||||
Name: gvfs
|
Name: gvfs
|
||||||
Version: 1.51.1
|
Version: 1.51.90
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Backends for the gio framework in GLib
|
Summary: Backends for the gio framework in GLib
|
||||||
|
|
||||||
License: GPLv3 and LGPLv2+ and BSD and MPLv2.0
|
License: GPLv3 and LGPLv2+ and BSD and MPLv2.0
|
||||||
URL: https://wiki.gnome.org/Projects/gvfs
|
URL: https://wiki.gnome.org/Projects/gvfs
|
||||||
Source0: https://download.gnome.org/sources/gvfs/1.51/gvfs-%{version}.tar.xz
|
Source0: https://download.gnome.org/sources/gvfs/1.51/gvfs-%{version}.tar.xz
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2219172
|
|
||||||
Patch0: udisks2-Disconnect-signal-handlers-before-freeing-da.patch
|
|
||||||
|
|
||||||
BuildRequires: meson
|
BuildRequires: meson
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: pkgconfig(glib-2.0) >= %{glib2_version}
|
BuildRequires: pkgconfig(glib-2.0) >= %{glib2_version}
|
||||||
@ -431,6 +428,9 @@ killall -USR1 gvfsd >&/dev/null || :
|
|||||||
%{_datadir}/installed-tests
|
%{_datadir}/installed-tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Aug 06 2023 Kalev Lember <klember@redhat.com> - 1.51.90-1
|
||||||
|
- Update to 1.51.90
|
||||||
|
|
||||||
* Fri Jul 28 2023 Michel Alexandre Salim <salimma@fedoraproject.org> - 1.51.1-4
|
* Fri Jul 28 2023 Michel Alexandre Salim <salimma@fedoraproject.org> - 1.51.1-4
|
||||||
- Rebuilt for libimobiledevice and libplist soname bump
|
- Rebuilt for libimobiledevice and libplist soname bump
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (gvfs-1.51.1.tar.xz) = e879da09ac3ebe8e35e09ef224c46519fb6fdd5d09d8b06976836e2e521f653a954214f2f9436b7a4a91a2bf9c0e487da89fb1feaf29ef1e3db231aa879a916d
|
SHA512 (gvfs-1.51.90.tar.xz) = 1193616f8476dcd3f0088f6fcbfea873cc76046f21ef0d9008687e48b2183756af85c786e04d6126e7faa62cfbb3103e836e1b902ee9f52002a80cc8550b94a9
|
||||||
|
@ -1,30 +0,0 @@
|
|||||||
From 70d5ff3c52820840344df1a3e3b83a07dfb8e672 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ondrej Holy <oholy@redhat.com>
|
|
||||||
Date: Thu, 13 Jul 2023 10:15:03 +0200
|
|
||||||
Subject: [PATCH] udisks2: Disconnect signal handlers before freeing data
|
|
||||||
|
|
||||||
After the commit 1b80450a, the udisks2 volume monitor crashes sometimes after
|
|
||||||
showing the unmount notification. This is because the `UnmountNotifyData`
|
|
||||||
struct is freed, but signal handlers are still connected. Let's disconnect
|
|
||||||
the signal handlers to avoid those crashes caused by invalid reads.
|
|
||||||
|
|
||||||
Related: https://bugzilla.redhat.com/show_bug.cgi?id=2219172
|
|
||||||
---
|
|
||||||
monitor/udisks2/gvfsudisks2utils.c | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/monitor/udisks2/gvfsudisks2utils.c b/monitor/udisks2/gvfsudisks2utils.c
|
|
||||||
index 1f48ceb0..345c93ab 100644
|
|
||||||
--- a/monitor/udisks2/gvfsudisks2utils.c
|
|
||||||
+++ b/monitor/udisks2/gvfsudisks2utils.c
|
|
||||||
@@ -709,6 +709,7 @@ unmount_notify_data_free (gpointer user_data)
|
|
||||||
UnmountNotifyData *data = user_data;
|
|
||||||
|
|
||||||
unmount_notify_stop_timer (data);
|
|
||||||
+ g_signal_handlers_disconnect_by_data (data->op, data);
|
|
||||||
|
|
||||||
g_clear_object (&data->mount);
|
|
||||||
g_clear_object (&data->drive);
|
|
||||||
--
|
|
||||||
2.41.0
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user