- Update GVfs gdu patch to fix mount detection confusion (#488399)

This commit is contained in:
David Zeuthen 2009-03-04 21:33:17 +00:00
parent e3319e5dcb
commit 1fe862dc81
2 changed files with 24 additions and 21 deletions

View File

@ -1,6 +1,6 @@
Index: configure.ac Index: configure.ac
=================================================================== ===================================================================
--- configure.ac (revision 2275) --- configure.ac (revision 2286)
+++ configure.ac (working copy) +++ configure.ac (working copy)
@@ -198,6 +198,31 @@ @@ -198,6 +198,31 @@
@ -54,7 +54,7 @@ Index: configure.ac
" "
Index: monitor/Makefile.am Index: monitor/Makefile.am
=================================================================== ===================================================================
--- monitor/Makefile.am (revision 2275) --- monitor/Makefile.am (revision 2286)
+++ monitor/Makefile.am (working copy) +++ monitor/Makefile.am (working copy)
@@ -5,6 +5,10 @@ @@ -5,6 +5,10 @@
SUBDIRS += hal SUBDIRS += hal
@ -67,7 +67,7 @@ Index: monitor/Makefile.am
if USE_GPHOTO2 if USE_GPHOTO2
SUBDIRS += gphoto2 SUBDIRS += gphoto2
endif endif
--- /dev/null 2009-03-02 15:45:22.087299058 -0500 --- /dev/null 2009-03-04 16:07:30.099029290 -0500
+++ monitor/gdu/gdu-volume-monitor-daemon.c 2009-03-01 23:47:15.000000000 -0500 +++ monitor/gdu/gdu-volume-monitor-daemon.c 2009-03-01 23:47:15.000000000 -0500
@@ -0,0 +1,46 @@ @@ -0,0 +1,46 @@
+/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */ +/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */
@ -116,7 +116,7 @@ Index: monitor/Makefile.am
+ "org.gtk.Private.GduVolumeMonitor", + "org.gtk.Private.GduVolumeMonitor",
+ G_TYPE_GDU_VOLUME_MONITOR); + G_TYPE_GDU_VOLUME_MONITOR);
+} +}
--- /dev/null 2009-03-02 15:45:22.087299058 -0500 --- /dev/null 2009-03-04 16:07:30.099029290 -0500
+++ monitor/gdu/ggdudrive.c 2009-03-01 23:48:33.000000000 -0500 +++ monitor/gdu/ggdudrive.c 2009-03-01 23:48:33.000000000 -0500
@@ -0,0 +1,691 @@ @@ -0,0 +1,691 @@
+/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */ +/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */
@ -810,7 +810,7 @@ Index: monitor/Makefile.am
+{ +{
+ return drive->presentable; + return drive->presentable;
+} +}
--- /dev/null 2009-03-02 15:45:22.087299058 -0500 --- /dev/null 2009-03-04 16:07:30.099029290 -0500
+++ monitor/gdu/ggdudrive.h 2009-03-01 23:48:26.000000000 -0500 +++ monitor/gdu/ggdudrive.h 2009-03-01 23:48:26.000000000 -0500
@@ -0,0 +1,69 @@ @@ -0,0 +1,69 @@
+/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */ +/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */
@ -882,7 +882,7 @@ Index: monitor/Makefile.am
+G_END_DECLS +G_END_DECLS
+ +
+#endif /* __G_GDU_DRIVE_H__ */ +#endif /* __G_GDU_DRIVE_H__ */
--- /dev/null 2009-03-02 15:45:22.087299058 -0500 --- /dev/null 2009-03-04 16:07:30.099029290 -0500
+++ monitor/gdu/ggdumount.c 2009-03-02 14:18:23.000000000 -0500 +++ monitor/gdu/ggdumount.c 2009-03-02 14:18:23.000000000 -0500
@@ -0,0 +1,958 @@ @@ -0,0 +1,958 @@
+/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */ +/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */
@ -1843,7 +1843,7 @@ Index: monitor/Makefile.am
+{ +{
+ return mount->volume == volume; + return mount->volume == volume;
+} +}
--- /dev/null 2009-03-02 15:45:22.087299058 -0500 --- /dev/null 2009-03-04 16:07:30.099029290 -0500
+++ monitor/gdu/ggdumount.h 2009-03-01 23:48:16.000000000 -0500 +++ monitor/gdu/ggdumount.h 2009-03-01 23:48:16.000000000 -0500
@@ -0,0 +1,64 @@ @@ -0,0 +1,64 @@
+/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */ +/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */
@ -1910,8 +1910,8 @@ Index: monitor/Makefile.am
+G_END_DECLS +G_END_DECLS
+ +
+#endif /* __G_GDU_MOUNT_H__ */ +#endif /* __G_GDU_MOUNT_H__ */
--- /dev/null 2009-03-02 15:45:22.087299058 -0500 --- /dev/null 2009-03-04 16:07:30.099029290 -0500
+++ monitor/gdu/ggduvolume.c 2009-03-02 14:37:46.000000000 -0500 +++ monitor/gdu/ggduvolume.c 2009-03-04 16:19:41.000000000 -0500
@@ -0,0 +1,1408 @@ @@ -0,0 +1,1408 @@
+/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */ +/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */
+/* gvfs - extensions for gio +/* gvfs - extensions for gio
@ -3277,7 +3277,7 @@ Index: monitor/Makefile.am
+ device = gdu_presentable_get_device (presentable); + device = gdu_presentable_get_device (presentable);
+ if (device != NULL) + if (device != NULL)
+ { + {
+ ret = g_strcmp0 (gdu_device_get_mount_path (device), mount_path); + ret = g_strcmp0 (gdu_device_get_mount_path (device), mount_path) == 0;
+ g_object_unref (device); + g_object_unref (device);
+ } + }
+ } + }
@ -3321,7 +3321,7 @@ Index: monitor/Makefile.am
+ +
+ return GDU_PRESENTABLE (ret); + return GDU_PRESENTABLE (ret);
+} +}
--- /dev/null 2009-03-02 15:45:22.087299058 -0500 --- /dev/null 2009-03-04 16:07:30.099029290 -0500
+++ monitor/gdu/ggduvolume.h 2009-03-01 23:48:05.000000000 -0500 +++ monitor/gdu/ggduvolume.h 2009-03-01 23:48:05.000000000 -0500
@@ -0,0 +1,78 @@ @@ -0,0 +1,78 @@
+/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */ +/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */
@ -3402,8 +3402,8 @@ Index: monitor/Makefile.am
+G_END_DECLS +G_END_DECLS
+ +
+#endif /* __G_GDU_VOLUME_H__ */ +#endif /* __G_GDU_VOLUME_H__ */
--- /dev/null 2009-03-02 15:45:22.087299058 -0500 --- /dev/null 2009-03-04 16:07:30.099029290 -0500
+++ monitor/gdu/ggduvolumemonitor.c 2009-03-01 23:48:01.000000000 -0500 +++ monitor/gdu/ggduvolumemonitor.c 2009-03-04 16:29:02.000000000 -0500
@@ -0,0 +1,1432 @@ @@ -0,0 +1,1432 @@
+/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */ +/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */
+/* gvfs - extensions for gio +/* gvfs - extensions for gio
@ -4837,7 +4837,7 @@ Index: monitor/Makefile.am
+ +
+ g_list_free (cur_discs); + g_list_free (cur_discs);
+} +}
--- /dev/null 2009-03-02 15:45:22.087299058 -0500 --- /dev/null 2009-03-04 16:07:30.099029290 -0500
+++ monitor/gdu/ggduvolumemonitor.h 2009-03-01 23:49:48.000000000 -0500 +++ monitor/gdu/ggduvolumemonitor.h 2009-03-01 23:49:48.000000000 -0500
@@ -0,0 +1,60 @@ @@ -0,0 +1,60 @@
+/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */ +/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */
@ -4900,7 +4900,7 @@ Index: monitor/Makefile.am
+G_END_DECLS +G_END_DECLS
+ +
+#endif /* __G_GDU_VOLUME_MONITOR_H__ */ +#endif /* __G_GDU_VOLUME_MONITOR_H__ */
--- /dev/null 2009-03-02 15:45:22.087299058 -0500 --- /dev/null 2009-03-04 16:07:30.099029290 -0500
+++ monitor/gdu/polkit.c 2009-03-01 23:47:50.000000000 -0500 +++ monitor/gdu/polkit.c 2009-03-01 23:47:50.000000000 -0500
@@ -0,0 +1,137 @@ @@ -0,0 +1,137 @@
+/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */ +/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */
@ -5040,7 +5040,7 @@ Index: monitor/Makefile.am
+ dbus_message_unref (message); + dbus_message_unref (message);
+ dbus_connection_unref (connection); + dbus_connection_unref (connection);
+} +}
--- /dev/null 2009-03-02 15:45:22.087299058 -0500 --- /dev/null 2009-03-04 16:07:30.099029290 -0500
+++ monitor/gdu/polkit.h 2009-03-01 23:47:41.000000000 -0500 +++ monitor/gdu/polkit.h 2009-03-01 23:47:41.000000000 -0500
@@ -0,0 +1,44 @@ @@ -0,0 +1,44 @@
+/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */ +/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*- */
@ -5087,7 +5087,7 @@ Index: monitor/Makefile.am
+G_END_DECLS +G_END_DECLS
+ +
+#endif /* __POLKIT_H__ */ +#endif /* __POLKIT_H__ */
--- /dev/null 2009-03-02 15:45:22.087299058 -0500 --- /dev/null 2009-03-04 16:07:30.099029290 -0500
+++ monitor/gdu/Makefile.am 2009-03-01 21:13:46.000000000 -0500 +++ monitor/gdu/Makefile.am 2009-03-01 21:13:46.000000000 -0500
@@ -0,0 +1,53 @@ @@ -0,0 +1,53 @@
+ +
@ -5143,7 +5143,7 @@ Index: monitor/Makefile.am
+ rm -f *~ *.loT $(BUILT_SOURCES) $(service_DATA) + rm -f *~ *.loT $(BUILT_SOURCES) $(service_DATA)
+ +
+EXTRA_DIST = $(service_in_files) gdu.monitor +EXTRA_DIST = $(service_in_files) gdu.monitor
--- /dev/null 2009-03-02 15:45:22.087299058 -0500 --- /dev/null 2009-03-04 16:07:30.099029290 -0500
+++ monitor/gdu/gdu.monitor 2009-02-11 06:42:26.000000000 -0500 +++ monitor/gdu/gdu.monitor 2009-02-11 06:42:26.000000000 -0500
@@ -0,0 +1,5 @@ @@ -0,0 +1,5 @@
+[RemoteVolumeMonitor] +[RemoteVolumeMonitor]
@ -5151,7 +5151,7 @@ Index: monitor/Makefile.am
+DBusName=org.gtk.Private.GduVolumeMonitor +DBusName=org.gtk.Private.GduVolumeMonitor
+IsNative=true +IsNative=true
+NativePriority=3 +NativePriority=3
--- /dev/null 2009-03-02 15:45:22.087299058 -0500 --- /dev/null 2009-03-04 16:07:30.099029290 -0500
+++ monitor/gdu/org.gtk.Private.GduVolumeMonitor.service.in 2009-02-19 22:34:26.000000000 -0500 +++ monitor/gdu/org.gtk.Private.GduVolumeMonitor.service.in 2009-02-19 22:34:26.000000000 -0500
@@ -0,0 +1,3 @@ @@ -0,0 +1,3 @@
+[D-BUS Service] +[D-BUS Service]

View File

@ -1,7 +1,7 @@
Summary: Backends for the gio framework in GLib Summary: Backends for the gio framework in GLib
Name: gvfs Name: gvfs
Version: 1.1.7 Version: 1.1.7
Release: 2%{?dist} Release: 3%{?dist}
License: LGPLv2+ License: LGPLv2+
Group: System Environment/Libraries Group: System Environment/Libraries
URL: http://www.gtk.org URL: http://www.gtk.org
@ -32,7 +32,7 @@ BuildRequires: libtool
Patch1: gvfs-0.99.2-archive-integration.patch Patch1: gvfs-0.99.2-archive-integration.patch
# http://bugzilla.gnome.org/show_bug.cgi?id=573826 # http://bugzilla.gnome.org/show_bug.cgi?id=573826
Patch2: gvfs-gdu.patch Patch2: gvfs-gdu-volume-monitor-3.patch
%description %description
The gvfs package provides backend implementations for the gio The gvfs package provides backend implementations for the gio
@ -259,6 +259,9 @@ update-desktop-database &> /dev/null ||:
%changelog %changelog
* Wed Mar 4 2009 David Zeuthen <davidz@redhat.com> - 1.1.7-3
- Update GVfs gdu patch to fix mount detection confusion (#488399)
* Mon Mar 2 2009 Matthias Clasen <mclasen@redhat.com> - 1.1.7-2 * Mon Mar 2 2009 Matthias Clasen <mclasen@redhat.com> - 1.1.7-2
- Port to DeviceKit-disks - Port to DeviceKit-disks