a27e7de978
- Restore SELinux file contexts of modified PPDs.
446 lines
12 KiB
Diff
446 lines
12 KiB
Diff
diff -up gutenprint-5.2.2/configure.ac.O6 gutenprint-5.2.2/configure.ac
|
|
--- gutenprint-5.2.2/configure.ac.O6 2008-11-19 11:23:29.000000000 +0000
|
|
+++ gutenprint-5.2.2/configure.ac 2008-11-19 11:24:35.000000000 +0000
|
|
@@ -625,27 +625,6 @@ AH_TEMPLATE(PKGMODULEDIR,, [Package modu
|
|
PKGMODULEDIR="${PACKAGE_LIB_DIR}/${GUTENPRINT_RELEASE_VERSION}/modules"
|
|
AC_DEFINE_UNQUOTED(PKGMODULEDIR, ["$PKGMODULEDIR"])
|
|
|
|
-dnl Compiler flags
|
|
-if test x$ac_compiler_gnu = "xyes"; then
|
|
- STP_ADD_COMPILER_ARGS([-Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072],, [GNUCFLAGS])
|
|
- if test x${USE_MAINTAINER_MODE} = xyes ; then
|
|
- STP_ADD_COMPILER_ARGS([-pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls],, [GNUCFLAGS])
|
|
- fi
|
|
- if test x$ENABLE_DEBUG = xyes ; then
|
|
- STP_ADD_COMPILER_ARG([-g])
|
|
- else
|
|
- STP_ADD_FIRST_COMPILER_ARG([-O6 -O3 -O2 -O1 -O])
|
|
- fi
|
|
-else
|
|
- if test x$ENABLE_DEBUG = xyes ; then
|
|
- STP_ADD_COMPILER_ARG([-g])
|
|
- else
|
|
- STP_ADD_FIRST_COMPILER_ARG([-O])
|
|
- fi
|
|
-fi
|
|
-if test x$ENABLE_PROFILE = xyes ; then
|
|
- STP_ADD_COMPILER_ARG([-pg])
|
|
-fi
|
|
AC_SUBST(GNUCFLAGS)
|
|
|
|
AH_TEMPLATE([HAVE_GCC_ATTRIBUTES],
|
|
diff -up gutenprint-5.2.2/configure.O6 gutenprint-5.2.2/configure
|
|
--- gutenprint-5.2.2/configure.O6 2008-11-19 11:23:32.000000000 +0000
|
|
+++ gutenprint-5.2.2/configure 2008-11-19 11:24:49.000000000 +0000
|
|
@@ -26509,410 +26509,6 @@ cat >>confdefs.h <<_ACEOF
|
|
_ACEOF
|
|
|
|
|
|
-if test x$ac_compiler_gnu = "xyes"; then
|
|
-
|
|
- for stp_ac_arg in -Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072 ; do
|
|
-
|
|
- { echo "$as_me:$LINENO: checking if ${CC} supports ${stp_ac_arg}" >&5
|
|
-echo $ECHO_N "checking if ${CC} supports ${stp_ac_arg}... $ECHO_C" >&6; }
|
|
- stp_acOLDCFLAGS="${CFLAGS}"
|
|
- CFLAGS="${GNUCFLAGS} ${stp_ac_arg}"
|
|
- cat >conftest.$ac_ext <<_ACEOF
|
|
-/* confdefs.h. */
|
|
-_ACEOF
|
|
-cat confdefs.h >>conftest.$ac_ext
|
|
-cat >>conftest.$ac_ext <<_ACEOF
|
|
-/* end confdefs.h. */
|
|
-
|
|
-int
|
|
-main ()
|
|
-{
|
|
-
|
|
- ;
|
|
- return 0;
|
|
-}
|
|
-_ACEOF
|
|
-rm -f conftest.$ac_objext
|
|
-if { (ac_try="$ac_compile"
|
|
-case "(($ac_try" in
|
|
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
- *) ac_try_echo=$ac_try;;
|
|
-esac
|
|
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
|
|
- (eval "$ac_compile") 2>conftest.er1
|
|
- ac_status=$?
|
|
- grep -v '^ *+' conftest.er1 >conftest.err
|
|
- rm -f conftest.er1
|
|
- cat conftest.err >&5
|
|
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
- (exit $ac_status); } && {
|
|
- test -z "$ac_c_werror_flag" ||
|
|
- test ! -s conftest.err
|
|
- } && test -s conftest.$ac_objext; then
|
|
- { echo "$as_me:$LINENO: result: yes" >&5
|
|
-echo "${ECHO_T}yes" >&6; };
|
|
- stp_newCFLAGS="$CFLAGS"
|
|
-else
|
|
- echo "$as_me: failed program was:" >&5
|
|
-sed 's/^/| /' conftest.$ac_ext >&5
|
|
-
|
|
- { echo "$as_me:$LINENO: result: no" >&5
|
|
-echo "${ECHO_T}no" >&6; };
|
|
- stp_newCFLAGS="$stp_acOLDCFLAGS"
|
|
-fi
|
|
-
|
|
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
- CFLAGS="$stp_acOLDCFLAGS"
|
|
- GNUCFLAGS="${stp_newCFLAGS}"
|
|
-
|
|
- done
|
|
-
|
|
- if test x${USE_MAINTAINER_MODE} = xyes ; then
|
|
-
|
|
- for stp_ac_arg in -pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls ; do
|
|
-
|
|
- { echo "$as_me:$LINENO: checking if ${CC} supports ${stp_ac_arg}" >&5
|
|
-echo $ECHO_N "checking if ${CC} supports ${stp_ac_arg}... $ECHO_C" >&6; }
|
|
- stp_acOLDCFLAGS="${CFLAGS}"
|
|
- CFLAGS="${GNUCFLAGS} ${stp_ac_arg}"
|
|
- cat >conftest.$ac_ext <<_ACEOF
|
|
-/* confdefs.h. */
|
|
-_ACEOF
|
|
-cat confdefs.h >>conftest.$ac_ext
|
|
-cat >>conftest.$ac_ext <<_ACEOF
|
|
-/* end confdefs.h. */
|
|
-
|
|
-int
|
|
-main ()
|
|
-{
|
|
-
|
|
- ;
|
|
- return 0;
|
|
-}
|
|
-_ACEOF
|
|
-rm -f conftest.$ac_objext
|
|
-if { (ac_try="$ac_compile"
|
|
-case "(($ac_try" in
|
|
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
- *) ac_try_echo=$ac_try;;
|
|
-esac
|
|
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
|
|
- (eval "$ac_compile") 2>conftest.er1
|
|
- ac_status=$?
|
|
- grep -v '^ *+' conftest.er1 >conftest.err
|
|
- rm -f conftest.er1
|
|
- cat conftest.err >&5
|
|
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
- (exit $ac_status); } && {
|
|
- test -z "$ac_c_werror_flag" ||
|
|
- test ! -s conftest.err
|
|
- } && test -s conftest.$ac_objext; then
|
|
- { echo "$as_me:$LINENO: result: yes" >&5
|
|
-echo "${ECHO_T}yes" >&6; };
|
|
- stp_newCFLAGS="$CFLAGS"
|
|
-else
|
|
- echo "$as_me: failed program was:" >&5
|
|
-sed 's/^/| /' conftest.$ac_ext >&5
|
|
-
|
|
- { echo "$as_me:$LINENO: result: no" >&5
|
|
-echo "${ECHO_T}no" >&6; };
|
|
- stp_newCFLAGS="$stp_acOLDCFLAGS"
|
|
-fi
|
|
-
|
|
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
- CFLAGS="$stp_acOLDCFLAGS"
|
|
- GNUCFLAGS="${stp_newCFLAGS}"
|
|
-
|
|
- done
|
|
-
|
|
- fi
|
|
- if test x$ENABLE_DEBUG = xyes ; then
|
|
-
|
|
- { echo "$as_me:$LINENO: checking if ${CC} supports -g" >&5
|
|
-echo $ECHO_N "checking if ${CC} supports -g... $ECHO_C" >&6; }
|
|
- stp_acOLDCFLAGS="${CFLAGS}"
|
|
- CFLAGS="${CFLAGS} -g"
|
|
- cat >conftest.$ac_ext <<_ACEOF
|
|
-/* confdefs.h. */
|
|
-_ACEOF
|
|
-cat confdefs.h >>conftest.$ac_ext
|
|
-cat >>conftest.$ac_ext <<_ACEOF
|
|
-/* end confdefs.h. */
|
|
-
|
|
-int
|
|
-main ()
|
|
-{
|
|
-
|
|
- ;
|
|
- return 0;
|
|
-}
|
|
-_ACEOF
|
|
-rm -f conftest.$ac_objext
|
|
-if { (ac_try="$ac_compile"
|
|
-case "(($ac_try" in
|
|
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
- *) ac_try_echo=$ac_try;;
|
|
-esac
|
|
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
|
|
- (eval "$ac_compile") 2>conftest.er1
|
|
- ac_status=$?
|
|
- grep -v '^ *+' conftest.er1 >conftest.err
|
|
- rm -f conftest.er1
|
|
- cat conftest.err >&5
|
|
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
- (exit $ac_status); } && {
|
|
- test -z "$ac_c_werror_flag" ||
|
|
- test ! -s conftest.err
|
|
- } && test -s conftest.$ac_objext; then
|
|
- { echo "$as_me:$LINENO: result: yes" >&5
|
|
-echo "${ECHO_T}yes" >&6; };
|
|
- stp_newCFLAGS="$CFLAGS"
|
|
-else
|
|
- echo "$as_me: failed program was:" >&5
|
|
-sed 's/^/| /' conftest.$ac_ext >&5
|
|
-
|
|
- { echo "$as_me:$LINENO: result: no" >&5
|
|
-echo "${ECHO_T}no" >&6; };
|
|
- stp_newCFLAGS="$stp_acOLDCFLAGS"
|
|
-fi
|
|
-
|
|
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
- CFLAGS="$stp_acOLDCFLAGS"
|
|
- CFLAGS="${stp_newCFLAGS}"
|
|
-
|
|
- else
|
|
-
|
|
- for stp_ac_arg in -O6 -O3 -O2 -O1 -O ; do
|
|
- stp_ac_save_CFLAGS="${CFLAGS}"
|
|
-
|
|
- { echo "$as_me:$LINENO: checking if ${CC} supports ${stp_ac_arg}" >&5
|
|
-echo $ECHO_N "checking if ${CC} supports ${stp_ac_arg}... $ECHO_C" >&6; }
|
|
- stp_acOLDCFLAGS="${CFLAGS}"
|
|
- CFLAGS="${CFLAGS} ${stp_ac_arg}"
|
|
- cat >conftest.$ac_ext <<_ACEOF
|
|
-/* confdefs.h. */
|
|
-_ACEOF
|
|
-cat confdefs.h >>conftest.$ac_ext
|
|
-cat >>conftest.$ac_ext <<_ACEOF
|
|
-/* end confdefs.h. */
|
|
-
|
|
-int
|
|
-main ()
|
|
-{
|
|
-
|
|
- ;
|
|
- return 0;
|
|
-}
|
|
-_ACEOF
|
|
-rm -f conftest.$ac_objext
|
|
-if { (ac_try="$ac_compile"
|
|
-case "(($ac_try" in
|
|
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
- *) ac_try_echo=$ac_try;;
|
|
-esac
|
|
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
|
|
- (eval "$ac_compile") 2>conftest.er1
|
|
- ac_status=$?
|
|
- grep -v '^ *+' conftest.er1 >conftest.err
|
|
- rm -f conftest.er1
|
|
- cat conftest.err >&5
|
|
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
- (exit $ac_status); } && {
|
|
- test -z "$ac_c_werror_flag" ||
|
|
- test ! -s conftest.err
|
|
- } && test -s conftest.$ac_objext; then
|
|
- { echo "$as_me:$LINENO: result: yes" >&5
|
|
-echo "${ECHO_T}yes" >&6; };
|
|
- stp_newCFLAGS="$CFLAGS"
|
|
-else
|
|
- echo "$as_me: failed program was:" >&5
|
|
-sed 's/^/| /' conftest.$ac_ext >&5
|
|
-
|
|
- { echo "$as_me:$LINENO: result: no" >&5
|
|
-echo "${ECHO_T}no" >&6; };
|
|
- stp_newCFLAGS="$stp_acOLDCFLAGS"
|
|
-fi
|
|
-
|
|
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
- CFLAGS="$stp_acOLDCFLAGS"
|
|
- CFLAGS="${stp_newCFLAGS}"
|
|
-
|
|
- test "${stp_ac_save_CFLAGS}" != "${CFLAGS}" && break
|
|
- done
|
|
-
|
|
- fi
|
|
-else
|
|
- if test x$ENABLE_DEBUG = xyes ; then
|
|
-
|
|
- { echo "$as_me:$LINENO: checking if ${CC} supports -g" >&5
|
|
-echo $ECHO_N "checking if ${CC} supports -g... $ECHO_C" >&6; }
|
|
- stp_acOLDCFLAGS="${CFLAGS}"
|
|
- CFLAGS="${CFLAGS} -g"
|
|
- cat >conftest.$ac_ext <<_ACEOF
|
|
-/* confdefs.h. */
|
|
-_ACEOF
|
|
-cat confdefs.h >>conftest.$ac_ext
|
|
-cat >>conftest.$ac_ext <<_ACEOF
|
|
-/* end confdefs.h. */
|
|
-
|
|
-int
|
|
-main ()
|
|
-{
|
|
-
|
|
- ;
|
|
- return 0;
|
|
-}
|
|
-_ACEOF
|
|
-rm -f conftest.$ac_objext
|
|
-if { (ac_try="$ac_compile"
|
|
-case "(($ac_try" in
|
|
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
- *) ac_try_echo=$ac_try;;
|
|
-esac
|
|
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
|
|
- (eval "$ac_compile") 2>conftest.er1
|
|
- ac_status=$?
|
|
- grep -v '^ *+' conftest.er1 >conftest.err
|
|
- rm -f conftest.er1
|
|
- cat conftest.err >&5
|
|
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
- (exit $ac_status); } && {
|
|
- test -z "$ac_c_werror_flag" ||
|
|
- test ! -s conftest.err
|
|
- } && test -s conftest.$ac_objext; then
|
|
- { echo "$as_me:$LINENO: result: yes" >&5
|
|
-echo "${ECHO_T}yes" >&6; };
|
|
- stp_newCFLAGS="$CFLAGS"
|
|
-else
|
|
- echo "$as_me: failed program was:" >&5
|
|
-sed 's/^/| /' conftest.$ac_ext >&5
|
|
-
|
|
- { echo "$as_me:$LINENO: result: no" >&5
|
|
-echo "${ECHO_T}no" >&6; };
|
|
- stp_newCFLAGS="$stp_acOLDCFLAGS"
|
|
-fi
|
|
-
|
|
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
- CFLAGS="$stp_acOLDCFLAGS"
|
|
- CFLAGS="${stp_newCFLAGS}"
|
|
-
|
|
- else
|
|
-
|
|
- for stp_ac_arg in -O ; do
|
|
- stp_ac_save_CFLAGS="${CFLAGS}"
|
|
-
|
|
- { echo "$as_me:$LINENO: checking if ${CC} supports ${stp_ac_arg}" >&5
|
|
-echo $ECHO_N "checking if ${CC} supports ${stp_ac_arg}... $ECHO_C" >&6; }
|
|
- stp_acOLDCFLAGS="${CFLAGS}"
|
|
- CFLAGS="${CFLAGS} ${stp_ac_arg}"
|
|
- cat >conftest.$ac_ext <<_ACEOF
|
|
-/* confdefs.h. */
|
|
-_ACEOF
|
|
-cat confdefs.h >>conftest.$ac_ext
|
|
-cat >>conftest.$ac_ext <<_ACEOF
|
|
-/* end confdefs.h. */
|
|
-
|
|
-int
|
|
-main ()
|
|
-{
|
|
-
|
|
- ;
|
|
- return 0;
|
|
-}
|
|
-_ACEOF
|
|
-rm -f conftest.$ac_objext
|
|
-if { (ac_try="$ac_compile"
|
|
-case "(($ac_try" in
|
|
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
- *) ac_try_echo=$ac_try;;
|
|
-esac
|
|
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
|
|
- (eval "$ac_compile") 2>conftest.er1
|
|
- ac_status=$?
|
|
- grep -v '^ *+' conftest.er1 >conftest.err
|
|
- rm -f conftest.er1
|
|
- cat conftest.err >&5
|
|
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
- (exit $ac_status); } && {
|
|
- test -z "$ac_c_werror_flag" ||
|
|
- test ! -s conftest.err
|
|
- } && test -s conftest.$ac_objext; then
|
|
- { echo "$as_me:$LINENO: result: yes" >&5
|
|
-echo "${ECHO_T}yes" >&6; };
|
|
- stp_newCFLAGS="$CFLAGS"
|
|
-else
|
|
- echo "$as_me: failed program was:" >&5
|
|
-sed 's/^/| /' conftest.$ac_ext >&5
|
|
-
|
|
- { echo "$as_me:$LINENO: result: no" >&5
|
|
-echo "${ECHO_T}no" >&6; };
|
|
- stp_newCFLAGS="$stp_acOLDCFLAGS"
|
|
-fi
|
|
-
|
|
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
- CFLAGS="$stp_acOLDCFLAGS"
|
|
- CFLAGS="${stp_newCFLAGS}"
|
|
-
|
|
- test "${stp_ac_save_CFLAGS}" != "${CFLAGS}" && break
|
|
- done
|
|
-
|
|
- fi
|
|
-fi
|
|
-if test x$ENABLE_PROFILE = xyes ; then
|
|
-
|
|
- { echo "$as_me:$LINENO: checking if ${CC} supports -pg" >&5
|
|
-echo $ECHO_N "checking if ${CC} supports -pg... $ECHO_C" >&6; }
|
|
- stp_acOLDCFLAGS="${CFLAGS}"
|
|
- CFLAGS="${CFLAGS} -pg"
|
|
- cat >conftest.$ac_ext <<_ACEOF
|
|
-/* confdefs.h. */
|
|
-_ACEOF
|
|
-cat confdefs.h >>conftest.$ac_ext
|
|
-cat >>conftest.$ac_ext <<_ACEOF
|
|
-/* end confdefs.h. */
|
|
-
|
|
-int
|
|
-main ()
|
|
-{
|
|
-
|
|
- ;
|
|
- return 0;
|
|
-}
|
|
-_ACEOF
|
|
-rm -f conftest.$ac_objext
|
|
-if { (ac_try="$ac_compile"
|
|
-case "(($ac_try" in
|
|
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
- *) ac_try_echo=$ac_try;;
|
|
-esac
|
|
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
|
|
- (eval "$ac_compile") 2>conftest.er1
|
|
- ac_status=$?
|
|
- grep -v '^ *+' conftest.er1 >conftest.err
|
|
- rm -f conftest.er1
|
|
- cat conftest.err >&5
|
|
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
- (exit $ac_status); } && {
|
|
- test -z "$ac_c_werror_flag" ||
|
|
- test ! -s conftest.err
|
|
- } && test -s conftest.$ac_objext; then
|
|
- { echo "$as_me:$LINENO: result: yes" >&5
|
|
-echo "${ECHO_T}yes" >&6; };
|
|
- stp_newCFLAGS="$CFLAGS"
|
|
-else
|
|
- echo "$as_me: failed program was:" >&5
|
|
-sed 's/^/| /' conftest.$ac_ext >&5
|
|
-
|
|
- { echo "$as_me:$LINENO: result: no" >&5
|
|
-echo "${ECHO_T}no" >&6; };
|
|
- stp_newCFLAGS="$stp_acOLDCFLAGS"
|
|
-fi
|
|
-
|
|
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
- CFLAGS="$stp_acOLDCFLAGS"
|
|
- CFLAGS="${stp_newCFLAGS}"
|
|
-
|
|
-fi
|
|
|
|
|
|
|