diff --git a/.gitignore b/.gitignore
index 2ad0286..5e0926b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -7,3 +7,4 @@ gutenprint-5.2.3.tar.bz2
gutenprint-5.2.4.tar.bz2
gutenprint-5.2.5.tar.bz2
gutenprint-5.2.6.tar.bz2
+/gutenprint-5.2.7.tar.bz2
diff --git a/gutenprint-O6.patch b/gutenprint-O6.patch
index ba997f0..0c1084b 100644
--- a/gutenprint-O6.patch
+++ b/gutenprint-O6.patch
@@ -1,6 +1,6 @@
-diff -up gutenprint-5.2.4/configure.ac.O6 gutenprint-5.2.4/configure.ac
---- gutenprint-5.2.4/configure.ac.O6 2009-07-31 17:29:06.175961565 +0100
-+++ gutenprint-5.2.4/configure.ac 2009-07-31 17:29:32.117962246 +0100
+diff -up gutenprint-5.2.7/configure.ac.O6 gutenprint-5.2.7/configure.ac
+--- gutenprint-5.2.7/configure.ac.O6 2011-05-02 03:20:49.000000000 +0200
++++ gutenprint-5.2.7/configure.ac 2011-05-05 12:40:29.000000000 +0200
@@ -625,27 +625,6 @@ AH_TEMPLATE(PKGMODULEDIR,, [Package modu
PKGMODULEDIR="${PACKAGE_LIB_DIR}/${GUTENPRINT_RELEASE_VERSION}/modules"
AC_DEFINE_UNQUOTED(PKGMODULEDIR, ["$PKGMODULEDIR"])
@@ -29,26 +29,23 @@ diff -up gutenprint-5.2.4/configure.ac.O6 gutenprint-5.2.4/configure.ac
AC_SUBST(GNUCFLAGS)
AH_TEMPLATE([HAVE_GCC_ATTRIBUTES],
-diff -up gutenprint-5.2.4/configure.O6 gutenprint-5.2.4/configure
---- gutenprint-5.2.4/configure.O6 2009-07-31 17:29:39.376961485 +0100
-+++ gutenprint-5.2.4/configure 2009-07-31 17:31:08.881961477 +0100
-@@ -17925,421 +17925,6 @@ cat >>confdefs.h <<_ACEOF
+diff -up gutenprint-5.2.7/configure.O6 gutenprint-5.2.7/configure
+--- gutenprint-5.2.7/configure.O6 2011-05-02 03:32:21.000000000 +0200
++++ gutenprint-5.2.7/configure 2011-05-05 12:52:09.000000000 +0200
+@@ -16589,246 +16589,6 @@ cat >>confdefs.h <<_ACEOF
+ #define PKGMODULEDIR "$PKGMODULEDIR"
_ACEOF
-
+-
-if test x$ac_compiler_gnu = "xyes"; then
-
- for stp_ac_arg in -Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072 ; do
-
-- { $as_echo "$as_me:$LINENO: checking if ${CC} supports ${stp_ac_arg}" >&5
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports ${stp_ac_arg}" >&5
-$as_echo_n "checking if ${CC} supports ${stp_ac_arg}... " >&6; }
- stp_acOLDCFLAGS="${CFLAGS}"
- CFLAGS="${GNUCFLAGS} ${stp_ac_arg}"
-- cat >conftest.$ac_ext <<_ACEOF
--/* confdefs.h. */
--_ACEOF
--cat confdefs.h >>conftest.$ac_ext
--cat >>conftest.$ac_ext <<_ACEOF
+- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-/* end confdefs.h. */
-
-int
@@ -59,36 +56,15 @@ diff -up gutenprint-5.2.4/configure.O6 gutenprint-5.2.4/configure
- return 0;
-}
-_ACEOF
--rm -f conftest.$ac_objext
--if { (ac_try="$ac_compile"
--case "(($ac_try" in
-- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-- *) ac_try_echo=$ac_try;;
--esac
--eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
--$as_echo "$ac_try_echo") >&5
-- (eval "$ac_compile") 2>conftest.er1
-- ac_status=$?
-- grep -v '^ *+' conftest.er1 >conftest.err
-- rm -f conftest.er1
-- cat conftest.err >&5
-- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); } && {
-- test -z "$ac_c_werror_flag" ||
-- test ! -s conftest.err
-- } && test -s conftest.$ac_objext; then
-- { $as_echo "$as_me:$LINENO: result: yes" >&5
+-if ac_fn_c_try_compile "$LINENO"; then :
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-$as_echo "yes" >&6; };
- stp_newCFLAGS="$CFLAGS"
-else
-- $as_echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
-- { $as_echo "$as_me:$LINENO: result: no" >&5
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; };
- stp_newCFLAGS="$stp_acOLDCFLAGS"
-fi
--
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
- CFLAGS="$stp_acOLDCFLAGS"
- GNUCFLAGS="${stp_newCFLAGS}"
@@ -99,15 +75,11 @@ diff -up gutenprint-5.2.4/configure.O6 gutenprint-5.2.4/configure
-
- for stp_ac_arg in -pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls ; do
-
-- { $as_echo "$as_me:$LINENO: checking if ${CC} supports ${stp_ac_arg}" >&5
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports ${stp_ac_arg}" >&5
-$as_echo_n "checking if ${CC} supports ${stp_ac_arg}... " >&6; }
- stp_acOLDCFLAGS="${CFLAGS}"
- CFLAGS="${GNUCFLAGS} ${stp_ac_arg}"
-- cat >conftest.$ac_ext <<_ACEOF
--/* confdefs.h. */
--_ACEOF
--cat confdefs.h >>conftest.$ac_ext
--cat >>conftest.$ac_ext <<_ACEOF
+- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-/* end confdefs.h. */
-
-int
@@ -118,36 +90,15 @@ diff -up gutenprint-5.2.4/configure.O6 gutenprint-5.2.4/configure
- return 0;
-}
-_ACEOF
--rm -f conftest.$ac_objext
--if { (ac_try="$ac_compile"
--case "(($ac_try" in
-- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-- *) ac_try_echo=$ac_try;;
--esac
--eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
--$as_echo "$ac_try_echo") >&5
-- (eval "$ac_compile") 2>conftest.er1
-- ac_status=$?
-- grep -v '^ *+' conftest.er1 >conftest.err
-- rm -f conftest.er1
-- cat conftest.err >&5
-- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); } && {
-- test -z "$ac_c_werror_flag" ||
-- test ! -s conftest.err
-- } && test -s conftest.$ac_objext; then
-- { $as_echo "$as_me:$LINENO: result: yes" >&5
+-if ac_fn_c_try_compile "$LINENO"; then :
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-$as_echo "yes" >&6; };
- stp_newCFLAGS="$CFLAGS"
-else
-- $as_echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
-- { $as_echo "$as_me:$LINENO: result: no" >&5
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; };
- stp_newCFLAGS="$stp_acOLDCFLAGS"
-fi
--
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
- CFLAGS="$stp_acOLDCFLAGS"
- GNUCFLAGS="${stp_newCFLAGS}"
@@ -157,15 +108,11 @@ diff -up gutenprint-5.2.4/configure.O6 gutenprint-5.2.4/configure
- fi
- if test x$ENABLE_DEBUG = xyes ; then
-
-- { $as_echo "$as_me:$LINENO: checking if ${CC} supports -g" >&5
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports -g" >&5
-$as_echo_n "checking if ${CC} supports -g... " >&6; }
- stp_acOLDCFLAGS="${CFLAGS}"
- CFLAGS="${CFLAGS} -g"
-- cat >conftest.$ac_ext <<_ACEOF
--/* confdefs.h. */
--_ACEOF
--cat confdefs.h >>conftest.$ac_ext
--cat >>conftest.$ac_ext <<_ACEOF
+- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-/* end confdefs.h. */
-
-int
@@ -176,36 +123,15 @@ diff -up gutenprint-5.2.4/configure.O6 gutenprint-5.2.4/configure
- return 0;
-}
-_ACEOF
--rm -f conftest.$ac_objext
--if { (ac_try="$ac_compile"
--case "(($ac_try" in
-- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-- *) ac_try_echo=$ac_try;;
--esac
--eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
--$as_echo "$ac_try_echo") >&5
-- (eval "$ac_compile") 2>conftest.er1
-- ac_status=$?
-- grep -v '^ *+' conftest.er1 >conftest.err
-- rm -f conftest.er1
-- cat conftest.err >&5
-- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); } && {
-- test -z "$ac_c_werror_flag" ||
-- test ! -s conftest.err
-- } && test -s conftest.$ac_objext; then
-- { $as_echo "$as_me:$LINENO: result: yes" >&5
+-if ac_fn_c_try_compile "$LINENO"; then :
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-$as_echo "yes" >&6; };
- stp_newCFLAGS="$CFLAGS"
-else
-- $as_echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
-- { $as_echo "$as_me:$LINENO: result: no" >&5
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; };
- stp_newCFLAGS="$stp_acOLDCFLAGS"
-fi
--
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
- CFLAGS="$stp_acOLDCFLAGS"
- CFLAGS="${stp_newCFLAGS}"
@@ -215,15 +141,11 @@ diff -up gutenprint-5.2.4/configure.O6 gutenprint-5.2.4/configure
- for stp_ac_arg in -O6 -O3 -O2 -O1 -O ; do
- stp_ac_save_CFLAGS="${CFLAGS}"
-
-- { $as_echo "$as_me:$LINENO: checking if ${CC} supports ${stp_ac_arg}" >&5
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports ${stp_ac_arg}" >&5
-$as_echo_n "checking if ${CC} supports ${stp_ac_arg}... " >&6; }
- stp_acOLDCFLAGS="${CFLAGS}"
- CFLAGS="${CFLAGS} ${stp_ac_arg}"
-- cat >conftest.$ac_ext <<_ACEOF
--/* confdefs.h. */
--_ACEOF
--cat confdefs.h >>conftest.$ac_ext
--cat >>conftest.$ac_ext <<_ACEOF
+- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-/* end confdefs.h. */
-
-int
@@ -234,36 +156,15 @@ diff -up gutenprint-5.2.4/configure.O6 gutenprint-5.2.4/configure
- return 0;
-}
-_ACEOF
--rm -f conftest.$ac_objext
--if { (ac_try="$ac_compile"
--case "(($ac_try" in
-- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-- *) ac_try_echo=$ac_try;;
--esac
--eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
--$as_echo "$ac_try_echo") >&5
-- (eval "$ac_compile") 2>conftest.er1
-- ac_status=$?
-- grep -v '^ *+' conftest.er1 >conftest.err
-- rm -f conftest.er1
-- cat conftest.err >&5
-- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); } && {
-- test -z "$ac_c_werror_flag" ||
-- test ! -s conftest.err
-- } && test -s conftest.$ac_objext; then
-- { $as_echo "$as_me:$LINENO: result: yes" >&5
+-if ac_fn_c_try_compile "$LINENO"; then :
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-$as_echo "yes" >&6; };
- stp_newCFLAGS="$CFLAGS"
-else
-- $as_echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
-- { $as_echo "$as_me:$LINENO: result: no" >&5
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; };
- stp_newCFLAGS="$stp_acOLDCFLAGS"
-fi
--
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
- CFLAGS="$stp_acOLDCFLAGS"
- CFLAGS="${stp_newCFLAGS}"
@@ -275,15 +176,11 @@ diff -up gutenprint-5.2.4/configure.O6 gutenprint-5.2.4/configure
-else
- if test x$ENABLE_DEBUG = xyes ; then
-
-- { $as_echo "$as_me:$LINENO: checking if ${CC} supports -g" >&5
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports -g" >&5
-$as_echo_n "checking if ${CC} supports -g... " >&6; }
- stp_acOLDCFLAGS="${CFLAGS}"
- CFLAGS="${CFLAGS} -g"
-- cat >conftest.$ac_ext <<_ACEOF
--/* confdefs.h. */
--_ACEOF
--cat confdefs.h >>conftest.$ac_ext
--cat >>conftest.$ac_ext <<_ACEOF
+- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-/* end confdefs.h. */
-
-int
@@ -294,36 +191,15 @@ diff -up gutenprint-5.2.4/configure.O6 gutenprint-5.2.4/configure
- return 0;
-}
-_ACEOF
--rm -f conftest.$ac_objext
--if { (ac_try="$ac_compile"
--case "(($ac_try" in
-- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-- *) ac_try_echo=$ac_try;;
--esac
--eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
--$as_echo "$ac_try_echo") >&5
-- (eval "$ac_compile") 2>conftest.er1
-- ac_status=$?
-- grep -v '^ *+' conftest.er1 >conftest.err
-- rm -f conftest.er1
-- cat conftest.err >&5
-- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); } && {
-- test -z "$ac_c_werror_flag" ||
-- test ! -s conftest.err
-- } && test -s conftest.$ac_objext; then
-- { $as_echo "$as_me:$LINENO: result: yes" >&5
+-if ac_fn_c_try_compile "$LINENO"; then :
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-$as_echo "yes" >&6; };
- stp_newCFLAGS="$CFLAGS"
-else
-- $as_echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
-- { $as_echo "$as_me:$LINENO: result: no" >&5
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; };
- stp_newCFLAGS="$stp_acOLDCFLAGS"
-fi
--
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
- CFLAGS="$stp_acOLDCFLAGS"
- CFLAGS="${stp_newCFLAGS}"
@@ -333,15 +209,11 @@ diff -up gutenprint-5.2.4/configure.O6 gutenprint-5.2.4/configure
- for stp_ac_arg in -O ; do
- stp_ac_save_CFLAGS="${CFLAGS}"
-
-- { $as_echo "$as_me:$LINENO: checking if ${CC} supports ${stp_ac_arg}" >&5
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports ${stp_ac_arg}" >&5
-$as_echo_n "checking if ${CC} supports ${stp_ac_arg}... " >&6; }
- stp_acOLDCFLAGS="${CFLAGS}"
- CFLAGS="${CFLAGS} ${stp_ac_arg}"
-- cat >conftest.$ac_ext <<_ACEOF
--/* confdefs.h. */
--_ACEOF
--cat confdefs.h >>conftest.$ac_ext
--cat >>conftest.$ac_ext <<_ACEOF
+- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-/* end confdefs.h. */
-
-int
@@ -352,36 +224,15 @@ diff -up gutenprint-5.2.4/configure.O6 gutenprint-5.2.4/configure
- return 0;
-}
-_ACEOF
--rm -f conftest.$ac_objext
--if { (ac_try="$ac_compile"
--case "(($ac_try" in
-- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-- *) ac_try_echo=$ac_try;;
--esac
--eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
--$as_echo "$ac_try_echo") >&5
-- (eval "$ac_compile") 2>conftest.er1
-- ac_status=$?
-- grep -v '^ *+' conftest.er1 >conftest.err
-- rm -f conftest.er1
-- cat conftest.err >&5
-- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); } && {
-- test -z "$ac_c_werror_flag" ||
-- test ! -s conftest.err
-- } && test -s conftest.$ac_objext; then
-- { $as_echo "$as_me:$LINENO: result: yes" >&5
+-if ac_fn_c_try_compile "$LINENO"; then :
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-$as_echo "yes" >&6; };
- stp_newCFLAGS="$CFLAGS"
-else
-- $as_echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
-- { $as_echo "$as_me:$LINENO: result: no" >&5
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; };
- stp_newCFLAGS="$stp_acOLDCFLAGS"
-fi
--
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
- CFLAGS="$stp_acOLDCFLAGS"
- CFLAGS="${stp_newCFLAGS}"
@@ -393,15 +244,11 @@ diff -up gutenprint-5.2.4/configure.O6 gutenprint-5.2.4/configure
-fi
-if test x$ENABLE_PROFILE = xyes ; then
-
-- { $as_echo "$as_me:$LINENO: checking if ${CC} supports -pg" >&5
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports -pg" >&5
-$as_echo_n "checking if ${CC} supports -pg... " >&6; }
- stp_acOLDCFLAGS="${CFLAGS}"
- CFLAGS="${CFLAGS} -pg"
-- cat >conftest.$ac_ext <<_ACEOF
--/* confdefs.h. */
--_ACEOF
--cat confdefs.h >>conftest.$ac_ext
--cat >>conftest.$ac_ext <<_ACEOF
+- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-/* end confdefs.h. */
-
-int
@@ -412,36 +259,15 @@ diff -up gutenprint-5.2.4/configure.O6 gutenprint-5.2.4/configure
- return 0;
-}
-_ACEOF
--rm -f conftest.$ac_objext
--if { (ac_try="$ac_compile"
--case "(($ac_try" in
-- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-- *) ac_try_echo=$ac_try;;
--esac
--eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
--$as_echo "$ac_try_echo") >&5
-- (eval "$ac_compile") 2>conftest.er1
-- ac_status=$?
-- grep -v '^ *+' conftest.er1 >conftest.err
-- rm -f conftest.er1
-- cat conftest.err >&5
-- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); } && {
-- test -z "$ac_c_werror_flag" ||
-- test ! -s conftest.err
-- } && test -s conftest.$ac_objext; then
-- { $as_echo "$as_me:$LINENO: result: yes" >&5
+-if ac_fn_c_try_compile "$LINENO"; then :
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-$as_echo "yes" >&6; };
- stp_newCFLAGS="$CFLAGS"
-else
-- $as_echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
-- { $as_echo "$as_me:$LINENO: result: no" >&5
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; };
- stp_newCFLAGS="$stp_acOLDCFLAGS"
-fi
--
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
- CFLAGS="$stp_acOLDCFLAGS"
- CFLAGS="${stp_newCFLAGS}"
@@ -450,7 +276,6 @@ diff -up gutenprint-5.2.4/configure.O6 gutenprint-5.2.4/configure
-
-
-
--
- { $as_echo "$as_me:$LINENO: checking if $CC supports __attribute__ syntax" >&5
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking if $CC supports __attribute__ syntax" >&5
$as_echo_n "checking if $CC supports __attribute__ syntax... " >&6; }
- cat >conftest.$ac_ext <<_ACEOF
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
diff --git a/gutenprint-brother-hl-2040.patch b/gutenprint-brother-hl-2040.patch
deleted file mode 100644
index 7e10843..0000000
--- a/gutenprint-brother-hl-2040.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up gutenprint-5.2.6/src/xml/printers.xml.brother-hl-2040 gutenprint-5.2.6/src/xml/printers.xml
---- gutenprint-5.2.6/src/xml/printers.xml.brother-hl-2040 2010-08-11 02:26:09.000000000 +0200
-+++ gutenprint-5.2.6/src/xml/printers.xml 2010-08-11 15:19:50.000000000 +0200
-@@ -706,7 +706,7 @@
-
-
-
--
-+
-
-
-
diff --git a/gutenprint-device-ids.patch b/gutenprint-device-ids.patch
index ca15524..22a5257 100644
--- a/gutenprint-device-ids.patch
+++ b/gutenprint-device-ids.patch
@@ -1,10 +1,10 @@
-diff -up gutenprint-5.2.6/src/xml/printers.xml.device-ids gutenprint-5.2.6/src/xml/printers.xml
---- gutenprint-5.2.6/src/xml/printers.xml.device-ids 2010-12-02 18:40:53.000000000 +0100
-+++ gutenprint-5.2.6/src/xml/printers.xml 2010-12-02 18:50:23.000000000 +0100
-@@ -127,11 +127,11 @@
-
-
-
+diff -up gutenprint-5.2.7/src/xml/printers.xml.device-ids gutenprint-5.2.7/src/xml/printers.xml
+--- gutenprint-5.2.7/src/xml/printers.xml.device-ids 2011-05-01 17:44:04.000000000 +0200
++++ gutenprint-5.2.7/src/xml/printers.xml 2011-05-05 13:07:51.000000000 +0200
+@@ -143,11 +143,11 @@
+
+
+
-
+
@@ -15,7 +15,7 @@ diff -up gutenprint-5.2.6/src/xml/printers.xml.device-ids gutenprint-5.2.6/src/x
-@@ -265,7 +265,7 @@
+@@ -331,7 +331,7 @@
@@ -24,16 +24,7 @@ diff -up gutenprint-5.2.6/src/xml/printers.xml.device-ids gutenprint-5.2.6/src/x
-@@ -311,7 +311,7 @@
-
-
-
--
-+
-
-
-
-@@ -323,11 +323,11 @@
+@@ -389,7 +389,7 @@
@@ -42,39 +33,16 @@ diff -up gutenprint-5.2.6/src/xml/printers.xml.device-ids gutenprint-5.2.6/src/x
--
-+
-
-
-
-@@ -337,7 +337,7 @@
-
-
-
--
-+
-
-
-
-@@ -449,7 +449,7 @@
-
-
-
--
-+
-
-
-
-@@ -705,7 +705,7 @@
+@@ -785,7 +785,7 @@
-
+
-
+
-@@ -838,9 +838,9 @@
+@@ -918,9 +918,9 @@
@@ -86,16 +54,7 @@ diff -up gutenprint-5.2.6/src/xml/printers.xml.device-ids gutenprint-5.2.6/src/x
-@@ -925,7 +925,7 @@
-
-
-
--
-+
-
-
-
-@@ -1010,19 +1010,19 @@
+@@ -1090,19 +1090,19 @@
@@ -110,8 +69,8 @@ diff -up gutenprint-5.2.6/src/xml/printers.xml.device-ids gutenprint-5.2.6/src/x
-
+
-
--
+
+-
+
@@ -120,7 +79,7 @@ diff -up gutenprint-5.2.6/src/xml/printers.xml.device-ids gutenprint-5.2.6/src/x
-@@ -1030,15 +1030,15 @@
+@@ -1110,15 +1110,15 @@
diff --git a/gutenprint-null-pointer.patch b/gutenprint-null-pointer.patch
index a455d6b..7560c04 100644
--- a/gutenprint-null-pointer.patch
+++ b/gutenprint-null-pointer.patch
@@ -1,7 +1,7 @@
-diff -up gutenprint-5.2.6/src/escputil/escputil.c.null-pointer gutenprint-5.2.6/src/escputil/escputil.c
---- gutenprint-5.2.6/src/escputil/escputil.c.null-pointer 2009-12-23 21:13:54.000000000 +0100
-+++ gutenprint-5.2.6/src/escputil/escputil.c 2010-12-02 13:05:58.000000000 +0100
-@@ -1313,10 +1313,8 @@ do_new_status(status_cmd_t cmd, char *bu
+diff -up gutenprint-5.2.7/src/escputil/escputil.c.null-pointer gutenprint-5.2.7/src/escputil/escputil.c
+--- gutenprint-5.2.7/src/escputil/escputil.c.null-pointer 2010-12-11 23:04:07.000000000 +0100
++++ gutenprint-5.2.7/src/escputil/escputil.c 2011-05-05 13:11:37.000000000 +0200
+@@ -1340,10 +1340,8 @@ do_new_status(status_cmd_t cmd, char *bu
const char *ind;
const stp_string_list_t *color_list = NULL;
stp_parameter_t desc;
@@ -11,10 +11,10 @@ diff -up gutenprint-5.2.6/src/escputil/escputil.c.null-pointer gutenprint-5.2.6/
- color_list = desc.bounds.str;
+ const stp_vars_t *printvars = NULL;
+
- STP_DEBUG(fprintf(stderr, "New format bytes: %d bytes\n", bytes));
+ STP_DEBUG(printf("New format bytes: %d bytes\n", bytes));
if (cmd == CMD_STATUS)
printf(_("Printer Name: %s\n"),
-@@ -1373,6 +1371,13 @@ do_new_status(status_cmd_t cmd, char *bu
+@@ -1409,6 +1407,13 @@ do_new_status(status_cmd_t cmd, char *bu
for (j = 0; j < total_param_count; j++)
{
param = (unsigned) buf[i + j + 2];
diff --git a/gutenprint.spec b/gutenprint.spec
index da20c21..f25ce34 100644
--- a/gutenprint.spec
+++ b/gutenprint.spec
@@ -3,8 +3,8 @@
Name: gutenprint
Summary: Printer Drivers Package
-Version: 5.2.6
-Release: 3%{?dist}
+Version: 5.2.7
+Release: 1%{?dist}
Group: System Environment/Base
URL: http://gimp-print.sourceforge.net/
Source0: http://dl.sf.net/gimp-print/gutenprint-5.2/%{version}/gutenprint-%{version}.tar.bz2
@@ -15,10 +15,9 @@ Source2: cups-genppdupdate.py.in
Patch0: gutenprint-menu.patch
Patch1: gutenprint-O6.patch
Patch2: gutenprint-selinux.patch
-Patch3: gutenprint-brother-hl-2040.patch
-Patch4: gutenprint-postscriptdriver.patch
-Patch5: gutenprint-device-ids.patch
-Patch6: gutenprint-null-pointer.patch
+Patch3: gutenprint-postscriptdriver.patch
+Patch4: gutenprint-device-ids.patch
+Patch5: gutenprint-null-pointer.patch
License: GPLv2+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: cups-libs >= 1.1.22-0.rc1.9.10, cups >= 1.1.22-0.rc1.9.10
@@ -151,10 +150,8 @@ Epson, HP and compatible printers.
%patch1 -p1 -b .O6
# Restore file contexts when updating PPDs.
%patch2 -p1 -b .selinux
-# Don't claim support for Brother HL-2040.
-%patch3 -p1 -b .brother-hl-2040
# Allow the CUPS dynamic driver to run inside a build root.
-%patch4 -p1 -b .postscriptdriver
+%patch3 -p1 -b .postscriptdriver
# Added IEEE 1284 Device ID for
# Epson Stylus D92 (bug #570888).
# Epson Stylus Photo R230 (from Ubuntu #520466).
@@ -169,9 +166,9 @@ Epson, HP and compatible printers.
# HP LaserJet 4050/4100/4350/5100/8000/M3027 MFP/M3035 MFP/P3005 (bug #659043).
# HP Color LaserJet 2500/4550 (bug #659044).
# Brother hl-2035 (bug #651603#c3)
-%patch5 -p1 -b .device-ids
+%patch4 -p1 -b .device-ids
# Avoid null pointer access in escputil (bug #659120).
-%patch6 -p1 -b .null-pointer
+%patch5 -p1 -b .null-pointer
cp %{SOURCE2} src/cups/cups-genppdupdate.in
@@ -301,6 +298,9 @@ fi
/bin/rm -f /var/cache/foomatic/*
%changelog
+* Thu May 05 2011 Jiri Popelka 5.2.7-1
+- 5.2.7.
+
* Thu Dec 02 2010 Jiri Popelka 5.2.6-3
- Added IEEE 1284 Device ID for:
Canon PIXMA iP4200 (bug #626365).
diff --git a/sources b/sources
index 845fd1c..5dc5a1f 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-1f0d0cbef6c089f4f095e21869fa70db gutenprint-5.2.6.tar.bz2
+b19029972bf28f6efd693270daf8f5de gutenprint-5.2.7.tar.bz2