Fix building against libxml2 2.12.0 or above
Additionally, use SPDX for license expression.
This commit is contained in:
parent
19ce454acf
commit
15664f9fe3
@ -1,28 +0,0 @@
|
||||
From dbc32a55e265814a83cea7c1254d85f51f99b54b Mon Sep 17 00:00:00 2001
|
||||
From: Jens Georg <mail@jensge.org>
|
||||
Date: Tue, 4 Jan 2022 15:05:14 +0100
|
||||
Subject: [PATCH] Revert "build: Do not write man page during test"
|
||||
|
||||
This reverts commit 79a2cb24cd0079e9a025809d11dce13edce68bdd.
|
||||
|
||||
Does not work, will exit xsltproc with an error as if the file was not
|
||||
writeable
|
||||
---
|
||||
doc/meson.build | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/doc/meson.build b/doc/meson.build
|
||||
index de94aa2..2fd0106 100644
|
||||
--- a/doc/meson.build
|
||||
+++ b/doc/meson.build
|
||||
@@ -66,7 +66,6 @@ if xsltproc.found()
|
||||
xsltproc,
|
||||
xlstproc_flags,
|
||||
'--noout',
|
||||
- '--nowrite',
|
||||
stylesheet,
|
||||
'gupnp-binding-tool.xml'
|
||||
]
|
||||
--
|
||||
2.33.1
|
||||
|
82
gupnp-1.6.6-libxml2-2.12-includes.patch
Normal file
82
gupnp-1.6.6-libxml2-2.12-includes.patch
Normal file
@ -0,0 +1,82 @@
|
||||
From 00514fb62ebd341803fa44e26a6482a8c25dbd34 Mon Sep 17 00:00:00 2001
|
||||
From: Jens Georg <mail@jensge.org>
|
||||
Date: Sat, 25 Nov 2023 17:56:02 +0100
|
||||
Subject: [PATCH] all: Fix compatibility with libxml2 2.12.x
|
||||
|
||||
---
|
||||
libgupnp/gupnp-control-point.c | 2 ++
|
||||
libgupnp/gupnp-service-proxy-action.c | 2 ++
|
||||
libgupnp/gupnp-service-proxy.c | 2 ++
|
||||
libgupnp/gupnp-xml-doc.c | 3 +++
|
||||
libgupnp/xml-util.h | 2 ++
|
||||
5 files changed, 11 insertions(+)
|
||||
|
||||
diff --git a/libgupnp/gupnp-control-point.c b/libgupnp/gupnp-control-point.c
|
||||
index d4b44721..4374f726 100644
|
||||
--- a/libgupnp/gupnp-control-point.c
|
||||
+++ b/libgupnp/gupnp-control-point.c
|
||||
@@ -27,6 +27,8 @@
|
||||
#include <config.h>
|
||||
#include <string.h>
|
||||
|
||||
+#include <libxml/parser.h>
|
||||
+
|
||||
#include "gupnp-control-point.h"
|
||||
#include "gupnp-context-private.h"
|
||||
#include "gupnp-resource-factory-private.h"
|
||||
diff --git a/libgupnp/gupnp-service-proxy-action.c b/libgupnp/gupnp-service-proxy-action.c
|
||||
index b241d86c..6ea241ad 100644
|
||||
--- a/libgupnp/gupnp-service-proxy-action.c
|
||||
+++ b/libgupnp/gupnp-service-proxy-action.c
|
||||
@@ -9,6 +9,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <libxml/parser.h>
|
||||
+
|
||||
#include "gupnp-error.h"
|
||||
#include "gupnp-service-proxy.h"
|
||||
#include "gvalue-util.h"
|
||||
diff --git a/libgupnp/gupnp-service-proxy.c b/libgupnp/gupnp-service-proxy.c
|
||||
index adba5ab0..3f1a4454 100644
|
||||
--- a/libgupnp/gupnp-service-proxy.c
|
||||
+++ b/libgupnp/gupnp-service-proxy.c
|
||||
@@ -16,6 +16,8 @@
|
||||
#include <locale.h>
|
||||
#include <errno.h>
|
||||
|
||||
+#include <libxml/globals.h>
|
||||
+
|
||||
#include "gena-protocol.h"
|
||||
#include "gupnp-context-private.h"
|
||||
#include "gupnp-error-private.h"
|
||||
diff --git a/libgupnp/gupnp-xml-doc.c b/libgupnp/gupnp-xml-doc.c
|
||||
index 627f1a28..66f9b3dd 100644
|
||||
--- a/libgupnp/gupnp-xml-doc.c
|
||||
+++ b/libgupnp/gupnp-xml-doc.c
|
||||
@@ -15,6 +15,9 @@
|
||||
#include <config.h>
|
||||
#include <string.h>
|
||||
#include <gio/gio.h>
|
||||
+
|
||||
+#include <libxml/parser.h>
|
||||
+
|
||||
#include "gupnp-xml-doc.h"
|
||||
#include "gupnp-error.h"
|
||||
|
||||
diff --git a/libgupnp/xml-util.h b/libgupnp/xml-util.h
|
||||
index a02eb3d4..d0dcaeba 100644
|
||||
--- a/libgupnp/xml-util.h
|
||||
+++ b/libgupnp/xml-util.h
|
||||
@@ -10,6 +10,8 @@
|
||||
#define GUPNP_XML_UTIL_H
|
||||
|
||||
#include <libxml/tree.h>
|
||||
+#include <libxml/parser.h>
|
||||
+
|
||||
#include <stdarg.h>
|
||||
#include <glib-object.h>
|
||||
|
||||
--
|
||||
GitLab
|
||||
|
@ -4,12 +4,14 @@
|
||||
|
||||
Name: gupnp
|
||||
Version: 1.6.6
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: A framework for creating UPnP devices & control points
|
||||
|
||||
License: LGPLv2+
|
||||
License: LGPL-2.1-or-later
|
||||
URL: https://www.gupnp.org/
|
||||
Source0: https://download.gnome.org/sources/%{name}/1.6/%{name}-%{version}.tar.xz
|
||||
# https://gitlab.gnome.org/GNOME/gupnp/-/commit/00514fb62ebd341803fa44e26a6482a8c25dbd34
|
||||
Patch: gupnp-1.6.6-libxml2-2.12-includes.patch
|
||||
|
||||
BuildRequires: docbook-style-xsl
|
||||
BuildRequires: gi-docgen
|
||||
@ -85,6 +87,9 @@ This package contains developer documentation for %{name}.
|
||||
%{_docdir}/gupnp-%{apiver}/
|
||||
|
||||
%changelog
|
||||
* Mon Nov 27 2023 David King <amigadave@amigadave.com> - 1.6.6-2
|
||||
- Fix building against libxml2 2.12.0 or above
|
||||
|
||||
* Thu Nov 02 2023 Kalev Lember <klember@redhat.com> - 1.6.6-1
|
||||
- Update to 1.6.6
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user