6f2364b74b
Created as a split from libguestfs, see: https://bugzilla.redhat.com/show_bug.cgi?id=1942114
130 lines
4.5 KiB
Diff
130 lines
4.5 KiB
Diff
From 6bfe41474937bbaabd7c953ac62dc9a28aa6fa30 Mon Sep 17 00:00:00 2001
|
|
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
Date: Tue, 23 Mar 2021 13:38:56 +0000
|
|
Subject: [PATCH 3/7] build: Remove dependency on gobject-introspection.
|
|
|
|
Only required for libguestfs GObject bindings, not for these tools.
|
|
|
|
Fixes: commit 4354a3126152a2748cc9097cba139b3908ccc342
|
|
---
|
|
Makefile.am | 1 -
|
|
m4/introspection.m4 | 94 ---------------------------------------------
|
|
2 files changed, 95 deletions(-)
|
|
delete mode 100644 m4/introspection.m4
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index 382f2db130..b5c1bc0b87 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -75,7 +75,6 @@ EXTRA_DIST = \
|
|
common/README \
|
|
lib/guestfs-internal-all.h \
|
|
m4/.gitignore \
|
|
- m4/introspection.m4 \
|
|
podcheck.pl \
|
|
test-functions.sh \
|
|
tmp/.gitignore \
|
|
diff --git a/m4/introspection.m4 b/m4/introspection.m4
|
|
deleted file mode 100644
|
|
index 586d679eea..0000000000
|
|
--- a/m4/introspection.m4
|
|
+++ /dev/null
|
|
@@ -1,94 +0,0 @@
|
|
-dnl -*- mode: autoconf -*-
|
|
-dnl Copyright 2009 Johan Dahlin
|
|
-dnl
|
|
-dnl This file is free software; the author(s) gives unlimited
|
|
-dnl permission to copy and/or distribute it, with or without
|
|
-dnl modifications, as long as this notice is preserved.
|
|
-dnl
|
|
-
|
|
-# serial 1
|
|
-
|
|
-m4_define([_GOBJECT_INTROSPECTION_CHECK_INTERNAL],
|
|
-[
|
|
- AC_BEFORE([AC_PROG_LIBTOOL],[$0])dnl setup libtool first
|
|
- AC_BEFORE([AM_PROG_LIBTOOL],[$0])dnl setup libtool first
|
|
- AC_BEFORE([LT_INIT],[$0])dnl setup libtool first
|
|
-
|
|
- dnl enable/disable introspection
|
|
- m4_if([$2], [require],
|
|
- [dnl
|
|
- enable_introspection=yes
|
|
- ],[dnl
|
|
- AC_ARG_ENABLE(introspection,
|
|
- AS_HELP_STRING([--enable-introspection[=@<:@no/auto/yes@:>@]],
|
|
- [enable introspection for this build]),,
|
|
- [enable_introspection=auto])
|
|
- ])dnl
|
|
-
|
|
- AC_MSG_CHECKING([for gobject-introspection])
|
|
-
|
|
- dnl presence/version checking
|
|
- AS_CASE([$enable_introspection],
|
|
- [no], [dnl
|
|
- found_introspection="no (disabled, use --enable-introspection to enable)"
|
|
- ],dnl
|
|
- [yes],[dnl
|
|
- PKG_CHECK_EXISTS([gobject-introspection-1.0],,
|
|
- AC_MSG_ERROR([gobject-introspection-1.0 is not installed]))
|
|
- PKG_CHECK_EXISTS([gobject-introspection-1.0 >= $1],
|
|
- found_introspection=yes,
|
|
- AC_MSG_ERROR([You need to have gobject-introspection >= $1 installed to build AC_PACKAGE_NAME]))
|
|
- ],dnl
|
|
- [auto],[dnl
|
|
- PKG_CHECK_EXISTS([gobject-introspection-1.0 >= $1], found_introspection=yes, found_introspection=no)
|
|
- ],dnl
|
|
- [dnl
|
|
- AC_MSG_ERROR([invalid argument passed to --enable-introspection, should be one of @<:@no/auto/yes@:>@])
|
|
- ])dnl
|
|
-
|
|
- AC_MSG_RESULT([$found_introspection])
|
|
-
|
|
- INTROSPECTION_SCANNER=
|
|
- INTROSPECTION_COMPILER=
|
|
- INTROSPECTION_GENERATE=
|
|
- INTROSPECTION_GIRDIR=
|
|
- INTROSPECTION_TYPELIBDIR=
|
|
- if test "x$found_introspection" = "xyes"; then
|
|
- INTROSPECTION_SCANNER=`$PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0`
|
|
- INTROSPECTION_COMPILER=`$PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0`
|
|
- INTROSPECTION_GENERATE=`$PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0`
|
|
- INTROSPECTION_GIRDIR=`$PKG_CONFIG --variable=girdir gobject-introspection-1.0`
|
|
- INTROSPECTION_TYPELIBDIR="$($PKG_CONFIG --variable=typelibdir gobject-introspection-1.0)"
|
|
- INTROSPECTION_CFLAGS=`$PKG_CONFIG --cflags gobject-introspection-1.0`
|
|
- INTROSPECTION_LIBS=`$PKG_CONFIG --libs gobject-introspection-1.0`
|
|
- INTROSPECTION_MAKEFILE=`$PKG_CONFIG --variable=datadir gobject-introspection-1.0`/gobject-introspection-1.0/Makefile.introspection
|
|
- fi
|
|
- AC_SUBST(INTROSPECTION_SCANNER)
|
|
- AC_SUBST(INTROSPECTION_COMPILER)
|
|
- AC_SUBST(INTROSPECTION_GENERATE)
|
|
- AC_SUBST(INTROSPECTION_GIRDIR)
|
|
- AC_SUBST(INTROSPECTION_TYPELIBDIR)
|
|
- AC_SUBST(INTROSPECTION_CFLAGS)
|
|
- AC_SUBST(INTROSPECTION_LIBS)
|
|
- AC_SUBST(INTROSPECTION_MAKEFILE)
|
|
-
|
|
- AM_CONDITIONAL(HAVE_INTROSPECTION, test "x$found_introspection" = "xyes")
|
|
-])
|
|
-
|
|
-
|
|
-dnl Usage:
|
|
-dnl GOBJECT_INTROSPECTION_CHECK([minimum-g-i-version])
|
|
-
|
|
-AC_DEFUN([GOBJECT_INTROSPECTION_CHECK],
|
|
-[
|
|
- _GOBJECT_INTROSPECTION_CHECK_INTERNAL([$1])
|
|
-])
|
|
-
|
|
-dnl Usage:
|
|
-dnl GOBJECT_INTROSPECTION_REQUIRE([minimum-g-i-version])
|
|
-
|
|
-
|
|
-AC_DEFUN([GOBJECT_INTROSPECTION_REQUIRE],
|
|
-[
|
|
- _GOBJECT_INTROSPECTION_CHECK_INTERNAL([$1], [require])
|
|
-])
|
|
--
|
|
2.29.0.rc2
|
|
|