guestfs-tools/0007-Update-common-submodule-to-latest.patch
Richard W.M. Jones 6f2364b74b Initial import (RHBZ#1942114).
Created as a split from libguestfs, see:
https://bugzilla.redhat.com/show_bug.cgi?id=1942114
2021-03-25 18:58:35 +00:00

96 lines
3.4 KiB
Diff

From 6e80a33b70f89c18cd2fbde739243e8c5a7efc25 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Thu, 25 Mar 2021 08:14:49 +0000
Subject: [PATCH 7/7] Update common submodule to latest.
---
common | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Submodule common ca8a16a926..7c39a06fe3:
diff --git a/common/mlstdutils/Makefile.am b/common/mlstdutils/Makefile.am
index 2b4aed8..650f18c 100644
--- a/common/mlstdutils/Makefile.am
+++ b/common/mlstdutils/Makefile.am
@@ -85,7 +85,7 @@ OCAMLPACKAGES = \
-I $(builddir)
OCAMLPACKAGES_TESTS = $(MLSTDUTILS_CMA)
if HAVE_OCAML_PKG_OUNIT
-OCAMLPACKAGES_TESTS += -package oUnit
+OCAMLPACKAGES_TESTS += -package ounit2
endif
OCAMLFLAGS = $(OCAML_FLAGS) $(OCAML_WARN_ERROR) -ccopt '$(CFLAGS)'
diff --git a/common/mltools/Makefile.am b/common/mltools/Makefile.am
index 6bb2b88..5cec178 100644
--- a/common/mltools/Makefile.am
+++ b/common/mltools/Makefile.am
@@ -129,7 +129,7 @@ if HAVE_OCAML_PKG_GETTEXT
OCAMLPACKAGES += -package gettext-stub
endif
if HAVE_OCAML_PKG_OUNIT
-OCAMLPACKAGES_TESTS += -package oUnit
+OCAMLPACKAGES_TESTS += -package ounit2
endif
OCAMLCLIBS = \
@@ -263,7 +263,8 @@ tools_utils_tests_DEPENDENCIES = \
$(MLTOOLS_CMA) \
$(top_srcdir)/ocaml-link.sh
tools_utils_tests_LINK = \
- $(top_srcdir)/ocaml-link.sh -cclib '-lutils $(LIBXML2_LIBS) -lgnu' -- \
+ $(top_srcdir)/ocaml-link.sh \
+ -cclib '-pthread -lpthread -lutils $(LIBXML2_LIBS) -lgnu' -- \
$(OCAMLFIND) $(BEST) $(OCAMLFLAGS) $(OCAMLLINKFLAGS) \
$(OCAMLPACKAGES) $(OCAMLPACKAGES_TESTS) \
$(tools_utils_tests_THEOBJECTS) -o $@
@@ -290,7 +291,8 @@ JSON_tests_DEPENDENCIES = \
$(MLTOOLS_CMA) \
$(top_srcdir)/ocaml-link.sh
JSON_tests_LINK = \
- $(top_srcdir)/ocaml-link.sh -- \
+ $(top_srcdir)/ocaml-link.sh \
+ -cclib '-pthread -lpthread' -- \
$(OCAMLFIND) $(BEST) $(OCAMLFLAGS) $(OCAMLLINKFLAGS) \
$(OCAMLPACKAGES) $(OCAMLPACKAGES_TESTS) \
$(JSON_tests_THEOBJECTS) -o $@
@@ -303,7 +305,8 @@ JSON_parser_tests_DEPENDENCIES = \
$(MLTOOLS_CMA) \
$(top_srcdir)/ocaml-link.sh
JSON_parser_tests_LINK = \
- $(top_srcdir)/ocaml-link.sh -cclib '$(OCAMLCLIBS)' -- \
+ $(top_srcdir)/ocaml-link.sh \
+ -cclib '-pthread -lpthread $(OCAMLCLIBS)' -- \
$(OCAMLFIND) $(BEST) $(OCAMLFLAGS) $(OCAMLLINKFLAGS) \
$(OCAMLPACKAGES) $(OCAMLPACKAGES_TESTS) \
$(JSON_parser_tests_THEOBJECTS) -o $@
diff --git a/common/mlutils/Makefile.am b/common/mlutils/Makefile.am
index e86d7bb..17dfac3 100644
--- a/common/mlutils/Makefile.am
+++ b/common/mlutils/Makefile.am
@@ -112,10 +112,10 @@ c_utils_unit_tests_CFLAGS = $(libmlcutils_a_CFLAGS)
if !HAVE_OCAMLOPT
# Can't call this c_utils_unit_tests_OBJECTS because automake gets confused.
c_utils_unit_tests_THEOBJECTS = $(c_utils_unit_tests_BOBJECTS)
-c_utils_unit_tests.cmo: OCAMLPACKAGES += -package oUnit
+c_utils_unit_tests.cmo: OCAMLPACKAGES += -package ounit2
else
c_utils_unit_tests_THEOBJECTS = $(c_utils_unit_tests_XOBJECTS)
-c_utils_unit_tests.cmx: OCAMLPACKAGES += -package oUnit
+c_utils_unit_tests.cmx: OCAMLPACKAGES += -package ounit2
endif
OCAMLLINKFLAGS = \
@@ -131,7 +131,7 @@ c_utils_unit_tests_DEPENDENCIES = \
c_utils_unit_tests_LINK = \
$(top_srcdir)/ocaml-link.sh -cclib '-lutils -lgnu' -- \
$(OCAMLFIND) $(BEST) $(OCAMLFLAGS) \
- $(OCAMLPACKAGES) -package oUnit \
+ $(OCAMLPACKAGES) -package ounit2 \
$(OCAMLLINKFLAGS) \
$(c_utils_unit_tests_THEOBJECTS) -o $@
--
2.29.0.rc2