Add BR xorriso, needed to run the tests.
This commit is contained in:
parent
0ebebd7a2b
commit
e1c8031dd7
@ -0,0 +1,51 @@
|
|||||||
|
From 3a498512f58bc431db490e96cdb712b19389bda4 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||||
|
Date: Tue, 30 Mar 2021 12:41:58 +0100
|
||||||
|
Subject: [PATCH] tests: Prefer xorriso over genisoimage to generate test.iso
|
||||||
|
|
||||||
|
This Debian page explains the upstream situation:
|
||||||
|
https://wiki.debian.org/genisoimage
|
||||||
|
|
||||||
|
On Fedora, xorriso provides a compatibility program called "mkisofs".
|
||||||
|
However this is not present in Debian. Hence the choice to look for
|
||||||
|
the program called "xorrisofs".
|
||||||
|
|
||||||
|
(cherry picked from commit 2216ab2e328457ef172d6bfa534272edf2f81a3a)
|
||||||
|
---
|
||||||
|
m4/guestfs-progs.m4 | 6 +++---
|
||||||
|
test-data/Makefile.am | 2 +-
|
||||||
|
2 files changed, 4 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/m4/guestfs-progs.m4 b/m4/guestfs-progs.m4
|
||||||
|
index 2161b83136..1af1dc802a 100644
|
||||||
|
--- a/m4/guestfs-progs.m4
|
||||||
|
+++ b/m4/guestfs-progs.m4
|
||||||
|
@@ -39,10 +39,10 @@ AC_PROG_AWK
|
||||||
|
|
||||||
|
AC_PROG_LN_S
|
||||||
|
|
||||||
|
-dnl Check for genisoimage/mkisofs
|
||||||
|
-AC_PATH_PROGS([GENISOIMAGE],[genisoimage mkisofs],[no],
|
||||||
|
+dnl Check for xorriso/genisoimage/mkisofs.
|
||||||
|
+AC_PATH_PROGS([MKISOFS],[xorrisofs genisoimage mkisofs],[no],
|
||||||
|
[$PATH$PATH_SEPARATOR/usr/sbin$PATH_SEPARATOR/sbin])
|
||||||
|
-test "x$GENISOIMAGE" = "xno" && AC_MSG_ERROR([genisoimage must be installed])
|
||||||
|
+test "x$MKISOFS" = "xno" && AC_MSG_ERROR([xorriso or genisoimage or mkisofs must be installed])
|
||||||
|
|
||||||
|
dnl Check for optional xmllint.
|
||||||
|
AC_CHECK_PROG([XMLLINT],[xmllint],[xmllint],[no])
|
||||||
|
diff --git a/test-data/Makefile.am b/test-data/Makefile.am
|
||||||
|
index 21b88b9a4b..d818037dce 100644
|
||||||
|
--- a/test-data/Makefile.am
|
||||||
|
+++ b/test-data/Makefile.am
|
||||||
|
@@ -96,6 +96,6 @@ test.iso: $(images_files)
|
||||||
|
cp $(image_files) d/
|
||||||
|
mkdir -p d/directory
|
||||||
|
cd d && ln -sf /10klines abssymlink
|
||||||
|
- cd d && $(GENISOIMAGE) -J -r -o ../$@-t .
|
||||||
|
+ cd d && $(MKISOFS) -J -r -o ../$@-t .
|
||||||
|
rm -rf d
|
||||||
|
mv $@-t $@
|
||||||
|
--
|
||||||
|
2.29.0.rc2
|
||||||
|
|
@ -15,7 +15,7 @@
|
|||||||
%global verify_tarball_signature 1
|
%global verify_tarball_signature 1
|
||||||
|
|
||||||
# If there are patches which touch autotools files, set this to 1.
|
# If there are patches which touch autotools files, set this to 1.
|
||||||
%global patches_touch_autotools %{nil}
|
%global patches_touch_autotools 1
|
||||||
|
|
||||||
# The source directory.
|
# The source directory.
|
||||||
%global source_directory 1.45-development
|
%global source_directory 1.45-development
|
||||||
@ -26,7 +26,7 @@
|
|||||||
Summary: Tools to access and modify virtual machine disk images
|
Summary: Tools to access and modify virtual machine disk images
|
||||||
Name: guestfs-tools
|
Name: guestfs-tools
|
||||||
Version: 1.45.3
|
Version: 1.45.3
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
|
|
||||||
# Build only for architectures that have a kernel
|
# Build only for architectures that have a kernel
|
||||||
@ -44,6 +44,9 @@ Source1: http://download.libguestfs.org/guestfs-tools/%{source_directory}/
|
|||||||
Source2: libguestfs.keyring
|
Source2: libguestfs.keyring
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
# Upstream patch to change from genisoimage to xorriso.
|
||||||
|
Patch1: 0001-tests-Prefer-xorriso-over-genisoimage-to-generate-te.patch
|
||||||
|
|
||||||
%if 0%{patches_touch_autotools}
|
%if 0%{patches_touch_autotools}
|
||||||
BuildRequires: autoconf, automake, libtool, gettext-devel
|
BuildRequires: autoconf, automake, libtool, gettext-devel
|
||||||
%endif
|
%endif
|
||||||
@ -83,6 +86,7 @@ BuildRequires: perl(Expect)
|
|||||||
%endif
|
%endif
|
||||||
BuildRequires: bash-completion
|
BuildRequires: bash-completion
|
||||||
BuildRequires: /usr/bin/qemu-img
|
BuildRequires: /usr/bin/qemu-img
|
||||||
|
BuildRequires: xorriso
|
||||||
BuildRequires: perl(Locale::TextDomain)
|
BuildRequires: perl(Locale::TextDomain)
|
||||||
BuildRequires: perl(Sys::Guestfs)
|
BuildRequires: perl(Sys::Guestfs)
|
||||||
BuildRequires: perl(Win::Hivex)
|
BuildRequires: perl(Win::Hivex)
|
||||||
@ -398,8 +402,8 @@ end
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Wed Mar 31 2021 Richard W.M. Jones <rjones@redhat.com> - 1.45.3-2
|
* Wed Mar 31 2021 Richard W.M. Jones <rjones@redhat.com> - 1.45.3-3
|
||||||
- Bump and rebuild for updated libguestfs.
|
- Add BR xorriso, needed to run the tests.
|
||||||
|
|
||||||
* Mon Mar 29 2021 Richard W.M. Jones <rjones@redhat.com> - 1.45.3-1
|
* Mon Mar 29 2021 Richard W.M. Jones <rjones@redhat.com> - 1.45.3-1
|
||||||
- New upstream version 1.45.3.
|
- New upstream version 1.45.3.
|
||||||
|
Loading…
Reference in New Issue
Block a user